Jump to content
EwinRacing Flash Series Gaming Chairs
punkemolive

Replacement parts. Where to buy?

Recommended Posts

The problem occured after I formated laptop battery with Lenovo Energy Management. After battery charged 100% it started discharging. It discharged completly and laptop died. Laptop stopped detecting charger.

When I unplug the charger and plug it back in again, the laptop doesn't detect it (it keeps on draining the battery and does't prompt that a charger is connected). To make the charger work, I have to do following actions:

  1. OS shut down
  2. battery removed
  3. charger unplugged from laptop and wall socket
  4. charger plugged to wall socket
  5. charger plugged to the laptop
  6. power button pressed once (laptop boots up)
  7. after succesfull boot I can put back the battery

That is motherboard problem and i live in Kazakhstan, Kazakhstan doesn't have lenovo support center. And where to buy Lenovo Y580's motherboard?

Share this post


Link to post
Share on other sites

You might be able to find it in China, via a b2b platform similar to Ebay called taobao

y580

Unfortunately it is in Chinese but google translate does help a TON (I use it) and then once you locate your item you should engage a reputable taobao agent to buy the item on your behalf and then ship it to you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
    • By Soapy
      I reversed the input polarity on my m15x jack after a botched psu repair. Computer worked fine, but overall power control is messed up. System only boot on both battery and psu, no battery charge, and a very low battery drain (arround 6wh).
       
      I aways had battery issues whith my 8 years old m15x after my original battery died. Bought a new one two years ago, didn't work. Checked on upower, basically no info on manufacturer, power or history. So i refunded and used the system hooked on the psu as usual. In August i bought a new one, worked flawlessly for a day. The next day the battery died from nowere. Checked upower, bus was ok, battery was charging extremely slowly (6wh), history showed subpar disharge before shutting down. I got mad at this point, decided that psu was to blame. Opened it, checked everything, noticed some wear on the male jack. Resoldered it, connected on computer. Nothing happened, so i checked the voltage. That's when i realised that i screwed up big time. I swaped the positive and negative wires. Decided that one mistake was enough, so i sent my m15x to a trusted repair shop (latter found that they just hooked the battery and gave me back as soon as it booted, they didnt even open it). Got my pc a week later, but the battery didn't charge . Worse, it was slowly discharging (same 6wh as before), and it needed both the psu and the battery to turn on. At 65%, it worked as usual for my college semester, but the battery is dead, and so is my computer. I bellieve i burned some voltage controller or something. I'm pretty competent at soldering thing's (evem smd components) when i know what to do, and i can understand simple circuit's, but when i got my hands on the m15x datasheet i got overblown. I cant make heads or tails about it. I aways lurked this forum and i bellieve your guys are the best when it comes to finding creative solutions to technical problems concerning microelectronics. I followed a guide in this forum as a teenager to upgrade this same computer to a gtx680m, overclocked stuff, got custom bios, and had a lot of fun learning. The m15x is a deprecated platform, but it's a part of my history that i dont want to let go.
      So please guys, help me.
       
    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
    • By amidsal
      Hi again guys,
       
      I have one of those GT783R that disappeared from market very quickly, and one that is probably a lemon. I've tried to replace the processor and the video card so far and the computer still turns off after 3 or 4 minutes. In fact, it's strange because the BIOS shows GT780 instead of GT783R. My guess now is that I have to replace the motherboard.
       
      However, I can't find a spare motherboard for GT783R. I know it's a MS-17611 motherboard, so can I just buy a MS-17611 motherboard or does it have to have other specs to be compatible?
      Also, I noticed that there is a ver 1.0 and ver 1.1. Is there a difference between them?
       
      Anyone willing to help me? Please?????
       
      Best,
      Amid
    • By amidsal
      I have an MSI GT783R that is defective (turns off randomly) and now that I moved to US, I found out that it may be possible to repair/upgrade it.
      Since I'm relatively new in DIYing laptops, I have couple questions that I believe someone here may be able to answer. Below:
       
      - I noticed that this model is something related to MS-1761. What exactly is this? A type of notebook? A barebone (I think the word for this is barebook?)? A model that is similar to this one? Everytime I look for it I got motherboards, notebooks, bios all referring to this MS-1761. Can someone clarify this to me?
       
      - I suspect the issue may be with the motherboard (long story: when I was playing DA2 in a external monitor, I closed the computer and put it in a location that ended up overheating it and it turned off. After this incident, the computer turns off randomly, even when not playing anything). Can I replace the motherboard with one from some other model (called MSI and they don't have a spare one anymore).
       
      I have other questions but they are dependent on the answers of these two.
       
      Your help is greatly appreciated.
       
      Amid
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.