Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

New BIOS got released for the Alienware 17, unfortunately Dell didn't provide at change log, at least not yet... let's hope they don't fall back on old habits and stop providing any information...

Here's some information about what has changed:

- Intel GOP driver update

- some stuff that I think is XTU related

- a few minor other adjustments

- EC update, a lot of changes, probably also an adjustment of the fan algorithm as in the AW18 A03 bios.

>> Download link (direct) <<

  • Thumbs Up 1

Share this post

Link to post
Share on other sites

Nice ;) but m17x r5 with 780m still has problems with performance, even with You unlocked vbios:(

Wysyłane z mojego Nexus 4 za pomocą Tapatalk 2

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By guilhrme
      Hello guys, how are you?
      I got today a new graphics card for my Alienware 17 R1 (2013). The newer card is a gtx 970m. Before, the Alienware had no dedicated graphics card, but only the integrated Intel HD 4600 from processor.
      After I put the new card on laptop, I realized that the laptop wont turn on anymore. If I remove the graphics card, laptop turns on normally.
      Another thing that I noticed, is that with graphics card inside  when I plug AC adapter, the blue led of it (AC adapter) turns off. Without the card, this behavior dont happens.
      I already reseat the card a lot of times without success.
      My Alienware is a R1 Model (2013) or M17x R5.
      PSU: 240w
      Processor: 4910mq
      RAM: 32GB
      Battery: OK.
      Graphics Card: Alienware GTX 970m 6gb - G16E-A1
      Bios: A14 (lastest from Dell WebSite)
      I dont have another card to test.
      Thank you guys. I hope anyone can help me.
    • By Alucardoo
      please help me of this problem.

      Only using DGPU will have no problem. 

      But when i push fn + f5 and change into the optimus mode,

      the screen is flickering and glitching....
      like this video

      even i pulled out the dgpu and power on with integrated gpu,, it has the same situation.

      i flash the bios a14 and a13 but it isnt solved.

      i dont know why... i think it is related to the intel GPU...

      Is there anybody who know the source of the problem?
    • By Swick1981
      Bios Release Version – v2.0.0

      Updated or Modded Items:
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
      Thread link for more information and discussion:

    • By Swick1981
      Hey Everyone,
      Now on to the good stuff...
      I've officially cracked it - either by luck or persistence (I'm thinking LUCK, lol) - 
      Here is what I've added/updated/modded/changed/etc...
      You can now run Windows 7 with 900 series nVidia GPU's!  
      Changed the Default GPU from PEG to IGFX - No need to tear down laptop anymore.  8-Beeps are a thing of the PAST!
      Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED)
      Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED)
      Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132)
      Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132)
      Updated the LAN Firmware & PXE Boot from to v2.0.6.6)
      ADDED NvMe Support for m18xr2
      ADDED M.2 support for m18xr2
      Updated CPU Microcode to v29 for the 2900 CPU's
      Updated CPU Microcode to v1c for the 3900 CPU's
      Updated CPU Microcode for other supported CPU's if available! Sorry, I don't remember what version, but if it could be updated, it was!)
      Updated GOP Driver for Intel Sandy Bridge
      Updated GOP Driver for Intel Ivy Bridge 
      Updated GOP Policy for the m18xR2
      Raidriar added the "Package C-States Lock" to my bios mod - THANK YOU RAIDRIAR!
      My BIOS MOD should be available in the download section of TechInferno!  They have KINDLY offered to host the file, thankfully!  
      You MUST meet the minimum requirements of T|I in order to download files from their download section!  
      PLEASE NOTE:  Do not distribute this file.  Please tell others that want the file to download it from TechInferno, as the file is GUARANTEED to be clean if you get it from here.  If you download it from anywhere else, there is a chance that the code will be changed, and may BRICK your laptop.  Therefore, PLEASE make sure you download from here and ONLY here!   
      I'd like to THANK the following people for testing my bios mods to make sure they are safe for the rest of you:
      Mr. Fox, Raidriar, Rengsey R.H. Jr!  Thanks for testing, I'm grateful!
      RAIDRIAR, from nbr, needs an EXTRA shoutout for testing.  He was UTTERLY amazing!  He took risks no sane OR INSANE person would!  I owe him for testing this!  He deserves a LOT of credit for that!
      Also, I do have an UPDATE to Intel Management Firmware v8.1.64 (I think), but that is a SEPARATE package.  If you are interested, you can do that upgrade, too.  HOWEVER, PLEASE NOTE, if you plan on doing update you MUST do BIOS update FIRST - AGAIN, BIOS UPDATE MUST BE DONE FIRST!  AFTER bios update is done, then you can do IME update.  
      If you like this mod that I've done, please donate a couple KEGS of beer to me, as I put a TON of work into this.  I put more hours into this than I should have...  LoL
      I can also confirm that this has been tested by MANY people.  Mr. Fox, Raidriar, and a few others, and they had NO issues.  EXCEPT that they were finally able to install Windows 7 while in legacy mode (set from within bios),  and the GPU works completely.  The only ting I am still working on is the throttling issue on ALL GPU's (Some worse than others).  IF you use Mr. Fox's modded drivers, 355.20 I believe, the throttling issue is minimal with the 780m GPUs.  Anything above those drivers seems to throttle all GPU's at a more extreme rate.  I AM working on this throttling issue, but I am not sure it's fixable.  But I will TRY!  
      Again, I hope you ALL like this, and that it helps you out.  
      Lastly, IF you flash my MOD and you decide to purchase another 900 series GPU, please make sure you use woodstackz, as he sells them at the best rates.  Please let him know you are purchasing the GPU because of this mod, as it will help me out a little!
      I hope you like this!
      Link To Donate:   
      EDIT:  I forgot to put fparts.txt in the rar file with all the other files.  sorry about that.  I'm including it here on this post!
      PS.  I AM working on porting ALL these mods to the m17xR4, but dont know if I can get LEGACY SUPPORT ported!  I AM TRYING,  but if I can't, I'll be able to port EVERYTHING else...
      File download link:

    • By sukimu
      Hello fellow Aliens,
      My specs:
      Alienware M17xR4 got it back in Dec 2011 (Dell decided to upgrade my M17xR3 that crapped out on me) 
      Intel Core i7 3940XM
      Upgraded from 660m to 780m
      16GB Samsung 1600 RAM
      2 500GB Samsung SSD in Raid 0 ( i know sue me) 
      This will be a little guide with my journey of upgrading my dedicated GTX and CPU.
      Eagle vision activated and started the hunt on eBay for something that would not leave my bank with a massive dent. All i wanted to do is breathe more life into this monster that i have grown way too attached to. A quick search revealed people want way too much for their hard ware . How ever i started making offers and messaging people to negotiate a better price. I think it took me two days before i found a nice 3940XM listed for 350$. Messaged the dude and surely he replied with 200$ is a no go . But i can do 300$ . I had to come back with 280$ and to make the story short he accepted . Put my 3610QM after looking up on eBay they were going for 80$ give or take. So i listed it for 60$ with 4$ shipping . I got an E-mail from eBay; congrats on your listing...and your item sold . I did not want any negative feedback, so i removed the CPU wiped the thermal paste and decided to be with out my baby () until the 3940XM () arrived  ( which took 3 days). That package was like a  in my arms being delivered to its rightful owner. Reading all the replies on the offers i had made on 680m and 780m listings. From hell no to sorry you are crazy, there was a fellow that shared with me that the money is not a priority and his new 980m made him so happy he would sell his 780m for 300$ . Naturally i offered 280$ with paypal invoice = no eBay seller fees. What you know he accepted!!!!
      Listed my 660m for sale and till this day it is still there . I dont want to share my agony with you, waiting for a seven business day delivery by UPS ground , so lets fast forward to when i got the 780m and installing it. Seller advised i would need a 100W heat sink, which my poor 660m oddly had. So 780m is installed and a dual boot of Win10 and Win7 in order to see which Win the 780 preferred. Windows recognized the new hardware, so did the Bios, so i went to www.Nvidia.com and downloaded the latest drivers . The installer kept on saying no compatible hardware was found so that drove me . It was not until i googled " M17xR4 780m upgrade that i found out the 780m is not compatible the "Legal way" and a INF file modification was in place to get the drivers installed. Again googled M17xR4 780m upgrade drivers, and i found numerous of people crying for help as well. I thought to my self ( i will never see this work today, better try this in the morning, but before i went to sleep i needed some wisdom of a fellow Alien to come to my aid. A guy that goes by tanzmeister replied and guided me. Here is a copy paste for yas.
      These are the links you should check in order to install drivers properly:

      Flashing vBios:
      1- Guide:
      2 - vBios for the 780m

      Modded drivers:

      I am not actually sure these drivers are modded... They might just be "Enhanced". 
      So check out this link as well to learn how to mod drivers yourself (really not that hard)

      To install a modded driver you need to restart Windows with DSE disabled (driver signature). Please google this to find how to do it.
      I personally haven't tried MrFox's drivers but I read they yield fantastic results on Kepler GPU's (780m included) so you can give these a try.
      Everything worked!!!! Red Alert 2 and Age of Empires 2 were running!!!! Joking aside i launched Gta v and The witcher 3 which ran at a decent 30+ FPS. Castlevania Lords of Shadow 1 and 2 i could play at Ultra. I was genuinely happy with my rig.
      Until today, for some reason i wanted to try an unlocked Bios. I was on A13, looked up Drivers on Dell's website and downloaded A12, A11, A10 and A05.
      Did you guess what i did next? I flashed them all one by one, A12 first which was a sucess, A11 which also yielded good results. A10 finished flashing and instead of restarting my Alienware decided to take a nap. 
      Turn it on, and what i feared has happened. I HAD BRICKED MY BIOS!!!!  Pulled my crappy Pentium laptop and googled M17xR4 bricked Bios.
      Thank the merciful lord of forgiveness, of light, of hope, of all that is great. I had stumbles on T|I:
      Following that i Blindly flashed A05 through recovery (which you really do not know what the hell is going on, Put the file on a flash drive, insert it in eSata. Shut down and remove both battery and AC adapter. Hold the END button on your keyboard and plug in your AC-adapter. Fans turn on 100% All the lights where showing, but then it started beeping and i had to go to work in 30 mins so i left it and proceeded to a warm shower. Finishing up and coming back to the room it was still beeping so i unplugged the AC-adapter reinserted the battery and AC-adapter. Pressed the  and voila my tears were sucked back in.
      Thank you for reading, i know i am not much of a writer, but i just wanted to share my journey if someone was thinking of doing the 780m upgrade.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.