Jump to content
Latest News
  • Apologies for the downtime. We had to update our backend and theme.
  • We will continue pushing updates.
  • Apologies for the downtime. We had to update our backend and theme.
  • We will continue pushing updates.
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

WireMesh    34

Will do this ASAP and post pics for you! What about the ultrabay card though? Is it included or how are we to modify it?

EDIT: you posted the second post! Thanks! Working on this now.

Share this post


Link to post
Share on other sites
WireMesh    34

So I installed the mods and everything seems to be going good. Here are some pictures:

Here are the graphics cards before and after:

post-16380-14494996056876_thumb.png

Here are the BIOS screens:

post-16380-14494996061936_thumb.jpg

I plan on purchasing an Intel Wireless-AC 7260 and I will tell how installing that goes later! I might also have a try at some overclocking work... I don't know much though.

post-16380-14494996056298_thumb.png

post-16380-14494996056618_thumb.png

post-16380-14494996057236_thumb.png

post-16380-14494996057493_thumb.jpg

post-16380-14494996058038_thumb.jpg

post-16380-14494996058593_thumb.jpg

post-16380-14494996059143_thumb.jpg

post-16380-14494996059756_thumb.jpg

post-16380-14494996060298_thumb.jpg

post-16380-14494996060847_thumb.jpg

post-16380-14494996061386_thumb.jpg

Share this post


Link to post
Share on other sites
BryanK    10

Hey guys new to the site here but not exactly new to bios mods. Im looking forward to trying out this whitelist removal method in hopes that I can also use the Intel Wireless-AC 7260 (cant wait to hear WireMesh tell us if all works well). However I was curious about one thing. I have the Lenovo y510p and was just looking to do the whitelist, but I see there are steps for flashing something related to the send 750M in the ultra bay. Is this step required? Im thinking its not as it seems like this is a seperate flash to allow for modifying the clocks or others specs of the cards? If im wrong would you mind going into a little detail as to if the Ultrabay flash is required and what it does? Thanks!

Share this post


Link to post
Share on other sites
WireMesh    34
Hey guys new to the site here but not exactly new to bios mods. Im looking forward to trying out this whitelist removal method in hopes that I can also use the Intel Wireless-AC 7260 (cant wait to hear WireMesh tell us if all works well). However I was curious about one thing. I have the Lenovo y510p and was just looking to do the whitelist, but I see there are steps for flashing something related to the send 750M in the ultra bay. Is this step required? Im thinking its not as it seems like this is a seperate flash to allow for modifying the clocks or others specs of the cards? If im wrong would you mind going into a little detail as to if the Ultrabay flash is required and what it does? Thanks!

To my understanding, you could put a new wireless card in just fine with only the BIOS mod, but since one card already is modified to allow for overclocking, it makes no sense to not modify the ultrabay one to be the same.

Share this post


Link to post
Share on other sites
ghoul    27

Hi,

Ultrabay has to be updated, since this mod is covering gpu bios unlock as well, and system bios doesn't containing that.

Probably off topic here...

svl7!

Is there a way, to further unlock vga bios? Talking about allowing on the fly software modification of TDP limits of cards, with like Afterburner.

The reason behind this is the following:

Kepler voltage is automatic, probably based on a voltage table, maybe linked to ASIC quality too.

If you set 1058 mhz, it will run at 1058, with for example 1.056V.

If you set it to +135 which is 1189 it will run at that speed, with 1.056V.

But, if you set it to throttle back, temp or TDP or usage limit, it will throttle voltage too, and will run stable at 1058mhz with 1.006V.

Temp limit is kinda hard to choose, to maintain a stable clock speed, but TDP limit could be.

Or a direct way to edit that voltage table, or be able to offset to negative values.

As seen on attached screens, ultrabay bios can be set to negative offset, but this offset is too low, still higher voltage, idle, load, whatever.

Integrated card can just be offseted to positive values.

Did a quick factory/modded ultraby bios compare in kepler bios editor, attached it via picture, some features still locked.

Unfortunately Svet's bios editor from MSI HQ is currently not supporting these cards.

With this, maybe we can shave a few degree from gpu temperature.

Thanks!

post-17279-14494996063341_thumb.png

post-17279-14494996064054_thumb.png

Share this post


Link to post
Share on other sites
Stardeluxe    12
Flashing the ultra bay 750m - only for SLI users:

I notice that the Ultra bay VBIOS is of a newer version than the "main" GPU (xx.11 vs xx.07). Is it possible to upgrade the main GPU with the same ROM?

Share this post


Link to post
Share on other sites
ghoul    27

I dont think you would benefit anything from that.

And if you extract it from main bios, it has different size.(larger) Bios editor is able to open, seems fine, but could not flash integrated bios into ultrabay. Nvflash said all device id is full of zeros.

Share this post


Link to post
Share on other sites
crazybian    14

Hi,svl7

Can you share the new BIOS? etc v1.09 v1.10

You can remove the windows key from the files.

I want update my laptop bios(v1.07).

Thank you.

Share this post


Link to post
Share on other sites
jugermaut    10

AFAIK, Optimus cannot be disabled. But I think this Lenovo uses iGPU, which might be able to be modified from BIOS.

Share this post


Link to post
Share on other sites
euxoa    10

I get an error 51 when attempting to make a backup of the bios.

"Error 51: An attempt was made to read beyond the end of flash memory"

Any help?

info.txt

Share this post


Link to post
Share on other sites
svl7    5424
Hi,svl7

Can you share the new BIOS? etc v1.09 v1.10

You can remove the windows key from the files.

I want update my laptop bios(v1.07).

Thank you.

Can we turn off Optimus Technology after unlock?

Most likely not, but it depends on how the GPU is connected internally. Most similar Lenovo systems depend on the igpu, e.g. the Y580.

I get an error 51 when attempting to make a backup of the bios.

"Error 51: An attempt was made to read beyond the end of flash memory"

Any help?

Seems like one of the flash parts on your board is not recognized... I need to know it's name, else I can't help you. You could disassemble the system and check which flash chip is installed besides the one that is recognized or maybe if dumped the whole firmware I could figure it out. Try to run the flash tool with -d me.bin -me. It will most likely come up with an error though...

Share this post


Link to post
Share on other sites
euxoa    10
Seems like one of the flash parts on your board is not recognized... I need to know it's name, else I can't help you. You could disassemble the system and check which flash chip is installed besides the one that is recognized or maybe if dumped the whole firmware I could figure it out. Try to run the flash tool with -d me.bin -me. It will most likely come up with an error though...

This is what I'm getting when I use that command. First is with the original fparts.txt, and the second is with the one linked to in the OP. I doubt it's of any use, but I really don't wish to disassemble my laptop at the moment. I may just have to live with the locked down BIOS until I'm feeling less lazy.

post-17361-14494996068619_thumb.png

Share this post


Link to post
Share on other sites
svl7    5424

Well, that looks different than your info.txt file... you should be able to flash the bios with the error 104 fix file.

Share this post


Link to post
Share on other sites
euxoa    10
Well, that looks different than your info.txt file... you should be able to flash the bios with the error 104 fix file.

I am using the fparts.txt file from the 'Error 104' fix.zip file you linked to in the OP.

The first error in that image is the one I get when I use the Error 104 fix fparts.txt file. The second error is the error I get when I use the fparts.txt that was originally included in the Fptw64_(8_series).zip along with the program.

Share this post


Link to post
Share on other sites
svl7    5424

Yeah, then flash the bios with the 104 file, should work fine.

Share this post


Link to post
Share on other sites
euxoa    10
Yeah, then flash the bios with the 104 file, should work fine.

I'm somewhat hesitant to flash the bios without having made a backup first. I can't make a backup because, as I said I get an error 51 when I try to make a backup using the Error 104 fix file.

What are the chances of something going wrong when I attempt to flash it?

Wait, I'm stupid. The flashing process in the OP requires you to make a backup first anyway... How am I supposed to flash it if I can't make the backup?

Share this post


Link to post
Share on other sites
svl7    5424

Well, looking at the information you provided it should work... how exactly did you try to backup the bios?

Share this post


Link to post
Share on other sites
euxoa    10
Well, looking at the information you provided it should work... how exactly did you try to backup the bios?

Exactly as it says in the OP.

The archive contains the files of the program and a .bat file that will create a backup of your BIOS. You need to call the .bat file from an admin command prompt.

post-17361-14494996068861_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By Bos Maior
      Hey guys,
       
      This is a thread for sharing what you have learned about configuring a graphics card using Gerald's Y510p Ultrabay Graphics Adapter. It was created to make it easier for new users to find the information they need to successfully configure and use the adapter on their computer. I consulted Gerald before creating this thread.
       
      Please feel free to post information, insights and tips below.
       
      The Y510P Graphics Adapter
       
      What is it?
       
      The Y510P Graphics Adapter is a card which will allow you to use a full-length PCIe desktop graphics card with a Lenovo Y410p or Y510p laptop. It plugs into the device's Ultrabay. This is the swappable device bay which is, for instance, used for the second NVIDIA card in Y510P SLI configurations.

      Please be aware that the Y510P Graphics Card is only compatible with the Y410p and Y510p. It is not compatible, then, with the Y500 and other Lenovo or IBM laptops that feature an Ultrabay. The Y510P Graphics Card was developed by Gerald, a member of this forum.
       
      What it needs to run - hardware
       
      In addition to the Y410p/Y510p laptop itself, the Y510P Graphics Adapter requires a separate power supply unit (known also as a PSU) to provide the graphics card with electricity. An actual PCIe graphics card is, of course, also required. Please note that only AMD graphics cards will work, seemingly because features of the Y510P embedded controller prevent NVIDIA cards from working as intended.
       
      If you are going to use the power supply unit to power the Graphics Adapter and the graphics card plugged into it only, a 450-watt unit should suffice, at least for current graphics cards. While graphics cards manufacturers may advise you to obtain a more powerful PSU, this is because the PSU would normally also be used to power other components, such as the hard drive and CPU. Note that the Radeon RX Vega 64 and R9 Fury X are exceptions to this rule, as they have been shown to draw close to 500 watts of power when they are under a lot of strain.
       
      What it needs to run - software
       
      Three versions of the Y510P Graphics Adapter exist:
       
      * Version 1: this is the experimental version which Gerald originally posted about.
      * Version 2: this is the version that Gerald sold in 2016 and part of 2017. It requires BIOS version 2.07 and Windows 10 to function. Earlier BIOS versions may also work.
      * Version 3: this is the version Gerald is selling at the moment of writing. Thanks to a discovery first posted to the forums by user David 'Soap' Washington, it should work with any BIOS version. It may also work Windows 7, 8 and 8.1, in addition to Windows 10. I am currently using this version of the adapter with Windows 10, using BIOS version 3.07.
       
      Videos on installing and using the Y510P Graphics Adapter
       
      * Installing the adapter:
       
      - By Tesla: a general introduction on Version 2 of the adapter and how to install it: https://www.youtube.com/watch?v=KL7muHXsAmI
      - By ManyStrongWords/Go'Vic Gaming: a video on installing Version 2 of the adapter: https://www.youtube.com/watch?v=4pviqwFRDn4
       
      * Gameplay/performance:
       
      - By Tesla: using an AMD RX 470 with the adapter: https://www.youtube.com/watch?v=SqdDeZ0UCgc
      - By me: using an AMD Vega 56 with the adapter: https://www.youtube.com/watch?v=PVbsib8eHRg&t=25s
       
      Other useful videos
       
      * Removing the Y510P Ultrabay, by Someone7089: https://www.youtube.com/watch?v=tYcVlaMV0Ig
       
       
      Example of a configuration using the adapter
       
      My own configuration consists of the following:
       
      * Lenovo Y510P with an Intel Core i7-4700MQ CPU, 16 GB RAM and an Intel SSD hard drive;
      * iiyama G-Master GB2888UHSU 4K monitor;
      * Gerald's Ultrabay Graphics Adapter, version 3;
      * AMD RX Vega 56 graphics card;
      * Corsair 450W PSU;
      * OS: Windows 10 Creators' Update.
       
      In order to get this configuration to run well on an existing Windows 10 Creators Update install, I had to do the following:
       
      * Run the monitor at its native resolution. It appears that the current drivers for this card have difficulty repeatedly switching between resolutions.
      * Install the appropriate driver for the monitor, instead of the generic one provided by Microsoft.
      * Disable both the NVIDIA GeForce GT 755M and the Intel HD Graphics 4600 display adapters in the device manager.

      Note 1: removing the drivers for your Intel and NVIDIA display adapters is unnecessary. It is also likely to be futile as, ultimately, Windows may reinstall the driver even if you disable automatic driver updates.
       
      Note 2: an HDMI connection with your monitor should work just fine without you disabling the Intel HD Graphics 4600. A Displayport connection, however, will probably only work as intended if you do disable the Intel display adapter. If you do not do this, Windows will completely duplicate the video output displayed on the internal monitor on the external monitor, including the internal monitor's resolution. Note that this is not the ordinary 'duplicate screens' feature as there is no way to disable it until the Intal graphics adapter is disabled.
       
      A Displayport connection is generally preferable since most Freesync-capable monitors do not support Freesync over HDMI. Also, AMD cards usually do not output colour depths over 8bpc over HDMI connections.
       
      Note 3: should you find that the backlighting of the internal monitor remains on even though only the external monitor is active, all you have to do is press the FN and F2 keys at the same time. This will switch off the internal monitor.
       
      The above instructions may no longer apply. When I installed a fresh copy of the Fall Creators Update, Windows automatically recognised my hardware, monitor included, and I did not have to disable the other graphics adapters.
    • By Klem
      In this thread you can post your requests for Lenovo G710.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
       
      For prepare unlocked bios you should post your request here and then send me your file backup of bios via PM.  For creating backup of bios use attached program. Extract attached archive directly on the Desktop and run the program as administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Klem
      In this thread you can post your requests for Lenovo G500.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
       
      For prepare unlocked bios you should post your request here and then send me your file backup of bios via PM.  For creating backup of bios use attached program. Extract attached archive directly on the Desktop and run the program as administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By finerek123
      Hello everybody.
      Ive got 2 jack 3.5 ports. Microphone and for headphones.
       
      A few month ago i damaged headphone output(just my mistake) and now it doesnt work. Laptop doesnt see connected headphones to headphone port.
       
      On my computer, i can use any port on sound card as microphone or speaker or line in.  In realtek manager i can just switch.  But here i cant. I downloaded old drivers from lenovo website, because on newer one, i cant run realtek manager. On microphone port i can only switch between Line In or Microphone. I dont see headphone option.
       
      Is it possible to do it?
×

Important Information

By using this site, you agree to our Terms of Use.