Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

Guys I am having big trouble here.

Ok so I unlocked whitelist from bios and installed intel n6205 which has dual band support. I believe (I cannot remember clearly but) I tried 2.4ghz and 5ghz connection with my router and worked perfectly. However, I just reinstalled my windows 7 64bit yesterday and I cannot connect to 2.4ghz!!!! I can only connect to 5ghz!!! I mean seems like the wifi card finds 2.4ghz signal well beacuse I see it on my wifi list but when I type in the password and click connect, it says it cannot connect to wifi!!!!

All other desktop, laptops and smart phones work ok worh same router. And even I changed it back to original which was intel n2230 and it worked too?!

Please help me out here!! I have to use this laptop at school and froends house too!! I cant just use 5ghz!!!

Please!!!

Did you plug in the antenna cables properly?

Share this post


Link to post
Share on other sites
Is there a way to mod a y510p bios version 2.7?

As of yet I think we have no mods for 2.4 onwards, we are currently waiting for svl7 to work his magic :Banane04:

Share this post


Link to post
Share on other sites

v2.04 and v2.07 mod added to the first post, whitelist removal only for now. More to follow.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
v2.04 and v2.07 mod added to the first post, whitelist removal only for now. More to follow.

Is 2.07 the newest one that came out to fix SLI in Windows 8.1? If not, does anyone know what version that is?

Share this post


Link to post
Share on other sites
win8.1 SLI issue

you can flash the 2nd VGA card(GT750m)

at win8 run NVFlash.bat with Administrator Account

[ATTACH=CONFIG]9419[/ATTACH]

Yes, I know that. However, I have a different wireless card so I need to make sure svl7's mod works with the BIOS.

Share this post


Link to post
Share on other sites
Is 2.07 the newest one that came out to fix SLI in Windows 8.1? If not, does anyone know what version that is?

I don't know anything about an official bios update, all I got is a dump of that version.

Share this post


Link to post
Share on other sites

One problem with the software realized, if you are running under windows 8.1 you cannot drop just run as a windows 7 and it works like a charm :) now with my ac7260 :) :) :)

Share this post


Link to post
Share on other sites
How does that work? Is the vbios for the first GPU fused with the BIOS?

Yes.

One problem with the software realized, if you are running under windows 8.1 you cannot drop just run as a windows 7 and it works like a charm :) now with my ac7260 :) :) :)

Hmm, works perfectly fine for me on Win 8.1... might be an issue with your .NET config. The app will require 4.5 I think.

Share this post


Link to post
Share on other sites
Yes.

Hmm, works perfectly fine for me on Win 8.1... might be an issue with your .NET config. The app will require 4.5 I think.

Well i do have 3.5 4.5 as far as i can, but nevermind it was an easy work around :) i am already running the modded bios so i am happy :) (i am on the 2.04) and can tell no errors along the way.

Share this post


Link to post
Share on other sites

Thanks for the 2.04 bios whitelist.

I am currently running this bios; 2.04.

Do any of you people know what's changed from 2.04 to 2.07 in the official bios ?

Can i just download the 2.07 whitelist bios and flash it ?

Best regards

Share this post


Link to post
Share on other sites
Did you plug in the antenna cables properly?

yup. but I found the problem. somehow the n6205 doesnt work with y510p because n2230 and ac7260 works fine. only n6205 doesnt work on y510!!!!

Share this post


Link to post
Share on other sites

Allright, I've been motivated by techinferno to switch from "lurking" to posting :-). I've been keeping an eye on this thread for awhile and just got my y410p a few days ago (has bios v. 2.07). swl7, thank you so much for helping everyone out! As soon as I get my post contribution in I'll be flashing as well and tossing you a beer (or whatever that equates to...that's an excellent idea by the way).

Honestly, and I recognize I'll be kicking myself if I brick this thing, but this thread and your efforts are why Lenovo is not getting a return from me. Thank you!

Share this post


Link to post
Share on other sites
For those who don't like the restrictions put on their system by Lenovo, here's a BIOS mod that will get you back at least some of the freedom you should have over your own hardware.

Features:

- Wlan whitelist removed, any (hardware-wise compatible) card should now work

- hidden BIOS menus unlocked

- VBIOS tweaked for more performance and better tuning possibilities

Keep in mind that not necessarily all of the BIOS options available with this mod will function completely, so use the new functionality with care. If you're unsure about something don't change it and ask here, someone might be able to help.

This is currently only for v1.07 / v1.09 / v1.10 users. If you have a different BIOS I will need a copy of it in order to make it work for your system.

EDIT: v2.04 and v2.07 added (only whitelist removal as for now, more to follow).

Instructions:

  • Create a backup of your own BIOS by using this tool.
    The archive contains the files of the program and a .bat file that will create a backup of your BIOS. You need to call the .bat file from an admin command prompt.
    Don't delete your backup file, you will need it in case you want to go back to the stock BIOS some times. Also don't share it since it contains your personal Windows key including activation.
    .
  • Download the attached BiosFixer, simply drag and drop your BIOS backup on it and it will create your personal mod for you.
    .
  • Flash the modified file with the tool from the first step, use the command below:
    fptw64 -f v1xxMod.bin -bios


    .

  • Wait for the flash process to finish, if you don't get an error reboot. (You can safely ignore warnings about non-existing regions).
    .

If you get and 'Error 104' when trying to flash, grab this archive and extract the file to the folder with the flash tool. Overwrite the original one.

In case you still get the error after doing this, run fptw64 -i > info.txt and attach the .txt file to a post here, then I should be able to help you.

Can someone please post some pictures of the bios menus? Thanks.

A screenshot of Nvidia Inspector showing the OC part would be nice as well, just for visual confirmation. I don't have a system to test it myself.

My donation link in case you want to buy me a beer ;)

I got a " Error 200: Invalid parameter value specified by user. Use -? option to see help. " when trying to use the ftpw64. it just asks "press any key to continue," and after that it returns an error 200. seems only me get this here

Share this post


Link to post
Share on other sites

The file for v2.xx bios versions is called v2xxMod.bin, so make sure to adjust that.

Share this post


Link to post
Share on other sites
The file for v2.xx bios versions is called v2xxMod.bin, so make sure to adjust that.

post-18848-14494996342578_thumb.jpgI have everything in a same folder.

- - - Updated - - -

The file for v2.xx bios versions is called v2xxMod.bin, so make sure to adjust that.

post-18848-14494996342899_thumb.png

I run it in cmd. otherwise, it will flash out, and not able to capture a pic.

did I do anything wrong?

post-18848-1449499634269_thumb.png

Share this post


Link to post
Share on other sites

It's a command line application. In the folder where you have those files stored click on 'File' then move your mouse to 'Open command prompt' and then click on 'Open command prompt as administrator'. Then type the command specified above.

Share this post


Link to post
Share on other sites

I just ordered my ac 7260

So any thoughts on the wake up problem with ac7260?

did you face that ?

Share this post


Link to post
Share on other sites
It's a command line application. In the folder where you have those files stored click on 'File' then move your mouse to 'Open command prompt' and then click on 'Open command prompt as administrator'. Then type the command specified above.

How stupid I was! Thank you very much for your work, very valueable help and patient. Now I am using the new 7260 and I am looking forward to see your v2.04 2.07 bios unlock mod.

Thank you vey much

Share this post


Link to post
Share on other sites

I've almost got enough posts to start in on the mod for my y410p. I checked my bios version, and I'm running 1.07 at the moment. I'm wondering if updating to 1.10 before the mod is applied would really be worth it. Coming from a Desktop background, I'm accustomed to updating to the most recent BIOS, but I want to shy away from 2.x for now since there's no unlock mod available yet.

Would there be any advantage to upgrading to 1.10 before modding, or should I not bother with it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By GrayCryptoSpordium
      Well everyone...I have a confession to make-I flashed svl7 modified 970m vbios before I wiped my drivers! Everything seemed to run fine, I could game but noticed my clocks fluctuating a bit crazy. Figured I'd try a OC profile in afterburner while running a 27 27 26 26 clock in TS a bit stupid I know. Well 3d mark froze so I did a reboot...Black Screen on startup I heard windows boot so I feared I bricked my card. Tried external monitor..works fine. This is where my stupidity really hit the cosmos. I had another m15x 900p LCD laying around plugged that in. Worked fine back too overclocking bro! Well same thing happened. My profile was not overly crazy as I can remember. But I bricked another screen. Plugged in external monitor everything fine. I was using latest nvidia drivers 436.48 I believe. So I wiped drivers using DDU. Reflashed to stock clevo bios. Tried both LCD again still nothing. Installed old 7970m still nothing. Cleared CMos again nope. Reinstalled 970m with svl7 vbios with newest driver and been gaming on my external monitor. Have done some OC with inspector. Everything seems to work as it should. Temps and performance are great. Did I brick my monitors??? Never heard of this problem. 
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.