Jump to content
Apologies for the spam Read more... ×
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

I am considering installing the unlocked Bios in order to disable hyperthreading. Does anyone know if the unlocked Bios would, indeed, allow me to do so?

Currently I've set a Linux kernel option to disable hyperthreading, but apparently using the Bios to do this gives slightly better performance.

Share this post


Link to post
Share on other sites

I have question.
At the moment I read Your post on theme lenovo Y510p.
When I will did update, which WiFi card can I use (type).
There is new mod for bios Version 3.08?
How I understand (now) i have version 3.08 i must make downgrade and replace.

 

Share this post


Link to post
Share on other sites
Posted (edited)

So I successfully updated to the 3.05 modded BIOS on my Y410P but I screwed up afterwards. I noticed some odd stuttering in the games I was playing after teh mod so I fiddeled with someof the graphics settings.

Needless to say I did a right good job bricking the machine...

Now the system boots but does not show a display.

Things I've tried:

- FN+R with the 3.05 Crisis file but I get the 9 short beeps error for incorrect ROM.

- Attempted the steps listed here with no success.

 

Edited by Lain

Share this post


Link to post
Share on other sites
37 minutes ago, Lain said:

Now the system boots but does not show a display.

Hi!

In this case try to execute next steps:

1. Completely disable laptop with long press and hold the Power button.

2. Press and hold F2 button, and start laptop (to go in bios setup menu).

3. Press F9 button, then Enter button. Then press F10 button, then Enter button.

Done.

Share this post


Link to post
Share on other sites
1 hour ago, Klem said:

Hi!

In this case try to execute next steps:

1. Completely disable laptop with long press and hold the Power button.

2. Press and hold F2 button, and start laptop (to go in bios setup menu).

3. Press F9 button, then Enter button. Then press F10 button, then Enter button.

Done.

 

I went through the steps you suggested.

I held the power button down till it power cycled once.

Then did the F2, F9 enter, F10 enter.

I still don't have a screen but I believe the bios is now reset since I get a short PC beep if I connect or disconnect power,

Share this post


Link to post
Share on other sites
Posted (edited)

By any chance did anyone create a Yx01.bin crisis file for the 3.05 bios mod?

Edited by Lain

Share this post


Link to post
Share on other sites
5 hours ago, Lain said:

I held the power button down till it power cycled once.

No, you need to completely disable laptop (Power of).

Then press and hold F2 button, then start laptop ( after laptop starts, F2 button still hold 3-5 sec). Then release F2 button, then press F9 button, then Enter button. Then press F10 button, then Enter button.

Done.

Share this post


Link to post
Share on other sites

I have Lenovo IdeaPad Y510p

Bios 3.08

Intel Core I7-4700MQ

HDD SR1000LM14-8SSHD-8GB

HDD SAMSUNG SSD 860 PRO 256GB

Intel Centrino Wireless-N 2230

NVIDIA GeForce GT 755M

 

When I connects to router I have 60-65Mb. The connect is stable.
But when I do not uses laptop (for example 2 hours) WiFi speed decreases Max 30-35Mb and not increases when I start uses laptop.
I have to make manualy reconnect with router, and I have again 60-65Mb.
Where is the problem...?

I have driver Intel: 15.18.0.1, Windows 10 x64

The drivers from M$ working the same bad.

 

How I can resolve problem?
Only update BIOS on 3.5 MOD can resolve it?

My laptop is compatible with this BIOS?

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Klem said:

No, you need to completely disable laptop (Power of).

Then press and hold F2 button, then start laptop ( after laptop starts, F2 button still hold 3-5 sec). Then release F2 button, then press F9 button, then Enter button. Then press F10 button, then Enter button.

Done.

Followed your instructions but nothing is happening. Also it seems the caps lock light is on and won't turn off by pressing the caps lock key. Is that trying to tell me something?

Edited by Lain

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/15/2019 at 10:50 PM, Lain said:

Followed your instructions but nothing is happening. Also it seems the caps lock light is on and won't turn off by pressing the caps lock key. Is that trying to tell me something?

 

I'm did it.
In the evening I'll let you know.
Now after reset I have Default - set.

 

The problem still exists :-( 2019-06-16 10:56 PL

 

Hi,

Maybe someone has any idea?
How can resolve this problem :-)
Change Power options nothing give. 2019-06-17 22:40 PL

Edited by Artur

Share this post


Link to post
Share on other sites

I'm trying to download Lenovo_Y510p-Y410p_[v3.05]_modified.zip, but I'm getting this message.  Is there another download link for this file?

 

==========================

If you are unable to download this file, it may be due to one or a combination of the following reasons:

 

  • Your account lacks the proper credentials to access this download (e.g. T|I Elite or promoted permissions). 
  • Your account has not been validated or may have been disabled due to violations.
  • The download is restricted to certain permission groups which you are not a part of currently.

Share this post


Link to post
Share on other sites
5 hours ago, tekm8n said:

I'm trying to download Lenovo_Y510p-Y410p_[v3.05]_modified.zip, but I'm getting this message.  Is there another download link for this file?

 

==========================

If you are unable to download this file, it may be due to one or a combination of the following reasons:

 

  • Your account lacks the proper credentials to access this download (e.g. T|I Elite or promoted permissions). 
  • Your account has not been validated or may have been disabled due to violations.
  • The download is restricted to certain permission groups which you are not a part of currently.

Hi!

You can read "User Account Promotion Rules":

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

Share this post


Link to post
Share on other sites
Posted (edited)

Can I ask You about advice?
 

BYU

 

There is a few available models..., which can I buy?

 

Edited by Artur

Share this post


Link to post
Share on other sites

Now I have Bios 3.08
When I want update to Bios MOD, Have to:
1. Make downsize to version 3.05 (Bios Lenovo) - Ok.
2. But I do not understand point (3) instruction
    I have to downsize version BIOS 3.05 to 2.07...?

Share this post


Link to post
Share on other sites

Hi,

I have question on theme 7260HMW 867M BT4.0 802.11ac Mini PCI-E Wifi Card card.
Now I have Centrino N-2230 and few problems. When I not uses computer, speed card downgrade to 30-35Mb and not returned to 60-65Mb. I have Internet 60Mb.
Speed connect form computer to router is 300Mb - 2.4GHz

 

Card AC 7260 is stable?
Can someone check own speed connect to Internet for example before and after when You uses the computer. Pause use for example 2 hours.

Share this post


Link to post
Share on other sites
Posted (edited)

I checked my N-2230, I tried change power settings. Any changes and changed bios to version 3.05 (Stock) not give any effects.
Someone try check stabilize connect for 7260HMW??

Edited by Artur

Share this post


Link to post
Share on other sites

Hi,

I did flash bios version 3.05...?

=> ViQYx

=> 74CN44WW(V3.05)

 

In Bios laptop I see version 3.7

It is correctly?

Share this post


Link to post
Share on other sites
35 minutes ago, Artur said:

In Bios laptop I see version 3.7

It is correctly?

Hi!

Yes, it's correct.

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, Klem said:

Hi!

Yes, it's correct.

 

Thanks,

Alpha Centauri is far from Poland :-)
But I have question on theme Update...
1.)  I did points instruction 0 - 2.
2.)  Can I have to before flash I must downgrade bios in laptop to 2.7...? I reads this point correctly?
3.) Points 4-6 are clear.

 

I have question... how something will make bad?
For example: I assume, I can make only run Laptop from USB. Flash - did not go.

How can I make install - backup bios or bios from Lenovo?

Edited by Artur

Share this post


Link to post
Share on other sites

Thanks so much for the bios mod! I have been searching for a long time and finally found this, and my troubles have dissipated. 

Share this post


Link to post
Share on other sites

Help.. Step 3.. "BIOS Version compare error!" WHat does that means?

Screenshot (161).png

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for sharing. Recently I search a lot finding a way to enable "wake on lan" feature on my y410p. I can wake my laptop with my phone or router through ethernet cable at sleep, but I couldn't wake on lan when it's hibernate or shutdown. My current bios version is 3.05 and I never modded it before. I haven't flash it yet and i read a lot pages in case I ruin it. Does anyone succeed in enabling the wake on lan with modded bios? Thanks in advanced. 

Edited by wdnmd

Share this post


Link to post
Share on other sites

My laptop is lenovo y410p. The system is windows10 home 1903. My original bios version is 3.05.

I want to boot my laptop without opening the lid and pushing the power button. Then I found WOL(wake on lan) may help me. After some configuration in the device manager I can wake my laptop when it's in sleep state by sending magick packets from my phone or the router. But WOL couldn't work BOTH at HIBERNATE or SHUTDOWN.

I flashed this mod because I really want to use wake on lan feature at shutdown state. Everything goes smoothly when I flashed the modded bios. Then I try everything to make WOL(when shutdown) including bios settings, configs in device manager update or down grade drivers but at last I failed. Here is  my detail attempts.

1. bios settings

  I load default settings first after flashing the bios. Then I tried everything might related to wol in bios. 

  Configuration->Deep S3 Function----Disabled (I don't know if this matters)

  Advanced->Periphernal Congfiguration->Lan----Enabled

  Advanced->Periphernal Congfiguration->SLP_LAN# Low on DC Power----Enabled

  Power->Wake on PME----Enabled

  Power->Wake on Lan----Enabled

2. software configs.

  My network card is Qualcomm Atheros AR8187/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30). In device manager->properties->power management tab I have all the box checked. In advanced tab , Energy Efficient Ethernet--Disabled, Shutdown Wake Up--Enabled, Wake on magic packet--Enabled, Wake on pattern match--Enabled.

Also I have "fast boot" unchecked in power management. 

3. Drivers.

  For the network card the driver versions I tried: 2.10.16(windows default driver), 2.10.17(for win7-64bit, from lenovo drivers support website), 2.10.21(for win8.1-64bit, from lenovo drivers support website), 2.10.25(for win7-64bit, from https://www.ath-drivers.eu/download-driver-for-Atheros-chipset-with-id-89-and-Windows7-64bit.html), 2.10.27(for win10-64bit, fromhttps://www.ath-drivers.eu/download-driver-for-Atheros-chipset-with-id-127-and-Windows10-64bit.html)

 

Something I notice:

1. When laptop sleep the network adapter has light on, and I can wake on lan works good. But when laptop hibernate or shutdown, no light on the network adapter.

2. I bought this y410p from China. As far as I know it's has different hardware to American edition. Chinese edition has lower resolution(1366x768) and American edition is higher(1600x900). Chinese edition does't have backlit keyboard, while American edition has. 

 

I hope someone can help me enable this feature. I really need wake on lan at shutdown state. Any advice is appreciated. 

 

MVIMG_20191006_142913.thumb.jpg.7d69873cb98148a189adb8cbe9433990.jpg

IMG_20191006_142952.thumb.jpg.868dade020e7491d5a3653189faa2d7b.jpg

 

IMG_20191006_143054.thumb.jpg.951c3ed492a789e4f4ae0715430e263d.jpg

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/8/2015 at 5:15 AM, chris1870 said:

Is it possible to add another feature to a bios? I need the wake on wlan feature (wake on lan works tho). I´m searching my a**** off to get this done. Only problem is that the intel smart technology is not enabled in the bios. But its implemented in the y510p intel wireless n-2230 card. That smart technology is available in the bios of other ideapad laptops so I wanna know if its possible to add it to the y510p bios somehow? I´d be willing to pay for anybody that can help me or create this modified bios. When I try to go to the device manager on the wireless card I can only see "allow this device to wake up the computer" is greyed out. So I think a custom bios with intel smart support is the only way?

@chris1870 I'm struggling with wake on lan now. My laptop is y410p and I can only wake my laptop at sleep state. WOL won't work if hibernate or shutdown. Could you give me some advice or tell me how do you have "wake on lan" feature work on your laptop? Thanks in advanced. 

 

By the way I do see Intel Smart Technology configuration in this modded bios. But I don't know if it works because I don't have an intel network card. I use bcm94352 as my wireless card. 

4.thumb.jpg.8f6ea3e1688f5d513cd25e42961faad6.jpg

5.thumb.jpg.cdc31ed11ac0c5e75c61cb1fec1e8cb2.jpg

Edited by wdnmd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By GrayCryptoSpordium
      Well everyone...I have a confession to make-I flashed svl7 modified 970m vbios before I wiped my drivers! Everything seemed to run fine, I could game but noticed my clocks fluctuating a bit crazy. Figured I'd try a OC profile in afterburner while running a 27 27 26 26 clock in TS a bit stupid I know. Well 3d mark froze so I did a reboot...Black Screen on startup I heard windows boot so I feared I bricked my card. Tried external monitor..works fine. This is where my stupidity really hit the cosmos. I had another m15x 900p LCD laying around plugged that in. Worked fine back too overclocking bro! Well same thing happened. My profile was not overly crazy as I can remember. But I bricked another screen. Plugged in external monitor everything fine. I was using latest nvidia drivers 436.48 I believe. So I wiped drivers using DDU. Reflashed to stock clevo bios. Tried both LCD again still nothing. Installed old 7970m still nothing. Cleared CMos again nope. Reinstalled 970m with svl7 vbios with newest driver and been gaming on my external monitor. Have done some OC with inspector. Everything seems to work as it should. Temps and performance are great. Did I brick my monitors??? Never heard of this problem. 
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.