Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

My Y510p is bricked.

Boot but no image on display, can`t enter bios.

All I done is to set UMA only and set 300ms at video setup.

How to do emergency BIOS recovery for Y510Y?  With 3.05 stock bios and only Yx01.bin from Crisis folder on USB stick don`t work with FN+R 

 

 

Share this post


Link to post
Share on other sites

@dan71 Try to hard reset your bios settings by dissembling your y510p and manually removing the coin cell battery on the motherboard.

Share this post


Link to post
Share on other sites

THx for this job ..... Can we control the fan speed  ??

Share this post


Link to post
Share on other sites

Already try that, only coller start to spin and keyboard light up

Share this post


Link to post
Share on other sites
9 hours ago, dan71 said:

Already try that, only coller start to spin and keyboard light up

Found there is no need to unsoldered coin lithium for bios, under lover sodimm you will find 2 contact for reset.

But this not solve my problem still bricked

I will buy my bios chip from ebay, change it and I will unlock again, but not use it for eGPU.

 

Edited by dan71
Add some

Share this post


Link to post
Share on other sites
19 minutes ago, dan71 said:

Found there is no need to unsoldered coin lithium for bios, under lover sodimm you will find 2 contact for reset.

But this not solve my problem still bricked

I will buy my bios chip from ebay, change it and I will unlock again, but not use it for eGPU.

 

Desoldering the CMOS battery and soldering it back on worked for me but only twice was I able to boot into my OS.

Unfortunately I wasn't able to reproduce these results. I just need to boot into my OS one last time so that I can flash my bios back to stock.

Where are the reset contacts specifically, can you post a pic of it?

Share this post


Link to post
Share on other sites

A user by the name of Lizzo said that he had desoldered both BIOS chips and swapped their placements. Does anyone know which BOIS chip is the primary one and which one is the secondary?

I'm thinking of desoldering one of them and trying to boot to see what happens but I wanna desolder the primary one (since that's the one holding the bad BIOS settings.

Share this post


Link to post
Share on other sites

UPDATE: I swapped the bios chips I didn't get past POST. The laptop turns on for a few seconds, turns off, turns back on with fans at full speed then turns off and stays off.

Not really sure what to do at this point. I tried this once without the CMOS battery in and the second time I soldered it back on. Made no difference.

I guess the only solution at this point would be is to order a new BIOS chip and solder it on and see what happens. Not sure if I need to order two of them and replace both chips or just one.

If there's anyone out there that can help or give any information on where I can get a new BIOS chip, Please, help me out.

I know there's still hope on fixing this but I'm out of solutions, anything will help at this point.

Share this post


Link to post
Share on other sites
3 hours ago, dan71 said:

Found there is no need to unsoldered coin lithium for bios, under lover sodimm you will find 2 contact for reset.

But this not solve my problem still bricked

I will buy my bios chip from ebay, change it and I will unlock again, but not use it for eGPU.

 

Let me know where you buy the BIOS chip from, and if you're gonna buy both the BIOS and EC chips.

Lucky for me, I have a universal programmer that is able to program the BUOS chip but I'm not sure how I'm going to connect the chip to the programmer.

Since the pins are so tiny on the BIOS chip I'm thinking of soldering each pin to a thin wire and connecting those wires to the programmer.

Let me know if the new chips work for you and where you bought them from. I hope they work.

Share this post


Link to post
Share on other sites
11 hours ago, Imrule said:

UPDATE: I swapped the bios chips I didn't get past POST. The laptop turns on for a few seconds, turns off, turns back on with fans at full speed then turns off and stays off.

Not really sure what to do at this point. I tried this once without the CMOS battery in and the second time I soldered it back on. Made no difference.

I guess the only solution at this point would be is to order a new BIOS chip and solder it on and see what happens. Not sure if I need to order two of them and replace both chips or just one.

If there's anyone out there that can help or give any information on where I can get a new BIOS chip, Please, help me out.

I know there's still hope on fixing this but I'm out of solutions, anything will help at this point.

Both have numbers UH52 and UH53.

On Ebay they are sold in pair 25Q16DV (UH52 on our laptops) and 25Q32FV (UH53). I think 52 is primary but no sure.

JCMOS1 jumper done same thing as a desoldered coin lithium battery. 

This Lenovo laptop is for testing and learning only as I have a 17" Acer i7 with eGPU Asus 20161030_093636.jpgGTX1060 on it.

But when I use same setings on both laptop on Bios video settings Lenovo got bricked.

Share this post


Link to post
Share on other sites

Imrule, if you have a bios programmer there is no need to buy new chips, just put a stock 3.05 or 3.08 on both.

Then downgrade to 2.07 and upgrade to 3.05 modded

Place order on Ebay and now way my bios to come got last pair :)

http://www.ebay.com/itm/BIOS-Chip-LENOVO-Ideapad-Y510P-Dual-chips-/400641799916

Edited by dan71

Share this post


Link to post
Share on other sites
19 hours ago, dan71 said:

Imrule, if you have a bios programmer there is no need to buy new chips, just put a stock 3.05 or 3.08 on both.

Then downgrade to 2.07 and upgrade to 3.05 modded

Place order on Ebay and now way my bios to come got last pair :)

http://www.ebay.com/itm/BIOS-Chip-LENOVO-Ideapad-Y510P-Dual-chips-/400641799916

Thanks Dan, I have been able to reprogram the 25Q32DV which I believe is the chip that holds the BIOS info, but I don't have a EC dump to flash the 25Q16DV.

I found a link on this site but it didn't seem to work.

I have place an order already and waiting for them to ship it, in the mean time I was thinking I'd try to reprogram these chips and see if I can salvage them.

Do you have a dump of the EC I could use? I found one on this site but it didn't seem to work. It just caused my laptop to turn on and off with fans going at full speed.

 

Share this post


Link to post
Share on other sites

Ha, ha... when I place my order was last pair, now... another last pair :)).

Sorry but I don`t have any dump for 25Q16.

Share this post


Link to post
Share on other sites
On 10/31/2014 at 5:14 PM, elementalfx said:

Hi. Did anyone attempted to solder new bios chip after bricking?

I have seen that some company is selling bios chips for our laptop. I am probably going to buy it. I havent bricked my laptop(jet) but just in case it happens I will have those chips.

BIOS Chip:LENOVO Ideapad Y510P (Dual chips) | eBay

I have also seen other seller but its for Y510, they look same but I dont know if they are actually same, as they come preprogrammed already.

Lenovo IdeaPad Y510 (15303) Bios-Chip24.com

Also I am looking forward to buy this programmer if the chip will be compatible. I contacted the seller that I want to make sure what is the part number for bios chip of our laptop. I am too lazy to dissasemble my laptop again to look what part number it is :D

http://www.ebay.co.uk/itm/SPI-Flash-Programmer-WINBOND-ST-PMC-MXIC-ST-SST-ATMEL-/290587546215

Edit: It seems like chips in our laptop are Winbond 25Q32FV and Winbond 25Q16DV And they are pretty cheap to buy on aliexpress.com even if you buy them in bulk so in any case cost of chip plus programmer is cheaper rather than sending it to lenovo.

I ordered one of those chinese programmers. SP8-B SPI Programmer to be specific as it supports the chip we have in y510p and tommorow I am gonna order chips. I have to buy 10 of each but they are cheap. At least I have spare ones just in case.

I found this from another post which this user provided the dump of the EC chip but unfortunately it did not work for me.

I reprogrammed my 25Q32FV chip with my original bios backup and reprogrammed my 25Q16DV with his dump but it didnt work.

My laptop just turns on with the fans at full speed and then turns off. I know my bios backup is good but i dont know if the dump he provided was good.

I thought I might want to share this with others.

Share this post


Link to post
Share on other sites

is there another source to download ? My wireless card went south ... to the point I'm using a 30 foot ethernet cable. I want to download the files today. The link on the cosmo site is not working.

Share this post


Link to post
Share on other sites

So I found the files on the mirror provided and I encountered a few issues:

 

1) Could not get the FPTW64 to run. Discovered the BAT file is not running the correct command its missing the .exe). Work around is to open command prompt as admin - go to FPTW64 directory and run this command: fptw64.exe -d bios.bin -bios

 

2) Could not get the DOS Create file to work... is it ok to use something else and use freedos instead ?

Share this post


Link to post
Share on other sites
22 hours ago, redfox85 said:

So I found the files on the mirror provided and I encountered a few issues:

 

1) Could not get the FPTW64 to run. Discovered the BAT file is not running the correct command its missing the .exe). Work around is to open command prompt as admin - go to FPTW64 directory and run this command: fptw64.exe -d bios.bin -bios

 

2) Could not get the DOS Create file to work... is it ok to use something else and use freedos instead ?

Yes you can use freedos.

Share this post


Link to post
Share on other sites

I got it going... oddly when trying to do the EC flash it gave me a memory buffer 2 allocate failed error msg. A reboot cleared the issue though. Also, noticed I cant boot in pure UEFI mode, have to use Legacy Support. Small price to pay.

Share this post


Link to post
Share on other sites

Tried a couple of times, I'm always getting this:

 

Using Y510P Core i7 4700 Dual GPU GT750M

 

I was on 3.07 originaly, so I did:

-Flashed 3.05

-Created the hacked v305mod.bin

-Installed 2.07 stock

-Rebooted with USB thumb drive, then I ran bios and I get this

(The error when running EC is also there)

 

What am I doing wrong?

 

Thanks!

IMG_20161109_175715.jpg

Share this post


Link to post
Share on other sites

Nevermind my post, turns out you don't need to copy the whole win98_files folder after, all those apps end up loaded in the ram and saturate the thing!

 

Tried it without coping everything and it worked great!  Now I have my 7260 working!!

 

Still, one question:  Do I need to do the whole nvflash procedure if I don't intend to overclock the GPU (I have the SLI setup)?

 

Edited by t1mman

Share this post


Link to post
Share on other sites

Please help 
Flash bios successful installed with no error but when i run EC i have this error:
dos memory buffer 2 allocate failed
Any solution ?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

my battery is dead can i do it without battery ?

i fixed battery bios flashed without error but on EC command errors  dos memory buffer 2 allocate failed help pls

Edited by tecnicksx

Share this post


Link to post
Share on other sites
On 11/11/2016 at 8:03 AM, t1mman said:

 

Still, one question:  Do I need to do the whole nvflash procedure if I don't intend to overclock the GPU (I have the SLI setup)?

 

 
1

 

This is something that I would also like to know.  Because I could care less about the other mod features all I need is the whitelist removed.

 

On 11/8/2016 at 4:38 PM, redfox85 said:

 

1) Could not get the FPTW64 to run. Discovered the BAT file is not running the correct command its missing the .exe). Work around is to open command prompt as admin - go to FPTW64 directory and run this command: fptw64.exe -d bios.bin -bios

 

 
1

 

I tried your fix but all I seem to get is Error 75 and Error 201. After looking into it. Some y510p reject FPTW64 and doesn't allow it to work. The alternative supposedly is to use  the Universal bios backup toolkit which looks a lot easier to use than FPTW64 the problem is I can't find a download anywhere. If anyone knows where to find a working link please link it to me. I also heard that Backup tools 12 is another FPTW64 alternative if anyone can find a download link of that. As it has also magically been wiped off the internet along with the Univeral Bios Backup Toolkit.

 

UPDATE:

 

I found the Universal Bios Backup toolkit. The problem is it gives me a .rom and not a .bin.

What do I do now? 

 

Or how do I fix the FPT 201 Error? It says that it is not operational on my platform.

 

Please help.

Edited by blueluke234

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      NVIDIA 'Maxwell' VBIOS mods
       
       
      Here you find modified VBIOS versions for the mobile parts of the Nvidia 'Maxwell' series.
      The VBIOS versions in this post are tweaked for performance and versatility. You'll get almost complete control over the performance parameters of your GPU.
      List of available VBIOS mods:
       
      Nvidia GTX 970m - 'OC edition' rev0 - >> 6 GB Version << - modified by @johnksss & svl7 -> see attachments Nvidia GTX 980m - 'OC edition' rev0 - >> 8 GB Version << - modified by @johnksss & svl7 -> see attachments  
      Screenshot demonstrating the capabilities of the 970m versions:

      >> Read the instructions carefully before flashing! <<
      If anything is unclear after reading or if you have additional remarks, please post in the thread.
       
      Flashing:
       
      - Go to the device manager -> 'Display Adapters' -> chooser your GPU, right click on it and choose disable
      - Flash the VBIOS with mnvflash, a modified version of nvflash (see attachments). Here are detailed instructions for nvflash in case you aren't familiar with it.
      - After the flashing is done: Enable the GPU once again in the device manager.
      - Reboot
       
      Do NOT use driver 347.09, it's broken and useless and won't allow you to overclock, even with the stock firmware.
      Don't distribute the files hosted here outside of Tech|Inferno. Don't modify the files you download here.
       
      Donation link in case you want to buy me a beer

      Thanks and cheers!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.