Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

The last version on Lenovo website is 3.08. Maybe we can get this version modded?

For revert back to a stock version you have to enable flashback in bios. I think there is a tutorial at the beginning of the topic .

Sent from my HTC One_M8 using Tapatalk

Share this post


Link to post
Share on other sites

I'm having some issues enabling backflash. I enable the backflash option in the bios, but it resets to disabled every time I reboot

Sent from my Nexus 5 using Tapatalk

Share this post


Link to post
Share on other sites

Anybody wants to share their modded version of BIOS v.3.08 please?

Also I'm not sure but it seems that I would also have to mod vBIOS for my Y510p since I have dual GT 750M. How do I do that?

Share this post


Link to post
Share on other sites

I've realized that it would be easier and a lot faster to downgrade to BIOS v.3.05. Unfortunately it is not available on the Lenovo website anymore and so I had to spend a lot of time looking for it. Found it within this thread and successfully downgraded to 3.05 (had to enable BIOS backflash first). Now I've ran into more problems as soon as I started with the actual manual from the first page. Tried to backup BIOS but it does nothing. Extracted all the files into 1 folder and followed exactly what it says in the manual but NOTHING!!! WTF am I doing wrong?

Share this post


Link to post
Share on other sites

Ok, so I finally managed to flash both my BIOS and vBIOS but I wish the instructions were clearer especially for those who don't know much about computer hardware or still learning.

Share this post


Link to post
Share on other sites

svl17 is their a bios mod for less voltage on cpu and gpu? i live in a place where its very warm and instead of a modded bios that has higher clocks on gpu on my y410p with the 750m, i would appreciate a lower voltage settings... i have reasearched and tried various voltages with Intel Utility and the Nvidiainspector... cpu can work really well with -100mv with turbo off... and gpu can do really well at 0.9 volts with a 925mhz core clock

i wonder.... if this can be achieved... specially the gpu voltages since i have recently bought a Ultrabay GT750m5 and the temperature issues that have been posted by other people really concern me, maybe with lower voltages using the 2 gpus dont need to be capped at 60FPS

thanks for your time :tears_of_joy::tears_of_joy:

Share this post


Link to post
Share on other sites

Sup people. I hope this doesn't go unaware. I've managed to successfully upgrade from a crappy 2230 centrino wireless card to an Azurewave - Broadcom BCM-4352, but I've seen that the wireless signal is poor (like 50% of what it originally was).

What could it be? Could it be the modified BIOS?

Thanks in advance!!!

Share this post


Link to post
Share on other sites

ok, so I read about 100 pages of this thread and I have a pretty good idea of what I want to do.

Could someone please confirm the following things -

1) I have BIOS 3.05 and I only want to undervolt my Ultrabay GPU. (as it is over heating)

2) Can I undervolt my Ultrabay, just by flashing the VBIOS or do I need to flash the BIOS as well?

3) Do I need to go down to 2.07 BIOS in order to flash the VBIOS?

My CPU is under control with max temp of 80, my main GPU is fine with max temp of 80.

My Ultrabay GPU reaches 98 (on demanding games).

Thanks.

Share this post


Link to post
Share on other sites

Not sure if this is posted or not, so trying again -

ok, so I read about 100 pages of this thread and I have a pretty good idea of what I want to do.

Could someone please confirm the following things -

1) I have BIOS 3.05 and I only want to undervolt my Ultrabay GPU. (as it is over heating)

2) Can I undervolt my Ultrabay, just by flashing the VBIOS or do I need to flash the BIOS as well?

3) Do I need to go down to 2.07 BIOS in order to flash the VBIOS?

My CPU is under control with max temp of 80, my main GPU is fine with max temp of 80.

My Ultrabay GPU reaches 98 (on demanding games).

Thanks.

Note: I can delete this if it is duplicate or the mods can delete it.

Share this post


Link to post
Share on other sites

About my system - GT755M SLI - Ultrabay heating upto 98 degrees within 15 min. Ambient temp is 28 - 35 degrees

So, since I had to do this, I did the entire process, followed each step meticulously. Couple of things missing and may cause problems for some users -

1) To Back flash 2.07, you need to ENABLE the BIOS back flash function in BIOS menu. This can be done at the starting of the process.

2) When you create the DOS bootable USB, it will look empty.

3) If you are trying to boot DOS from USB and it doesnt work, you will need to go into BIOS and set the boot mode to 'Legacy Support'. and then priority as 'Legacy First'.

4) After Step 3, you will be able to boot from the DOS USB (but your windows wont boot)

5) To boot windows, you will have to revert back to UEFI mode in BIOS.

Many thanks to svl7 for creating this. After applying the BIOS and the VBIOS for GT755M SLI, I did the following modifications through NvidiaInspector -

1) GPU clock down by 120

2) Memory clock down by 300

3) Undervolt by -112.5mV

The max temp I got on Ultrabay was 75 degrees (with avg of 72). The system appears stable (no crashes in about an hour of gaming) but I will try to make the undervolting to 100mV and see the stability, maybe also reset the clocks to original settings.

The CPUs are maxing at about 80 and same for the main GPU.

If anyone has any questions, I can help you out. If you have bricked your BIOS, then this thread also has several solutions to try (I just went through all the posts, yes all).

Try boot, then F2, wait, F9 and then F10.

I would recommend creating a old BIOS backup on a DOS booting USB. Thanks again.

Share this post


Link to post
Share on other sites

I put Arctic Silver 5 on the Ultra Bay and replaced the thermal pads with some from an xbox 360, had to thin them out first, and my temps are peaking at about 83-85 under load from the ultrabay gpu. I just had my mother board replaced less than a month ago so it has fresh thermal paste on it. On board CPU and GPU usually floats around 80 degrees. Was thinking of doing the bios mod. Is this reversible if I backup my original bios image? I also have it on cooling pad with the bottom removed as well as the idea fan script. I have about 3 months left on my warranty. Trying to avoid voiding it out until I have to with my luck.

Share this post


Link to post
Share on other sites

I was able to downgrade and install the modded v3.05 BIOS. Got my AW-CE123H working.

Share this post


Link to post
Share on other sites

Currently trying to unlock my bios, I just have a couple of quick questions, as I have never done this before. How safe is this process? I need to unlock it because my wireless card is currently awful, and the internet is actually no longer usable, but if I'm just going to brick my damn computer I'd rather just keep it to do some random offline stuff on it. I have a Y410P if this helps.

Share this post


Link to post
Share on other sites
Sup people. I hope this doesn't go unaware. I've managed to successfully upgrade from a crappy 2230 centrino wireless card to an Azurewave - Broadcom BCM-4352, but I've seen that the wireless signal is poor (like 50% of what it originally was).

What could it be? Could it be the modified BIOS?

Thanks in advance!!!

Try to reinstall your new Azurewave - Broadcom card (may be it is poor connection in COaxial cable) or try other wi-fi card to discard problem with Azurewave - Broadcom or its drivers

Share this post


Link to post
Share on other sites

Thanks for this. Sadly Eso doesnt like optimus and this was the only way i could disable my integrated card so that my NVIDIA card is the main card all the time. Although power consuming, it works.

Share this post


Link to post
Share on other sites

Help!

Im currently running modded 1.09 bios and i wanted to update to the newer bios modded 3.05

When i try to update to latest bios it says

InsydeH20 - Secure Flash

Error: invalid Firmware Image!!!

Pplease press any key to reset system...

How do i fix this

I also do have a AC wireless wifi adapter currently installed as well, was able to do this because of the wifi whitelist mod.

1) Should and can i still go to the new modded 3.05 bios and still keep the wlan whitelist removed as i do now

2) does anyone have the factory bios for 1.09 available?

Share this post


Link to post
Share on other sites

I see there is uEFI security upgraded BIOS 3.08. Not sure if it brings any other updates (cannot find 3.06, 3.07 release notes, but for z410 someone mentioned fan ran on highest speed continiously with IdeaFan app, not sure if y510p recieved any updates regarding this).

Laptops and netbooks :: IdeaPad Y Series laptops :: IdeaPad Y510p Notebook - Lenovo Support (US)

Share this post


Link to post
Share on other sites

ok, so i have my backup, bios.bin file,.... i put the files from folder 1 in the root of my dos usb,.... when i drag the bios.bin file onto the biosfixer.exe, it says:

"This mod will replace the VBIOS of your GPU. Read the instructions carefully.

Use at your own risk"

in a little window, and that is all that happens, i dont get the v305mod.bin file to put on my usb, in the window i can only click the tech inferno header that opens my browser

help

nevermind, i figured it out

Share this post


Link to post
Share on other sites

I cannot drag and drop the .bin file into the BIOSFIXER. What to do?

I got it, just had to drag it onto exe not open and then drag.

Share this post


Link to post
Share on other sites

Hi, I know you probably get this a lot but I fruited up...being a man about it. I really fruited up, and I need your help. I'm not sure if you would be able to help, but I'm still asking.. Today I decided to flash the bios mod to my laptop because the WiFi card that came with my y410p disconnects every few minutes and I wanted to change it. I flashed the mod,everything went fine and I went tinkering in my bios and changed the igpu size and now my laptop powers on but the screen is blank and the keyboard lights up. I have followed the link posted many times to recover the bios and I have the files on my flash drive and my procedure is this.. Inserted flash drive with the bios files renamed accordingly, its formatted in fat 32 (tried all 3 ports) then plugged in the power cord with the battery out while holding fn+r (also tried x and B) the flash drive would only blink once as I powered it on but nothing flashed. Please direct me as to what I can try or what key combination worked for that y410p. I have read through the posts but no one really talks about what worked for them.thanks again

Share this post


Link to post
Share on other sites

I successfully flashed the bios today. It is very nice. I would like to know if the raid feature actually works and if so how do I configure it since I see no documentation. Also does the ram feature that lets me choose ram speed work with higher clocked ram. Offically the laptop with normal bios supported 1600Mhz ram would changing the option in mod bios allow me to use faster ram at higher speed? has anyone tried this and seen speed improvement?

Share this post


Link to post
Share on other sites

How you guys can play any games with undervolted GPU. I tried to undervolt both GPU-s -87.5mV and game crashes every time. I am talking about GTA V.

Share this post


Link to post
Share on other sites
How you guys can play any games with undervolted GPU. I tried to undervolt both GPU-s -87.5mV and game crashes every time. I am talking about GTA V.

I can go up to -137, with nvidia inspector.

BTW, which method are you using?

PD. I don't if it's just me but I can only undervolt when plugged in(with unlocked bios).

Share this post


Link to post
Share on other sites
I can go up to -137, with nvidia inspector.

BTW, which method are you using?

PD. I don't if it's just me but I can only undervolt when plugged in(with unlocked bios).

I used Nvidia Inspector Of course. And my laptop is plugged in Of course. I really don't know why I can't undervolt without game crashing. Maybe I have to downclock too? Can you send me picture of your nvidia inspector?

Share this post


Link to post
Share on other sites
How you guys can play any games with undervolted GPU. I tried to undervolt both GPU-s -87.5mV and game crashes every time. I am talking about GTA V.

Every chips isn't created perfectly equal. Some chips may require higher minimum voltage than others to stay stable.

It seem your chip can't handle -87.5mV UV so you'll want to give it more voltage maybe something like -50mV will do then test whether it's stable.

If it is then you may try lower it a bit more and retest but if it's not you will want to increase voltage and retest.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      NVIDIA 'Maxwell' VBIOS mods
       
       
      Here you find modified VBIOS versions for the mobile parts of the Nvidia 'Maxwell' series.
      The VBIOS versions in this post are tweaked for performance and versatility. You'll get almost complete control over the performance parameters of your GPU.
      List of available VBIOS mods:
       
      Nvidia GTX 970m - 'OC edition' rev0 - >> 6 GB Version << - modified by @johnksss & svl7 -> see attachments Nvidia GTX 980m - 'OC edition' rev0 - >> 8 GB Version << - modified by @johnksss & svl7 -> see attachments  
      Screenshot demonstrating the capabilities of the 970m versions:

      >> Read the instructions carefully before flashing! <<
      If anything is unclear after reading or if you have additional remarks, please post in the thread.
       
      Flashing:
       
      - Go to the device manager -> 'Display Adapters' -> chooser your GPU, right click on it and choose disable
      - Flash the VBIOS with mnvflash, a modified version of nvflash (see attachments). Here are detailed instructions for nvflash in case you aren't familiar with it.
      - After the flashing is done: Enable the GPU once again in the device manager.
      - Reboot
       
      Do NOT use driver 347.09, it's broken and useless and won't allow you to overclock, even with the stock firmware.
      Don't distribute the files hosted here outside of Tech|Inferno. Don't modify the files you download here.
       
      Donation link in case you want to buy me a beer

      Thanks and cheers!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.