Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

Anyone tried to flash newest Bios v3.08? Is it worth updating<? or just wait until its unlocked? Is there still a possibility to downgrade?

Share this post


Link to post
Share on other sites

I somehow was able to mange to flash BIOS, but I cannot run nvflash at all.

It fails to find any nVidia adapters. It should be related with BIOS option right? Do I need to turn off secureboot?

Share this post


Link to post
Share on other sites

Ight. I managed to flash both.

Tried to install N6300.

I realized that Intel's new Wi-FI card has some serious issue and it does NOT work in some system.

My D-Link Router allows me to have 2 possible connection. My primary connection does not work with N6300 installed in Y510p. (Actually, it is slower connection with stronger signal)

My Secondary Connection works. (Weak signal but faster.)

when that card is installed in other laptop, it works with no problem.

So, I think Lenovo is forcing us to use their authorized cards, cuz Intel sucks.

I also realized, in some other Y510p sometimes N6300 works without problem.... then suddenly realizes it does not work in some routers.

I think Intel's 8 series chipset and IvyBrige/Haswell have cause of this.

-

Indeed, you CAN use N6300 by flashing BIOS with this modified one. BUT, for some routers, it does not work. However, if you are using really expensive hardcore router, you should able to bypass the problem anyway.

---

Another possible causes

There are some stupid dudes attempting to interfere Wi-Fi signals. There are tons of them doing that malicious thing. So those pirating attempts might be a cause of problem.

Share this post


Link to post
Share on other sites
Does this mod allow any wifi card to work ?? I have an Intel 6300 Ultimate N here that I would like to put in?

Flashing with this mode DOES allow N6300 to work.

However, it does NOT guarantee proper connection.

N6300 is actually very buggy WiFi Card and causes mayhem in many system. Since Y510p is not designed to work 100% fine with N6300, N6300 tends to cause more trouble.

Well, N6300 actually works in Y510p. However, it depends on what WiFi connection that you are using. Some connection simply does not work with N6300+Y510p.

-

It seems like AC7260 makes less trouble, but I have seen people saying that ac7260 failed although their chipset, board, BIOS allows ac7260 to be fully functional.

- - - Updated - - -

Hi All, I followed the instructions to flash the 2.07 bios and the mod. Couldn't get the bios backup tool to work as as soon as I open it , it closes. So I tried some other bios backup utility to create the file. However after installing the 7260AC card the laptop fails to boot up. Just keyboard lights up for a second and screen is blank. The fan spins though. Am I doing something wrong?

[ATTACH=CONFIG]15168[/ATTACH]

Roll it back to v3.05 then reattempt flashing.

Make sure back BIOS is enabled.

Share this post


Link to post
Share on other sites
Roll it back to v3.05 then reattempt flashing.

Make sure back BIOS is enabled.

I rolled it back and did the whole process again twice without any luck. Then I tried staying on 2.07 Bios and just adding the white-list mod. There were no errors. But when I connected the wifi card the same thing happened, black screen and no activity besides the fan spinning. This is the card I bought off ebay http://www.ebay.com/itm/200972579194.

Am I supposed to get some super specific 7260AC card for lenovo? I assumed any 7260AC should work after the whitelist removal.

Share this post


Link to post
Share on other sites

I have a y510p with 3.05 should I use this unlocked bios or flash it to 3.08?

Also what's the chance of getting bricked?

Share this post


Link to post
Share on other sites

Hi guys!

I have a y410p in which I want to use a gt750M5 ultrabay to build a SLI.

Last night I removed the front panel of the gt750M5 to let it fit in the y410p ultrabay. The first time it seems it worked. I was playing around over the nvidia control panel, the second card was detected correctly but after a while the laptop just restarted. After that... yes, as you imagine... I got the "Unauthorized slave vga card is plugged in. power off and remove it" message.

Will this modded bios fix this problem?

Share this post


Link to post
Share on other sites

Thank you so much to this thread for helping me. My wireless card was so bad and getting worse and thanks to this thread i was able to install a new one and my internet has been working better than ever.

I just had one question though, I saw someone else ask about this but never saw an answer. I was flashing the EC and it only made it to 50% and then my laptop automatically rebooted. Is this normal? Is it something I should worry about? Should I just try and flash the EC again?

Share this post


Link to post
Share on other sites

check my y410 bios and I already have v3.07. Can I just downgrade to the required version and then flash to remove the whitelist?

Share this post


Link to post
Share on other sites

Can someone please post the LATEST MODDED BIOS for the Y510P.

I need it because I am using an Intel Wireless AC 7260try which is not on the Lenovo Whitelist and thus my laptop won't boot if I try to use this card.

I am currently using modded BIOS 3.05

So could someone please upload a MODDED version of BIOS 3.08. The couple thousand of us who are using the Y510p would REALLY be grateful!

Share this post


Link to post
Share on other sites

Hey can someone help me, and share their stock ultrabay and non ultrabay vbios files? I lost mines....

Share this post


Link to post
Share on other sites

I'm planning on installing my Intel AC 7260 very soon. I've got a Lenovo Y410P on BIOS 3.05. There's so many posts in this thread...and I'm new. Will I be able to use this wifi card with my laptop?

Share this post


Link to post
Share on other sites

Does anyone know where to find some videocards for the y410p/510p? The only ones I can find are like $200 which is just ridiculous..

Share this post


Link to post
Share on other sites
I'm planning on installing my Intel AC 7260 very soon. I've got a Lenovo Y410P on BIOS 3.05. There's so many posts in this thread...and I'm new. Will I be able to use this wifi card with my laptop?

You need the modded bios. I have the 7260 as well.

Sent from my SM-G920I using Tapatalk

Share this post


Link to post
Share on other sites

Looks like the AC 7260 is the defacto standard replacement WiFi card.

Anyone know of any issues using it with TP-Link's Archer C7 v2 Router?

thanks,

mlloyd1

Share this post


Link to post
Share on other sites

So could someone please upload a MODDED version of BIOS 3.08. The couple thousand of us who are using the Y510p would REALLY be grateful!

i too would appreciate a 3.08 modded bios, i had to update since my computer started acting erratically (it wouldnt charge randomly) and now im stuck with 3.08

ANOTHER QUESTION, WHAT DO I NEED TO KNOW IF I PLAN TO BUY A y510P uLTRABAY GPU FOR SLI INTO A Y410P? CAN SOMEONE TELL ME ALL THINGS TO KNOW BECAUSE FORM WHAT I KNOW IS THIS:

1- BUY A Y510P POWER ADAPTOR (170w)

2- BUY A SECOND GRAPHICS CARD

3- MOD THE GPU BY BREAKING OR BENDING SOME KIND OF PIN.... I DONT KNOW EXACTLY

ANYTHING ELSE???? PLEASE HELP :grumpy:

Share this post


Link to post
Share on other sites

Don't post in all caps, it makes it seem like you are yelling.

Y510p ultrabay card probably won't work with your Y410p. AFAIK the Y410p has the GT 750 the Y510p has the 755. Also you would need the power adapter. It's not worth bothering with if you didn't get the card with your laptop.

There's also issues reported by people who bought an aftermarket card and adapter that they can't get SLI working properly and they get stuttering in games.

Either way don't use all caps and do your own research. There's plenty of info on the lenovo forums.

Share this post


Link to post
Share on other sites

Maybe this only happened to me but my OneKey button by the charging port that allows you to go to the BIOS setup doesn't work after flashing the modded BIOS. It just turns on the laptop, I have go through advanced restart to get into the BIOS.

Has anyone else experienced this/is there a fix? It's a useful feature to have incase Windows starts acting up and I can't get to the BIOS that way.

Share this post


Link to post
Share on other sites
Does anyone know where to find some videocards for the y410p/510p? The only ones I can find are like $200 which is just ridiculous..

You can order the extra ultrabat gpu from thailand. Its less than $100. Not sure about the shipping thou. Just google JIB thailand

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
You can order the extra ultrabat gpu from thailand. Its less than $100. Not sure about the shipping thou. Just google JIB thailand

Sent from my iPhone using Tapatalk

Did you buy from them?

Sent from my SM-G920I using Tapatalk

Share this post


Link to post
Share on other sites
i too would appreciate a 3.08 modded bios, i had to update since my computer started acting erratically (it wouldnt charge randomly) and now im stuck with 3.08

ANOTHER QUESTION, WHAT DO I NEED TO KNOW IF I PLAN TO BUY A y510P uLTRABAY GPU FOR SLI INTO A Y410P? CAN SOMEONE TELL ME ALL THINGS TO KNOW BECAUSE FORM WHAT I KNOW IS THIS:

1- BUY A Y510P POWER ADAPTOR (170w)

2- BUY A SECOND GRAPHICS CARD

3- MOD THE GPU BY BREAKING OR BENDING SOME KIND OF PIN.... I DONT KNOW EXACTLY

ANYTHING ELSE???? PLEASE HELP :grumpy:

The GT750M5 is the ultrabay option of the gt750m for the y510p. I am using one of those cards with my y410p working in SLI without any problem. You may have some problems to let it fit in the y410p, but it works. I modded mine to let it fit perfectly. The 170w adapter is needed in order to SLI function correctly, at least in my case.

Share this post


Link to post
Share on other sites

Hello, will modding the BIOS remove the warranty from Lenovo? Is there a way back to revert the bios to original?

Thanks!

Share this post


Link to post
Share on other sites

Does anyone know if there is an updated guide for BIOS v3.07? I have tried to backflash the BIOS to v3.05, but after it says it was successfully flashed, the BIOS remains at v3.07

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
    • By Donz7733
      Hi
       
      Currently I am using Nvidia 376.44 version for SLI functionality. On trying to install any higher version , SLI wont function & only 1 card works.
       
      if anyone is using higher version Than the one mentioned above for SLI, please let me know
       
      Thank You
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.