Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

I think it's good modded bios... ( I don't have find any else)....

Anyone have brick on this laptop with this bios?

From what I can tell from reading through the thread only a handful have been affected, and its only the ones that have tried overclocking/undervolting from within the bios itself. Everyone else seems to be running just fine.

Share this post


Link to post
Share on other sites
I think it's good modded bios... ( I don't have find any else)....

Anyone have brick on this laptop with this bios?

As long as you follow the instructions carefully and correctly and don't try to undervolt from the bios you should be fine.

Share this post


Link to post
Share on other sites

I will probably flash mine again so I can upgrade my wifi but I won't try fooling around with any of the other settings any more.

Share this post


Link to post
Share on other sites
I think it's good modded bios... ( I don't have find any else)....

Anyone have brick on this laptop with this bios?

I bricked mine, didn't change any voltage settings or overclocking. As soon as I flashed the EC it shut down. Deader than dead, any recovery attempts failed. I was able to get it fixed by Lenovo, though I haven't been able to verify yet, the package just arrived at home today.

Share this post


Link to post
Share on other sites
That's unfortunate, that's exactly what I did as well. Won't be messing with that next time. How long did it take to get it fixed? Also do I have to worry about my data or my 128gb m.2 ssd?

You don't need to worry about the data on your SSD. The firmware update flashes the BIOS chip on your MOBO. The HDD/SSD should remain undisturbed. If you do brick your laptop though you should be able to remove the SSD and put it in another computer and retrieve the data but I would backup your data prior to the firmware update in case you do brick it you don't have to figure out a way to retrieve data should you need it urgently.

Share this post


Link to post
Share on other sites

If someone would like to know, my CPU is "dead" (they tested it on another laptop). So, do not undervolt via BIOS :P

Share this post


Link to post
Share on other sites
If someone would like to know, my CPU is "dead" (they tested it on another laptop). So, do not undervolt via BIOS :P

Wow, strange that a little undervolting would kill the processor.

Share this post


Link to post
Share on other sites
If someone would like to know, my CPU is "dead" (they tested it on another laptop). So, do not undervolt via BIOS :P

Holly shit! Really? That is insane that a little under volting somehow killed the chip. I have a feeling the under volt didn't actually under volt if that is the case.

Share this post


Link to post
Share on other sites

What excuse did you guys tell lenovo? I think ill just tell them i tried to update my bios and then it wouldnt turn on.

Share this post


Link to post
Share on other sites
What excuse did you guys tell lenovo? I think ill just tell them i tried to update my bios and then it wouldnt turn on.

Do it so, since mine got bricked just after updating with regular original bios setup downloaded from their own page; and they are repairing it without any excuse.

Share this post


Link to post
Share on other sites
Does anyone know if the modded BIOS for the laptop BIOS only work, even if I have the 755M SLI?

It works with SLI. Follow the instructions in post 2 to flash the vbios to your ultrabay gpu.

Did you guys call lenovo or start a chat? I see an option for Warrenty and Claim Administration and I would assume thats the chat I want.

Share this post


Link to post
Share on other sites

My case is even funnier :D Today i found out that Lenovo knows nothing about my y510p (only country of origin= Holand).. and they can't register my warranty yet:D so now i need to wait for shop, where i bought y510p (some import seller) to give me their invoice as a proof or sth.. what a mess

and final: i was using this laptop for 1 (one) week :D

im gonna cry now

cheers guys

Share this post


Link to post
Share on other sites

Ugh, i told them I updated my bios and that it didnt turn on afterwords but they labeled it a user accident and so i have to pay for them to replace the motherboard...such as my luck.

I should have just said i turned it off and then it wouldnt turn back on.

Share this post


Link to post
Share on other sites
Ugh, i told them I updated my bios and that it didnt turn on afterwords but they labeled it a user accident and so i have to pay for them to replace the motherboard...such as my luck.

I should have just said i turned it off and then it wouldnt turn back on.

Just curious, what price did they quote (if you're in the US)?

I did just tell them it wouldn't turn on. Didn't even pay shipping. I figured they wouldn't spend the time needed to see exactly what happened.

Share this post


Link to post
Share on other sites
Just curious, what price did they quote?

I did just tell them it wouldn't turn on. Didn't even pay shipping. I figured they wouldn't spend the time needed to see exactly what happened.

they didnt know when I asked. They said "we wont know until after the repairs are finished." Which makes no sense but I would guess $200-$250. If the cpu died like someone said in a previous post, add about $100 more. I might try to contest it being a user accident though since their software should work regardless.

Share this post


Link to post
Share on other sites
So I installed the 3.05 modded bios and vbios on my ultrabay gpu, after changing a few settings with fan speed and processor frequency I can no longer get into the setup menu when i press the novo button. It just boots into windows instead as if i pressed the power button. Anyone know how to fix this?

Edit: After searching google I figured out that if you press F2 on bootup it will take you directly into the bios. It worked and i reset all my settings back and now the novo button works again.

Edit 2: just bricked my motherboard. Keyboard lights up and fans spin but nothing shows up on the display. Tried the methods on the first page, anyone have anymore methods to reset the bios?

have you tried taking out the mobo battery? the one that looks like a quarter?

Share this post


Link to post
Share on other sites

WHAAAAAA!!!

My lenovo is working !!!

No one knows why :DDD

In service they said that its impossible to repair it cause CPU is damaged :D

Today y510p arrived, i turned it on and BUM ITS FKING WORKING !!

Praise the lord :D

Share this post


Link to post
Share on other sites

Hi again, im trying to repea my question.

What can i do if i cannot save my lenovo bios using: fptw64.exe, fpt.exe ??

Im using W8 x64. On screenhots you can see what error i have when im trying to backup bios, also what hardware/os im using and what bios i have now.

please help me.

Maybe i can use vendor bios? It is nessesary to use my own to flash it??

Thanks in adwance.

Share this post


Link to post
Share on other sites
@Cassiel: That's great news. Do you still have the old bios? That's the best way to know.

Hmm, yes i have 2.04 again. But other computer service already changed bios (even bios chip) and it did not help, sooo.

Maybe replacing CPU helped when they tested it on another laptop.

Share this post


Link to post
Share on other sites
On screenhots you can see what error i have when im trying to backup bios, also what hardware/os im using and what bios i have now.

Can't see any screenshots...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      NVIDIA 'Maxwell' VBIOS mods
       
       
      Here you find modified VBIOS versions for the mobile parts of the Nvidia 'Maxwell' series.
      The VBIOS versions in this post are tweaked for performance and versatility. You'll get almost complete control over the performance parameters of your GPU.
      List of available VBIOS mods:
       
      Nvidia GTX 970m - 'OC edition' rev0 - >> 6 GB Version << - modified by @johnksss & svl7 -> see attachments Nvidia GTX 980m - 'OC edition' rev0 - >> 8 GB Version << - modified by @johnksss & svl7 -> see attachments  
      Screenshot demonstrating the capabilities of the 970m versions:

      >> Read the instructions carefully before flashing! <<
      If anything is unclear after reading or if you have additional remarks, please post in the thread.
       
      Flashing:
       
      - Go to the device manager -> 'Display Adapters' -> chooser your GPU, right click on it and choose disable
      - Flash the VBIOS with mnvflash, a modified version of nvflash (see attachments). Here are detailed instructions for nvflash in case you aren't familiar with it.
      - After the flashing is done: Enable the GPU once again in the device manager.
      - Reboot
       
      Do NOT use driver 347.09, it's broken and useless and won't allow you to overclock, even with the stock firmware.
      Don't distribute the files hosted here outside of Tech|Inferno. Don't modify the files you download here.
       
      Donation link in case you want to buy me a beer

      Thanks and cheers!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.