Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

I've been having strange issues which I suspect started after flashing the bios fixer (btw, I'm on the 1.07 one). The display driver crashes every time I play some game (AC4 and NFS:Rivals as far as I've noticed). "The "Nvidia Windows Kernel Mode Driver 331.93 stopped responding and has recovered successfully" - this is the notification that comes up on the Windows taskbar after I force close the frozen game window using the task manager. As you can see, I am on the latest Nvidia (Beta) driver. I have already tried out most of the recent drivers posted on Nvidia's website without any fruitful results.

The present condition of the laptop has the flashed 1.07 bios with the Intel AC7260 wireless card installed. The rest of the laptop is all stock running Windows 8 at present (I have already tried running Windows 8.1 without the issue being resolved).

After doing some searching around on the internet for a solution, I'm almost certain the problem has got something to do with the inefficient power management (I'm also getting a "compatibility issue with your power management system" warning in the Windows Action Center). Upon a fellow user's suggestion, I tried tweaking the power management settings in the Nvidia Control Panel and set it for maximum performance and yet the same issues remain.

Also tried setting a TDR (timeout detection and recovery) delay value of 8 within the registry and it seemed to work for a short while. But, it seems I'm back to square one at the moment.

I was thinking this might be a bios issue and wondering if there are any settings I need to change so that the power management is better handled. I've been searching around for an updated bios file for the 410p but can't seem to find them anywhere. I'm surprised I am the only one who seems to have this problem; at least I can't find anybody else who has made a remark about this anywhere on the internet. Any help would be appreciated.

Share this post


Link to post
Share on other sites

Hi Everyone!

I've Y510P and i dump bios using FPT Tool. I mod (remove whitelist) BIOS 3.05 (without Windows Key, i have no OS version) with EZH20 Tool (Option - "Removed module" -> D378C2-B472-412F-AD87-1BE4CD8B33A6). But when i try to flash with the same tool that i make dump Intel FPT Tool and i have error -> Error 280: Failed to disable write protection for the BIOS space!

I enable/disable option Flash Back in BIOS but flash is still without sucess :-/

Sorry for my english and i hope that can someone help me :(

Share this post


Link to post
Share on other sites
I've been having strange issues which I suspect started after flashing the bios fixer (btw, I'm on the 1.07 one). The display driver crashes every time I play some game (AC4 and NFS:Rivals as far as I've noticed). "The "Nvidia Windows Kernel Mode Driver 331.93 stopped responding and has recovered successfully" - this is the notification that comes up on the Windows taskbar after I force close the frozen game window using the task manager. As you can see, I am on the latest Nvidia (Beta) driver. I have already tried out most of the recent drivers posted on Nvidia's website without any fruitful results.

The present condition of the laptop has the flashed 1.07 bios with the Intel AC7260 wireless card installed. The rest of the laptop is all stock running Windows 8 at present (I have already tried running Windows 8.1 without the issue being resolved).

After doing some searching around on the internet for a solution, I'm almost certain the problem has got something to do with the inefficient power management (I'm also getting a "compatibility issue with your power management system" warning in the Windows Action Center). Upon a fellow user's suggestion, I tried tweaking the power management settings in the Nvidia Control Panel and set it for maximum performance and yet the same issues remain.

Also tried setting a TDR (timeout detection and recovery) delay value of 8 within the registry and it seemed to work for a short while. But, it seems I'm back to square one at the moment.

I was thinking this might be a bios issue and wondering if there are any settings I need to change so that the power management is better handled. I've been searching around for an updated bios file for the 410p but can't seem to find them anywhere. I'm surprised I am the only one who seems to have this problem; at least I can't find anybody else who has made a remark about this anywhere on the internet. Any help would be appreciated.

Nah it is not the bios it happens to me with most intensive games, sometimes I hear the sound becoming unstable, I fast get out of the game cause if I let it continue I get a BOSD and sometimes the message of nvidia crashed, I've tried everything, this happens with my desktop too which I got a gtx 460 I guess this is an nvidia problem not the bios. This happened after an update?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Nah it is not the bios it happens to me with most intensive games, sometimes I hear the sound becoming unstable, I fast get out of the game cause if I let it continue I get a BOSD and sometimes the message of nvidia crashed, I've tried everything, this happens with my desktop too which I got a gtx 460 I guess this is an nvidia problem not the bios. This happened after an update?

Sent from my iPhone using Tapatalk

Yeap, I hear the strange noises too indicating the display driver is unstable and that's the same thing I do myself to avoid a BSOD. It's quite a relief to know that its not a laptop defect of some kind. Regarding your question, I can't remember making any major changes (other than updating Nvidia drivers) recently that would cause something like this to happen. That's why it made sense to narrow it down as a BIOS issue. Now that you mention about your other rig having the same problem, I'm sure the modded BIOS is not the issue here. The strange thing is Nvidia's latest drivers claim to be optimized for these two games specifically. Ironic. Hope it gets resolved soon. Thanks a lot for your helpful reply. Do make a post if you manage to solve this.

Share this post


Link to post
Share on other sites
Yeap, I hear the strange noises too indicating the display driver is unstable and that's the same thing I do myself to avoid a BSOD. It's quite a relief to know that its not a laptop defect of some kind. Regarding your question, I can't remember making any major changes (other than updating Nvidia drivers) recently that would cause something like this to happen. That's why it made sense to narrow it down as a BIOS issue. Now that you mention about your other rig having the same problem, I'm sure the modded BIOS is not the issue here. The strange thing is Nvidia's latest drivers claim to be optimized for these two games specifically. Ironic. Hope it gets resolved soon. Thanks a lot for your helpful reply. Do make a post if you manage to solve this.

Well to be honest I haven't found a way to solve it and it is a common problem between users, if you google "weird sound before nvidia drivers crash" or "nvidia kernel stopped responding and recovered successfully" many people suffers from this and it is a quite old problem the worst part it's that it's based on luck since some of my friends doesn't suffer from this and some does, I even changed my desktop graphic's card from a 9800 gtx+ to the ati 4770 vapor edition and still suffered from it with a non nvidia card, then moved to the gtx 460 768mb edition and the problem was there :P, changed motherboard from the Msi p35 platinum to the asus p45 p5q pro, changed ram from ocz sli ready to ocz stealth, the power supply from ocz to thermaltake with more watts and Amps output, even changed it from wall electrical socket, and... The problem was there, sold it to a friend and he still got the problem, so I bought the y410p and guess what... The problem is there :P I flashed the bios and tweaked my CPU to be an 4072qm but in some weird cases it shuts down and reverts back the changes, and the problem persist, I got another laptop an asus republic of gamer g51jx-3D which gets hot like hell with a gTs 360m and it doesn't suffer from this. I contacted nvidia regarding the gtx 460 having the issue and they wanted me to send it for repairs but my guarantee was over so I didn't send it. It is not heat problems cause when I game I get around 76 - 80C from both CPU and gpu after I updated the bios, was getting to 80c to 83c in processor before the modded bios and from 90c to 97C in graphic card and the nvidia problem was there, updated all drivers in my Lenovo and I feel like it is doing it more frequently, but oh well I just learned to deal with it, or waiting for someone to get a real fix, people changes some values in the registry to give it a little more wait time before crashing but it didn't solve my problem.... so... It is like having a strange decease which it got no cure, so we learn to live with it until some is found or until death, if you find anything, please share it, I will too.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Well to be honest I haven't found a way to solve it and it is a common problem between users, if you google "weird sound before nvidia drivers crash" or "nvidia kernel stopped responding and recovered successfully" many people suffers from this and it is a quite old problem the worst part it's that it's based on luck since some of my friends doesn't suffer from this and some does, I even changed my desktop graphic's card from a 9800 gtx+ to the ati 4770 vapor edition and still suffered from it with a non nvidia card, then moved to the gtx 460 768mb edition and the problem was there :P, changed motherboard from the Msi p35 platinum to the asus p45 p5q pro, changed ram from ocz sli ready to ocz stealth, the power supply from ocz to thermaltake with more watts and Amps output, even changed it from wall electrical socket, and... The problem was there, sold it to a friend and he still got the problem, so I bought the y410p and guess what... The problem is there :P I flashed the bios and tweaked my CPU to be an 4072qm but in some weird cases it shuts down and reverts back the changes, and the problem persist, I got another laptop an asus republic of gamer g51jx-3D which gets hot like hell with a gTs 360m and it doesn't suffer from this. I contacted nvidia regarding the gtx 460 having the issue and they wanted me to send it for repairs but my guarantee was over so I didn't send it. It is not heat problems cause when I game I get around 76 - 80C from both CPU and gpu after I updated the bios, was getting to 80c to 83c in processor before the modded bios and from 90c to 97C in graphic card and the nvidia problem was there, updated all drivers in my Lenovo and I feel like it is doing it more frequently, but oh well I just learned to deal with it, or waiting for someone to get a real fix, people changes some values in the registry to give it a little more wait time before crashing but it didn't solve my problem.... so... It is like having a strange decease which it got no cure, so we learn to live with it until some is found or until death, if you find anything, please share it, I will too.

Sent from my iPhone using Tapatalk

Anybody else with similar problems kindly report back if you have found a fix. I'm an occasional gamer and I can live without playing some modern titles but the thought of their being a possible weakness in the display driver/bios/power management/or whatever else it may be is driving me nuts. I wish there were downloadable BIOS 1.09, 1.10 or any of the later versions with a white list mod so that people could flash and keep it updated as is with the other drivers.

Share this post


Link to post
Share on other sites

I just got this laptop and am running Windows 8.1 with latest Nvidia drivers, BIOS 3.05.. So far I've played Tomb Raider and Assassin's Creed 3 & 4 at the max FPS this laptop can handle without running into any kind of issues. I am a casual gamer though, rarely more than 45min at a time

Share this post


Link to post
Share on other sites

So I changed to integrated video aperture from 256 to 512 and now system won't boot properly. It powers up, black screen, and then repeatedly restarts every 10 seconds or so until I do a hard shut down. Any thoughts?

I tried hitting F2 after powering up to hopefully get into the BIOS, but it still restarts even then so I'm assuming it's not even getting into the BIOS screen (again, screen is black).

Everything was working just fine prior to this change.

Thanks for any help..!!!

Share this post


Link to post
Share on other sites

Hello. sorry for my English - I use the translator. I have a problem with y510p. And in the course of the experiments, I came to the conclusion that the problem is in the BIOS.

When I replaced my hdd by ssd crucial_M4 he does not appear in the list of devices in the BIOS. However, when you boot from the ssd cache 24G (on which I installed 8) crucial_M4 available in Windows Explorer and in disk management. I tried to change all the settings in the BIOS but crucial ssd and has not appeared in the list. On other computers crucial_M4_ssd is displayed in the BIOS. You can record crucial to the white list.

Thank you.

Share this post


Link to post
Share on other sites

Hi!

I have found one chance to replace the WiFi in our y510p. In hardware maintenance manual (official from Lenovo) are list of compatible adapters with FRU from Lenovo.

Hardware Maintenance Manual - IdeaPad Y410p, Y510p

There are three cards with 2x2 antenna:

BCM4352 AC

BCM4322 Dual Band

AR9462 (aka WB222)

I'm call to Lenovo Support in Poland without success (they say bla bla bla)

Then i'm call to authorized repair center RAMSERWIS.PL in Warsaw and they told me that:

BCM4352 AC it's not available now and don't know that card will available.

BCM4322 Dual Band it's possible to order (2-4 weeks) - price 285PLN -> 92$ it's very expensive but it's work

AR9462 (aka WB222) it's possible to order (2-4 weeks) - price 285PLN -> 92$ it's very expensive but it's work

Above adapters have the same FRU like FRU in hardware maintenance manual :D

Probably i order one of them and i forget about bios mod 3.05 because probably it isn't possible to flash with flash protect.

Share this post


Link to post
Share on other sites
Hi!

I have found one chance to replace the WiFi in our y510p. In hardware maintenance manual (official from Lenovo) are list of compatible adapters with FRU from Lenovo.

Hardware Maintenance Manual - IdeaPad Y410p, Y510p

There are three cards with 2x2 antenna:

BCM4352 AC

BCM4322 Dual Band

AR9462 (aka WB222)

I'm call to Lenovo Support in Poland without success (they say bla bla bla)

Then i'm call to authorized repair center RAMSERWIS.PL in Warsaw and they told me that:

BCM4352 AC it's not available now and don't know that card will available.

BCM4322 Dual Band it's possible to order (2-4 weeks) - price 285PLN -> 92$ it's very expensive but it's work

AR9462 (aka WB222) it's possible to order (2-4 weeks) - price 285PLN -> 92$ it's very expensive but it's work

Above adapters have the same FRU like FRU in hardware maintenance manual :D

Probably i order one of them and i forget about bios mod 3.05 because probably it isn't possible to flash with flash protect.

I had tried the same thing with the 3.05 file you provided and am getting the same result as you. Do you think it's the 3.05 file that is causing the "Error 280" or is it the method we're using to try to modify and flash the file? I would love to be able to install the Intel 7260 AC adapter, as it's supposed to play nicer with our hardware than the broadcom one does. Worst case scenario, the Broadcom AC card sells for ~$90-$100 on ebay, which isn't too terrible.

Regardless, thank you for providing the 3.05 file. I was able to install another version of Windows without the hard coded Windows key getting in the way, which is very much appreciated. :encouragement:

Share this post


Link to post
Share on other sites

No problem Men, u Welcome :) Problem with the flash isn't simple. Mod that i make with EZH2O utility (remove whitelist) is ok but with 3.05 Lenovo provide hard to brick protection against the flash anything :-/ svl7 - my guru :D said me that is probably impossible ;-( Probably only way to have another adapter is order the right card listed on here Hardware Maintenance Manual - IdeaPad Y410p, Y510p of course with FRU from Lenovo. In my country only few authorized service center Lenovo can order for me orginaly parts from Lenovo - and it's more expensive than the same card without FRU on ebay for ex. (the same card without exactly the same FRU can't work with Y510P)

Share this post


Link to post
Share on other sites
No problem Men, u Welcome :) Problem with the flash isn't simple. Mod that i make with EZH2O utility (remove whitelist) is ok but with 3.05 Lenovo provide hard to brick protection against the flash anything :-/ svl7 - my guru :D said me that is probably impossible ;-( Probably only way to have another adapter is order the right card listed on here Hardware Maintenance Manual - IdeaPad Y410p, Y510p of course with FRU from Lenovo. In my country only few authorized service center Lenovo can order for me orginaly parts from Lenovo - and it's more expensive than the same card without FRU on ebay for ex. (the same card without exactly the same FRU can't work with Y510P)

That's kind of what I was worried about. It's not like I absolutely NEED a wireless AC card, but it feels like a waste of my router's potential. Maybe I'll have to look into downgrading my BIOS to the modifiable one (if possible), then focusing my efforts on figuring out how to remove the Windows key from the old version instead.

Share this post


Link to post
Share on other sites

has anyone with the unlocked bios managed to modify the fan control. I wonder how is it possible to leave the fan at dust removal speed because it would be useful while gaming i dont mind my notebook noisy while gaming

Share this post


Link to post
Share on other sites

can anyone suggest an ac wifi adapter with bluetooth that would work as a better replacement than the 2230 poop thats currently onboard

Share this post


Link to post
Share on other sites
Anyone else noticed that Lenovo is now selling a new build(59399853) with a better wireless card? In fact it's the very Intel 7260, but the wifi N only version instead of the newer draft AC

I have the 7260 single band(as in latest Y410p) in Z510 and it sucks. Signal drops to 11mbps very often even with 16.6.0 drivers. I really wanted to upgrade to 7260 AC Dual Band but I have 3.7 bios... so write protection rules! :D

I truly hate Lenovo!

Share this post


Link to post
Share on other sites

Are there any benefits by unlocking my Y510p Bios? like for making hackintosh or something like that? can it be dangerous? like laptop dying or something? or is it safe?

Thanks!

Share this post


Link to post
Share on other sites

Have anyone noticed after upgrading windows 8 to windows 8.1 that SLI is not working ?

Share this post


Link to post
Share on other sites

Is it difficult to unlock the BIOS by doing this? I've never touched the BIOS on my laptop before but the wifi card needs to go so i recently bought a 7260 and was just wondering how difficult it is to do.

Share this post


Link to post
Share on other sites
Is it difficult to unlock the BIOS by doing this? I've never touched the BIOS on my laptop before but the wifi card needs to go so i recently bought a 7260 and was just wondering how difficult it is to do.

If you have one of the supported versions it's fairly easy :)

Share this post


Link to post
Share on other sites

First post here, is there a way to take a bios from one persons 510p and applying it to your own laptop (without coping over their CD key)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By GrayCryptoSpordium
      Well everyone...I have a confession to make-I flashed svl7 modified 970m vbios before I wiped my drivers! Everything seemed to run fine, I could game but noticed my clocks fluctuating a bit crazy. Figured I'd try a OC profile in afterburner while running a 27 27 26 26 clock in TS a bit stupid I know. Well 3d mark froze so I did a reboot...Black Screen on startup I heard windows boot so I feared I bricked my card. Tried external monitor..works fine. This is where my stupidity really hit the cosmos. I had another m15x 900p LCD laying around plugged that in. Worked fine back too overclocking bro! Well same thing happened. My profile was not overly crazy as I can remember. But I bricked another screen. Plugged in external monitor everything fine. I was using latest nvidia drivers 436.48 I believe. So I wiped drivers using DDU. Reflashed to stock clevo bios. Tried both LCD again still nothing. Installed old 7970m still nothing. Cleared CMos again nope. Reinstalled 970m with svl7 vbios with newest driver and been gaming on my external monitor. Have done some OC with inspector. Everything seems to work as it should. Temps and performance are great. Did I brick my monitors??? Never heard of this problem. 
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.