Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

Bios 2.07 Y510p intel 7260 working perfectly

Bios 2.07 y410p intel 7260 working wonders expect for the sleep problem when Bluetooth is switched on.

Share this post


Link to post
Share on other sites

Does this mod happen to affect the video card fan? I never noticed mine before, but now it seems to always be running

Share this post


Link to post
Share on other sites
Bios 2.07 y410p intel 7260 working wonders expect for the sleep problem when Bluetooth is switched on.

I think mine is ok. I tried press sleep button. The fan will still work for couple minutes and then my pc goes to sleep (fan off).

check "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power" see if there is "AwayModeEnabled--value=1" delet it.

check powercfg /requests and powercfg /a and see if those are normal

check power setting see if those settings are sleep or "hibernate", if that is what you want.

or disable bluetooth because even open bluetooth it will still lost data during sleeping.

Hope this helps

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Does anybody know where to find an update from my current BIOS v.1.07 to v 1.10 and what's the difference? I'm planning to unlock it after the update.

Share this post


Link to post
Share on other sites

Can the tools provided here work on my Z510 Haswell Lenovo?

I've tried flashing a modded bios either from DOS or from Windows 8.1 with ftp/fpt64 and I get Error 280: Failed to disable write protection for the BIOS space!.

I was able to backup my bios.

Nobody was able to help me yet, any ideas?

Thanks!

Share this post


Link to post
Share on other sites

Hello svl7!

I recently bought a y510p, and have been tinkering around with it in my free time. I see recently you added support for versions 2.04, and 2.07. Unfortunately, after a disappointing trip to the bios menu I have version 3.07. I can't find official links anywhere from lenovo, but I could certainly make a backup of the bios.

Is is there any chance at getting some help unlocking/un-whitelisting my wireless card on this version? Or is there a safe path to downgrade, and then lock perhaps?

Any help you could provide in any way would be extremely helpful as research material is seemingly scarce online.

I've been googling this is different ways for some time, just hoping for an update somewhere.

Kind regards,

Crux

Share this post


Link to post
Share on other sites
Can the tools provided here work on my Z510 Haswell Lenovo?

I've tried flashing a modded bios either from DOS or from Windows 8.1 with ftp/fpt64 and I get Error 280: Failed to disable write protection for the BIOS space!.

I was able to backup my bios.

Nobody was able to help me yet, any ideas?

Thanks!

Nope, that will require a separate mod, but according to the error you get it will most likely not be possible for your system, unless you buy a bios chip with a modified bios on it.

I don't recommend you to flash BIOS of different laptop.

Me neither. It definitely won't work in this case.

Hello svl7!

I recently bought a y510p, and have been tinkering around with it in my free time. I see recently you added support for versions 2.04, and 2.07. Unfortunately, after a disappointing trip to the bios menu I have version 3.07. I can't find official links anywhere from lenovo, but I could certainly make a backup of the bios.

Is is there any chance at getting some help unlocking/un-whitelisting my wireless card on this version? Or is there a safe path to downgrade, and then lock perhaps?

Any help you could provide in any way would be extremely helpful as research material is seemingly scarce online.

I've been googling this is different ways for some time, just hoping for an update somewhere.

Send me a copy of your bios and I'll mod it as well.

Are there any differences in the version 1.7, 1.9 and 1.10?

Yes of course.

Share this post


Link to post
Share on other sites

svl7, are you also planning to modify the VBIOS of Ultra Bay 750M graphic card? I mean the new VBIOS released by Lenovo few weeks ago to fix no SLI problems under Win 8.1. Thanks.

Share this post


Link to post
Share on other sites

Good afternoon,

I am new to this forum, but I think I am in the right place.

I currently have a Lenovo Y510P notebook and I just installed Windows 8.1

Since doing so, the integrated Intel graphics card is taking lead and my nVidia GT 750M card is in the back seat.

This is not making me happy as I don't like having to share resources.

My BIOS is rev 3.07 which crux161 had mentioned earlier.

I would greatly appreciate any help in getting either the integrated video board disabled or the GT 750M as primary.

Cheers,

D

Share this post


Link to post
Share on other sites

In the haste of being so ready to mod this system, I find myself making armature mistakes. The version I have is 2.07, (74CN41WW) Rev3.7 is the InsydeH20 util. I just have to get my wireless card (Broadcom for hackintoshing like my old mbp 8,1). I've found a lot of good information and when I can scrape together some cash, you guys will certainly get something donated.

Thanks for your quick reply and for the 2.07 release :) I just need to contribute a little and I'll be able to take part in the un whitelisting process and get my install of mavericks online! OS X apparently hates intel wireless cards... And yet Bluetooth, built into the same hardware as the wifi, worked out of the box with zero configuration on my part... But I digress. Thanks again!

kind Regards,

crux

Share this post


Link to post
Share on other sites

Hello svl7!

Unfortunately my y510p has bios version 2.02..

Can you help me by adding v2.02 support to the tool? Or is it possible that I update my current bios to a white-list-tool friendly version?

Thanks! :)

Share this post


Link to post
Share on other sites

@dmgloden

No worries! You IGU is by default, disabled! Windows runs on the first 750m card that you can't remove. If you're having an issue activating SLI there is an update in the lenovo forms where moderators in line with tech support first released the fix for windows 8.1. The issue is that when the new driver (anything newer than the release in sometime this last April) would break SLI functionality. After many complaints on the forum, they released new drivers and specifically -- this is Key -- a VBIOS update for the ultrabay 750m card which wasn't receiving the intended VBIOS update that apparently was already performed on the internal dedicated 750m. I don't understand how that works entirely, but for SLI to function I know the cards usually need to be the same so maybe the different VBIOS created an issue in windows 8.1.

Performing the steps listed on the site I was able to restore SLI with the ultrabay card in windows 8.1 pro. I'll edit try to get the link up here if you can't find it on their forums. A lot of people are having trouble with the fix, but it was pretty simple for me — I mean, you unzip a file, run a bat, and click y, then restart lol.

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Great work ! i'll donate as soon as i have it up and running i have a Killer 1202 that i really really want to install. I simply can't understand why the would put in a lousy wireless card in a gaming laptop !

Share this post


Link to post
Share on other sites
Hello svl7!

Unfortunately my y510p has bios version 2.02..

Can you help me by adding v2.02 support to the tool? Or is it possible that I update my current bios to a white-list-tool friendly version?

Thanks! :)

Are you sure it's 2.02 and not just the utility, if it's true svl7 needs a copy of your bios. He have written a nice guide on the first page.

Share this post


Link to post
Share on other sites

@crux161

So I would agree that my IGU was disabled when I was running Win 8 Pro, but not in Win 8.1 Pro,

I am not sure how or why, but if you take a look at my attachments, I think you would agree that the IGU is most definitely not disabled.

Note that these are not with my second SLI GPU in the system.

I will gather that information when I get home to my second GPU.

Cheers

post-19691-14494996394026_thumb.jpg

post-19691-14494996394471_thumb.jpg

post-19691-14494996394922_thumb.jpg

post-19691-14494996395336_thumb.jpg

Share this post


Link to post
Share on other sites
Are you sure it's 2.02 and not just the utility, if it's true svl7 needs a copy of your bios. He have written a nice guide on the first page.

post-17359-14494996395921_thumb.jpg

I'm afraid not.. And this is also what it says at the bios screen.

Anyway.. My bios backup is send via PM.

Share this post


Link to post
Share on other sites

Maybe you should remove the bios from here and send it personally it contains your windows key.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Thanks for all your work!

Do you know if there's a hidden option to enable/disable SLI on the ultrabay or it should be plug and play?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By GrayCryptoSpordium
      Well everyone...I have a confession to make-I flashed svl7 modified 970m vbios before I wiped my drivers! Everything seemed to run fine, I could game but noticed my clocks fluctuating a bit crazy. Figured I'd try a OC profile in afterburner while running a 27 27 26 26 clock in TS a bit stupid I know. Well 3d mark froze so I did a reboot...Black Screen on startup I heard windows boot so I feared I bricked my card. Tried external monitor..works fine. This is where my stupidity really hit the cosmos. I had another m15x 900p LCD laying around plugged that in. Worked fine back too overclocking bro! Well same thing happened. My profile was not overly crazy as I can remember. But I bricked another screen. Plugged in external monitor everything fine. I was using latest nvidia drivers 436.48 I believe. So I wiped drivers using DDU. Reflashed to stock clevo bios. Tried both LCD again still nothing. Installed old 7970m still nothing. Cleared CMos again nope. Reinstalled 970m with svl7 vbios with newest driver and been gaming on my external monitor. Have done some OC with inspector. Everything seems to work as it should. Temps and performance are great. Did I brick my monitors??? Never heard of this problem. 
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.