Jump to content
EwinRacing Flash Series Gaming Chairs

Lenovo Y500 strange bootup problem ( maybe the screen cable issue )

Recommended Posts

Hi all;

I'm having some strange problems when booting up my Lenovo Y500 past two days.

When I power up the device, screen doesn't turn on as it was before.

One way that I able to use the computer is closing the top cover and re-opening it.

But before doing this I need to wait around twentyfive seconds until the system boots.

If I'm a bit quick and do this top cover trick before the lockscreen appears ( of corse I need to guess every time ) the screen turns on but there is no video on it.

This way the screen turns on and everything is normal until I reboot or shotdown the device.

For a good understanding I have taken a short video to explane the situation...


Please take a look what I have found last night.

Is this the screen cable ? Correct me if I wrong but I'm clearly sure that this thing doesn't have to seen from there...

Is there any possibility that these are some kind of hardware problem, not the software one ?

I really need your help bros, thanks in advance...

( I'm sorry about my English, thanks for reading )


Share this post

Link to post
Share on other sites


Thanks for the reply, that shows the screen problem and this cable is not connected whit each other.

I assume you are using Lenovo Y500, is this cable visible on your device, or it doesn't ?

Share this post

Link to post
Share on other sites

Hmm maybe your laptop tries to display on external screen? I had a thinkpad T400 and I remember when I attached the external screen to it, then it would automatically switch to predefined setting (clone, extended, or external only depending on what you used last time), but when I closed the lid it would automatically switch to external screen only (unless it was set to sleep with closed lid). Well, that's my guess.

Another thing you could try is to disable the external GPU in BIOS and see if it's any different. I'm not saying it's GPU fault (and it most probably isn't), just see if it's the same.

Share this post

Link to post
Share on other sites

I guess you can't even access the BIOS as nothing is displayed until you've loaded windows? Can you hook up an external monitor with a VGA cable (NOT HDMI) and see if it displays anything? This might not work as it does not have an integrated gpu..

Share this post

Link to post
Share on other sites

correct me if I'm wrong, but I'm pretty sure Y500 has integrated GPU, but it's turned off if you use SLI.

Share this post

Link to post
Share on other sites

It has because it uses i5, i7 but it's hardware disabled by manufacturer, you can't enable it. It always uses the single card no matter what.

Share this post

Link to post
Share on other sites

I looked around on the internet and you're right. Another reason why I'm happy I went with y580 instead of y500... If only it would look as good as y500 I would be completely satisfied... Ok end of OT.

Any progress on the problem VP650M?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By thinkdad
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.

      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By Qvixot
      Hello everyone! First of all sorry if this isn't the correct forum to post this.
      I bought a laptop few days ago. The laptop is Sager P150EM.
      Cpu:i7 3610qm 
      Gpu: amd hd 7970m
      Ram: 8gb
      Os: windows 8.1 pro
      So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
      Thank you so much !!!
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.