Jump to content
EwinRacing Flash Series Gaming Chairs

Transferring OS/Data from HDD to SSD in Laptop using External Hard Drive?

Recommended Posts

Okay guys, I'm completely stumped. I've tried for about the past two days now to transfer all of my data from my current 250gb HDD to my new 128gb SSD in my Alienware M15x. There's only 69.7gb on the old hdd, and I've shrunken the partition down to 106gb to fit into the 128gb (119gb in actuality) SSD. The M15x only has one SATA port (correct term?) for me to fit in an HDD/SSD, so I'm forced to use a 200gb external hard drive (again, the partition shrunken down to 94.1gb to fit into the new SSD) as a "middleman" to transfer the data. I've attempted the "Create a system image" option by creating a system image in the external hard drive, taking out the HDD and replacing it with the SSD, putting in a Windows 7 64x installation disk, and selecting the "Repair my computer" option to recover the system image from the external hard drive into the new SSD. When I try to do so, however, I can an error message stating: "No disk that can be used for recovering the system disk can be found."

Another note: When I attempt to create my own system repair disk and use them, I get an error message (I forgot what it said, it was just a bunch of numbers), therefore I'm forced to use a different Windows 7 64x disk I got off the internet (and that I know works). I do have the original Windows 7 64x disk that came with the Alienware M15x, however, when I attempt to use that, I never get the "Repair your computer" option, it only gives me the option to install the OS.

So essentially, here is my question: Does anyone know how I can transfer my OS/data from my old HDD to my new SSD? If you new any more details, or anything else to help me resolve this problem, feel free to ask. Thank you in advance!

Share this post

Link to post
Share on other sites

"Note: If you have a laptop, this becomes a bit more difficult, since you only have room for one hard drive in your computer. You'll either have to get an SSD big enough to fit all your data, or remove your optical drive and replace it with a second hard drive."

Removing the optical bay was what I was trying to avoid (that was actually the first guide of all of the n + 1 guides I tried). I've decided it would just be easier to get a 2.5" enclosure for the SSD to essentially "cut out the middleman." In which case, I've found a guide for that. Thank you for your help! I'll let y'all know if I stumble upon anymore trouble.

Share this post

Link to post
Share on other sites

I am sure the software can back up the image to an external drive and then restore from it (booting from a usb stick with the soft on it). I've done it several times with acronis true image home.

Sent from my GT-N7100 using Tapatalk 2

Share this post

Link to post
Share on other sites

I bought an adapter for the harddrive (10$), next I used the PARAGON software - it is free for home use, coped easily. I would recommend.

Share this post

Link to post
Share on other sites

I did exactly what you are trying to do with my M15x. I bought the SSD, placed it in a USB 2.0 enclosure (about £10) then used Acronis True Image to clone the current HDD. (You may need to go on Administrative tools and assign the SSD a drive letter so that it shows up in my computer). Then swapped SSD into hard drive slot and it worked perfectly.

Share this post

Link to post
Share on other sites

I've done this as well using Acronis, just make sure after you get everything back up and running you switch to a AHCI controller and ensure TRIM is enabled. This will help to make sure the SSD is running at its fastest and lasts as long as possible.

Share this post

Link to post
Share on other sites
I did exactly what you are trying to do with my M15x. I bought the SSD, placed it in a USB 2.0 enclosure (about £10) then used Acronis True Image to clone the current HDD. (You may need to go on Administrative tools and assign the SSD a drive letter so that it shows up in my computer). Then swapped SSD into hard drive slot and it worked perfectly.

I ended up doing what you did. It wasn't my initial action because I didn't have a 2.5" enclosure (I was using a 3.5" HDD converted into an external hard drive.) Without the 2.5" enclosure, I was basically adding 2-3 extra steps into the equation. However, I ended up just getting a 2.5" enclosure, and am now using the SSD. Thank you all for your help.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Max2016
      Help me Tech Inferno, you're my only hope.
      Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.
      I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.
      I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.
      Here's what I've done so far in the last 7 days:
      -Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)
      -Removed  660m and installed 980m
      -With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX
      -Tried to switch to PEG but got 8 beeps so reset CMOS battery
      -Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps
      -Reset battery, booted to Windows and disabled the 980m in Device Manager
      -Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)
      -Re enabled 980m and restarted Laptop still in Legacy SG.
      -Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.
      -Tried PEG again, still 8 beeps
      I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.
      I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.
      I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.
      Thank you,

    • By Mengqin
      Hi there,
          This is the quick step, if you don't want read more:
         1. download intel graphics driver
         2. Do the inf hack, looks into the Graphics directory, find the file igdlh64.inf, modify it. Add this line into windows 7 install section [IntelGfx.NTamd64.6.1]
                   %iKBLULTGT2%        = iSKLD_w7, PCI\VEN_8086&DEV_5917
         3. Find the file igdumdim32.dll, edit it by a hex editor, like winhex or ultraedit. Search this binary string in it:
                   83 F8 13 75 43 F7 42 04 00 00 00 02
             modify the following two bytes into
                   90 90
         4. Find the file igdumdim64.dll, edit it by a hex editor, like winhex or ultraedit. Search this binary string in it:
                   01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02
             modify the following two bytes into
                   90 90
         5. install the driver, restart.
         6. install/reinstall the discrete video card driver, not recommend a newest one. I use nvidia 397.64 driver on my MX150.
         7. enjoy it with full fucntion works.
      Start from here:
           As you know Intel didn't support graphics drivers for 7th and 8th CPU on windows 7, I do lots of research on web found some inf hack to resolve it like this:
          This way looks  work, but not perfect, I found when I playback video, player always crash on my UHD 620 (Embedded in I7 8550U) , whatever I used.
         And someone said replace some dll file will let playback work normal, but 3D function couldn't work, like this guy:
          I try all methods in the post found the same issue, so I try to dig into this problem, and finally I hack the driver binary file(DLL file) successfully.
          I must say this is not easy, you need some hacking background to understand how it work.
          First things, choose a right driver version. I do a lot testing work to test different version.I try to merge some of them but all of them couldn't work stable enough. Finally I did some research the about the  display drivers difference between winows 7 and windows 10.
          Basically, the display drivers support windows 7 must follow WDDM  1.1, but on windows 10 it support WDDM 2.0+. This means you must choose a version which support WDDM 1.1 and it support 6th or 7th CPU at the same time. Another words, your driver version must support both windows 7, and then  can support graphics like HD 620 on windows 10. 
          Drivers can match this demands isn't too much, the newest you can found officially is version (
          This version is OK, but I didn't use it, because I found drivers in same series 21.20.16.xxx, which is 4839 is listing on the windows update catalog directory by Microsoft. This means it should be more stable, you can download it from here:
          The windows catalog version is here:
          Then, the inf hack work, this is most easy part. You can learn how to do it on youtube from my first link. Here's some notice, the UHD 620's device ID is PCI\VEN_8086&DEV_5917, add the line in windows 7 section which should be like the following part. Here I use a new marco iKBLULTGT2R , and this can let you name your device, but not use HD 620's name,
      ;    Windows 7 Install - DT Only
      ; SKL HW
      %iSKLULTGT1%     = iSKLD_w7, PCI\VEN_8086&DEV_1906
      %iSKLULTGT2%     = iSKLD_w7, PCI\VEN_8086&DEV_1916

      %iSKLWSGT4%    = iSKLD_w7, PCI\VEN_8086&DEV_193D
      %iKBLULTGT2R%        = iSKLD_w7, PCI\VEN_8086&DEV_5917
            And add some lack parts for UHD 620, this is not really important thing, if you don't do it's OK. Add these lines follow the 5916 section:
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, DeviceID, %REG_DWORD%, 0x5916
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5916, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, DeviceID, %REG_DWORD%, 0x5917
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5917, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, DeviceID, %REG_DWORD%, 0x5921
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iKBL_5921, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"
          And here:
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, DeviceID, %REG_DWORD%, 0x5916
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5916, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, DeviceID, %REG_DWORD%, 0x5917
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5917, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, DeviceID, %REG_DWORD%, 0x5921
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, VendorID, %REG_DWORD%, 0x8086
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, APIVersion, %REG_DWORD%, 0x108
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, Merit,%REG_DWORD%, 0x08000015
      HKLM, Software\Intel\MediaSDK\Dispatch\iKBL_5921, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"
           And don't forget add the new display name at the end of this file:
      ; KBL 
      iKBLULTGT1     =   "Intel(R) HD Graphics 610" 
      iKBLULTGT2     =   "Intel(R) HD Graphics 620" 
      iKBLULTGT2R     =   "Intel(R) UHD Graphics 620" 
      iKBLULTGT2F    =   "Intel(R) HD Graphics 620" 
      iKBLULTGT3E15  =   "Intel(R) Iris(TM) Plus Graphics 640" 
      iKBLULTGT3E28  =   "Intel(R) Iris(TM) Plus Graphics 650" 
      iKBLULXGT2     =   "Intel(R) HD Graphics 615" 
      iKBLDTGT1      =   "Intel(R) HD Graphics 610" 
          OK, now save the file and run setup to install the drivers, it should be work. After restart, you will found the Aero came back again. And run dxdiag to check if the 3D function can work, it should work. Here you even can play some 3D game now. But the player crash couldn't stop. And the video tab of intel configure panel will crash too.
         Most tutorial  on web will end here, but my hacking is just begin. Here I must claim someone wants try to merge file to let this work, I don't think this will work. Because the different WDDM support in diffferent system, if one driver only support in windows 10 it couldn't be run on the windows 7.
         I tried merge the windows 10 driver into windows 7, and resolved tons of DLL missed and function redirect, modify tons of improt table of DLL, The drivers can be loaded, but it won't work. Just like you install a defalut VGA driver, no 3D function will work correctly.
         I started from the player crash, it reported that it crash in igdumdim32.dll @0x59c4EA0C,  the igdumdim32.dll and igdumdim64.dll is the Intel's user space graphics drivers' core file, the Intel's graphics has a small kernel part called miniports, it only open the tunnel between userspace application and the hardware, the real working part is in the DLL, like 3D function, video acceleration  and Direct draw. Use a debuger like ollydbg to debug it I found it's a function do some  setting work:
      59C4E948    8B87 0C010000   mov     eax, dword ptr ds:[edi+10C]
      59C4E94E    53              push    ebx
      59C4E94F    57              push    edi
      59C4E950    FFD0            call    eax
      59C4E952    8B8F 00010000   mov     ecx, dword ptr ds:[edi+100]
      59C4E958    8BD8            mov     ebx, eax
      59C4E95A    8D45 DC         lea     eax, dword ptr ss:[ebp-24]
      59C4E95D    50              push    eax
      59C4E95E    57              push    edi
      59C4E95F    FFD1            call    ecx
      59C4E961    8B56 10         mov     edx, dword ptr ds:[esi+10]
      59C4E964    8B0A            mov     ecx, dword ptr ds:[edx]
      59C4E966    F7C1 00002000   test    ecx, 200000
      59C4E96C    74 0C           je      short 59C4E97A                   ; igdumdim.59C4E97A
      59C4E96E    C746 18 2404655>mov     dword ptr ds:[esi+18], 5E650424
      59C4E975    E9 84000000     jmp     59C4E9FE                         ; igdumdim.59C4E9FE
      59C4E97A    F7C1 00000004   test    ecx, 4000000
      59C4E980    74 09           je      short 59C4E98B                   ; igdumdim.59C4E98B
      59C4E982    C746 18 5C04655>mov     dword ptr ds:[esi+18], 5E65045C
      59C4E989    EB 73           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E98B    F7C1 00000020   test    ecx, 20000000
      59C4E991    74 09           je      short 59C4E99C                   ; igdumdim.59C4E99C
      59C4E993    C746 18 9404655>mov     dword ptr ds:[esi+18], 5E650494
      59C4E99A    EB 62           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E99C    85C9            test    ecx, ecx
      59C4E99E    79 09           jns     short 59C4E9A9                   ; igdumdim.59C4E9A9
      59C4E9A0    C746 18 CC04655>mov     dword ptr ds:[esi+18], 5E6504CC
      59C4E9A7    EB 55           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9A9    8B45 DC         mov     eax, dword ptr ss:[ebp-24]
      59C4E9AC    83F8 15         cmp     eax, 15
      59C4E9AF    74 1C           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B1    83F8 16         cmp     eax, 16
      59C4E9B4    74 17           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B6    83F8 13         cmp     eax, 13
      59C4E9B9    75 43           jnz     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9BB    F742 04 0000000>test    dword ptr ds:[edx+4], 2000000
      59C4E9C2    75 A3           je     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9C4    C746 18 AC05655>mov     dword ptr ds:[esi+18], 5E6505AC
      59C4E9CB    EB 31           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9CD    8B42 04         mov     eax, dword ptr ds:[edx+4]
      59C4E9D0    A9 00004000     test    eax, 400000
      59C4E9D5    74 09           je      short 59C4E9E0                   ; igdumdim.59C4E9E0
      59C4E9D7    C746 18 3C05655>mov     dword ptr ds:[esi+18], 5E65053C
      59C4E9DE    EB 1E           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9E0    A9 00008000     test    eax, 800000
      59C4E9E5    74 09           je      short 59C4E9F0                   ; igdumdim.59C4E9F0
      59C4E9E7    C746 18 0405655>mov     dword ptr ds:[esi+18], 5E650504
      59C4E9EE    EB 0E           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9F0    A9 00000001     test    eax, 1000000
      59C4E9F5    74 07           je      short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9F7    C746 18 7405655>mov     dword ptr ds:[esi+18], 5E650574
      59C4E9FE    85DB            test    ebx, ebx
      59C4EA00    74 0D           je      short 59C4EA0F                   ; igdumdim.59C4EA0F
      59C4EA02    8B4B 04         mov     ecx, dword ptr ds:[ebx+4]
      59C4EA05    85C9            test    ecx, ecx
      59C4EA07    74 06           je      short 59C4EA0F                   ; igdumdim.59C4EA0F
      59C4EA09    8B46 18         mov     eax, dword ptr ds:[esi+18]
      59C4EA0C    8948 0C         mov     dword ptr ds:[eax+C], ecx         <============ crash here
      59C4EA0F    C746 1C 1800000>mov     dword ptr ds:[esi+1C], 18
      59C4EA16    C746 20 4000000>mov     dword ptr ds:[esi+20], 40
      59C4EA1D    C746 24 4000000>mov     dword ptr ds:[esi+24], 40
      59C4EA24    C746 28 4000000>mov     dword ptr ds:[esi+28], 40
      59C4EA2B    C746 2C 0400000>mov     dword ptr ds:[esi+2C], 4
      59C4EA32    C746 30 1000000>mov     dword ptr ds:[esi+30], 10
      59C4EA39    C746 34 1000000>mov     dword ptr ds:[esi+34], 10
      59C4EA40    C746 38 0008000>mov     dword ptr ds:[esi+38], 800
      59C4EA47    C746 3C 8000000>mov     dword ptr ds:[esi+3C], 80
      59C4EA4E    C746 40 2000000>mov     dword ptr ds:[esi+40], 20
      59C4EA55    C746 44 0008000>mov     dword ptr ds:[esi+44], 800
      59C4EA5C    C746 48 2004000>mov     dword ptr ds:[esi+48], 420
      59C4EA63    C746 4C 4004000>mov     dword ptr ds:[esi+4C], 440
      59C4EA6A    C746 50 2000000>mov     dword ptr ds:[esi+50], 20
      59C4EA71    C746 54 1000000>mov     dword ptr ds:[esi+54], 10
      59C4EA78    56              push    esi
      59C4EA79    C786 B8000000 3>mov     dword ptr ds:[esi+B8], 59C4D630
      59C4EA83    C786 BC000000 1>mov     dword ptr ds:[esi+BC], 59C4E410
      59C4EA8D    C786 C0000000 3>mov     dword ptr ds:[esi+C0], 59C4D830
      59C4EA97    C786 C4000000 4>mov     dword ptr ds:[esi+C4], 59C4E440
      59C4EAA1    C786 C8000000 A>mov     dword ptr ds:[esi+C8], 59D71FA0
      59C4EAAB    C786 CC000000 1>mov     dword ptr ds:[esi+CC], 59C4DB10
      59C4EAB5    C786 D4000000 8>mov     dword ptr ds:[esi+D4], 59C4E680
      59C4EABF    C786 D8000000 1>mov     dword ptr ds:[esi+D8], 59C4DC10
      59C4EAC9    C786 DC000000 8>mov     dword ptr ds:[esi+DC], 59C4E680
      59C4EAD3    C786 E0000000 8>mov     dword ptr ds:[esi+E0], 59C4E880
      59C4EADD    C786 E4000000 2>mov     dword ptr ds:[esi+E4], 59C4DD20
      59C4EAE7    C786 EC000000 6>mov     dword ptr ds:[esi+EC], 59C4CE60
      59C4EAF1    C786 F0000000 D>mov     dword ptr ds:[esi+F0], 59C4CED0
      59C4EAFB    C786 F4000000 8>mov     dword ptr ds:[esi+F4], 59C4CC80
      59C4EB05    C786 F8000000 F>mov     dword ptr ds:[esi+F8], 59C4E8F0
      59C4EB0F    E8 7CF8FFFF     call    59C4E390                         ; igdumdim.59C4E390
      59C4EB14    8B4D FC         mov     ecx, dword ptr ss:[ebp-4]
      59C4EB17    5B              pop     ebx
      59C4EB18    5F              pop     edi
      59C4EB19    33CD            xor     ecx, ebp
      59C4EB1B    5E              pop     esi
      59C4EB1C    E8 7354EEFF     call    59B33F94                         ; igdumdim.59B33F94
      59C4EB21    8BE5            mov     esp, ebp
      59C4EB23    5D              pop     ebp
      59C4EB24    C2 0400         retn    4
          This function is setting some thing according a flag which read from call on @59C4E95F, and the following part is a complex branch to select correct arguments for the function call @59C4EB0F. I tried some trace route and found we need let  branch @59C4E9C2 goes false, so here we make it to nop like this:
      59C4E9B1    83F8 16         cmp     eax, 16
      59C4E9B4    74 17           je      short 59C4E9CD                   ; igdumdim.59C4E9CD
      59C4E9B6    83F8 13         cmp     eax, 13
      59C4E9B9    75 43           jnz     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9BB    F742 04 0000000>test    dword ptr ds:[edx+4], 2000000
      59C4E9C2    90              nop
      59C4E9C3    90              nop
      59C4E9C4    C746 18 AC05655>mov     dword ptr ds:[esi+18], 5E6505AC
      59C4E9CB    EB 31           jmp     short 59C4E9FE                   ; igdumdim.59C4E9FE
      59C4E9CD    8B42 04         mov     eax, dword ptr ds:[edx+4]
      59C4E9D0    A9 00004000     test    eax, 400000
      59C4E9D5    74 09           je      short 59C4E9E0                   ; igdumdim.59C4E9E0
          OK, the most important part comes, translate the RVA into file address, and modify it. Sounds really hard isn't it? Good news is there is a more easy way, and this is the signature about this fix:
          83 F8 13 75 43 F7 42 04 00 00 00 02
          Search this hex string in the file, modify the following two bytes into "90 90"
      00291280h: 74 09 C7 46 18 5C 35 C6 14 EB 73 F7 C1 00 00 00 ; t.荈.\5?雜髁...
      00291290h: 20 74 09 C7 46 18 94 35 C6 14 EB 62 85 C9 79 09 ;  t.荈.??隻吷y.
      002912a0h: C7 46 18 CC 35 C6 14 EB 55 8B 45 DC 83 F8 15 74 ; 荈.??險婨軆?t
      002912b0h: 1C 83 F8 16 74 17 83 F8 13 75 43 F7 42 04 00 00 ; .凐.t.凐.uC鰾...
      002912c0h: 00 02 90 90 C7 46 18 AC 36 C6 14 EB 31 8B 42 04 ; ..悙荈.???婤.
      002912d0h: A9 00 00 40 00 74 09 C7 46 18 3C 36 C6 14 EB 1E ; ?.@.t.荈.<6??
      002912e0h: A9 00 00 80 00 74 09 C7 46 18 04 36 C6 14 EB 0E ; ?.€.t.荈..6??
           We need the do same thing for file igdumdim64.dll, but because this is 64bit dll, so the signature is different:
         01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02
          The modify should like this
      002d56f0h: 73 09 48 8D 05 1F AD A7 04 EB 6D 0F BA E1 1D 73 ; s.H?..雖.横.s
      002d5700h: 09 48 8D 05 48 AD A7 04 EB 5E 85 C9 79 09 48 8D ; .H?H.隵吷y.H?
      002d5710h: 05 73 AD A7 04 EB 51 8B 4C 24 20 8D 41 EB 83 F8 ; .s.隥婰$ 岮雰?
      002d5720h: 01 76 17 83 F9 13 75 44 F7 42 04 00 00 00 02 90 ; .v.凒.uD鰾.....?
      002d5730h: 90 48 8D 05 30 AE A7 04 EB 2E 8B 42 04 0F BA E0 ; 怘?0.?婤..亨
      002d5740h: 16 73 09 48 8D 05 AE AD A7 04 EB 1C 0F BA E0 17 ; .s.H???.亨.
      002d5750h: 73 09 48 8D 05 67 AD A7 04 EB 0D 0F BA E0 18 73 ; s.H?g.?.亨.s
           OK after modify the two file, replace it into the windows directory, if your windows is 64 bit, put igdumdim64.dll into windows\system32, and  igdumdim32.dll into windows\sysWow64. This must be done under the safe mode, restart windows and press F8 before windows startup, goes into safe mode to replace it.
          After reboot, you will get all things work.
         PS: In my system the nvidia's video card cause some problem, it will let system hang sometime, I highly recommand to reinstall the nvidia's drivers after install the Intel's drivers. and choose a lower version, but not the newest version. I have UHD 620 and MX 150 in my system, and after I reinstall the 397.64 nvidia drivers the problem gone away and the laptop works like a charm.
    • By AMan
      I recently bought the new Toshiba RC100 m.2 2242 NVMe SSD for my Lenovo Y510p which has an m.2 port in it.
      After installation the SSD wasn't showing up in my BIOS and also not on my OS Win 10 disk management. So I did a bit of research and installed mod BIOS for my Y510p by following the steps in the link: ( https://www.techinferno.com/index.php?/forums/topic/3546-lenovo-y410p-y510p-unlocked-bios-wlan-whitelist-mod-vbios-mod/ )
      There are a lot more options in the BIOS menu now.
      Even after doing the mod it's not showing up. The SSD works on my friend's "new 2017 dell gaming laptop" which has m.2 ssd support in it. I don't know what exactly to configure my BIOS to make it work. I've just done some hit-and-trial configs which have eventually failed.
      If someone can help solve it Pleasee!!
      P.S. : I can share all the available options available in the BIOS if required.
    • By awesum
      hi guys,
      i have a z510 59398016 indian variant.
      I had replaced the oem 1tb sshd on sata 3 port that came in it with 250 gb ssd 1 year ago.
      now the optical disk drive on sata1 has gone haywire and i do not want to replace it as cd and dvd are obeolete and useless to me.
      can some one suggest a caddy for z510 to use my old sshd in place of optical disc drive ?
      would i be able to dualboot BW 2 drives if i do the above?
      I tried caddy from local vendor but it is not getting recognised.
      plz suggest some caddies compatible with z510
    • By SenikTheFasthog
      Good day,

      I am the owner of a used m18x r2 struggling to build it back up into a functional machine. The previous user had his system installed in RAID mode which won't suffice for my desired SSD boot speeds. I've ensured that both AHCI and UEFI are active in the A11 BIOS. I have also ensured to clean the main drive via diskpart CMD upon custom installing my copy of Win 7 Ultimate. Oddly enough, when the setup completes, I'll get an error message stating windows can't finish configuring and needs to restart. Heeding this message will only cause it to happen again on the next reboot, so CMD to the rescue and creating and off to making user account I go. Unfortunately, boot speeds are as slow as ever and I've verified that no RAID controllers have been left installed in the device manager. So far, my only potential lead is that I've noticed during each boot, Windows mentions that "Setup Is Updating Registry Settings" after about of minute of Starting Windows. I've been researching this exact string but I can't say I've found a concrete solution to attempt just yet.

      So here I am, requesting for advice as to what I should check next.

      Thanks in advance!

      EDIT: I've tried out a new install accessing the CD through legacy but still keeping the SDD Boot drive on UEFI mode. So far haven't had to mess with CMD anymore to proceed nor has the Setup needed to Update Registry Settings. I also remembered to install the intel rapid storage driver.  Alas, I'm still left with 2 minute boot times(particularly on the Starting Windows screen), so the problem still remains.

      EDIT2: Diagnosing with a Boot Manager, I discovered it takes about a minute before svchost even starts running. So with that, I ruled out it wasn't a software problem. I then decided on the possibility that maybe the other drives could be interfering with booting. Pulling out the other HDDs had no effect, but the actual culprit was the mSATA SSD that was left in from the last user. Now I can enter windows in 3 seconds!

      Even fishier, this mSATA drive says its 32 GB but Speccy says its a 1GB drive. But that's a problem for another time, at last my 850 EVO is showing off its expecting speeds.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.