Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

First BIOS update for the new Alienware 18 has just been released, grab version A02 here: Driver Details | Dell US

>>>>>

Before updating to A02 please check whether your machine came with A01, I'm still looking for a dump of that version. If that's the case please wait with updating and let me know so I can tell you how to dump your current version for me. Would be really appreciated.

>>>>>

Changelog A02:

1. Update Intel GOP 5.0.1032.

2. Update Intel VBIOS 2175.

3. Modify load default behavior in Setup Menu.

4. Enhance secure boot function.

5. Enhance Panel information interface.

6. Update Microcode 306C3h Rev.09h.

7. Add New ROM part support.

8. Disable WLAN ASPM L0s.

9. Modify SATA configuration behavior for tool load default.

10. Add CMFC OEM Project Function.

  • Thumbs Up 4

Share this post


Link to post
Share on other sites

I'm assuming this bios has no effect on the throttling issues being reported recently? I haven't even gotten my AW 18 system yet and now we have throttling problems, driver issues, inadequate PSU, GAH!

Share this post


Link to post
Share on other sites
Guest

The PSU is not inadequate for almost all purposes. If you ordered 4930MX and 780M SLI and plan to do extreme overclocking, it won't be enough. Otherwise, it will be totally fine. Even with extreme overclocking, there are not many benchmarks that will completely exhaust the 330W AC adapter and no games will unless you are pouring on more power than appropriate or necessary. The GPU throttling problem is fixed thanks to John and svl7, and I am optimistic there will be a BIOS update to take care of the CPU power settings that prevent the CPU from running full speed under load. I believe your story should have a happy ending, but you may have to be patient while it gets worked out. This is one of the hazards of being an early adopter/pioneer with a new product... happens a lot of the time. It was like that with 580M, 680M and 7970M. None of them were without issues or performed that well at launch.

Share this post


Link to post
Share on other sites

Hi svl7, I just got hold of an AW18. it was built last week and shipped with BIOS A00, do you need this BIOS version?

Also what is the precedure to dump the BIOS?

I could not see any way to do this using various windows or DOS BIOS tools. The supplied flash utility just flashes your BIOS without giving you a backup option as far as I can see.

To this point I have not tried to flash A02 on this system.

Share this post


Link to post
Share on other sites

Thank you, I already have a copy of that version.

Share this post


Link to post
Share on other sites

Yes, I can send you a chip with an unlocked BIOS.

Flashing per software won't work at the moment. I don't have a system to test it myself and most people don't seem to be eager to test anything.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I just updated to BIOS A02, and noticed the CPU fan is now always running. with the A00 BIOS it would switch off when the CPU was idle and had a low temp.

Has anyone else found this?

Also is there an application that can contol the fan speed on these systems?

Share this post


Link to post
Share on other sites

a chip for unlocked bios!! don't got the machine and I likely won't have enough skills to use this unlocked chip.

Share this post


Link to post
Share on other sites

Anxiously awaiting whichever genius manages to unlock the Alienware 18 bios. Able to tune about 95% of what I want using Intel XTU and the unlocked 780m VBios but still missing some things like core current limit.

Good luck!

Share this post


Link to post
Share on other sites

Already did that, only need to figure out how to flash it. Kinda hard without a system for testing. Or a tester.

Share this post


Link to post
Share on other sites
Already did that, only need to figure out how to flash it. Kinda hard without a system for testing. Or a tester.

Share this post


Link to post
Share on other sites

I'll see that I can come up with some easy things to test. I'll send you an email when I get the chance.

Share this post


Link to post
Share on other sites
I'll see that I can come up with some easy things to test. I'll send you an email when I get the chance.

Hey let me know if I could help test out the unlocked BIOS too, as long as it won't break the comp :D

Share this post


Link to post
Share on other sites
Yes, I can send you a chip with an unlocked BIOS.

Flashing per software won't work at the moment. I don't have a system to test it myself and most people don't seem to be eager to test anything.

May I have this, and what would it cost you to provide me with this please. We're talking some small microcontroller or the bios rom itself on ic itself ?

Share this post


Link to post
Share on other sites

An eeprom flashed with the modified bios. Send me a PM with your location and so I can check shipping costs and tell you a total.

Share this post


Link to post
Share on other sites
An eeprom flashed with the modified bios. Send me a PM with your location and so I can check shipping costs and tell you a total.

sent awhile ago, but haven't heard back from you. Any news? Did you get my paypal ?

Share this post


Link to post
Share on other sites

bump. still now word. Also, where is the bios chip itself on the mobo ? And anything think using some thermalconductive paint to hold a new on be okay ? shouldn't have more then like >100 Ohms resistance... probably single digits too...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By elppa
      I bought an Alienware 18 off of eBay that was not working and I am trying to figure out what I need to get it working.  Currently, when you try to power it on it doesn't do anything, no lights, no fans, no screen backlight, no beeps.  I have tried unplugging it, taking the battery and CMOS battery out, hold the power button for 30 seconds etc. still doesn't work.
       
      I also tried the steps found in this thread. 
      http://forum.notebookreview.com/threads/how-to-reset-the-bios-if-one-runs-into-no-post-with-a-messed-up-bios.735514/
       
      The power adapter powers up other computers, so that seems good.  I also measured the voltage on the motherboard and it is 19.1 volts.  So everything seems good. 
       
      I am thinking the motherboard is bad and I need to order another one, but before I did that I wanted to see if there was anything else to check/do.  Any help would be greatly appreciated. 
    • By pathan707
      Hi Everyone !! This is my very 1st post in the forum so please pardon my ignorance.  Screen flashes 3 times, turns on and off before it begins to boot when UEFI fast boot is enabled.This has been driving me crazy,when I boot only from msata, boot time is around 10 seconds or when I connect only 1 hd in caddy and 1 in normal bay, laptop boots fine but when all three connected, ssd, msata, 2 hd 7200rpm, the screen keeps on flashing several times before it boots relatively slow. I think it starts going nuts when I connect samsung ssd combined with normal hd. I ran Microsoft assessment and got few error about BIOS initialization  I would appreciate any kind of input .... cheers    My  setup. Aleinware 18  i7 4900mq Nvidia 780m SLI  Windows 10 256gb msata ssd (boot drive)  256gb samsung evo 840(hd 1) 1tb 7200rpm hard drive (hd 2) 750gb wd black 7200rpm (hd 3 in Blu-ray slot)  Fast boot enabled, uefi enabled  Bios(latest) Ahci    Things i have done  Removed/updated free fall sensor  Uninstalled intel RST Updated bios  Updated ssd firmware  Swap hd bays  turned off fast boot in windows Fresh OS installed  Driver updates
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:

       
    • By Swick1981
      Hey Everyone,
       
      First off, YOU TAKE FULL RESPONSIBILITY FOR FLASHING THIS!  YOU WILL NOT HOLD ME RESPONSIBLE FOR ANY PROBLEMS YOU MAY RUN IN TO BY FLASHING MY MOD!
      YOU WILL NOT HOLD TECHINFERNO RESPONSIBLE, EITHER!  THIS IS YOUR CHOICE!
       
      Now on to the good stuff...
       
      I've officially cracked it - either by luck or persistence (I'm thinking LUCK, lol) - 
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 - FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      Here is what I've added/updated/modded/changed/etc...
      ADDED LEGACY SUPPORT FOR THE m18XR2 -
      You can now run Windows 7 with 900 series nVidia GPU's!  
      Changed the Default GPU from PEG to IGFX - No need to tear down laptop anymore.  8-Beeps are a thing of the PAST!
      Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED)
      Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED)
      Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132)
      Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132)
      Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6)
      ADDED NvMe Support for m18xr2
      ADDED M.2 support for m18xr2
      Updated CPU Microcode to v29 for the 2900 CPU's
      Updated CPU Microcode to v1c for the 3900 CPU's
      Updated CPU Microcode for other supported CPU's if available! Sorry, I don't remember what version, but if it could be updated, it was!)
      Updated GOP Driver for Intel Sandy Bridge
      Updated GOP Driver for Intel Ivy Bridge 
      Updated GOP Policy for the m18xR2
      Raidriar added the "Package C-States Lock" to my bios mod - THANK YOU RAIDRIAR!
       
      YOU TAKE FULL RESPONSIBILITY FOR FLASHING THIS, AS FLASHING CUSTOM BIOS's HAS SOME RISK!!
      I AM IN NO WAY RESPONSIBLE FOR ANYTHING THAT HAPPENS TO YOUR PC BY FLASHING THIS MOD!!
       
      DOWNLOAD INFO:
      My BIOS MOD should be available in the download section of TechInferno!  They have KINDLY offered to host the file, thankfully!  
      You MUST meet the minimum requirements of T|I in order to download files from their download section!  
      PLEASE NOTE:  Do not distribute this file.  Please tell others that want the file to download it from TechInferno, as the file is GUARANTEED to be clean if you get it from here.  If you download it from anywhere else, there is a chance that the code will be changed, and may BRICK your laptop.  Therefore, PLEASE make sure you download from here and ONLY here!   
       
      I'd like to THANK the following people for testing my bios mods to make sure they are safe for the rest of you:
      Mr. Fox, Raidriar, Rengsey R.H. Jr!  Thanks for testing, I'm grateful!
      RAIDRIAR, from nbr, needs an EXTRA shoutout for testing.  He was UTTERLY amazing!  He took risks no sane OR INSANE person would!  I owe him for testing this!  He deserves a LOT of credit for that!
       
       
      Also, I do have an UPDATE to Intel Management Firmware v8.1.64 (I think), but that is a SEPARATE package.  If you are interested, you can do that upgrade, too.  HOWEVER, PLEASE NOTE, if you plan on doing update you MUST do BIOS update FIRST - AGAIN, BIOS UPDATE MUST BE DONE FIRST!  AFTER bios update is done, then you can do IME update.  
      If you update the IME then BIOS, YOU WILL BRICK YOUR SYSTEM!  YOU MUST DO BIOS FIRST, THEN THE Intel ME Update!
       
      If you like this mod that I've done, please donate a couple KEGS of beer to me, as I put a TON of work into this.  I put more hours into this than I should have...  LoL
       
      I can also confirm that this has been tested by MANY people.  Mr. Fox, Raidriar, and a few others, and they had NO issues.  EXCEPT that they were finally able to install Windows 7 while in legacy mode (set from within bios),  and the GPU works completely.  The only ting I am still working on is the throttling issue on ALL GPU's (Some worse than others).  IF you use Mr. Fox's modded drivers, 355.20 I believe, the throttling issue is minimal with the 780m GPUs.  Anything above those drivers seems to throttle all GPU's at a more extreme rate.  I AM working on this throttling issue, but I am not sure it's fixable.  But I will TRY!  
       
      Again, I hope you ALL like this, and that it helps you out.  
      Lastly, IF you flash my MOD and you decide to purchase another 900 series GPU, please make sure you use woodstackz, as he sells them at the best rates.  Please let him know you are purchasing the GPU because of this mod, as it will help me out a little!
       
      I hope you like this!
       
      Swick
       
      Link To Donate:   
       
      EDIT:  I forgot to put fparts.txt in the rar file with all the other files.  sorry about that.  I'm including it here on this post!
      SORRY!
       
      PS.  I AM working on porting ALL these mods to the m17xR4, but dont know if I can get LEGACY SUPPORT ported!  I AM TRYING,  but if I can't, I'll be able to port EVERYTHING else...
       
      File download link:

       
       
       
       
    • By DroidiQ
      Specs: 4900MQ, 16Gb, 980m SLI.
       
      I recently upgraded my GPU from 780m SLI to 980m SLI.
       
      I am facing performance issues. I had very low passmark 43xx, I mainly play dota 2 and with my 780m sli, i used to get around 120FPS on medium settings. 
      With the new 980m sli i am getting anywhere from 80fps to 30fps on highest settings. And FPS is not stable at all. If i even drop the settings to medium or low I still get the same fps. 
      I got the latest drivers for everything and made sure that SLI is turned on. 
       
      I am missing anything? Any help would be appreciated. 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.