Jump to content
EwinRacing Flash Series Gaming Chairs
whatisit

Lenovo Y400 (and Y500) trackpad disable on boot/resume/wakeup

Recommended Posts

If I missed a thread about this, please let me know. I couldn't find it, though.

I prefer not using the trackpad on my Y400 unless I forget to bring my mouse where I go. So, I would like to disable it upon boot, resuming from hibernation, or when waking from sleep. I know that I can manually hit Fn+F6, but I would prefer to do that only if I forget my mouse and need to enable it. So, default = disabled.

Another related issue is that even when I have the trackpad disabled (ie. most of the time) and I put the computer to sleep to travel somewhere, it automatically enables the trackpad again upon resuming from standby. I am not sure if the solution to both these issues would be the same or not...but in case not, I thought I would mention it also.

So, I guess my question is: do I do this via a bios setting? Or, do I need to follow some other method to do so?

Some additional info. Under Device Manager, I cannot disable the Lenovo Pointing Device. There is simply no option for it. And in the properties for it, the Disable option is greyed out.

Share this post


Link to post
Share on other sites

From what little time I owned my y500, the trackpad was really flimsy and wouldn't even pick up a lot of time. Maybe consider tweaking its sensitivity? Or you can disable it manually in device manager under mouse and pointing devices.

Alternatively, why not use hibernate instead of suspend? Suspend (assumimg you're OS is booting from mSSD) writes to the SSD where as hibernate writes to RAM. It takes more of a toll on your SSD's lifespan than hibernate would and draws more power.

Share this post


Link to post
Share on other sites

I generally do hibernate if I don't need it on for a lengthy period of time. The 20 minutes that it takes to walk to school isn't very lengthy, so I generally don't for this trip. Regardless of my methods, hibernate *and* sleep have the same effect, whereby the trackpad is enabled aftering resuming from either.

The trackpad isn't the best quality I've every experienced, but it's far from the worst also. I've had problems where it's too sensitive, rather than the opposite like you mentioned. Also, as I mentioned in the extra info at the bottom of the previous post, I actually cannot disable it. There's no option when I right click. When I go into the properties for it, the disable option is greyed out. I would rather not uninstall it completely, because there are a handful of times where I use it or forget to bring my mouse with.

One update to my first post is that I checked within the BIOS and definitely couldn't find anything about it there. So, I guess that answers that particular question I had. I'm looking to flash/unlock the BIOS soon, so maybe something will be available in there. I can update after I find out (or if someone already happens to know....).

Share this post


Link to post
Share on other sites

Many trackpad drivers have the option to automatically disable it as soon as a mouse is plugged in, did you check for this option?

Share this post


Link to post
Share on other sites

No, didn't look before. I checked and there's no such option in either of the drivers' properties. It gave me an idea to install the actual software (I only had the drivers), for the mouse, which is an MS arc mouse. After installing that (Microsoft Mouse and Keyboard Center), I didn't find any options other than controlling the button settings, unfortunately. There is this "app-specific settings" option, but that's basically so the mouse buttons perform different actions depending on which application is open. Nothing related to completing an action (such as disabling the trackpad) if the mouse is attached to the computer.

A bit of an aside, but all this stuff reminded me that I had this ability with my last Toshiba laptop. There was an option in the BIOS where the trackpad could be disabled upon boot. There was a button near it which, when pressed, enabled it, similar to Fn+F6. I guess that's why I was thinking maybe the BIOS on this one would have something similar.

Share this post


Link to post
Share on other sites

Do you have the Synaptics touchpad? If so, it's a really easy fix. Just double-click on the gray touchpad icon in the Notification Area and go to the touchpad settings under the last tab. Under Advanced there is a setting called Switch Touchpad Off For One Session. If you uncheck it, your touchpad will remain in its last state (on/off) even after you log off.

Share this post


Link to post
Share on other sites

I wish it was that easy. I have the icon, no problem. When I bring up the Pointing Device Properties, I don't have an Advanced tab. Still, I looked under all the tabs for anything again and didn't see an option like switching it off for a one session. Under the Device Settings tab, there *is* an option to enable/disable (not specifically for one session, however). I tried disabling it, but it came back on when resuming the computer like before. I also tried clicking the Settings button and dug through all the options there but didn't see anything relating to enabling or disabling.

Since you obviously have this...I'm wondering if my driver is not correct somehow. I'll try downloading the ones from Lenovo, uninstalling, reinstalling to see if this fixes and will report back.

EDIT: The driver may actually be the problem. I am still downloading but can verify afterwards. The reason I think this is because I've had issues with a couple other drivers, specifically audio and webcam, because I am running Win 7 and used the Win 7 drivers. For whatever reason, the Win 8 drivers *did* work. Found this out a couple months ago when I was first installing the new drivers on my existing SSD.

Share this post


Link to post
Share on other sites
I wish it was that easy. I have the icon, no problem. When I bring up the Pointing Device Properties, I don't have an Advanced tab. Still, I looked under all the tabs for anything again and didn't see an option like switching it off for a one session. Under the Device Settings tab, there *is* an option to enable/disable (not specifically for one session, however). I tried disabling it, but it came back on when resuming the computer like before. I also tried clicking the Settings button and dug through all the options there but didn't see anything relating to enabling or disabling.

Since you obviously have this...I'm wondering if my driver is not correct somehow. I'll try downloading the ones from Lenovo, uninstalling, reinstalling to see if this fixes and will report back.

EDIT: The driver may actually be the problem. I am still downloading but can verify afterwards. The reason I think this is because I've had issues with a couple other drivers, specifically audio and webcam, because I am running Win 7 and used the Win 7 drivers. For whatever reason, the Win 8 drivers *did* work. Found this out a couple months ago when I was first installing the new drivers on my existing SSD.

Sounds like a driver issue. You should only use the Lenovo-provided touchpad drivers and not the ones from the Synaptics website because those are missing a lot of features and functionality. I learned that when I did my clean install of Windows 8.

Share this post


Link to post
Share on other sites
Sounds like a driver issue. You should only use the Lenovo-provided touchpad drivers and not the ones from the Synaptics website because those are missing a lot of features and functionality. I learned that when I did my clean install of Windows 8.

Share this post


Link to post
Share on other sites

I don't know why it's not working properly for you because it's fine on my machine. With the option unchecked I can disable the touchpad using Fn+F6 and it will stay off no matter how many times I sleep/hibernate/reboot until I decide to manually enable it again. With the option checked the touchpad will automatically be enabled each time I reach the login screen.

Share this post


Link to post
Share on other sites

Got it! Honestly, I"m not exactly sure what I did. Last night in my tired haze, I tried installing the ELAN drivers then the Synaptic drivers for Windows 7, then I did the same for Windows 8. For whatever reason, when I got the Win 8 Synaptic drivers installed, it seemed to work after restarting. Now I'm just leaving it unchecked. I did notice that for a brief moment during booting, just after the desktop becomes visible that the touchpad is responsive. It quickly stops, however. Thanks for all the help/suggestions, everyone!

Share this post


Link to post
Share on other sites

This might be a bit of a stupid suggestion, but why not just pull the ribbon cable that connects the touchpad to the motherboard?

Share this post


Link to post
Share on other sites

Because, 95% of the time, I don't want to use it. But, that 5%....I don't want to take apart the computer everytime that 5% comes to pass.

Share this post


Link to post
Share on other sites

Not to mention it's not exactly easy to get to that step without breaking anything, and you definitely don't want to be taking the laptop apart each time you want to use the touchpad.

Share this post


Link to post
Share on other sites

In the system tray click synaptics icon.

Just modify the setting: disable for one session.

Disable that or uncheck it.

Done

Share this post


Link to post
Share on other sites
In the system tray click synaptics icon.

Just modify the setting: disable for one session.

Disable that or uncheck it.

Done

I fixed the title of the thread, because I already fixed the problem. But the first problem was that this option wasn't available for me (because of driver version). Then it wasn't working. Anyway, see my previous post for a semi-explanation on how it fixed. But fixed nonetheless.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.