Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
savvas

[SOFTWARE MOD] Backlight Controller with LightFX

Recommended Posts

So it could be possible to add a 50% brightness level to the default colours, e.g. Bright Red (100%) and a Dark Red (50%) which could effectively double the colour palette (well sort of double it as we cant do custom colours). Just a idea.

In a way yes, as long as you don't overdo it. In fact i have used that trick in the alienFX library in the other thread

Share this post


Link to post
Share on other sites

Sounds good. I think settings of 100% and 50% would be more than enough, as you any more would be overkill.

Share this post


Link to post
Share on other sites

I've got a sager np8250, and hotkey works fine. however, when I copy over the new files for the custom light controller, it says i need to update my .net framework. I've reinstalled version 4 of the .net framework and it still gives me the error. If i use the original ”LEDKB.exe” and “GetProductdll.dll" files, then hotkey works fine again. any suggestions?

Share this post


Link to post
Share on other sites
Sounds good. I think settings of 100% and 50% would be more than enough, as you any more would be overkill.

thing is you can't set separate brightness for each of the keyboard zones. It's a single brightness for the whole thing.

So what you're saying only applies if you use the same color for all 3 zones.

That aside, i'll incorporate a brightness slider in the custom color panel in the next version.

Share this post


Link to post
Share on other sites
thing is you can't set separate brightness for each of the keyboard zones. It's a single brightness for the whole thing.

So what you're saying only applies if you use the same color for all 3 zones.

That aside, i'll incorporate a brightness slider in the custom color panel in the next version.

Shame about the single brightness for the whole keyboard. But the brightness slider idea would be a handy option.

Share this post


Link to post
Share on other sites

I have steelseries keyboard on my clevo p150em.

This mod working with this keyboard?

Share this post


Link to post
Share on other sites

new version out:

0.0.5.3: 12/8/13

-replaced colorstrip with an animated alienware style colorwheel

-added brightness slider in custom color panel

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
new version out:

0.0.5.3: 12/8/13

-replaced colorstrip with an animated alienware style colorwheel

-added brightness slider in custom color panel

0.0.5.2 works on my system. 5.3 faults...

Faulting application name: LEDKB.exe, version: 0.0.5.3, time stamp: 0x52089d57

Faulting module name: KERNELBASE.dll, version: 6.2.9200.16451, time stamp: 0x50988950

Exception code: 0xe0434352

Fault offset: 0x00014b32

Faulting process id: 0xf30

Faulting application start time: 0x01ce97ca07d445b9

Faulting application path: C:\Program Files (x86)\Hotkey\LEDKB.exe

Faulting module path: C:\windows\SYSTEM32\KERNELBASE.dll

Report Id: 45cbd363-03bd-11e3-bf40-0090f5e33744

Faulting package full name:

Faulting package-relative application ID:

---

another event at the same time gives this:

Application: LEDKB.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.TypeInitializationException

Stack:

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])

at LEDKB.Program.Main()

[system is a P370EM]

Share this post


Link to post
Share on other sites

Ok we'll fix it.but I'll need a bit more from the error message.scroll down and read the rest of you can

Share this post


Link to post
Share on other sites

Can confirm bohr's error. Getting the same message in my event viewer here.

Share this post


Link to post
Share on other sites
'Updated the earlier post with the full event viewer log from the crash..

Share this post


Link to post
Share on other sites

for those dealing with crashes i've released a new version today that should fix the problem

Share this post


Link to post
Share on other sites
I have steelseries keyboard on my clevo p150em.

This mod working with this keyboard?

Share this post


Link to post
Share on other sites

0.5.2 works great on my P170EM but .3 and .4 both fail to start.

Share this post


Link to post
Share on other sites

I assume this won´t work with SM units right?

May i be of some help to make this compatible with the new 4th generation SM units?

Share this post


Link to post
Share on other sites
I assume this won´t work with SM units right?

May i be of some help to make this compatible with the new 4th generation SM units?

it should work actually. Try it out.

If you're interested in helping out you're more than welcome!

Share this post


Link to post
Share on other sites
it should work actually. Try it out.

If you're interested in helping out you're more than welcome!

Well im sure it doesn´t work in SM units with Windows 8 i just tested and it didn´t, probably something to due with the Clevo Hotkey driver version.

I am going to try it with Windows 7 and the hotkey windows 7 version (wich is the same for the old EM units) and i will let you know.

Share this post


Link to post
Share on other sites

Since the last few versions, the program does not minimize to the tray correctly.

Whenever I open Task-Manager it is shown as an active window (app) and not as a background process. This wasn't happening in previous version (e.g. 0.0.5.0).

And the annoying thing is that whenver I use Alt+Tab in a fullscreen program, the interface opens every time, although it is minimzed to tray.

Share this post


Link to post
Share on other sites
Since the last few versions, the program does not minimize to the tray correctly.

Whenever I open Task-Manager it is shown as an active window (app) and not as a background process. This wasn't happening in previous version (e.g. 0.0.5.0).

And the annoying thing is that whenver I use Alt+Tab in a fullscreen program, the interface opens every time, although it is minimzed to tray.

yeah i see what you mean, i'm on it

Share this post


Link to post
Share on other sites

I'm in the same boat as deis... I click the link in Hotkey, or try the default keyboard shortcut, and nothing pops up. I can tell it tries to load, because CPU usage goes up for a few seconds, then that's it. If there was an error message, I'd give you one, but never did anything show up.

EDIT: I'm on Windows 8 with a P150EM with 7970M dGPU and Intel HD 4000 iGPU... I'm also running hotkey 8.0129...

EDIT2: I did find some errors in the Event Viewer...

Application: LEDKB.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.TypeInitializationException

Stack:

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])

at LEDKB.Program.Main()

And

Faulting application name: LEDKB.exe, version: 0.0.5.4, time stamp: 0x520c919b
Faulting module name: KERNELBASE.dll, version: 6.2.9200.16451, time stamp: 0x50988950
Exception code: 0xe0434352
Fault offset: 0x00014b32
Faulting process id: 0xe08
Faulting application start time: 0x01cea36fcac2f28e
Faulting application path: C:\Program Files (x86)\Hotkey\LEDKB.exe
Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll
Report Id: 08bb2d82-0f63-11e3-be74-446d575a9349
Faulting package full name:
Faulting package-relative application ID:

Share this post


Link to post
Share on other sites
yeah i see what you mean, i'm on it

thank your for this awesome piece of software. it work nearly perfect on my system (p170em).

Only one small bug and it works perfect. When I let the program show the temps at the tasklist, then I`ve got a freeze (only your program) after gaming. I´ver check all versions with this feature (think above 0.52).

Thank you

Share this post


Link to post
Share on other sites

new version is out. It should fix the problem with the app showing in alt-tab when minimized to tray

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.