Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

The GT 555m is basically exactly equal to the desktop 9800 GT except for the fact that the former has more memory, DX11 support, and handles heat and energy better. Additionally, Anno 2070 is very CPU heavy as with most strategy games, so that might help to post.

Share this post


Link to post
Share on other sites

I like to compare a well overclocked 555mgt to a 450gts, the 450gts is a bit stronger(10-15%~) but is generally used at higher resolutions. So on sites like Nvidia optimize its makes it really easy to get a solid ballpark for what settings you should be using.

Share this post


Link to post
Share on other sites

You need to test to know if cpu is causing excessive gpu temps. Turn turbo off with Throttle Stop and restest or even drop it lower with Throttle Stop so you can see if gpu still hits those temps on stock and overclocked.

Sent from my Paranoid Samsung Galaxy S3 on Sprint using Tapatalk 2 Jelly Bean flavor included

Share this post


Link to post
Share on other sites

I'm not sure if anyone plays Dota 2 here but the game runs at extremely low fps on m14x on High settings. I think it's not optimised to run with Nvidia Optimus as it suffers an inconsistent fps the longer you play. :(

Share this post


Link to post
Share on other sites

Anybody else have a really hard time running GTAIV? I am lucky to get a 30fps and I usually hang around 22fps with drops. It doesn't really make sense to me since it is such an old game but I guess that could be a problem right there.

Share this post


Link to post
Share on other sites
Anybody else have a really hard time running GTAIV? I am lucky to get a 30fps and I usually hang around 22fps with drops. It doesn't really make sense to me since it is such an old game but I guess that could be a problem right there.

Its not the problem that its old but poor written. The prob is rockstar never applied enough work to get their last patch or update to fix all the problems. Its unoptimized. It uses 4-8threads heavily and sucks up all gpu and cpu power you have. I suggest turning off shadows or down to almost none. Lower resolution helps keep vram low enough... If its too high you will be skippy or crash since it doesnt load the gpu vram as well as our modern games. Try setting reflections down from max to maybe two options below max. Turn off that one option thats called something like High resolution textures or something. Use half the amount of cars on screen you can use maybe 20 or less is better. View distance keep very low only high enough that you can see whats necessary in front of you. Hope this advice gets you over the fps you were at.

Paranoid Galaxy S3 on Tapatalk 2

Share this post


Link to post
Share on other sites

Your getting better FPS now? Great if so... Yeah the PC version of IV was not worked at enough so i hope if there is a V that its supported better.

Paranoid Galaxy S3 on Tapatalk 2

Share this post


Link to post
Share on other sites
Its not the problem that its old but poor written. The prob is rockstar never applied enough work to get their last patch or update to fix all the problems. Its unoptimized. It uses 4-8threads heavily and sucks up all gpu and cpu power you have. I suggest turning off shadows or down to almost none. Lower resolution helps keep vram low enough... If its too high you will be skippy or crash since it doesnt load the gpu vram as well as our modern games. Try setting reflections down from max to maybe two options below max. Turn off that one option thats called something like High resolution textures or something. Use half the amount of cars on screen you can use maybe 20 or less is better. View distance keep very low only high enough that you can see whats necessary in front of you. Hope this advice gets you over the fps you were at.

Paranoid Galaxy S3 on Tapatalk 2

I hope rockstar will aply more work on the new GTA game next year, i have already pre ordered that game! so i'm glad if it will rune fine on my m14x r2....

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Personally I agree with some other posts here telling that PC games aren't optimized at all.

I have been an happy M14X owner almost from the day one, I think that's an amazing and very powerful machine, it can do almost everything, but I always find something "weird" behaviour in-game: the last i can mention is Risen 2, where I experience drop of FPS in less complex sceneries (ie village at night pointing the character toward a blank wall) while in other cases (more complex scenes to be rendered, ie jungle at daylight with lightbeams, shadows etc.) this issue doesn't show up.

Same for other games, same situations....

Share this post


Link to post
Share on other sites

Hello ! I do think , I might have some issues. I do have an M14XR1 8gb , 55M 3gb and a SATA III SSD. However, in almost every game i do play, I do have some really bad fps. I played skyrim on low setings and I do have 22 FPS, Guild wars 2 on low at 24 FPS, minecraft on normal at 23 FPS... My computer is not that hot, so I'm not convinced it's a repaste issue. Any idea ?

Thanks !

Share this post


Link to post
Share on other sites

Metro 2033 works best on either high or medium in dx9 depending if you prefer graphics or performance. (750/1080 clocks 555mgt)

I found that on high it would occasionally dip into mid/high 20's For FPS(26 to be exact), and averaged about 40 FPS, while medium would never dip below 30 and hovered around the 50-60 fps mark.

This was with the I5 Model, so if you have an i7 model, or a 650m you will have no problem with high settings, but very high and DX11 effects are probably still too demanding in this game.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I agree with Ninjahunter.

I used to play with an i7-2630qm and a non overclocked gt 555 with high settings (dx10) and I always get between 30-40 fps.

But when I try to put dx11 option, fps felt to 10-13 so I never try again.

Hope it helps.

Share this post


Link to post
Share on other sites

M14x R1 is still good for 2013's games. I actually run Crysis3 and Tomb Raider with maxed high settings to an average 30FPS !

This is really good for an almost 2 years old laptop !

Share this post


Link to post
Share on other sites

For anyone who wants to play SWTOR, stay away from the game if you have overheating problems. The game has gained notoriety with overheating (desktops even) and might make matters worse. I have encountered throttle-related lag spikes in PVP and crowded maps. Otherwise, the M14x R1 and of course R2 can handle "High" settings with 2x AA and high shadows at 1366x768.

My temporary fix was to disable Turbo Boost and will try modded BIOS until my next repaste. This is on a system That plays BF3, ME3, Skyrim and the like with good and steady FPS.

Share this post


Link to post
Share on other sites
M14x R1 is still good for 2013's games. I actually run Crysis3 and Tomb Raider with maxed high settings to an average 30FPS !

This is really good for an almost 2 years old laptop !

I don't know how you can run crysis 3 on max settings with 30fps.

I have i7 2,20 GHZ , Nvidia GT555M 3GB and standard lcd 1366x768 and even if i overclock (without vmods just afterburner and standard bios) i get 15 fps avarage.(anti-aliasing - off)

Share this post


Link to post
Share on other sites

flav106 is right. i have 34 fps average in crysis 3 too. what is your 3dmarks score or other benchmark score? ı didn't understand why you get low fps.

Share this post


Link to post
Share on other sites

Has anyone got War of the Roses running really well on their r1? It lags quite a bit for me, especially on certain maps. There doesn't seem to be much difference between high and low settings.

Share this post


Link to post
Share on other sites

I'm trying to get Tomb Raider to run on maximum @ 1200x1920 on external display, but it struggles a lot. I'm only OC'ed at the locked bios at the moment, waitng for modded A12. How is your performance?

Share this post


Link to post
Share on other sites

After I installed my ssd I noticed a massive improvement in War of the Roses. It's now running smooth on high settings (30+fps). When I reinstalled windows after changing to the ssd I did get a newer driver for the graphics card than the one I was previously using, so that might also be linked to the better performance. But then the driver I had been using certainly wasn't old...

Share this post


Link to post
Share on other sites

My 14 came in earlier this week. I gave my step daughter my Asus g75vx to justify getting a new laptop :) I play 2 games, COD2 online with some old clan buddies ive been playing online with since cod2 came out 2005 and Battlefield 3. This little machine is simply amazing! Run BF3 on high and it never dips below 45 fps in online 64 player maps.

It does run a little warm, so put it on my cooler master sf17 cooler and the gpu temps max 65c. Without it runs around 75-80.

Share this post


Link to post
Share on other sites
My 14 came in earlier this week. I gave my strep daughter my Asus g75vx to justify getting a new laptop :) I play 2 games, COD2 online with some old clan buddies ive been playing online with since cod2 came out 2005 and Battlefield 3. This little machine is simply amazing! Run BF3 on high and it never dips below 45 fps in online 64 player maps.

It does run a little warm, so put it on my cooler master sf17 cooler and the gpu temps max 65c. Without it runs around 75-80.

Question: Do you start to see throttling issues when you get to the 75-80 ranges? I'm curious about the newer 14 models as I currently am on a M14r2

Share this post


Link to post
Share on other sites

First make sure that you selected the high-performance Nvidia graphics card in your nvidia control panel. If that doesnt solve it, then try overclocking your GPU with MSI Afterburner and Furmark, as well as disabling Turbo in the BIOS and BD Prochot with ThrottleStop. I had the same problem, and in my case at least, it was due to the CPU overheating and throttling the GPU. Before I overclocked my GPU, I could run Metro Last Light with no problems whatsoever, but The Witcher and Skyrim both lagged terribly at even the lowest graphics settings. Afterwards, they run fairly well at High settings (I have around a dozen mods active in skyrim atm)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      Files contained in this archive:
      FTP-DOS.zip prr2.zip M18x R2 - BIOS A03 'unlocked.zip M18x R2 - BIOS A08 'unlocked.zip M18x_R2_-_BIOS_A08_-_[unlocked]_-_[IRST 11.0.6.1702].zip M18x_R2_BIOS_A03_-_[unlocked] - [IRST 11.6.0.1702].zip M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A10_-_[unlocked]_V2.zip M18x_R2_-_BIOS_A08_-_[unlocked].zip M18x_R2_BIOS_A03_-_[unlocked].zip  
      For information on how to use the files in this archive, see here:
       
       
      My donation link in case you want to buy me a beer
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.