Jump to content
EwinRacing Flash Series Gaming Chairs
Izenhour

Help forcing two Primary (D/PN C8245) 5870M's to work in Crossfire in a m17x R2?

Recommended Posts

Ok so I recently bought a 5870M with the right side heat sink on it, and well.. my M17x R2 doesn't even want to boot up with both cards installed.

It just turns on, all FX lights turn on, then the screen goes darker but unlit, BUT I can barely see the alien head that shows when the system is started up.

Here is a list of things I've done to try to get this working:

-Bought a 240 watt AC adapter ✓

-bought a crossfire cable ✓ (one that the seller of the card suggested from Eurocom)

-flashed both cards to the latest Vbios ✓

-Flash laptop to A10 Bios ✓

-Cleaned the PCIe slot with compressed are ✓

-tried both cards with out Crossfire cable ✓

-I HAVE ORDERED A GPU FAN- Coming in the mail still-

-Take out Bios battery and hold the power button for 30 seconds ✓

-I've even taken out 1 stick of ram and still nothing ✓

-I've tried both cards in the primary slot, and the swapping the cards in a crossfire configuration and nothing

(they both work in the primary slot)

Would the system as a fail safe not boot with out the second GPU fan installed?

As I've said the system turns on, but freezes right at the alien head and the screen stays unlit.

Also the laptop came in a non SLI/Xfire setup, just a single 5870M.

Share this post


Link to post
Share on other sites

So... if I understand this right, if you put just one card in the system, as primary, there are no issues?

I mean both cards are definitely functional?

Share this post


Link to post
Share on other sites
So... if I understand this right, if you put just one card in the system, as primary, there are no issues?

I mean both cards are definitely functional?

Yes, and yes both cards are completely functional. I know they are both primary cards, I just want to try and get them working with each other. other wise I'll be returning it.

Share this post


Link to post
Share on other sites

It could be the lack of a second GPU fan. Try only with a single card in the primary slot which you know works but disconnect the primary GPU fan and see if you experience the same symptoms. Worth a try as I see you're waiting for the secondary GPU fan.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Now that you mention it... The M15x doesn't boot with the GPU fan unplugged. So that's most likely the cause.

Share this post


Link to post
Share on other sites

I have tried that but it still boots with the primary GPU fan unplugged.. :/ I've even tried putting the Cpu fan in the second GPU slot Spins up but does the same thing. i can upload a video showing what happens.

Share this post


Link to post
Share on other sites

If it still boots with the primary GPU fan unplugged, try using the primary fan in the secondary slot and leave the CPU fan as per normal... or have you tried that?

Share this post


Link to post
Share on other sites

Yeah I've tried that. :/ as said, they are both "primary cards" And the one that was originally in my laptop is REV:A00 and the one I ordered is REV:A01

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Nospheratu
      Dolby Home Theater v4 - M17x R2 and IDT High Definition Audio   So I decided I needed a headset with a mic and I'm a sucker for matching peripherals so I set my sights on the TactX headset (Rebranded SteelSeries 5HV2). There's some pretty appalling reviews of it online but I have to try them out for myself. One of the "problem" areas is an apparent lack of bass since its tuned for FPS gaming. In preparation I figured I should get some sound enhancement software. I've been using the Dolby Home Theater v4 application on my HTPC with a Xonar DX soundcard and its very effective particularly with movies and it's volume leveler feature. All processing effects can be switched off for music by just switching profiles using a handy system tray utility so its very convenient to use. You can read more about it on Dolby's official page.
       
      System Tray Utility

      I'm not sure if many users are still soldiering on with the M17x R2 but heres a fix if you wanted the use the Dolby Home Theater v4 application. Support for the IDT High Definition controller used in this machine is non-existant. The only driver I could use was the one's directly from Dell (apart from this Dolby Driver) so I hope this is of some help to fellow M17x R2 users who are looking for more customisable sound.

      I've replicated my steps a few times and I'm fairly certain should work without isue on an Alienware M17x R2 with Windows 8.1 as that's what I'm using. You could give it a try if you have an onboard IDT HD Audio card as well.

      Fixing the INF for use with an IDT High Definition Audio sound card 1. Uninstall all audio applications/drivers and reboot. Windows should install the default "High Definition Audio" driver. 2. Download the installation files from here. Extract the rar. 3. Extract the "Dolby PCEE Drivers.msi" installation file using msiexec and the command line. eg...
        msiexec /a "C:\Dolby PCEE Drivers.msi" /qb TARGETDIR="C:\Extracted Dolby PCEE Drivers"  

      4. Using the above extraction path as reference, go to C:\Extracted Dolby PCEE Drivers\Dolby PCEE Drivers\Drivers64\Release. You should see a file called PCEE4-DHT.INF 5. Open the file and find and replace all occurances of HDAUDIOFUNC_01&VEN_11D1 with HDAUDIOFUNC_01&VEN_111D. Save and close. 5.1 Optional depending on whether you're running Windows 8.1. Reboot with Driver signing off. ie. Hold down Shift when clicking Restart. Select Troubleshoot->Advanced Options->Startup Settings. Click Restart. Once the machine reboots press F7 at the Startup Settings screen to Disable driver signature enforcement. 6. Go back to the extracted Dolby PCEE Drivers folder and run "Dolby PCEE Drivers.msi". Select the "DHT(release)" driver. You should be prompted on whether to install the driver or not, select Install.

      Your drivers should now be installed. If you're using another machine (not an M17xR2) with IDT HD Audio and can hear a marked difference in sound when you go to your Playback Device's properties and switch between the Dolby profiles on the Dolby tab you can go ahead and install the "Dolby Home Theater v4.msi" application.

      If you do not have the Dolby Tab under your speaker playback device and have the Enhancements Tab instead read on. At this point if I plugged in a pair of Headphones into the 2nd or 3rd audio jacks, the Headphones properties under Playback Devices contained the Dolby Tab and the Dolby effects were working with the headphone playback devices.

      Enabling the Dolby Tab and effects on the Speaker Playback Device 1. Open regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render. There should be multiple entries here. Expand the entries and look for the ones with both "FxProperties" and "Properties" keys. To identify the Speakers playback device one of the "Properties" key values will have a string value called "{a45c254e-df1c-4efd-8020-67d146a850e0},2" with a data value of "Speakers". We're interested in the "FxProperties" key above this "Properties" key. 2. Under this "FxProperties" key, delete all values apart from (Default). 3. Copy and paste the below to Notepad making sure to change ****** to the name of the parent key of that particular "FxProperties" key. eg. Mines was called {36018a56-954a-437d-8bdb-0b6bbf830dbc}. The name will vary as it changes with every driver install.
       
      Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\*********************\FxProperties] "{b725f130-47ef-101a-a5f1-02608c9eebac},10"="Dolby PCEE4" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},3"="{C53E5AAF-5F6F-41c2-9F63-ADEBBC9B6B64}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},0"="{00000000-0000-0000-0000-000000000000}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},1"="{BC8E3B67-3306-4eef-B230-6798E9A67F0B}" "{1da5d803-d492-4edd-8c23-e0c0ffee7f0e},5"=dword:00000000
      3. Run this reg file and select yes when prompted on whether you want to add this information to the registry. If you have a look at the same "FxProperties" key again you will notice the above values have been added. 4. Reboot the machine. 5. You should now have Dolby effects working on your speaker device. Install the "Dolby Home Theater v4.msi" and you're done!

      Notes: The effects are only really worth while if you're using headphones, the M17x R2's speakers aren't that good. So this exercise is a bit pointless really. I'm not a fan of processed sound but what really annoyed me was that the effects only worked when the Headphones were plugged in. Hopefully some of you guys enjoy it.

      Credits: I'd like to thank @fr33jack from guru3d forums for providing the install files on his post here and @epguy19 also from guru3D for pointing out the flaw in the drivers INF for the IDT device ID on his post here. I'd also like to thank @erp-ster7n from the laptopvideo2go forums for the insight into the enhancement tab mods with his post here.

      DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.
       
    • By Confused Troll
      I have installed a 980m card in an M17x from early 2014 and am now here to ask the experts of this fine establishment if they can help with what needs to be done to get it to work, if at all possible.
       
      It tries to upgrade a shorted out 780m. Modded driver was installed (445.75 WHQL from 2020.3.23), but device manager says error 43.
       
      sBIOS is stock A17 from Dell. UEFI enabled, legacy and safe boot disabled.
       
      OS is Windows 10 Home 64-bit on an SSD.
       
      Can it be done at all? If it can, what needs be done?
       
      Edit:
      I think my model is actually 17 R1, judging by the date, processor being a 4th gen i7 (4700MQ) and also this matches my regulatory model.
      I know this is my only post here and in I come, asking for help, but... pretty please help?
       
      Further edit:
      I have identified the 980m as being a Dell version. (as per GPU-Z)
    • By Nospheratu
      This modification involves going a step further than a straight ID chip swap between the 240W and the 330W. The reason I chose this method was, I did not want to perform the mod again in the rare case that the 330W died and I had to get a new one.
      In order to complete this mod, you will require the following items.
      1. Dell 330W PSU (This PSU was built for the M18X and X51 product lines). Part Numbers: Y90RR / 5X3NX / F0K0N / XM3C3 / 331-2429
      2. Dell 240W PSU (Either a Flextronix or Delta). Part numbers: PA-9E / J938H / Y044M / U896K / J211H / Y044M
      3. Dell or HP standalone PSU cable/Connector. I used a right angle connector but any Dell/HP 7.4 x 5.0mm barrel connector will work.
      4. M17x/M18X Power Jack. The part number for this power jack seems to be P01E. Look for the one that resembles the one used here.
      5. Small PCB designed for a SOT-23 packaged chip. (If using the Flextronics 240W PSU).
      6. Small housing (Optional depending on whether you would like to mod the ferrite choke housing)
       
      PSU DISASSEMBLY
       
      First we begin with the disassembly of the 240W PSU to retrieve the ID chip for our adapter. Since I had the Flextronics version some of these steps might not be the same for the Delta PSU. We start by lifting up the rubber feet on the bottom of the 240W using your nail or a flat tool. Underneath each rubber foot you will find a screw which you can go ahead and unscrew.
       
       
      One of the screws will be a tamper-resistant Torx T10 type, the difference to a normal Torx T10 being a small pin the centre so you would have to use a Torx screwdriver with a hole in the center.
       
       
      TIP: If you do not have this tamper-resistant screwdriver you can use a normal Torx T10 screwdriver but you will have to hammer down the pin at the centre of the screw slightly in order to get the normal T10 screwdriver to grip.
       
      Once you have removed all screws you will have to pry open the casing. I stuck a thin knife between the power plug and the casing to gently pry it open.
       
       
      The top half and bottom half of the casing are held together by interlocking clips. Twist the case a bit to get them to unclip. Then remove the PSU from the case. You will then be presented with the first metal layer which is held on by tape. Cut the tape and slide out the first metal layer.
       
       
      You will then see the second metal layer which is held in place by 3 points soldered onto the PSU PCB. It is indicated in the picture below. Desolder all 3 points and remove the second metal layer.
       
       
      The last layer is black and seems to be a type of flexible hard plastic. It will be stuck in place by white thermal stuff on the PCB, simply lift it and peel it away.
       
       
      Depending on whether you have a Flextronics or Delta PSU your ID chip will look different.
       
       
      Desolder this chip and keep it in a safe place (If you lose it, you have to buy a new 240W PSU). On the Flextronix PSU the chip is also stuck in place apart from being soldered on, so you have to work quickly heating the solder and pushing the chip away with a bit of force.
      To reassemble the PSU reverse the above steps. You can still use this PSU connected to the adapter with your M17X so it won't be collecting dust.
       
      THE ADAPTER MOD
       
      You will have to decide on whether you want to mod the ferrite choke housing into your enclosure or use a dedicated enclosure (small as possible as this circuit is tiny). If you are using a dedicated enclosure jump straight to the labelled wire photo to continue. If you would like to mod the ferrite choke housing continue reading.
      I did not take sufficient pictures during this portion as I was unsure if the ferrite choke housing would work. The rubber around the ferrite choke and the connector that I purchased was soft and very flexible which made it easy to work with. I used a knife and pressed against the rubber of the ferrite choke housing for a clean cut so that I could glue it back together. I cut off one end and then length ways along either seam of the housing making sure to leave a bit of extra cable.
       
       
      Here is a picture of what we’re trying to achieve with the cutting.
       
       
      You will then see the ferrite choke which you can crack with a hammer. Remove the pieces (be careful as they will be very sharp).
       
       
      Then the cut off the cable strain relief that's covering the cable with small wire snips.
       
       
      You will then see the cable which you can strip to positive, negative and the ID line.
       
       
      You will then need to connect those wires to the power jack. The two pins at the top are negative. The two pins at the back forming the shape of a U are positive and the pin at the back in the centre is the ID line.
       
       
      Solder the positive wire to positive pin and negative wire to negative pins as shown in the image below. The negative wire can be soldered to the negative pins and simultaneously joining the ID pin on the jack.
       
      The reason behind joining the ID pin to the negative pins on the jack is because we need to ground the ID line coming from the 330W in order for it to operate beyond its artificial 240W limit.
       
       
      Now all that’s left to do is connect the ID chip. If you have the Flextronics PSU the ID chip will be in a SOT-23 package and the Delta ID chip will be in a TO-92 package. The Flextronics SOT-23 package is difficult to work with and should be first soldered to a bit of PCB that had a SOT-23 package so that you do not break the legs off.
      I initially soldered the wires directly to the legs and moving it about in my "enclosure" to find the best spot to place it was too much stress on the chips tiny legs and they broke off... yes, all of them. Luckily I could still see a tiny bit of metal from each of the legs. I managed to salvage it by soldering it to a piece of PCB that I jacked from a broken mouse which had SOT-23 connections.
      The blue ID wire coming from the cable needs to be soldered to the data leg of the ID chip. Connect the remaining two pins from the ID Chip together and then to the negative connection on the PSU jack.
       
      Dont judge my pathetic soldering skills!
       
      Place your ID chip into the enclosure and test the adapter to make sure all your connections have proper contact. If it’s working properly you can close it up.
       

       

       
      I considered flooding the enclosure with silicone to secure the ID chip and its connections but I did not, as I thought it would be more work if one of the connections broke and I had to open it up again. You can do it if you like.
       
      I used a drill to make the hole at the centre of the disc large enough for the 330W connector tip fit through. I then stuck the enclosure back together using superglue along the sides and then attaching the disc. Add a bit of glue to the disc/jack so that the disc and jack are stuck together as well. This is so that the jack does not move when plugging the PSU connector tip in.
       
      THE COMPLETED MOD
       

       
      Pros/Cons over the ID Chip swap Mod
      Pros
      - Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack.
      - If the 330W PSU dies all you have to do is plug a new one in. No need to perform the mod on a new 330W.
      - No need to open up the 330W at all.
      - Your ID chip donor 240W PSU can still be used with your M17X by attaching this adapter.
      Cons
      - Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack (Could be dangerous with low wattage PSU's).
      - A lot more work compared to swapping the chips.
       
      Notes: I also had to trim a bit of rubber at the right angle connector for the cable I used as it’s a bit of a tight fit if you don't. The rubber around the connector did get a warm at the right angle after testing but it's being blasted by the heat of the CPU fan continuously so I don't think it’s the connector itself that's causing it. These cables are very short and should be able to handle the power easily.
      Since there are two positive terminals you will have to either split the positive wire coming from the PSU connector to each pin or join both pins (bend one pin over to the other and solder them together making sure to place an insulator to cover the ID pin) and solder the positive wire to a single point.
      Also worth noting is that this adapter mimics the original 240W adapter perfectly. So if you experienced the "plugged in, not charging" issue when connected this adapter will not resolve it (I still have to pop the battery and clip it back in to resolve).
       
      Credits: @imsolidstate, without his in-depth investigation this would have not been possible. His website detailing his investigation and the ID chip transplant can be found here and the subsequent update here.
       
      DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.
    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
    • By MessiWessi
      Hi,
       
      I bought a alienware m17x r4 a few weeks ago. The problem is: I have noise (distorsion) on the right speaker. Had anybody in past the same problem and is it a known problem regarding this model? I feared at the beginning that the soundblaster is defect but I tested it with headphones and everything is fine. I already ordered a new speaker pair and will install it within the next weeks.
       
      But if you tell me that this problem is known and not resolvable I can save my effort.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.