Jump to content
EwinRacing Flash Series Gaming Chairs
Guest

[BIOS/vBIOS - MODS] Prema Mod™ & Stock

Recommended Posts

I am not sure what you want?!?

Crossflash P170EM version to your P15xEM.

Thanks that worked! Much appreciated.

Share this post


Link to post
Share on other sites

I remember reading some warnings about the crossflash when I bought my P150EM. Are things changed? It's 'safe' to crossflash?

Share this post


Link to post
Share on other sites
I remember reading some warnings about the crossflash when I bought my P150EM. Are things changed? It's 'safe' to crossflash?

It was mythlogic that originally said that caused problems (motherboard died soon after the flash), but they sell their P150EM's with P170EM BIOS's now so it looks like their problem was unrelated.

My P150EM has never run anything besides a P170EM BIOS. Just make sure you flash on a similar P170EM BIOS to avoid EC version changes.

Share this post


Link to post
Share on other sites
Guest

Updated Clevo BIOS base to v08 for P370EM3/NP9370 3D. ;)

ENJOY!

Share this post


Link to post
Share on other sites
Updated Clevo BIOS base to v08 for P370EM3/NP9370 3D. ;)

ENJOY!

Good job! :Banane31:

Any idea of the next updates ? (what do you plan exactly :acne: )

Share this post


Link to post
Share on other sites
Guest
Good job! :Banane31:

Any idea of the next updates ? (what do you plan exactly :acne: )

Since P-EM & W-Series owners are taken care of for the time being I am going to focus on the P-HM Series and give it some love. :17_002:

That being said I have my own system pending since a long time now...:01:

Share this post


Link to post
Share on other sites
Since P-EM & W-Series owners are taken care of for the time being I am going to focus on the P-HM Series and give it some love. :17_002:

That being said I have my own system pending since a long time now...:01:

Awesome Prema !!! I cant w8 till my P150-HM gets some love from you :-)

Kind regards,

Manuel

Share this post


Link to post
Share on other sites

Hi Prema!

First, thanks for your work and the huge amount of support you're giving in this thread, it's just awesome!

I'm going to install your BIOS for my P150EM in a few minutes, but I was wondering about something : why are there two things to install, I understand the BIOS par but what is the

ME?

Thanks!

EDIT: Okay, just found out on your website ME means "Intel Management Engine Firmware & Driver", still, what does it controls exactly?

Share this post


Link to post
Share on other sites

Hi Prema!

May I ask you to do for the 150EM bios what you did for the W110ER? Enable the HDD password options?

Thanks! And thanks again!

PS No hurry, though. Without your next release.

Share this post


Link to post
Share on other sites
Guest
...Thanks!

EDIT: Okay, just found out on your website ME means "Intel Management Engine Firmware & Driver", still, what does it controls exactly?

Some of the start-up routines rely on the ME firmware. The clock-gen and all associated buses are controlled via the ME. Windows also needs the ME driver to be installed to communicate with the ME based interfaces (any on-the-fly bus adjustments for example).

Hi Prema!

May I ask you to do for the 150EM bios what you did for the W110ER? Enable the HDD password options?

Thanks! And thanks again!

PS No hurry, though. Without your next release.

The P-Series has locked down menus, so re-linking them in a way to make extra stuff visible isn't easy...I have made some progress, but I had no time recently to follow up with my research...

Share this post


Link to post
Share on other sites

Hello Prema,

thanks for all the work,

but i have some serious troble with your mod.

When i change the mode from AHCI to RAID its stucks on the BIOS Date Screen.

i rebuild my Raid after Flashing your Mod. But still no change, i installed the latest intel ME driver and still no change.

What can i do now?

Share this post


Link to post
Share on other sites

When is the xtu p150em version coming out and can you solve any of these issue?

CPU turbo diabled when dGPU active

GPU fan not turning off after GPU is sleeping and temps are down.

Cheers

Share this post


Link to post
Share on other sites
Guest
Hello Prema,

thanks for all the work,

but i have some serious troble with your mod.

When i change the mode from AHCI to RAID its stucks on the BIOS Date Screen.

i rebuild my Raid after Flashing your Mod. But still no change, i installed the latest intel ME driver and still no change.

What can i do now?

What model do you have?

Could someone here who uses RAID please guide fabihabie...?!

When is the xtu p150em version coming out and can you solve any of these issue?

CPU turbo diabled when dGPU active

GPU fan not turning off after GPU is sleeping and temps are down.

Cheers

I can make the xtu tweaks as soon as someone gets back to me ragarding TDP settings sticking or not in stock P170EM BIOS...no one did, yet...

For the first thing use Throttlestop. I am afraid if I remove the Turbo lock throughout the line that someone will fry his system and then blame me.

But I also thought that this is a W-series problem only!?!

I don't think I can fix the GPU sleep fan reading bug if Clevo still can't after 12 ECs...

Share this post


Link to post
Share on other sites

Sorry but I'm a noob here. What's the ME firmware for and is it necessary to install it along with the modded BIOS?

Share this post


Link to post
Share on other sites
What model do you have?

Could someone here who uses RAID please guide fabihabie...?!

I can make the xtu tweaks as soon as someone gets back to me ragarding TDP settings sticking or not in stock P170EM BIOS...no one did, yet...

For the first thing use Throttlestop. I am afraid if I remove the Turbo lock throughout the line that someone will fry his system and then blame me.

But I also thought that this is a W-series problem only!?!

I don't think I can fix the GPU sleep fan reading bug if Clevo still can't after 12 ECs...

I have flashed your p170em bios on my p150em what do you need me to check?

Share this post


Link to post
Share on other sites

I got the p370em with GTX 680M SLI Crucial m4 msata + 2x Seagate Momentus XT 750GB Raid 0 / 16 GB Corsair CL9 Ram (4X4GB) / Killer 1202 i7 3630qm

Share this post


Link to post
Share on other sites
Guest
Sorry but I'm a noob here. What's the ME firmware for and is it necessary to install it along with the modded BIOS?

It's a good idea to do so. Explained the functionality 4 posts above yours. ;)

Look forward to P-EM

You mean P-HM?! ;)

I have flashed your p170em bios on my p150em what do you need me to check?

When you change the TDP settings in XTU (Turbo Boost Power Max & Turbo Boost Short Power Max)does Throttlestop "TPL" window report the same Long and Short package power limits?

On the older HM series Clevo faked the TDP change in XTU and TS showed us that in reality nothing had changed.

I got the p370em with GTX 680M SLI Crucial m4 msata + 2x Seagate Momentus XT 750GB Raid 0 / 16 GB Corsair CL9 Ram (4X4GB) / Killer 1202 i7 3630qm

I asked another member here who is successfully using RAID on the same model (with the mod) to help you.

Share this post


Link to post
Share on other sites

Is the updated ME firmware the only difference between the modded NP8130 original BIOS and the upcoming modded BIOS?

Share this post


Link to post
Share on other sites

So, quick question - i love getting all teh performance i can, but admittedly, warranty is still somewhat of an issue for me.

From what i understand, once i flash to a Clevo bios on my 9170, it is very very difficult to go back to a Sager bios. Is it the same with this bios? Perhaps more importantly, is it even worth worrying about should i ever need warranty (will they look at it and deny me, or not care)?

Share this post


Link to post
Share on other sites
Guest
Is the updated ME firmware the only difference between the modded NP8130 original BIOS and the upcoming modded BIOS?

LOL...Nope!!! Take this as an indication (read comment section fore more)

So, quick question - i love getting all teh performance i can, but admittedly, warranty is still somewhat of an issue for me.

From what i understand, once i flash to a Clevo bios on my 9170, it is very very difficult to go back to a Sager bios. Is it the same with this bios? Perhaps more importantly, is it even worth worrying about should i ever need warranty (will they look at it and deny me, or not care)?

The Myth

As for warranty it depends on your re-seller, some support the use of the mods, some officially don't but won't void your warranty if you still do and then some even tell you that you will loose your warranty if you change the CPU on your own... ;)

Share this post


Link to post
Share on other sites

When you change the TDP settings in XTU (Turbo Boost Power Max & Turbo Boost Short Power Max)does Throttlestop "TPL" window report the same Long and Short package power limits?

On the older HM series Clevo faked the TDP change in XTU and TS showed us that in reality nothing had changed.

Sorry i flashed back to you p150em BIOS but i can remember XTU allowed me to change the valves and saved them on a reboot it also allowed me to change the memory frequency and timing perfectly fine, only thing it wouldn't let me do is change the turbo ratio if i set it to 37 and applied it would set it correctly as soon as the laptop restarted or shut down it would revert back.

I would try a BIOS out if you modded a p150em with XTU, the P170EM bios seems to play a bit with the temperature i was getting 52-55C on each core idle on P150EM BIOS i get 35-40C.

Can you not stop it from disabling turbo when using the DGPU i know someone could overclock their GPU and CPU and then fry their system but if they are flashing modded BIOS's they should be aware of these things anyway.

I play ARMA 3 and i have to use throttle stop other wise i loose 10fps cause its CPU heavy game.

Share this post


Link to post
Share on other sites
Guest
Sorry i flashed back to you p150em BIOS but i can remember XTU allowed me to change the valves and saved them on a reboot it also allowed me to change the memory frequency and timing perfectly fine, only thing it wouldn't let me do is change the turbo ratio if i set it to 37 and applied it would set it correctly as soon as the laptop restarted or shut down it would revert back.

I would try a BIOS out if you modded a p150em with XTU, the P170EM bios seems to play a bit with the temperature i was getting 52-55C on each core idle on P150EM BIOS i get 35-40C.

Can you not stop it from disabling turbo when using the DGPU i know someone could overclock their GPU and CPU and then fry their system but if they are flashing modded BIOS's they should be aware of these things anyway.

I play ARMA 3 and i have to use throttle stop other wise i loose 10fps cause its CPU heavy game.

The P170EM EC has different fan spin settings, I guess that's why the temps are different...I need to know if Throttlestop shows the same TDP values after changing them in XTU, because if it doesn't the XTU is faking it like on the HMs...

My comment regarding dGPU & Turbo being active even without Throttlestop was regarding the W-Series. AFAIK the P-Series shouldn't have the Turbo 100% disabled all the time with active dGPU, only while reaching temp limits etc...?!?

Share this post


Link to post
Share on other sites

No its disabled all the time the CPU is at 70C and if i play crysis 3 or Arma 3 the cpu is locked to 2.7Ghz close the game it will go up to 3.5Ghz its a I7-3740QM, im not the only one who has this.

Any way to modd into the bios like FN + 8 to force CPu to turbo all the time? Would be awesome id test that.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By Qvixot
      Hello everyone! First of all sorry if this isn't the correct forum to post this.
      I bought a laptop few days ago. The laptop is Sager P150EM.
      Cpu:i7 3610qm 
      Gpu: amd hd 7970m
      Ram: 8gb
      Os: windows 8.1 pro
      So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.