Jump to content
EwinRacing Flash Series Gaming Chairs
Guest

[BIOS/vBIOS - MODS] Prema Mod™ & Stock

Recommended Posts

Guest
hallo prema . can you please attach for me the original sager p9370 dual 7970 bios and ec (1.02.08xxx) thank you

- - - Updated - - -

hallo prema . can you please attach the original bios and EC for sager p9370 dual 7970m (1.02.08xxx) thank you

Someone else will have to help you with those, don't have any 7970 vBs...

Share this post


Link to post
Share on other sites

can anyone one help as when i try to flash custom bios with usb stick i type flashme.bat but i keep getting bad command please any steps in fixing this would be great....

Share this post


Link to post
Share on other sites
Guest

What you have to run depends on what you are trying to install.

In case of the P-EM models it is "update.bat"..."flashme.bat" is only for the old DOS ME installer

Share this post


Link to post
Share on other sites
Prema! any news on the new stuff coming from your next p-em bios?

I already know that will have a amazing new splash logo! :bananapowerslide:

Share this post


Link to post
Share on other sites

Hi prema, Im very exiting to get the new BCKL BIOS. Up to now all of your Mods working without any problems on my book.

VG,

Share this post


Link to post
Share on other sites

Hi Prema,

could you add a mod for the P150EM bios to remove the 2GHz CPU throttling when discrete GPU is in use?

Cheers,

Selphie

Share this post


Link to post
Share on other sites
Hi Prema,

could you add a mod for the P150EM bios to remove the 2GHz CPU throttling when discrete GPU is in use?

Cheers,

Selphie

Throttlestop gets rid of throttling that I got when using the discrete gpu. It would be nice though to not need to run TS.

Share this post


Link to post
Share on other sites
Guest

I have fixed it on my W110ER... ;)

Does the CPU Turbo deactivate while dGPU is active on P-EM models, too? Or how does it show?

 

OK I am going through the code, they use a different method on the EM series...

Share this post


Link to post
Share on other sites
I have fixed it on my W110ER... ;)

Does the CPU Turbo deactivate while dGPU is active on P-EM models, too? Or how does it show?

Turbo turns off.

TS not running: http://i.imgur.com/CbYwZK8.png

TS running: http://i.imgur.com/d4miHHl.png

CPU isn't really burning that much power btw. It reports around 25W high when dGPU is on without updating the microcode.

Share this post


Link to post
Share on other sites
OK I am going through the code, they use a different method on the EM series...

Apparently the Turbo limit when using dGPU only affects P150EM, the P170EM is unaffected.

Share this post


Link to post
Share on other sites
Apparently the Turbo limit when using dGPU only affects P150EM, the P170EM is unaffected.

I'm running a P170em bios.

Share this post


Link to post
Share on other sites
Guest

The current BIOS v17 code that is responsible for the throttle is equal in P170EM & P150EM, but it looks like on the P-EM Series the whole throttle thingy was only introduced in the later BIOS revisions. I am looking at an earlier BIOS it is absent, so are some sleep-states...but it helps me in isolating it, so let's see. I am digging :)

OK, I have isolated the code, ready for a beta run tonight Kheng-man? ;)

Share this post


Link to post
Share on other sites
Guest
What settings are you using for ThrottleStop?

1) Launch Throttlestop v5+

2) Set multiplier to “Turbo” (Highest value) and check the box.

3) Click “Turn On” in the bottom-right corner.

4) Click “Save” in the bottom-left corner.

Share this post


Link to post
Share on other sites
The current BIOS v17 code that is responsible for the throttle is equal in P170EM & P150EM, but it looks like on the P-EM Series the whole throttle thingy was only introduced in the later BIOS revisions. I am looking at an earlier BIOS it is absent, so are some sleep-states...but it helps me in isolating it, so let's see. I am digging :)

OK, I have isolated the code, ready for a beta run tonight Kheng-man? ;)

I am! Running a bit older bios anyway.

Did you also get rid of the stupid x15 multi limit when on battery? It doesn't save power at all while making things take 2x as long to load. TS kills it, but it's still silly.

Also the missing sleep states in early bios makes sense since the earlier bioses did have poor battery life. IMO battery life is still a bit short for an 8 cell, but 5h is still decent.

Share this post


Link to post
Share on other sites

Thanks Prema, these look great. I'm excited to try out the P150EM T1 version tomorrow and finally get the fan power back.

Share this post


Link to post
Share on other sites

I have a Sager NP9150 with Corsair Vengeance 32Gb @ 1600Mhz. Win 8 Pro 64Bit.

My system currently is:

ME FW Version: 8.1.40.1416

Bios Revision: 1.02.17LS1 Sager

KBC-EC firmware Revision: 1.02.11SA Sager

Which Prema Mod should I use? The 1T or 2T version? I'm thinking 2T because I have 32GB RAM but I'm asking just to make sure since I'm usng Corsair Vengeance @1600Mhz.

Also my Windows key is on the left and my Fn key is on the right side. Do I need to manually switch the keys or is the placement fine?

Thanks for helping a newbie.

Share this post


Link to post
Share on other sites
I have a Sager NP9150 with Corsair Vengeance 32Gb @ 1600Mhz. Win 8 Pro 64Bit.

My system currently is:

ME FW Version: 8.1.40.1416

Bios Revision: 1.02.17LS1 Sager

KBC-EC firmware Revision: 1.02.11SA Sager

Which Prema Mod should I use? The 1T or 2T version? I'm thinking 2T because I have 32GB RAM but I'm asking just to make sure since I'm usng Corsair Vengeance @1600Mhz.

Also my Windows key is on the left and my Fn key is on the right side. Do I need to manually switch the keys or is the placement fine?

Thanks for helping a newbie.

Try the T1. If it's unstable (unlikely) then you can safely flash to a t2 bios after removing 2 sticks of ram.

Share this post


Link to post
Share on other sites
I have a Sager NP9150 with Corsair Vengeance 32Gb @ 1600Mhz. Win 8 Pro 64Bit.

My system currently is:

ME FW Version: 8.1.40.1416

Bios Revision: 1.02.17LS1 Sager

KBC-EC firmware Revision: 1.02.11SA Sager

Which Prema Mod should I use? The 1T or 2T version? I'm thinking 2T because I have 32GB RAM but I'm asking just to make sure since I'm usng Corsair Vengeance @1600Mhz.

Also my Windows key is on the left and my Fn key is on the right side. Do I need to manually switch the keys or is the placement fine?

Thanks for helping a newbie.

Try 1T.

I have Corsair Vengeance DDR3-1600 8GB*4.

No problem with DDR3-1600 10-10-10-27 1T.

and I oveclocked these to DDR3-1866(11-11-11-27) 1T.

It's stable and passed memtest86+ with this setting.

(1866-10-10-10-27 1T wasn't able to pass the tests)

post-11556-14494995529777_thumb.jpg

Share this post


Link to post
Share on other sites
Try 1T.

I have Corsair Vengeance DDR3-1600 8GB*4.

No problem with DDR3-1600 10-10-10-27 1T.

and I oveclocked these to DDR3-1866(11-11-11-27) 1T.

It's stable and passed memtest86+ with this setting.

(1866-10-10-10-27 1T wasn't able to pass the tests)

[ATTACH=CONFIG]7832[/ATTACH]

Thanks all for the advise.

I upgraded with 1T and all appears well. I really like the feature where the cooling fan kicks in when the temps begin to rise at 49C keeping my laptop cool between 47-48C. Really great!

Share this post


Link to post
Share on other sites
The current BIOS v17 code that is responsible for the throttle is equal in P170EM & P150EM, but it looks like on the P-EM Series the whole throttle thingy was only introduced in the later BIOS revisions. I am looking at an earlier BIOS it is absent, so are some sleep-states...but it helps me in isolating it, so let's see. I am digging :)

OK, I have isolated the code, ready for a beta run tonight Kheng-man? ;)

Where are these throttle fixed BIOS? Also can you change the boot screen, that huge circle one is hideous.

Share this post


Link to post
Share on other sites
Guest
Where are these throttle fixed BIOS? Also can you change the boot screen, that huge circle one is hideous.

Still in testing stages...and yeah the old logo is already gone... ;)

Share this post


Link to post
Share on other sites

Hi Prema! thanks for nice job, I know am too late for all this but you got tester if you didn't found one, P370EM3 with Windows 8, i7 3940XM, was SLI now single GTX680M, Prema BIOS and svl7 vBIOS..

Attached screenshots for Main BIOS and start logo..

post-13002-14494995539251_thumb.jpg

post-13002-14494995538781_thumb.jpg

Share this post


Link to post
Share on other sites

I can't get the system to boot in UEFI mode. I have Windows 8 installed on an NP9150. What settings should I have? With Sager's stock BIOS I could use UEFI mode with just having OS set to Windows and UEFI set to enabled. I could toggle Secure Boot on and off and the system would always still boot correctly in UEFI mode. Now, when I enable UEFI mode, the system will always boot and go to the BIOS screen. I can tell it my OS is Windows 8 or Other and boot in normal BIOS mode, but I can't get UEFI boot to work. I've tried all combination of Secure Boot settings and no luck. Any help please, someone?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By Cubitci
      İ'm trying to backup my bios but program shows this error: Error 201: [FPTw.exe] cannot be run on the current platform. Please contact your vendor. And my system is x64 but programs shows System = x32 . How can i solve this error ?
       
      EDİT: Now shows "Error 285: Fail to load driver (PCİ access for Windows). Tool needs to run with an administrator priviledge account." And at the end the system says it cannot find the specified location, and therefore no results. 
       
      EDİT 2: Now shows Error 284 but i cant see text.
       
      ------------------------
      Intel's FPT v.1.0.4.1089
      ------------------------
      System = x32
      Desktop path = C:\Users\Remzi Ince\Desktop
       
      program shows its my desktop path but its not my desktop path. My laptop language is turkish and my desktop path is C:\Kullanıcılar\Remzi Ince\Masaüstü
       
    • By Hyuk Yun
      I need help to unlock my BIOS can somebody teach or help me??
       
      I want to unlock the hidden advanced and chipset tab plz help me.....
       
      https://drive.google.com/open?id=172WwwQC-IGfGeFA55lr2a5ahe7rIS0Sf
       
       
    • By Luisrr2029
      Hello can anyone suggest a mod for bios or alternative bios for Msi GE72 2qc apache gaming laptop to overclock 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.