Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

I fixed it.  Bios is modded and flashed and running well.   Now I'm on to why my Ultrabay 650m isnt being recognized when it has been (it stopped before the bios update)  but thatnks for the info.   Yeah just copying the 104 fix over and keeping the files in the root folder worked well.  Thanks

Share this post


Link to post
Share on other sites

Great guide! Seems pretty simple to follow, and I'm looking forward to attempting this as soon as I'm allowed to download things. :)

Share this post


Link to post
Share on other sites

Hey guys! 

 

I'd like to replace my WLAN module of my Lenovo Y500 with a newer one (Intel Wireless N 7260) and want to replace my BIOS with the modded one here from first page.

 

First problem is, my english is not the best but (luckily) good enough to understand, what is written in the tutorial on first page. That's what I hope. Besides that, nothing will work from first page. 

 

I tried to backup my BIOS with FPTDos and FPTw64 (I know I need five posts to download anything from here so I searched for it in the net) but none of them works. Or I don't know what to do with them. When I try to open the DOS backup.bat file I get an error because of 16 Bit incompatibility and when I open the Windows thing, I don't know what to do here. It opens a black window with a lot of commands and at the end, all I can do is, press any key to continue and then the window shut down.

 

Then I googled for an alternate prog to backup my BIOS and found a prog called "universal BIOS Backup ToolKit 2.0" which created a backup of my BIOS in 10 seconds (it's called LENOVO-6BCN44WW v2.04.rom). 

 

But then I stuck at the point 

 

Open the downloaded tool and execute it. Drag and drop your BIOS backup file on it, it will create the mod for you. It will look like this: 

 

So I opened it but I can't drop my backup file into it. What am I doing wrong?

 

 

Share this post


Link to post
Share on other sites

Ah, ok. I need to put the BIOS Fixer tool onto the USB drive. Now I've got an 'v204mod' file. So before I continue, I have to put the 'v204mod' file, the prr.exe tool and the fpt.exe tool onto the USB drive, restart, execute the prr.exe but with which name should I replace the filename.bin? The name of my BIOS backup file (in my case fpt.exe -f LENOVO-6BCN44WW(v2.04).rom -bios)? Do I have to put the BIOS backup onto my USB drive aswell? 

 

I don't get it...

Share this post


Link to post
Share on other sites

Okay, using Universal BIOS Backup Toolkit I've successfully made a backup of my BIOS, and modded it with the BIOS fixer tool, but how do I flash it, when I keep getting error 104 with FPT? The 104-fix doesn't work for me :-(

 

This is the error I get with FPT:

 

Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid

    --- Flash Devices Found ---
    W25Q32BV    ID:0xEF4016    Size: 4096KB (32768Kb)
    MX25L1605A    ID:0xC22015    Size: 2048KB (16384Kb)


Error 104: The 2 SPI flash devices do not have compatible command sets.

 

The two flash devices has already been added to fparts:

 

MX25L1605A,  0xC22015, 0x1000000,  0x1000, 0x20, 64, 0, 0x60, 80000
W25Q32BV,    0xEF4016, 0x2000000,  0x1000, 0x20, 64, 0, 0x60, 80000

 

Is there another piece of software, I can use to flash the modded BIOS?

Share this post


Link to post
Share on other sites

What exactly IS Error 104? Is a an error you get when you try to flash the BIOS or is it a permanent error you get once your flashing failed? Can you still use Windows when you boot normal? 

Share this post


Link to post
Share on other sites
On 22/3/2017 at 4:29 PM, Arcane said:

 

18 hours ago, Arcane said:

What exactly IS Error 104? Is a an error you get when you try to flash the BIOS or is it a permanent error you get once your flashing failed? Can you still use Windows when you boot normal? 

 

I'd very much like to know as well. It's the last hurdle I need to get past, in order for me to unlock my BIOS. I'm stuck with a shitty WiFi card in my Y500, which will only allow me to connect to 2.4GHz @ 72Mbit. An upgrade of the WiFi card is quite needed, since the rest of the laptop is awesome.

 

Another solution would be that someone could make a modded version of the BIOS, which could be flashed with Lenovos own InsydeFlash.

 

Yet another solution would be to modify platform.ini from InsydeFlash, in order for it to be able to flash the modded BIOS.

 

Suggestions?

Share this post


Link to post
Share on other sites
5 hours ago, ShamblerDK said:

 

I'd very much like to know as well. It's the last hurdle I need to get past, in order for me to unlock my BIOS.

I thought you already get the 104 error, so shouldn't you know if your OS still works? Can you still boot in Windows? 

 

And can you help me maybe with the rename thing? 

On 22.3.2017 at 5:09 PM, Arcane said:

...but with which name should I replace the filename.bin? The name of my BIOS backup file (in my case fpt.exe -f LENOVO-6BCN44WW(v2.04).rom -bios)? Do I have to put the BIOS backup onto my USB drive aswell? 

 

I don't get it...

 

Share this post


Link to post
Share on other sites
3 hours ago, Arcane said:

I thought you already get the 104 error, so shouldn't you know if your OS still works? Can you still boot in Windows? 

 

And can you help me maybe with the rename thing? 

 

 

Look at my previous post. It's the error I get when I try to use the FPT tool to either backup or flash my BIOS. Many others are getting it as well. There's even a fix for it, which works for some people. Appearently none of my flash chips are recognized by the FPT tool, even though they've both been added to fparts.txt.

Share this post


Link to post
Share on other sites

Aaah, ok then. I thought it's an error you get after the flashing

Share this post


Link to post
Share on other sites

Disregard my posts. Got someone over at www.bios-mods.com to help me. Their response-time is amazing! I asked for help yesterday afternoon and today I already have a flashable version of my BIOS. It works like a charm, I might add :-)

Share this post


Link to post
Share on other sites
1 hour ago, ShamblerDK said:

Disregard my posts. Got someone over at www.bios-mods.com to help me. Their response-time is amazing! I asked for help yesterday afternoon and today I already have a flashable version of my BIOS. It works like a charm, I might add :-)

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

Share this post


Link to post
Share on other sites
32 minutes ago, Arcane said:

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

 

Just go here and ask:

https://www.bios-mods.com/forum/Thread-REQUEST-Lenovo-Y500-Whitelist-removal?page=3

 

You'll get help in no time :-)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
5 hours ago, lucasheringer said:

Hey guys, was anyone able to use intel hd4000 with the unlocked bios?

Nope. No one has found a way to do that. I would be really impressed if someone does.

On 4/4/2017 at 3:41 PM, MIGUELEBS said:

my pc says i have V.1.5 of bios, do i need to update to 2.2 then 2.4 modded?

It has to be at least v2.02

Share this post


Link to post
Share on other sites
12 minutes ago, lucasheringer said:

Thanks jacobspeeds,

To bad I really would like to use OSx but without intel gpu there is no way to do that.

We all wanted to do something with the internal gpu but Lenovo being either incompetent or selfish made it impossible.

Share this post


Link to post
Share on other sites

Found this post that someone was able to enable iGPU intel hd4000, I just asked there if someone was able to use the gpu.

 

Share this post


Link to post
Share on other sites

Guys, I've made a super easy tutorial for this mod. As clear as I possibly could and much clearer for amateurs than the original. No offence, but if this is hard to follow then you shouldn't attempt to unlock your bios. Download here.

Share this post


Link to post
Share on other sites
On 3/28/2017 at 5:32 AM, Arcane said:

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

try this,

 

5 minutes ago, jacobspeeds said:

Guys, I've made a super easy tutorial for this mod. As clear as I possibly could and much clearer for amateurs than the original. No offence, but if this is hard to follow then you shouldn't attempt to unlock your bios. Download here.

 

Share this post


Link to post
Share on other sites
3 hours ago, jacobspeeds said:

try this,

 

 

 

For some it's an imossible task, since they get error 104 using FPT regardless of having used the fix.

 

My solution was going to www.bios-mods.com, and ask one of the members there to help me. Took less than 24 hours to get help as opposed to getting no help on here. My BIOS is now modded and my Y500 is running an Intel Wireless-AC 7260 connecting to WiFi networks @ 866Mbps.

Share this post


Link to post
Share on other sites

 

29 minutes ago, ShamblerDK said:

 

For some it's an imossible task, since they get error 104 using FPT regardless of having used the fix.

 

My solution was going to www.bios-mods.com, and ask one of the members there to help me. Took less than 24 hours to get help as opposed to getting no help on here. My BIOS is now modded and my Y500 is running an Intel Wireless-AC 7260 connecting to WiFi networks @ 866Mbps.

I wasn't talking about the error. I just made a easy to follow tutorial. Btw what did those people over at bios-mods say was the reason for the error?

Edited by jacobspeeds

Share this post


Link to post
Share on other sites
9 hours ago, jacobspeeds said:

 

I wasn't talking about the error. I just made a easy to follow tutorial. Btw what did those people over at bios-mods say was the reason for the error?

 

They didn't. You upload the backup of your BIOS, made with Universal BIOS Backup Toolkit, plus the newest BIOS package from Lenovos website, to one of the filesharing websites, and one of the users do the mod for you and then re-upload it to that same site. Very simple.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.