Jump to content
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

I fixed it.  Bios is modded and flashed and running well.   Now I'm on to why my Ultrabay 650m isnt being recognized when it has been (it stopped before the bios update)  but thatnks for the info.   Yeah just copying the 104 fix over and keeping the files in the root folder worked well.  Thanks

Share this post


Link to post
Share on other sites

Great guide! Seems pretty simple to follow, and I'm looking forward to attempting this as soon as I'm allowed to download things. :)

Share this post


Link to post
Share on other sites

Hey guys! 

 

I'd like to replace my WLAN module of my Lenovo Y500 with a newer one (Intel Wireless N 7260) and want to replace my BIOS with the modded one here from first page.

 

First problem is, my english is not the best but (luckily) good enough to understand, what is written in the tutorial on first page. That's what I hope. Besides that, nothing will work from first page. 

 

I tried to backup my BIOS with FPTDos and FPTw64 (I know I need five posts to download anything from here so I searched for it in the net) but none of them works. Or I don't know what to do with them. When I try to open the DOS backup.bat file I get an error because of 16 Bit incompatibility and when I open the Windows thing, I don't know what to do here. It opens a black window with a lot of commands and at the end, all I can do is, press any key to continue and then the window shut down.

 

Then I googled for an alternate prog to backup my BIOS and found a prog called "universal BIOS Backup ToolKit 2.0" which created a backup of my BIOS in 10 seconds (it's called LENOVO-6BCN44WW v2.04.rom). 

 

But then I stuck at the point 

 

Open the downloaded tool and execute it. Drag and drop your BIOS backup file on it, it will create the mod for you. It will look like this: 

 

So I opened it but I can't drop my backup file into it. What am I doing wrong?

 

 

Share this post


Link to post
Share on other sites

Ah, ok. I need to put the BIOS Fixer tool onto the USB drive. Now I've got an 'v204mod' file. So before I continue, I have to put the 'v204mod' file, the prr.exe tool and the fpt.exe tool onto the USB drive, restart, execute the prr.exe but with which name should I replace the filename.bin? The name of my BIOS backup file (in my case fpt.exe -f LENOVO-6BCN44WW(v2.04).rom -bios)? Do I have to put the BIOS backup onto my USB drive aswell? 

 

I don't get it...

Share this post


Link to post
Share on other sites

Okay, using Universal BIOS Backup Toolkit I've successfully made a backup of my BIOS, and modded it with the BIOS fixer tool, but how do I flash it, when I keep getting error 104 with FPT? The 104-fix doesn't work for me :-(

 

This is the error I get with FPT:

 

Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid

    --- Flash Devices Found ---
    W25Q32BV    ID:0xEF4016    Size: 4096KB (32768Kb)
    MX25L1605A    ID:0xC22015    Size: 2048KB (16384Kb)


Error 104: The 2 SPI flash devices do not have compatible command sets.

 

The two flash devices has already been added to fparts:

 

MX25L1605A,  0xC22015, 0x1000000,  0x1000, 0x20, 64, 0, 0x60, 80000
W25Q32BV,    0xEF4016, 0x2000000,  0x1000, 0x20, 64, 0, 0x60, 80000

 

Is there another piece of software, I can use to flash the modded BIOS?

Share this post


Link to post
Share on other sites

What exactly IS Error 104? Is a an error you get when you try to flash the BIOS or is it a permanent error you get once your flashing failed? Can you still use Windows when you boot normal? 

Share this post


Link to post
Share on other sites
On 22/3/2017 at 4:29 PM, Arcane said:

 

18 hours ago, Arcane said:

What exactly IS Error 104? Is a an error you get when you try to flash the BIOS or is it a permanent error you get once your flashing failed? Can you still use Windows when you boot normal? 

 

I'd very much like to know as well. It's the last hurdle I need to get past, in order for me to unlock my BIOS. I'm stuck with a shitty WiFi card in my Y500, which will only allow me to connect to 2.4GHz @ 72Mbit. An upgrade of the WiFi card is quite needed, since the rest of the laptop is awesome.

 

Another solution would be that someone could make a modded version of the BIOS, which could be flashed with Lenovos own InsydeFlash.

 

Yet another solution would be to modify platform.ini from InsydeFlash, in order for it to be able to flash the modded BIOS.

 

Suggestions?

Share this post


Link to post
Share on other sites
5 hours ago, ShamblerDK said:

 

I'd very much like to know as well. It's the last hurdle I need to get past, in order for me to unlock my BIOS.

I thought you already get the 104 error, so shouldn't you know if your OS still works? Can you still boot in Windows? 

 

And can you help me maybe with the rename thing? 

On 22.3.2017 at 5:09 PM, Arcane said:

...but with which name should I replace the filename.bin? The name of my BIOS backup file (in my case fpt.exe -f LENOVO-6BCN44WW(v2.04).rom -bios)? Do I have to put the BIOS backup onto my USB drive aswell? 

 

I don't get it...

 

Share this post


Link to post
Share on other sites
3 hours ago, Arcane said:

I thought you already get the 104 error, so shouldn't you know if your OS still works? Can you still boot in Windows? 

 

And can you help me maybe with the rename thing? 

 

 

Look at my previous post. It's the error I get when I try to use the FPT tool to either backup or flash my BIOS. Many others are getting it as well. There's even a fix for it, which works for some people. Appearently none of my flash chips are recognized by the FPT tool, even though they've both been added to fparts.txt.

Share this post


Link to post
Share on other sites

Aaah, ok then. I thought it's an error you get after the flashing

Share this post


Link to post
Share on other sites

Disregard my posts. Got someone over at www.bios-mods.com to help me. Their response-time is amazing! I asked for help yesterday afternoon and today I already have a flashable version of my BIOS. It works like a charm, I might add :-)

Share this post


Link to post
Share on other sites
1 hour ago, ShamblerDK said:

Disregard my posts. Got someone over at www.bios-mods.com to help me. Their response-time is amazing! I asked for help yesterday afternoon and today I already have a flashable version of my BIOS. It works like a charm, I might add :-)

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

Share this post


Link to post
Share on other sites
32 minutes ago, Arcane said:

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

 

Just go here and ask:

https://www.bios-mods.com/forum/Thread-REQUEST-Lenovo-Y500-Whitelist-removal?page=3

 

You'll get help in no time :-)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
5 hours ago, lucasheringer said:

Hey guys, was anyone able to use intel hd4000 with the unlocked bios?

Nope. No one has found a way to do that. I would be really impressed if someone does.

On 4/4/2017 at 3:41 PM, MIGUELEBS said:

my pc says i have V.1.5 of bios, do i need to update to 2.2 then 2.4 modded?

It has to be at least v2.02

Share this post


Link to post
Share on other sites
12 minutes ago, lucasheringer said:

Thanks jacobspeeds,

To bad I really would like to use OSx but without intel gpu there is no way to do that.

We all wanted to do something with the internal gpu but Lenovo being either incompetent or selfish made it impossible.

Share this post


Link to post
Share on other sites

Found this post that someone was able to enable iGPU intel hd4000, I just asked there if someone was able to use the gpu.

 

Share this post


Link to post
Share on other sites

Guys, I've made a super easy tutorial for this mod. As clear as I possibly could and much clearer for amateurs than the original. No offence, but if this is hard to follow then you shouldn't attempt to unlock your bios. Download here.

Share this post


Link to post
Share on other sites
On 3/28/2017 at 5:32 AM, Arcane said:

...and I still stuck at the point where I have to rename the filenmae.bin file :D Propably I'm to dumb for those things and have to live with my old 2.4Ghz wireless card for the rest of my life. 

try this,

 

5 minutes ago, jacobspeeds said:

Guys, I've made a super easy tutorial for this mod. As clear as I possibly could and much clearer for amateurs than the original. No offence, but if this is hard to follow then you shouldn't attempt to unlock your bios. Download here.

 

Share this post


Link to post
Share on other sites
3 hours ago, jacobspeeds said:

try this,

 

 

 

For some it's an imossible task, since they get error 104 using FPT regardless of having used the fix.

 

My solution was going to www.bios-mods.com, and ask one of the members there to help me. Took less than 24 hours to get help as opposed to getting no help on here. My BIOS is now modded and my Y500 is running an Intel Wireless-AC 7260 connecting to WiFi networks @ 866Mbps.

Share this post


Link to post
Share on other sites

 

29 minutes ago, ShamblerDK said:

 

For some it's an imossible task, since they get error 104 using FPT regardless of having used the fix.

 

My solution was going to www.bios-mods.com, and ask one of the members there to help me. Took less than 24 hours to get help as opposed to getting no help on here. My BIOS is now modded and my Y500 is running an Intel Wireless-AC 7260 connecting to WiFi networks @ 866Mbps.

I wasn't talking about the error. I just made a easy to follow tutorial. Btw what did those people over at bios-mods say was the reason for the error?

Edited by jacobspeeds

Share this post


Link to post
Share on other sites
9 hours ago, jacobspeeds said:

 

I wasn't talking about the error. I just made a easy to follow tutorial. Btw what did those people over at bios-mods say was the reason for the error?

 

They didn't. You upload the backup of your BIOS, made with Universal BIOS Backup Toolkit, plus the newest BIOS package from Lenovos website, to one of the filesharing websites, and one of the users do the mod for you and then re-upload it to that same site. Very simple.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
    • By 9vul14
      Hey allI, I need help  with modding my BIOS. I was wondering if anyone could help me mod my BIOS to unlock the 'Advanced' tab which I don't have on my InsydeH20 F.52 Rev 5.0 Bios? Thanks so much and I look forward to your response! Laptop: HP Pavilion x360  ba109tx
       
      Specs: 
      i7-8550U
      Nvidia Geforce 940MX
      Intel(R) UHD Graphics 620
      12GB DDR4-2400 SODIMM RAM
      128GB SSD, 1TB HDD
       
      Laptop Product Page: https://support.hp.com/gb-en/document/c05650773
      Vanilla BIOS: https://support.hp.com/sg-en/drivers/selfservice/hp-pavilion-14-ba100-x360-convertible-pc/16851098/model/18161600
    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES with most menus and options unlocked.
       
      THESE BIOS MODS ARE ONLY FOR PEOPLE WHO KNOW WHAT THEY ARE DOING!
       
       
       
      NEW:
      I'VE BEEN BUSY WITH SOME STUFF PLUS MY SYSTEM HASN'T BEEN WORKING FOR SOME TIME BUT I SHOULD BE ABLE TO CONTINUE MY WORK SOON 
       
      I'M CURRENTLY WORKING ON V3.0 WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      I'M ALSO WORKING ON MODS FOR OTHER MODELS TOO.
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
       
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
       
      TM, KM AND DM SERIES
       
      P6 AND P4 SERIES
       
      INSTRUCTIONS
        IF YOU LIKE MY WORK FEEL FRE TO BUY ME A COFFEE   ENJOY!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.