Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

I don't have SLI, and how can I save a copy of my bios?

Use the fptw64 tool in the first post of this thread. After unzipping the folder right-click on fptw64.exe and go to its Properties. Under the Compatibilty tab tick 'Run this program as administrator.' Then, double-click on backup.bat and it will generate a copy of the BIOS as a .bin file in the same folder.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@octiceps: Here's something you could try with your v1.05 system, flash with the included Insydeflash utility. If it allows you to flash please let me know the both vbios versions afterwards.

@Others: I doubt it will let you flash this way if you're on 2.0x already, and if you're on 2.02 you don't even need to try because it won't make any difference.

In any case, keep a backup of your current bios.

- file removed -

Share this post


Link to post
Share on other sites

svl7-

quick question. I have actually installed some new hardware to my machine and a different OS as well - mSATA Crucial SSD running as my boot drive, WD Scorpio black storage HDD, and win 8 pro (clean install). is this going to impact the bios flash any (I am using 2.02)? I am only really interested in being able to upgrade my Wi-Fi card.

on a side note, does anyone else have any flex in their lower laptop body? right above the keyboard, when I press down there it squeaks/snaps as if the internals are not 100% flushly connected. I suppose your mileage may vary since mine has been opened.

Share this post


Link to post
Share on other sites
@octiceps: Here's something you could try with your v1.05 system, flash with the included Insydeflash utility. If it allows you to flash please let me know the both vbios versions afterwards.

Nope doesn't flash. I get 'Error: invalid firmware image!!!' or something like that. Still on modded v1.05.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
quick question. I have actually installed some new hardware to my machine and a different OS as well - mSATA Crucial SSD running as my boot drive, WD Scorpio black storage HDD, and win 8 pro (clean install). is this going to impact the bios flash any (I am using 2.02)? I am only really interested in being able to upgrade my Wi-Fi card.

Nope, just follow the instructions and you'll be fine. Only use the 2.02 mod of course since you're already on that version.

Nope doesn't flash. I get 'Error: invalid firmware image!!!' or something like that. Still on modded v1.05.

Lol, thought so. Too bad.

Share this post


Link to post
Share on other sites
Nope, just follow the instructions and you'll be fine. Only use the 2.02 mod of course since you're already on that version.

Lol, thought so. Too bad.

Is there any hope for an SLI fix? I'll do anything within my power to help.

Share this post


Link to post
Share on other sites

I need to check one or two things, but I'm running out of ideas.

Has anyone ever disassembled the ultra bay GPU?

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
You could update to v2.02 if you want, with the leaked update, NOT with fpt. But this won't fix the SLI issue just now... .

So I DON'T flash it with fpt? What would I flash it with then? Sorry I'm confused, and thank you for your patience and time.

Share this post


Link to post
Share on other sites

You can flash it with the leaked update linked a couple of pages ago. If it is a valid update it will flash.

Then once you're on v2.02 (stock) you can follow the instructions in the first post and flash with fpt.

I will update the information in the first post when I get the chance.

Share this post


Link to post
Share on other sites
I need to check one or two things, but I'm running out of ideas.

Has anyone ever disassembled the ultra bay GPU?

Not that I know of. Another Y500 owner disassembled his single-GPU machine here with pictures but no Ultrabay GPU.

What specifically are you looking for and what should I be photographing? I can disassemble mine later today if needed. Hope I can put it all back together when I'm done lol.

In the meantime, these are some images and specifications of the disassembled Ultrabay GPU from the Lenovo hardware manual. They're pretty crude illustrations but might be of some use until I get around to taking apart my GPU. View full size as they are from an iPad.

http://i.imgur.com/DHb6u6Q.png

http://i.imgur.com/UM9Hktq.png

http://i.imgur.com/81TFb8n.png

http://i.imgur.com/JV62fGx.png

http://i.imgur.com/j170BJh.png

post-10698-14494994942576_thumb.jpg

Share this post


Link to post
Share on other sites
Use the tool in the first post and run the backup.bat as admin.

Thanks! Ok will do, I just need one final post before I can downlaod anything.. :)

Share this post


Link to post
Share on other sites

Hi,sorry for noob questions and English..

I'd never flashed bios and i don't want brick my new laptop-its my work machine(3D Artist)

my system is:

Lenovo Y500 i7 gt650m sli 16gb ram no ssd win 8

bios v1.05

I don't have any problems with sli,but here are lots of people who have.Can bios flash cause some problems?will Win 8 license be saved?

What bios version should i use?v1.05 or 2xx?

Share this post


Link to post
Share on other sites

Only flash a mod of the same version as you're using. If you want to go 2.02 then use the leaked stock update linked above, and once you done this flash the mod according to the instructions. Whatever you do, don't flash a mod of a different version than the one on your system.

Read the instructions and your Win8 cert and activation will be fine.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I have Bios 2.02, sli... whether yours will work fashions? I here read that fashions not the worker for sli

Share this post


Link to post
Share on other sites
Only flash a mod of the same version as you're using. If you want to go 2.02 then use the leaked stock update linked above, and once you done this flash the mod according to the instructions. Whatever you do, don't flash a mod of a different version than the one on your system.

Read the instructions and your Win8 cert and activation will be fine.

So it is not safe to update to modded v1.03 bios from a v1.02 bios. I've PM you my Y400 BIOS 6BCN30WW(v1.02,

but can I disable hyperthreading once a flashed to a modded bios? Does it lower the temps?

Share this post


Link to post
Share on other sites

Is there an option to adjust the system shared memory in the modded bios? Can't seem to find it other than for the IDG.

Share this post


Link to post
Share on other sites
Only flash a mod of the same version as you're using. If you want to go 2.02 then use the leaked stock update linked above, and once you done this flash the mod according to the instructions. Whatever you do, don't flash a mod of a different version than the one on your system.

Read the instructions and your Win8 cert and activation will be fine.

I can confirm that using the update link from 2.00 to 2.02 works, then flash with the modded bios. I am currently running on 5.0Ghz Wi-Fi and loving it. svl7 - beer money coming your way!

Share this post


Link to post
Share on other sites

I have updated from a modded 1.03 to a modded 2.02

Step 1: Take out your 3rd party wificard (if you have it already installed on an older modded version)

Step 2: Flash the leaked firmware (2.02)

Step 3: Create a backup of the Bios and create a modded version (Follow instruction from page 1)

Step 4: Flash the modded 2.02 bios

Step 5: Put your 3rd party wifi card back in place.

I tested the overclocking (with MSI Afterburner)and GPU clock is max 1375 MHz (instead of the regular 835 MHz) and Memory Clock is max 1500 (instead of the regular 1000 MHz)

@svl7, great job on the vbios and whitelist removal!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I just updated my Y500 v1.03 modded bios to v2.02 factory bios use the leaked stock update linked above without any problem.

So I think it save to use this file.

Share this post


Link to post
Share on other sites

Well I guess it might interest some people here too, I tried upgrading from the 2230N to a 6300N, which worked flawlessly, too.

Unfortunately, I had to remove the Wireless Card first and then upgrade and put it back in but that was worth the try. Now I have 5Ghz Wifi, much more reliable and stable than ever before.

Thanks!

EDIT: What I forgot. If you disable the Wifi in BIOS, you can upgrade the BIOS without removing the already built in 3rd party card. Then just re-enable after upgrading to the modded bios and you're fine :)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Alright, upgraded from 2.00 to 2.02 and ran into problems. Y500fix ran through, no problems so far. Now i tried to flash the new "fixed" bios file.

"Error 28: Protected Range Registers are currently set by BIOS, preventing flash access. Please contact the target system BIOS vendor for an option to disable Protected Range Registers."

Share this post


Link to post
Share on other sites

Hey svl7 I'm planning to take apart my Ultrabay GPU. What are you looking for and did the images in my previous post help at all?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Krak
      Hi everyone, I have a problem. I need to unlock the bios settings because I only have basic functions and I need to increase the memory of VRam. Sorry if I posted a post not in this topic.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad X240.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden advanced menus and settings in bios setup menu, or upgrade to new display (with brightness control), then you can post your request in this thread.
      Important!
      For creating your personal bios dump and to flash your bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/itm/USB-Programmer-CH341A-Series-Burner-Chip-24-EEPROM-BIOS-Writer-25-SPI-Flash-AU/153117073868?epid=577511738&hash=item23a67d21cc:g:XKEAAOSw5UdbW-iL
       
      https://www.amazon.com/Parts-tower-CH341A-Programmer-Software/dp/B01FVVHCVC/ref=sr_1_4?ie=UTF8&qid=1522179315&sr=8-4&keywords=ch341a&dpID=51BO7eGgO5L&preST=_SY300_QL70_&dpSrc=srch
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/MAUSAN-Socket-Adapter-150MIL-205MIL/dp/B06ZYSNJF3/ref=pd_sbs_21_3?_encoding=UTF8&psc=1&refRID=XM79QJWGED6B4K2VEZDJ
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
    • By spiderthink
      Hi,
      I am looking to remove the bios wifi whitelist restriction for a Lenovo G700 version 7ACN89WW . This is version 3.07
      I have used a programmer to read direclly from bios chip but it has failed. Is there any other method available to remove bios restriction from this laptop?
       
       
       
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.