Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

Yeah, will put it up in an hour or so. Can you (or any other 2.04 user) do me a favor? Some users seem to be eager to update to 2.04, this might be possible with your help. PM me if you want to help. I completely forgot about this, wanted to do this a while ago already.

If you can figure this out, it would be nice to know what changes 2.04 brings over, say, 2.03 and 2.02, and what hardware (750M and/or 650M) is supported, since Lenovo doesn't bother to provide any of this info.

Share this post


Link to post
Share on other sites

v2.04 added. Only for 2.04 users at the moment, I'm looking into providing an update for the rest.

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

Can someone with a 750m please post a picture of 2.04 showing the overclocking part of Nvidia Inspector?

Share this post


Link to post
Share on other sites
Can someone with a 750m please post a picture of 2.04 showing the overclocking part of Nvidia Inspector?
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Is this mod allow to overclock the gpu while it stay on battery (to for example 500 mhz on gpu and 1000 mhz on memory), because it can't be play on baterry in any of the games even on low

Share this post


Link to post
Share on other sites

v2.04 updated, corrected something I forgot.

If anyone is seriously interested in going to v2.04 coming from a different version please let me know. Else I won't bother wasting time on it.

Share this post


Link to post
Share on other sites
v2.04 updated, corrected something I forgot.

If anyone is seriously interested in going to v2.04 coming from a different version please let me know. Else I won't bother wasting time on it.

I doubt it would be possible. I keep googling until i find something :)

explanations

BIOS Upgrade - ThinkWiki

flashing EC

http://www.msi.com/html/pdf/How_to_make_a_bootable_flash_disk_and_to_flash_EC.pdf

According to MSI admins you cannot backup EC.

Bios and EC update?

So probably it's not possible at all.

Share this post


Link to post
Share on other sites

Of course it's possible, I'm just not going to waste time on it if nobody is going to use it.

Share this post


Link to post
Share on other sites

I know others have expressed interest in upgrading to 2.04. As for me, I would like to know what changes are in 2.04 and whether it supports 650M, as opposed to just 750M. If nothing is different or better then I won't bother.

Share this post


Link to post
Share on other sites

Update to 2.04 for all v2.02 and v2.03 users. Should work flawlessly, I still have no machine to test it myself but I see no reason why this would cause issues.

Let me know if all is fine.

EDIT: See first post for files.

Share this post


Link to post
Share on other sites

Hi,

Do I need to go to stock v2.02 BIOS first, or can I go from modded v2.02 to modded v2.04?

Greetings,

Auke Nauta

Update to 2.04 for all v2.02 and v2.03 users. Should work flawlessly, I still have no machine to test it myself but I see no reason why this would cause issues.

Let me know if all is fine.

Share this post


Link to post
Share on other sites
Update to 2.04 for all v2.02 and v2.03 users. Should work flawlessly, I still have no machine to test it myself but I see no reason why this would cause issues.

Let me know if all is fine.

Is it safe for gt650m sli users?

Share this post


Link to post
Share on other sites

Just performed the upgrade.

I used my original v2.02 (stock) backup file for your BiosFixer_2.0.exe utility.

It created the v204mod.bin file just fine.

Flashing from DOS worked fine too :)

The only thing which is a bit strange is that in the BIOS setup, it still says v2.02.

Is that as intended?

Thanks and greetings,

Auke

Update to 2.04 for all v2.02 and v2.03 users. Should work flawlessly, I still have no machine to test it myself but I see no reason why this would cause issues.

Let me know if all is fine.

Share this post


Link to post
Share on other sites
Update to 2.04 for all v2.02 and v2.03 users. Should work flawlessly, I still have no machine to test it myself but I see no reason why this would cause issues.

Let me know if all is fine.

What does this new modded BIOS version fix?

Share this post


Link to post
Share on other sites

The only thing which is a bit strange is that in the BIOS setup, it still says v2.02.

Is that as intended?

Oh, hehehe, my bad. I can fix that, but it's not that important. Can you post a screenshot of the inspector showing the overclocking stuff?

Share this post


Link to post
Share on other sites

Fixed 2.04 version added to the first post, will work for 2.02 and 2.03 users.

People with older Bios versions than 2.02 should use the unmodified update to 2.02 and can then still proceed to 2.04 modified.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Just finished updating/flashing. Actually, I was trying to download the 2.02 modded version when you were updating and it kept failing until I reloaded the page. Anyway, straight forward and no problems whatsoever.

I wanted to comment about post-flashing. This took a solid 18 seconds off my boot time to the desktop and about 10 second of the complete load (ie. background servers finished). I didn't modify anything in the BIOS yet, just looked around. Not sure why or if it was supposed to work this way, but I have a definite zip to boot and even running apps within Windows, compared to before.

Thanks a lotǃǃǃ

Share this post


Link to post
Share on other sites

Cool!

I still want to see that nvidia inspector screenshot showing the overclocking stuff, can anyone please upload a screenshot?

Share this post


Link to post
Share on other sites
Cool!

I still want to see that nvidia inspector screenshot showing the overclocking stuff, can anyone please upload a screenshot?

post-14758-1449499567406_thumb.png

There's a new update that Nvidia is notifying me about, but I haven't installed it. Also, didn't play around with any settings yet, but hope it helpsǃ

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
    • By Zoarilamb
      A part of my BIOS got corrupted that controls my laptops backlights. Other methods like the Gary Key fix did not work for me because I do not get any light up during post. i followed this guide  that says I need to extract and use the 6MB portion of an 8MB bios dump, only AFUWIN tells me "Error, ROM file size does not match existing BIOS size which is because my laptop BIOS size is only 5.87MB.  I don't need to flash the whole BIOS, I only need to flash a portion of it. 
       
      I've searched everywhere online for a dump of my laptop model but non exist that I know of.
    • By Zoarilamb
      I fiddled around with modding my laptops BIOS to unlock XMP profiles and hopefully seeing if optimus could be disabled. After flashing my modded bios and trying it out, I noticed that my keyboards backlight no longer turns on. I was unaware it requires an official BIOS to function. They backlights wont turn on unless ASUS ATK package is installed but now it seems it also needs an official BIOS?
       
      The modded ROM and tool I used if anyone has any experience with this and doesn't mind telling me what to enable/disable, or anything else i can do to re-enable them 
        
    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.