Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

I tried a cursory search but couldn't find an answer - does the unlocked BIOS have hot plug options for the sata ports? I turned my ultrabay into an eSATA port, which of course works with a drive connected/powered on boot - but if I can enable hot-swapping, that would definitely make it more convenient. Since this is the only feature I'm interested in, I'm reluctant to flash my BIOS sight unseen.

Share this post


Link to post
Share on other sites

Thanks. I figured the answer was in one of the various screen grabs of the BIOS, but new user privileges and all...

That's great, though. I guess I'll go ahead with it.

Share this post


Link to post
Share on other sites

@svl7 Hi ya.

Thank you for the all you have done.

I received my brand new shiny Y500 750m yesterday late. I have 2.04 in it. I'll look around for the extraction process and if you still require it, let me know and I'll have it to you as early as tonight.

Cheers!

Share this post


Link to post
Share on other sites

@svl7 and or other Mods

I can do apparently nothing in these boards... So, if indeed 2.04 is to be uploaded I will need to be able to download the extractors (backup), etc. I'll pay the 5$, no problem there. Just be nice to know that my posts are actually going to appear in these boards one day... ;-) And that someone will read and reply...

Thanks.

Share this post


Link to post
Share on other sites
@svl7 Hi ya.

Thank you for the all you have done.

I received my brand new shiny Y500 750m yesterday late. I have 2.04 in it. I'll look around for the extraction process and if you still require it, let me know and I'll have it to you as early as tonight.

Cheers!

Also on 2.04 here - eagerly waiting, and glad to send something over, if need be.

Share this post


Link to post
Share on other sites
I have 2.04 but cant figure out how to pm a file?

Use a free file hosting site like MediaFire or Google Drive and PM svl7 the download link.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Would anyone happen to know what I did wrong when trying to mod the bios? When I try to boot the usb (it is DOS) it stays on the Lenovo screen and doesnt do anything. Any help would be great.

Share this post


Link to post
Share on other sites
Would anyone happen to know what I did wrong when trying to mod the bios? When I try to boot the usb (it is DOS) it stays on the Lenovo screen and doesnt do anything. Any help would be great.

Sounds like it's having trouble finding the boot device. Go into BIOS and check that boot mode is set to Legacy, UEFI first, and USB boot on. Also make sure you followed the OP instructions correctly for making the bootable USB.

Share this post


Link to post
Share on other sites
Sounds like it's having trouble finding the boot device. Go into BIOS and check that boot mode is set to Legacy, UEFI first, and USB boot on. Also make sure you followed the OP instructions correctly for making the bootable USB.

I did, also, I tried the legacy thing. However I might not have done it correctly so I shall try again. And I guess ill find a different flash drive as well, this one is not so great. Thanks.

Share this post


Link to post
Share on other sites

So now I found out it was just my flashdrive- so I'm around the last step. It says there's a filename.bin, however, I don't see one in my dir after putting the prr, fpt, and biosmod exes and fparts into the drive. What do I do now? Sorry for being a nub

Share this post


Link to post
Share on other sites
So now I found out it was just my flashdrive- so I'm around the last step. It says there's a filename.bin, however, I don't see one in my dir after putting the prr, fpt, and biosmod exes and fparts into the drive. What do I do now? Sorry for being a nub

Read the directions in the OP. You're supposed to use the BIOSFixer .exe tool for your specific BIOS version to create the modified BIOS yourself using a backup of your current BIOS. That's the file that's supposed to be flashed.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Well everything finally worked. I just hadn't done the Backup of bios correctly, and I never thought the outcome was a .bin file. I appreciate the help.

Share this post


Link to post
Share on other sites

Work in progress. Should be on today, hopefully.

Share this post


Link to post
Share on other sites
On notebook review they say 2.04 is unlocked already guess its bull huh?

As in it ships unlocked? Definitely not true.

Share this post


Link to post
Share on other sites
Did anyone manage to flash from 2.02 to 2.03 or 2.04? Someone who was crazy enough to try this ?

Has anyone actually tried this or failed in the past ?

You could probably do it, but it will only update the BIOS version and not the EC version, which is not good.

Share this post


Link to post
Share on other sites

1. hi guys little lost here newbie ive flashed to v2.02 fw on my y500 sli now i want to mode or flash the ultrabay gfx card but cant get or download the files.

2. after i fw the y500 to 2.02 do i then need ti install a modded fw and patch ?

3. how do i then oc or set the faster speed for each 650m is the a utility to do this

thanks

Share this post


Link to post
Share on other sites

Any eta on the 2.04 whitelist removal?

- - - Updated - - -

On notebook review they say 2.04 is unlocked already guess its bull huh?

no it is not unlocked, I tried 3 different cards, with no luck.

Share this post


Link to post
Share on other sites

Yeah, will put it up in an hour or so. Can you (or any other 2.04 user) do me a favor? Some users seem to be eager to update to 2.04, this might be possible with your help. PM me if you want to help. I completely forgot about this, wanted to do this a while ago already.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
    • By Zoarilamb
      A part of my BIOS got corrupted that controls my laptops backlights. Other methods like the Gary Key fix did not work for me because I do not get any light up during post. i followed this guide  that says I need to extract and use the 6MB portion of an 8MB bios dump, only AFUWIN tells me "Error, ROM file size does not match existing BIOS size which is because my laptop BIOS size is only 5.87MB.  I don't need to flash the whole BIOS, I only need to flash a portion of it. 
       
      I've searched everywhere online for a dump of my laptop model but non exist that I know of.
    • By Zoarilamb
      I fiddled around with modding my laptops BIOS to unlock XMP profiles and hopefully seeing if optimus could be disabled. After flashing my modded bios and trying it out, I noticed that my keyboards backlight no longer turns on. I was unaware it requires an official BIOS to function. They backlights wont turn on unless ASUS ATK package is installed but now it seems it also needs an official BIOS?
       
      The modded ROM and tool I used if anyone has any experience with this and doesn't mind telling me what to enable/disable, or anything else i can do to re-enable them 
        
    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.