Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

A final dumb question - does anyone happen to have a copy of the legacy Y500Fix? I'm flashing one of jester_socom's custom BIOSes but can't preprocess it since the only files being distributed are per-version versions of the Y500Fix - presumably with specific BIOSes embedded inside.

Share this post


Link to post
Share on other sites
A final dumb question - does anyone happen to have a copy of the legacy Y500Fix? I'm flashing one of jester_socom's custom BIOSes but can't preprocess it since the only files being distributed are per-version versions of the Y500Fix - presumably with specific BIOSes embedded inside.

You mean svl7's old command prompt BIOS Fixer tool? I have a backup of it I can send you but I'm away from my computer right now so it'll be in a few hours. svl7 can probably provide it too.

Share this post


Link to post
Share on other sites
You mean svl7's old command prompt BIOS Fixer tool? I have a backup of it I can send you but I'm away from my computer right now so it'll be in a few hours. svl7 can probably provide it too.

That's the one - it let you input any file so so wished, if I remember - thanks in advance.

Share this post


Link to post
Share on other sites

That version is outdated. It has an issue and mustn't be used anymore.

Share this post


Link to post
Share on other sites

My hands are bound, though: I've got one of jester_socom's custom BIOSes, and no means of doing the necessary fixes on them.

Share this post


Link to post
Share on other sites
That version is outdated. It has an issue and mustn't be used anymore.

What was wrong with it? I used it to flash three different laptops without problems.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
What was wrong with it? I used it to flash three different laptops without problems.

the bios flashing is a success! man it's like a whole new world blasted into your face with this mod, so much locked stuff! :Banane17:

BTW in the thermal settings(?) does changing the fan speed setting of low makes something happen?

and kudos and thanks to @svl7 @octiceps and @Kamnnoriel !!! gonna flash the vbios now for more oc awesomesauce

Share this post


Link to post
Share on other sites

BTW @svl7 you should specify the vbios flashing that you only need to flash the ultrabay cpu on sli models aka <1> to avoid confusion

and can i change how my laptopperforms in battery? like removing the 135 idle speeds of the laptop onbattery

Share this post


Link to post
Share on other sites

I haven't been able to successfully flash the newer 750 bios on the ultrabay card.

I get the following result when calling "nvflash -6 -i1 vbiosOC.rom" This is in the windows version 5.134 as 5.128 refused to even attempt flashing and said I needed a newer version to flash that firmware.

NVIDIA Firmware Update Utility (Version 5.134)

Checking for matches between display adapter(s) and image(s)...

Adapter: N14P-GT (10DE,0FE4,17AA,3802) H:--:NRM B:02,PCI,D:00,F:00

Current - Version:80.07.95.00.1A ID:10DE:0FE4:17AA:3802

GK107 Board - 2044nb3q (Normal Board)

Replace with - Version:80.07.9D.00.11 ID:10DE:0FE4:17AA:3802

GK107 Board - 2044nb3q (Normal Board)

Update display adapter firmware?

Press 'y' to confirm (any other key to abort): y

The display may go *BLANK* on and off for up to 10 seconds or more during the up

date process depending on your display adapter and output device.

Identifying EEPROM...

EEPROM ID (C2,2012) : MX MX25L2005 2.7-3.6V 2048Kx1S, page

ERROR: PCI Block corrupted - size mismatch

I am able to flash the previous version of the 750 firmware, but it doesn't seem to remove the 135 limit on the ultrabay card so I flashed it back to my original vbios.

Anyone else have any trouble with it?

Share this post


Link to post
Share on other sites

Also considering purchasing the Killer N1202 to put into my Y400. It came last month with version 2.02 installed from Lenovo. Just to clarify since I am a computer noob. If I download the modded version 2.02, this will allow me to add the killer N card to the machine without issues, correct? Thanks again. Great mod.

Share this post


Link to post
Share on other sites

Works well. I made a few stoopid mistakes like not pressing enter after running prr but she's done good now.

Share this post


Link to post
Share on other sites
I haven't been able to successfully flash the newer 750 bios on the ultrabay card.

I get the following result when calling "nvflash -6 -i1 vbiosOC.rom" This is in the windows version 5.134 as 5.128 refused to even attempt flashing and said I needed a newer version to flash that firmware.

NVIDIA Firmware Update Utility (Version 5.134)

Checking for matches between display adapter(s) and image(s)...

Adapter: N14P-GT (10DE,0FE4,17AA,3802) H:--:NRM B:02,PCI,D:00,F:00

Current - Version:80.07.95.00.1A ID:10DE:0FE4:17AA:3802

GK107 Board - 2044nb3q (Normal Board)

Replace with - Version:80.07.9D.00.11 ID:10DE:0FE4:17AA:3802

GK107 Board - 2044nb3q (Normal Board)

Update display adapter firmware?

Press 'y' to confirm (any other key to abort): y

The display may go *BLANK* on and off for up to 10 seconds or more during the up

date process depending on your display adapter and output device.

Identifying EEPROM...

EEPROM ID (C2,2012) : MX MX25L2005 2.7-3.6V 2048Kx1S, page

ERROR: PCI Block corrupted - size mismatch

I am able to flash the previous version of the 750 firmware, but it doesn't seem to remove the 135 limit on the ultrabay card so I flashed it back to my original vbios.

Anyone else have any trouble with it?

did you enter [ nvflash iX -r] before flashing the vbios? i had problems when i didn't enter that command before flashing. and please check if the vbios you have downloaded is the correct one

- - - Updated - - -

Also considering purchasing the Killer N1202 to put into my Y400. It came last month with version 2.02 installed from Lenovo. Just to clarify since I am a computer noob. If I download the modded version 2.02, this will allow me to add the killer N card to the machine without issues, correct? Thanks again. Great mod.

yes , the bios mod removes the whitelist that idiot lenovo put into the bios

Share this post


Link to post
Share on other sites

Yeah, I used the -r command first. Like I said, I can flash one of the two 750 firmwares, just not the newer one. The one I can flash doesn't seem to remove the 135 limit that I can tell.

Share this post


Link to post
Share on other sites

Can anyone bypass the idle speeds of the GPU's in battery through the BIOS? i want to run it at least at 300/600 so that i can play at low settings on battery. This laptop is awesome but we should game a bit on battery not always chained to the power outlet

Share this post


Link to post
Share on other sites
Yeah, I used the -r command first. Like I said, I can flash one of the two 750 firmwares, just not the newer one. The one I can flash doesn't seem to remove the 135 limit that I can tell.

Try the latest nvflash: http://forum.techinferno.com/nvidia-video-cards/3827-latest-nvflash-windows-dos.html

Can anyone bypass the idle speeds of the GPU's in battery through the BIOS? i want to run it at least at 300/600 so that i can play at low settings on battery. This laptop is awesome but we should game a bit on battery not always chained to the power outlet

Not very healthy for the battery, but Nvidia Inspector will probably allow you to do so. It's not a good idea for a bios mod to change the 2d profile because it will drain the battery a lot faster even when not gaming.

Share this post


Link to post
Share on other sites
Try the latest nvflash: http://forum.techinferno.com/nvidia-video-cards/3827-latest-nvflash-windows-dos.html

Not very healthy for the battery, but Nvidia Inspector will probably allow you to do so. It's not a good idea for a bios mod to change the 2d profile because it will drain the battery a lot faster even when not gaming.

how can i do it through Nvidia inspector please:01:

Share this post


Link to post
Share on other sites

Does it allow you to overclock the P-state which is used when you're running on battery?

Share this post


Link to post
Share on other sites

I have been reading a lot of questions regarding how to over-volt. However with this mod would it be possible to under-volt the 750m? The main reason is I don't have an AC, it hot these days and would prefer a much lower idle temperature than 50C! I think the cards are more than enough to run the games I play even at a lower clock rate.

Share this post


Link to post
Share on other sites
excuse my ignorance, can i unlock bios and whitelist without OC video card?

You don't have to overclock the video card if you don't want to, your choice.

Share this post


Link to post
Share on other sites
I have been reading a lot of questions regarding how to over-volt. However with this mod would it be possible to under-volt the 750m? The main reason is I don't have an AC, it hot these days and would prefer a much lower idle temperature than 50C! I think the cards are more than enough to run the games I play even at a lower clock rate.

you can underclock via MSI Afterburner and Nvidia Inspector even when not modded (correct me if i am wrong)

Share this post


Link to post
Share on other sites

My SLI had stopped working after I installed the mod. Although I had no OC plans I actually ended up installing the modified vbios as well which didn't help.

Anyway all I had to do was go to NVIDIA Control Panel > Set SLI & Physics Configuration > Disable SLI and then set it back to Maximize 3D Performance. Just putting it out there incase someone else gets the same problem.

Share this post


Link to post
Share on other sites

I tried a cursory search but couldn't find an answer - does the unlocked BIOS have hot plug options for the sata ports? I turned my ultrabay into an eSATA port, which of course works with a drive connected/powered on boot - but if I can enable hot-swapping, that would definitely make it more convenient. Since this is the only feature I'm interested in, I'm reluctant to flash my BIOS sight unseen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By spiderthink
      Hi,
      I am looking to remove the bios wifi whitelist restriction for a Lenovo G700 version 7ACN89WW . This is version 3.07
      I have used a programmer to read direclly from bios chip but it has failed. Is there any other method available to remove bios restriction from this laptop?
       
       
       
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.