Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

I picked up a 6235 and tried to install it today before finding out the hard way that the whitelist blocks them. I got my y500 recently, so it's rocking the 2.03 bios. Hopefully it will get hacked soon. Are you able to flash back the regular bios if you ever need to send in the laptop for service? Also, does anyone know of a wifi card that supports 5ghz in the whitelist now?

Share this post


Link to post
Share on other sites

Nevermind my question about flashing the original bios. Reading back through I see you just have to flash your bios backup.

Share this post


Link to post
Share on other sites
Thanks for the reply

I have a Y500 with 2.03. Just got it due to mine having a motherboard replaced and having parts shortage. My old one was 2.02, this one is 2.03.

How would I go about getting my BIOS copied to a file to send?

Edit: Nevermind, figured out how to copy it and sent svl7 a PM. Thanks again!

I have v2.03 as well. Can you let me know if there is any news on the mod? I have the more recent model that has the GT750m on-board, and no second card.

Share this post


Link to post
Share on other sites

After having flashing the modded 2.02 BIOS on my computer I have noticed that I lose access to my Bluetooth devices. I dug around in Windows to find that my Bluetooth hardware is unavailable (not even listed in device manager). I promptly went through the BIOS menu to see if it had been deactivated on accident to find that there isn't an option for it. The only solution I found was to "repair" the drivers by using the install on Lenovo's site, and reboot. However, once I shut the computer down, or put it to sleep I lose Bluetooth once more.

Has anyone ran into this issue? Or has any suggestions on how I should go about fixing this?

I tried uninstalling the drivers, flushing them out from the system, rebooting and re-installing. But, it does the same exact thing.

I am currently running Windows 8.

Share this post


Link to post
Share on other sites

Hey guys I'm just wondering why there's so much hate for the stock WiFi card that comes with the Y500? It's working great for me. Except the Bluetooth adapter isn't really compatible with a lot of my Bluetooth applications :/ Other than that, I have the Y500 with dual 750m graphics cards. Will I be able to overclock the cards without overvolting?

Share this post


Link to post
Share on other sites

Generally because the 2230 card has some pretty well known issues with speed and consistency of connection for wifi. The card should hit a max speed of 150mbps but most people rarely break 20mbps. Newer drivers have helped some. Disabling bluetooth has helped some. But it seems to be a hardware issue with the card and some people would just like to be able to replace the card with a better performing card. On top of that some people want to be able to use 5ghz connections and the card doesn't support that. That is useful for those people stuck in areas that have the 2.4ghz band flooded with competing signals(like 20 neighbors with wifi routers of their own).

Share this post


Link to post
Share on other sites

The modded 2.02 bios seems to be missing from the first post attachments. I don't need it since I'm on 2.03 and will need to wait for that version to get modded, but I just thought I should point it out.

Share this post


Link to post
Share on other sites
Hey guys I'm just wondering why there's so much hate for the stock WiFi card that comes with the Y500? It's working great for me. Except the Bluetooth adapter isn't really compatible with a lot of my Bluetooth applications :/ Other than that, I have the Y500 with dual 750m graphics cards. Will I be able to overclock the cards without overvolting?

I have the same issue. Do you use the original wifi card?

I have installed a broadcom card which seems tot have bad Windows 8 drivers (or maybe its BIOS related.)

Verstuurd van mijn Nexus 4 met Tapatalk

Share this post


Link to post
Share on other sites

Has anyone actually sent a firmware backup of 2.03 or 2.04 to svl7 yet so he can work on it? Is the backup something that's moddable or do we need to wait for the newer versions to get leaked like 2.02 was?

Share this post


Link to post
Share on other sites
Has anyone actually sent a firmware backup of 2.03 or 2.04 to svl7 yet so he can work on it? Is the backup something that's moddable or do we need to wait for the newer versions to get leaked like 2.02 was?

I posted my copy of 2.03 a few weeks ago.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
I posted my copy of 2.03 a few weeks ago.

I can probably do it myself for everyone by hex comparing stock and modded BIOS made by him. But if something is different I risk bricking everyone's motherboard. But you can always donate him prior making the BIOS mod, He doesn't have much free time probably. But this way he hopefully can release faster.

I can do the 750M and 650M unlock on 2.03 and 2.04 but the whitelist and menu unlock I have no experience with. Reason I don't make the mod myself is because I have a non-whitelisted WLAN card. And this is my only computer.

Share this post


Link to post
Share on other sites

I just noticed this too. Where is the modded 2.02 bios? I suscribed just to download that file and now is gone :(

Share this post


Link to post
Share on other sites

I'm not sure if this has been already asked but here goes:

I followed the guide step by step (and thus updating my bios to version 2.02 now the next point of the guide is that I need to have the same version of bios to flash a modded version. So I'm now on v2.02 but the only modded ones attached are the 1.03 and 1.04. So whats the point in updating to v2.02 first? And do I need to downgrade now in order to flash 1.05?

Thanks

EDIT: Found it, its in this thread:

http://forum.techinferno.com/lenovo-ibm/2874-lenovo-y400-y500-unlocked-bios-wlan-whitelist-mod-57.html#post49733

Hope this helps others

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I understand that Lenovo is not generally making these bioses available, but does anyone know where revision histories might be found for say the delta between 2.01 and 2.02/3/4, etc.?

Share this post


Link to post
Share on other sites

You guys should PM svl7 with the BIOS file you want modded and ask nicely. He hasn't popped in here in quite a while and there've been a lot of product launches recently so he's probably busy elsewhere.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

has anyone tried connecting to the internet via Bluetooth tethering from an android fone? (ex. galaxy s4)

Share this post


Link to post
Share on other sites
You guys should PM svl7 with the BIOS file you want modded and ask nicely. He hasn't popped in here in quite a while and there've been a lot of product launches recently so he's probably busy elsewhere.
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Sorry for asking this silly question, is Y500 able to upgrade the processor. I have a 3630QM model because I need to do some photo and video editing so does Lenovo have a white list for processors. If it didn't have, is it possible upgrade to 3740QM?

Share this post


Link to post
Share on other sites

whats the best budget wifi card to replace this crap intel with that supports bluetooth

Share this post


Link to post
Share on other sites

Hey guys I have the Y400 with the GT 750m and I really want to get rid of the centrino 2230, is this method recommended for my y400? I was reading the main post and it said it was also valid for the Y400, but I'm not sure if it'll work with the 750m edition (the method was made originally for the y400 with the 650m onboard)...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By spiderthink
      Hi,
      I am looking to remove the bios wifi whitelist restriction for a Lenovo G700 version 7ACN89WW . This is version 3.07
      I have used a programmer to read direclly from bios chip but it has failed. Is there any other method available to remove bios restriction from this laptop?
       
       
       
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.