Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

Run the fpt tool with -i as parameter and let me know what it says.

Share this post


Link to post
Share on other sites

Appreciate your prompt reply, svl7 . The followings are the command response as well as screen shot:

E:\Fptw64_2>fptw64 -d biosbackup.bin -bios
Intel (R) Flash Programming Tool. Version: 8.0.10.1464
Copyright (c) 2007 - 2012, Intel Corporation. All rights reserved.
Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q32BV ID:0xEF4016 Size: 4096KB (32768Kb)
MX25L1605A ID:0xC22015 Size: 2048KB (16384Kb)

Error 104: The 2 SPI flash devices do not have compatible command sets.
E:\Fptw64_2>fptw64 -i
Intel (R) Flash Programming Tool. Version: 8.0.10.1464
Copyright (c) 2007 - 2012, Intel Corporation. All rights reserved.
Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q32BV ID:0xEF4016 Size: 4096KB (32768Kb)
MX25L1605A ID:0xC22015 Size: 2048KB (16384Kb)

Error 104: The 2 SPI flash devices do not have compatible command sets.

post-10420-14494994348744_thumb.jpg

Looking forward to your reply, thanks again!

Share this post


Link to post
Share on other sites

Fix added to the first post. Replace the fparts file with the one provided in the fix archive.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

i'm disappoined that we can't enable the HD4000, i was wondering if i should get that notebook, i guess the answer is now NO, i need a decent battery life and this notebook wont give me that..

Share this post


Link to post
Share on other sites
This has been discussed, it's due to the motherboard design, leaving out the ability to use only the iGPU respectively only the dedicated GPU needs a more sophisticated mobo design, i.e. more expensive. Lenovo didn't put that ability in the Y500.

For clarity's sake, does this means that optimus tech and enabling the HD 4000 is impossible due to hardware limitations? My current wish for wanting the HD 4000 as a standard is that I have 650 sli which is wonderful for gaming, but horrid for using the laptop for regular use. It would be nice to enable the 4000 for those situations. Thanks for your help

Share this post


Link to post
Share on other sites

I'm not familiar with the Y500... the datasheet says the system is Optimus capable, so it should use the HD4000 automatically, however some users online report that there's no Optimus. I don't know what's true, never had my hands on such a system.

However, it seems that there's no way to run only the Intel HD4000, I'd say it's hardware related. Most systems which come with Optimus can't run on only the dGPU or only iGPU, some of the exceptions are the current AW systems, they use a different board design with additional parts in order to leave out the HD4000 completely.

Share this post


Link to post
Share on other sites

I would assume so. They're probably based on the same chipset/bios. But I wouldn't know for sure. svl7 is all-knowing xD.

Share this post


Link to post
Share on other sites

I don't know, there's no bios download for the Y400 on the Lenovo site, but if you can provide me with a dump of your bios I might be able to tell.

- - - Updated - - -

Well, I found a dump of the Y400 bios in another request thread. Seems to be the same platform, so it should work perfectly fine, but since we have only the bios and not the rest of the firmware you'll need to stay on the same version as you currently are. Can you tell me which bios version you have?

Share this post


Link to post
Share on other sites

thx for svl7 works =) my y400 1.04 version had been successfully flash into mod bios.Can i ask how to adjust voltage for my gt650m graphic card?

Share this post


Link to post
Share on other sites

This all looks very promising, and much kudos to svl7, whom is the only one giving all of us Y500 owners some hope. The biggest thing, I believe, is that we get the HD4000 enabled if we can. If not this laptop will have been a lie to many of us. If we can somehow do that then this laptop will be golden.

Share this post


Link to post
Share on other sites

would a BIOS+FIRMWARE update from lenovo solve the HD4000 Problem?

Share this post


Link to post
Share on other sites

Song814 U flash with mod bios v1.05 on top of v1.04 sucessfully?

Sent from my GT-I9300 using Tapatalk 2

Share this post


Link to post
Share on other sites

I see, I guess I read your last post about it incorrectly svl7. That is an incredible bummer I cannot lie. Nothing like actually being able to see your battery deplete in real time.

Share this post


Link to post
Share on other sites

I just achieved the highest 3DMark11 public score, so far, for a Y500 with just 1x GT 650m. A very respectable P3239 at 1150mhz/2700mhz, while resting on a cooling pad.

Could not have done it without svl7's work on unlocking the bios. Thanks again to you, good sir. Fine work, indeed.

We could actually crush this score if over-volting becomes available. When it fails during stress testing the temps are still in the 60 degree range; it just needs a few more drops of power.

CPU is another story... gets super hot super fast and can saturate the GPU over time. A decent laptop cooler pushes enough fresh air to keep the CPU happy at a rock-steady 3198.8mhz while topping out at 85C under load. Not bad. Without cooling help the CPU temps will reach 90-95C under load, though. Too close for comfort. One core spikes up to 100C and boom... auto-protect killswitch shuts ya down hard.

I'm still amazed by the potential of these GK107-A2's. So who's gonna knock me off the hill? Go for it! Let's get one to P3400 plus! :D

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

how u can reach 3239 with 1 card?my gt650m maximum can overclock till 924/1370 and reach p2693 only =(

Share this post


Link to post
Share on other sites
how u can reach 3239 with 1 card?my gt650m maximum can overclock till 924/1370 and reach p2693 only =(

GT650MOCd1200mhz_zpsb492be91.jpg

Share this post


Link to post
Share on other sites
GT650MOCd1200mhz_zpsb492be91.jpg

I have identical Y500 with yours....

<embed id="xunlei_com_thunder_helper_plugin_d462f475-c18e-46be-bd10-327458d045bd" type="application/thunder_download_plugin" height="0" width="0">

- - - Updated - - -

<embed id="xunlei_com_thunder_helper_plugin_d462f475-c18e-46be-bd10-327458d045bd" type="application/thunder_download_plugin" height="0" width="0">I flashed the BIOS from 1.07 down to 1.05-modified, all working good

I tried to enable HD4000 from the BIOS advanced option... Seems not working.

Share this post


Link to post
Share on other sites

To any who want to try and beat my score... and I hope you do! Don't brick your new computer, please. I take no responsibility. Been working with this stuff all my adult life... if you aren't super-comfortable with this, re-think.

Theoretically, your Y500 should be just as capable of reaching that score as mine. My P3239 is the highest of three consecutive runs. The score will vary by a few points each time. Use a cooler or place the laptop on a fan. Watch your temps on a second monitor, if you can. I haven't noticed any impact on the score when running dual external monitors.

You must stop the CPU from throttling completely and set it to run at 3.2ghz. To do this, set C-States, BDPROCHOT and Turbo Short PWR Duration to "disabled" in the svl7 modded bios. Use ThrottleStop to lock your multiplier to 32x, 33x or "Turbo". 32x should put you at 3198.8ghz. 33x and Turbo do the same thing. It tops out at 3.2 ghz. I'm not interested in unlocking that limit at the moment, but I did see a 3DMark score from what looked like a Y500 that reported CPU at 3.3ghz. It was probably throttling. The physics and mixed portions of the test are CPU-intensive, so steady CPU is better than bursting in this case. Also, any bump in CPU speed will yield a higher score. As a side note, disabling hyper-threading yielded much lower scores across the board. The decrease in heat generation was not worth the performance hit for me.

I had best results on the 310.70 Nvidia driver. I would NEVER recommend what I'm about to say if I hadn't experienced it myself, but... let windows upgrade the driver for you. (gasp) I was on the Lenovo 306.00 driver and had tried 310, 314, etc Nvidia installers, with varied results. In a moment of insanity I went into devmgr and clicked on the GT 650m, then upgrade driver, then search automatically. Windows found the 310.7 driver and replaced the 306.00 driver without much fanfare. After a restart I was surprised to find that my Windows driver update was working beautifully... that's when I achieved the posted score. My previous experience with Windows updating video drivers has been overwhelmingly poor... so poor that I disable those updates on my client's computers. This time it worked nicely... dunno. I'll take it though.

I used the latest Nvidia Inspector (1.9.7.0) to set clocks at 1150core and 2700 mem. Anything higher and there is simply not enough voltage to get it done. Hoping to be able to bump up the juice a bit eventually, but to be honest these gains are impressive as they stand. Crysis 3 runs on maxed out settings without issue. Planetside 2 with the "ultra" settings mod runs excellently and never drops below 25FPS. Pretty good for Planetside. Those battles get busy!

Please be careful and feel free to ask any questions. I check in here once a day at least. PM is ok too, but your question might benefit the group, so consider posting in the thread :)

-bearfight

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

thx for your reply bear =) maybe my card already locked by vbios,i cant overlock over 135 by nvidiaInspector

So I recently do some research on modding vbios by winhex,try over the 924 clock speed.First i try using gpu-z dump my gt650m vbios,but no luck my vbios is tied to my bios.So i dump my vbios from my bios.Then i starting modding my GT650m vbios by winhex.After finish edit i replace module into bios and flash mod bios.

After using the flashing tools svl7 given and successfully flash the modded bios,when i restart my system my screen become black.Then i recover my bios back.I have try a lot of software but still cant flash my vbios over 135.Maybe gt650m too new for them

So can somebody kindsoul help me edit my GT650m vbios. i will thank you very much

here is my vbios A274A98B-83A6-4C37-A816-9F93D79FD6D9_1_1114.ROM

thanks in advance

gpuzkt.jpg

Uploaded with ImageShack.us

Share this post


Link to post
Share on other sites

How did you get devmgr to do that because every single time I try it does nothing. Says device is up to date.

Share this post


Link to post
Share on other sites

Hi,

same problem as song_0814 above. Overclocking works up to 310.90 drivers. I am waiting impatiently for VBIOS mod from svl7 :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.