Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

please let me download bin files i need to recovery my bricked bios lenovo y500...

Share this post


Link to post
Share on other sites
4 hours ago, only4g said:

please let me download bin files i need to recovery my bricked bios lenovo y500...

Hi!

For recovery procedure try to use this file:  https://files.fm/u/gb8z44ys

 

Also read this thread:  

Share this post


Link to post
Share on other sites

how to reset the bios setting? when i flash the mod bios ,changed some setting ,and now i can't boot

Share this post


Link to post
Share on other sites
34 minutes ago, szhynet said:

how to reset the bios setting? when i flash the mod bios ,changed some setting ,and now i can't boot

Hi!

Just read my post above.

Share this post


Link to post
Share on other sites

when i successfully flashed modded BIOS, the HDMI port can't output the signal.and when i force-enable the intel HD graphic , system will halt when installing the graphic driver in win10.

Share this post


Link to post
Share on other sites

Im stuck with backing up the BIOS, I keep getting Error 201: [FPTw64.exe] cannot be run on the current platform

Edited by BuckyTM

Share this post


Link to post
Share on other sites

Hello,

 

I can't access the files since I have a new account. Need to update my bios before doing the flash because I'm currently on version 1.5. Could anyone PM me a link to the bios update included in OP's post? Thanks.

Share this post


Link to post
Share on other sites
hello everyone, I can't download the files related to the modified bios for lenovo y400, the links are still active? Thanks

 

I need modded bios to install intel wifi 7260 because my old intel centrino 2200 doesn't work properly and my lenovo y400 won't start because of bios that dosn't recognoize the new card

Share this post


Link to post
Share on other sites

So I ran into an interesting problem...

I did the bios flash on my Y500 and everything went fine. When the flash was complete, I noticed that my laptop was unplugged and plugged it in. When I did, the screen got sort of "tinted" to a blue-ish color. I rebooted the laptop and this blue tint persists on the screen. I have tried re-installing Nvidia display drivers and rolled back my bios to v2.04 again with no luck.

After this, I also can't adjust the screen brightness with the Fn-keys.

 

Any ideas? 

Share this post


Link to post
Share on other sites

Coming to this party extremely late, I have two questions:

1. Are these files still available at all, i.e. will I be able to download without issue them if I pay for the Tier I Elite membership?

2. Is it possible to perform this unlock without windows installed on my machine? Am I correct in understanding that the bios can be backed up and flashed from a bootable removable drive with DOS , and that windows is only required to do the patching, something I presume can be done with a Virtual Machine?

 

Share this post


Link to post
Share on other sites
52 minutes ago, piesang said:

Coming to this party extremely late, I have two questions:

1. Are these files still available at all, i.e. will I be able to download without issue them if I pay for the Tier I Elite membership?

2. Is it possible to perform this unlock without windows installed on my machine? Am I correct in understanding that the bios can be backed up and flashed from a bootable removable drive with DOS , and that windows is only required to do the patching, something I presume can be done with a Virtual Machine?

 

Someone else posted this link previously in this thread: https://www64.zippyshare.com/v/au26DAss/file.html

 

Although if you are on bios v1.5 and need to update to v2.04, you need to find that somewhere else. Can't remember where I got it but you'll find it with some googling.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
40 minutes ago, RickyW said:

Someone else posted this link previously in this thread: https://www64.zippyshare.com/v/au26DAss/file.html

 

Although if you are on bios v1.5 and need to update to v2.04, you need to find that somewhere else. Can't remember where I got it but you'll find it with some googling.

 

Saw that link earlier but was dead somehow, clicked on it now and Walla, managed to download the file!

 

Thank you!

Share this post


Link to post
Share on other sites
6 minutes ago, piesang said:

Looks like v2.04 is still available on Lenovo's website here:

https://support.lenovo.com/gb/en/downloads/ds101628-bios-update-for-windows-8-64-bit-ideapad-y400-y500

 

Unfortunately it looks like it is only possible to install via windows, to answer my own (2nd) question.


Aah bummer. Maybe you could install Windows as a secondary OS?

Share this post


Link to post
Share on other sites
3 minutes ago, RickyW said:

Aah bummer. Maybe you could install Windows as a secondary OS?

 

Yes, it is not an insurmountable problem, think I can probably create a bootable USB Windows drive.

Share this post


Link to post
Share on other sites

 

Alright, finally managed to get it done, everything worked beautifully. The only problem I encountered was with creating the bootable DOS drive as instructed here, encountered some "write protect" error, maybe some compatibility issues with Win 10. Did manage to make a FreeDOS drive with Rufus and flash successfully.

 

Thanks to all involved!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
14 hours ago, piesang said:

 

Alright, finally managed to get it done, everything worked beautifully. The only problem I encountered was with creating the bootable DOS drive as instructed here, encountered some "write protect" error, maybe some compatibility issues with Win 10. Did manage to make a FreeDOS drive with Rufus and flash successfully.

 

Thanks to all involved!

Glad to hear it! I also ran into that write protection issue, used diskpart to remove the "read only" disk attributes of my USB drive.

What Wifi-adapter are you upgrading to?

Share this post


Link to post
Share on other sites
3 hours ago, RickyW said:

What Wifi-adapter are you upgrading to?

 

I installed an Intel 7260 I bought some months ago, naively thinking I can just install it. 

Share this post


Link to post
Share on other sites
1 hour ago, piesang said:

 

I installed an Intel 7260 I bought some months ago, naively thinking I can just install it. 


I did the same, got the AC version from Amazon. Just put it in and Windows recognized it straight away and installed the drivers for it automatically.

Share this post


Link to post
Share on other sites

Also didn't have any issues in Linux Mint, it just worked.

Share this post


Link to post
Share on other sites

Hello,

 

Has anyone found a way to fix the error below without access to File 'Error 104' Fix - v01.zip?  Trying to scan through 101 pages of posts for an answer isn't working.

 

I think I am supposed to edit fparts.txt?

W25Q16BV,    0xEF4015, 0x1000000,  0x1000, 0x20, 64, 0, 0xc7, 80000

to

W25Q16BV,    0xEF4015, 0x1000000,  0x1000, 0x20, 64, 0, 0x60, 80000

 

But what do I do with...

MX25L3205D,  0xC22016, 0x2000000,  0x1000, 0x20, 64, 0, 0x60, 80000

 

 

Intel (R) Flash Programming Tool. Version:  8.0.10.1464
Copyright (c) 2007 - 2012, Intel Corporation. All rights reserved.

Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid

    --- Flash Devices Found ---
    MX25L3205D    ID:0xC22016    Size: 4096KB (32768Kb)
    W25Q16BV    ID:0xEF4015    Size: 2048KB (16384Kb)


Error 104: The 2 SPI flash devices do not have compatible command sets.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.