Jump to content
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

svl7 awesome guide !! cant thank yu enough :):20_003::78:

could yu please tell me wat are the options in the bios tht has to be changed for enabling intel HD 4000 graphics ?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

im a bit confused about the bios versions.... Is v1.5 the same as v1.05 and v1.3 the same as v1.03?

Btw, great job Svl7

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I never called the bios v1.5 or v1.3 as far as I know... in the bios itself it says 1.05v, where did you see 1.5v?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Earlier in the previous thread... I think it was someone else. Anyway, its good to know that there is only v1.0x. It just got me i bit confused..

Thanks

--

What is a whitelist exactly?

Is there any other card you can install thats "within" the whitelist? Or am i getting this all wrong?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Well, there might be a v1.5 bios sometime in the future... I'm not familiar with Lenovo's naming scheme.

Whitelist is the opposite of a blacklist :D In the case of this system it is a list of hardware IDs of wlan cards which are accepted by the bios, if you try to boot the system with a different card it will show an error message at POST and refuse to boot. This mod circumvents this.

Share this post


Link to post
Share on other sites

Okey. Is there an actual list ? I mean is there other wlan card that we know are accepted?

Sorry for all the questions, and thanks

Share this post


Link to post
Share on other sites

Yeah there is, but it shouldn't matter since the check is now removed. All cards should work.

Share this post


Link to post
Share on other sites

@ svl7, I followed your guide and everything went smooth. I also installed a dual band WLAN card which works just fine. Thanx for your work!

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

hello... I try to disperse the lenovo Y 500 GT650 SLI, but clock don't rise. how to correct it? thanks in advance... I am sorry for transfer

Share this post


Link to post
Share on other sites

Just flashed to the unlocked bios. Great instructions, everything went smoothly. Thanks svl7!!!

Share this post


Link to post
Share on other sites

Sir, kindly ask if this will work for v1.04 bios if I flash on top with v1.05 mod bios. TQ sir

attached bios backup for reference.

Sent from my GT-I9300 using Tapatalk 2

LENOVO-6BCN32WW(V1.04).zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Great job svl7! Got my laptop yesterday and installed the modified bios. No problems and i have never done anything like it before.

Share this post


Link to post
Share on other sites
Has anyone tried using the Intel Ultimate N 633ANHMW with the Y500?

No, but it should work because the Intel Centrino Ultimate-N 6300 is a commonly used card. If you want to use 3 instead of 2 connections you should buy an extra antenna.

Share this post


Link to post
Share on other sites

anyone with bios 6BCN32WW v1.04 flash with mod bios v1.05? working?

thks

Share this post


Link to post
Share on other sites
No, but it should work because the Intel Centrino Ultimate-N 6300 is a commonly used card. If you want to use 3 instead of 2 connections you should buy an extra antenna.

Thanks. I didn't realize replacing the adapter was going to be such an involved task.

Share this post


Link to post
Share on other sites
Thanks. I didn't realize replacing the adapter was going to be such an involved task.

It isn't you can also use two connections, or buy the Intel Centrino 6235. I assume you want 5GHz next to the 2,4GHz?

I have a Broadcom dual band card with Bluetooth installed on my Y500.

Share this post


Link to post
Share on other sites
It isn't you can also use two connections, or buy the Intel Centrino 6235. I assume you want 5GHz next to the 2,4GHz?

I have a Broadcom dual band card with Bluetooth installed on my Y500.

Yeah, I want dual band. I frequently move large amounts of data to/from a desktop and I want max throughput. I have no need for Bluetooth, so the lack of it on the 6300 isn't a problem. I'm just not sure if I'm up to the task of installing a third antenna inside the display and whether it's worth the trouble.

Share this post


Link to post
Share on other sites

The touchpad stuff is (in case it's software related) most likely in the EC. This method will only flash the bios, and as described in my guide, it's not necessarily a good idea to flash a modified which is a different version than your current bios, at least not when flashing this way. The EC isn't included and this might cause serious issues.

For going to a newer bios version I highly recommend waiting for an official bios update from Lenovo.

Share this post


Link to post
Share on other sites

Hi,

Can this method be used for IdeaPad Y400 as well? Thanks.

Updated: My Y400 has bios version v1.05 so I use the v1.05 file in the post to mod the bios. The modded bios works like a charm. I can now use Wifi Link 5100 AGN for the 5Ghz band. For those who are skeptical to try because your laptop is Y400 instead of Y500, just go ahead and follow the instruction of svl7 in this thread.

Good luck to all and thank you again svl7 for this great tool/instruction.

Share this post


Link to post
Share on other sites

This has been discussed, it's due to the motherboard design, leaving out the ability to use only the iGPU respectively only the dedicated GPU needs a more sophisticated mobo design, i.e. more expensive. Lenovo didn't put that ability in the Y500.

Share this post


Link to post
Share on other sites

Hi svl7, just wanted to thank you for wirting this tutorial and helping out the community~

Any idea on how to bypass the Error 104: The 2 SPI flash devices do not have compatible command sets?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BAKED
      CHECKING TO SEE WHICH CLEVO MODELS YOU WOULD LIKE ME TO MAKE BIOS MODS FOR.

    • By Klem
      Hi,
      In this thread you can post your requests for AMD-V unlock on ACER E5-553G and same laptops with AMD CPU's, for example Acer Aspire E15, Acer Aspire E5-523G, Acer Aspire E1-522, Acer Aspire E1-420, Acer Aspire E5-421, etc.
       
      Now we can unlock  AMD-V function for virtualization support. In general, this method described in the article on this link: http://www.geektech.co.nz/how-to-unlock-...enovo-y700
      This way requires Windows as a system because  some tool works only in Windows.
       
      Download this tool: https://drive.google.com/file/d/0B4NHIBM...RtQXM/view
      Extract the archive H2OUVE.rar directly on the Desktop and copy the H2OUVE folder directly on the disk C:\
      Then run the Command prompt as Administrator and execute these commands:
      cd  \
       
      cd  H2OUVE
       
      H2OUVE.exe   -gv   vars.txt

      After each command press the Enter button.
      After that, you'll have the file "vars.txt" in H2OUVE folder.
      Post here this file "vars.txt" or upload it to any fileserver and  send me the link.

      For reference, here's the EFI-table with available settings for this notebook: https://drive.google.com/open?id=0B4NHIB...WI4LW14bE0
      And here's the setting that needs to be changed:
      0x1C40B             Setting: SVM support, Variable: 0xEE {05 91 54 02 55 02 54 00 34 12 EE 00 00 10 00 01 00}
      0x1C41C                 Option: Disabled, Value: 0x0 (default) {09 07 27 00 10 00 00}
      0x1C423                 Option: Enabled, Value: 0x1 {09 07 28 00 00 00 01}
    • By dimaginexus
      It's locked & hidden by default, but I've got an i7 8700k & I'd like to use the intel graphic on my hackintosh mojave.
      Is there any way to activate or mod this?
      Thanks!
    • By IAmSteveRogers
      I have been attempting to change my boost clocks values for the longest time, though I've been unsuccessful. I managed to flash my modded BIOS, though no changes seem to have had happened, along with no errors either. Here's all the stuff I used and was able to get. If someone is able to help me with this, it would be greatly appreciated.
    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES with most menus and options unlocked. 
      These BIOS mods are only for advanced users who know what they are doing.
       
      NEW: New versions on all KM and DM series plus new mods for P7XXTM1 and P870TM1
      Mods for more models will be rolling out soon.
       
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
       
      TM, KM AND DM SERIES
       
      P6 AND P4 SERIES
       
      INSTRUCTIONS
        IF YOU LIKE MY WORK BUY ME A COFFEE =>DONATE<= ENJOY!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.