Jump to content
kid_maximus

GTX 675m SLI vs Radeon 6990m Crossfire?

Recommended Posts

Title says it all. i have in front of me a set of 675m's and 6990m's. which would perform better in terms of speed and reliability? don't really care about battery power since i use my laptop on ac power all the time. yes i know the 675m's are rebadged 580m's, got them as cheap as chips so thought they would be of some use in the future.

i have an m18x r2!

any help appreciated :)

Share this post


Link to post
Share on other sites

675M SLI will be better performance than 6990M CF.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Question though...How come ati mobile gpu's have higher wei score compared to Nvidia mobile gpu's when in fact nvidia performs much better but have a lower wei score?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Wei score probably has some polygon/geometry computation aspect to it where AMD is superior, but all in all 675M will perform better in gaming. WEI is also a flawed test.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I would also suggest to go with the 675M SLI. I never had a problem with my 6990M CF setup. Used and abused it. It just seems like Nvidia has a hardier card and better driver support.

Share this post


Link to post
Share on other sites

I also have a 6990 CF setup and would also recommend you join the green team.

I have had many issues trying to setup games to not have framerate issues. Currently I can't play Aliens: Colonial Marines without the games frame rates dropping when you shoot.

To save your hair go green :)

I am going to upgrade to the Clevo 680 soon

Share this post


Link to post
Share on other sites

I have a 675m SLI setup and can honestly say I have no complaints haha. I have played many games and have found nothing to trip these up at all.

I would guess that they may generate a little more heat then a 6990m cf setup due to the higher clockrate but nothing alarming.

If you were considering overclocking I know my 675's overclock fairly well but never had the chance to play with Radeon cards but ive herd there similar to the processors meaning they overclock with ease.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By GrisGris
      For when that rubber coating on your laptop phase shifts to fly paper...
       
      Here is what I did,
       
      Disassemble M18x:
      Well documented by debaucher:
      The palm rest section was the biggest offender for me;

      >I used a plastic spoon and nail polish remover to remove the rubber coating:
      >Obviously remove as many of the various utility boards as possible.
      >I left the touch pad in place because this model used thermally fused plastic rivet like pieces to hold the light pipes in place and I found it easier to mask it off.
      >"FrogTape Delicate Surface" worked very well for masking off various surfaces

      >I used Krylon Plastic Paint as a base coat and 'Jet Black metal flake Automotive Paint;

      >With the paint still setting up I dusted various glow powders over the substrate and dusted some additional black paint to achieve some depth to the effect .
      >I after the automotive paint set up I use mate clear coat the overcoat the entire surface. I personally believe glossy clear coat would not look as good. 
      >Adjust as needed and re-assemble.

      >I Used a USB LED clamp light available ebay/amazon $10 to illuminate
       
      Hope you enjoyed the first post...
      .
    • By p1npo1nt
      I'm going to be upgrading my Alienware M18x R1 with a GTX770m I purchased from ebay; 770m has a Dell P/N: HW6C9 for reference. I have a couple questions about performing this upgrade:

      -Is the /unlocked/ version A05 bios necessary? I am receiving 8 beeps on startup with the dell factory A05 bios installed w/ the 770m
      -Is a vBIOS flash required for basic functionality and driver installs? 
      -If so, is there a link to a compatible vBIOS for this card, finally, a guide for installing the new vbios?

      Any help is vastly appreciated, I've done some homework but I am new to upgrading MXM modules on laptops. 
    • By ivm
      Hi.
      Many of us are discontent that we can't freely swap dell and clevo AMD cards (7970m  and new rx480 included) but it seems that I may have found some clue to this problem.
      Few years ago I bought a broken p170em with some ugly black 6990m. It looked like it was baked in the oven with some cookies.
      I put it in my p150em and it was working normally with all sensors, data, etc. No beeping, no turning off.
      What I noticed was that the other soic8 chip "2" (apl-something) was swapped as well as the main bios chip "1".
      No other components were swapped and, as you know, if you just flash the main chip it won't save you from beeping.
      Unfortunately I sold this card as it wasn't powerful enough for me, but now I've ordered a rx480 that I can currently use only in my gt70 and  I think it gives me some clues how to put this thing into a clevo laptop.
      Does anyone have any Idea what that APL-somehing chip is and does it have its own firmware?




    • By Tristan0123
      So I have an old Alienware m18x R1 that I upgraded this past Sept. It shipped with nvidia 460m in sli and I ended up putting in a single 780m  I ended up getting everything swapped out and up and running after reading alot of post on this forum . Most of the old games I regularly play ran smooth enough but everything newer seemed to have a have a hard time running smoothly. first i though it was overheating but no temps are normal. Then I noticed that my gpu is throttling. At this point I had some new drivers, that I found ran pretty stable. Came across this thread 
        So I did as instructed and wiped the newer drivers in safe mode and loaded out some old ones suggest in the linked thread above.
      My problem currently is that throttling is still taking place. I am pretty sure I know what I need to do. When I upgraded the hardware I had trouble finding an unlocked bios for my m18x r1. I know there is a TechInferno link to download one but my account does not let me.  So I found a A05 version that was not unlocked but was still able to support the new card.  So I am attempting to find a unlocked version of the A05 driver so I can attempt to follow the instructions here http://forum.notebookreview.com/threads/alienware-m18x-r2-with-980m-possible-throttling-fix.791358/  and change some of the setting in the bios.  I have a feeling this may work but I am currently stuck as I am apparently not able to download anything from this site. 
       
      I am far from an expert on such so if anyone out there reads this let me know if you can help a fellow out or maybe point me in the right direction. Thank you for taking the time to read this.
    • By zaxx7
      This is my first post and I'd appreciate any help you guys can offer. 
       
      I've been using my AW M18x r1 since I bought it new. 
       
      Basics:
      I7 2760qm sandybridge
      Bios A5
      16 gb ram
      Radeon 6990m 2gb 
       
      I used to run 2 6990m's, but the primary died 3 yrs ago and I replaced it with the secondary card. Been working great until this week. 
       
      I'm using hwinfo64 for fan monitoring. 
       
      I started having lock-ups to black screen, grey screen or black with white vertical lines. I noticed my shader temp on my GPU was running out of control whenever I start  game or even run a video. The other temps seem to be in the normal range. The shader will jump from 39 C to 70 C almost immediately and then upwards from there. Over 100 C when I 1st caught it. I assume it's thermal shutdown. 
       
      I'm using the legacy driver for my card 15.7.1. 
       
      I'm willing to buy a new card, I'm looking at a 780m, but I want to figure out if it's just an issue with the card. 
       
      Any suggestions on testing for other issues? Why would it be the shader only, or is that just an issue with Hwinfo64? 
       
      Thanks in advance. 
       
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.