Jump to content
zizzzac

Which SSD fit the best for m14 r1??

Recommended Posts

i suggest Samsung 840 msata 120g it isvery good and score it high but i used Intel 525 60g it no problem and 12seconds to start windows

Share this post


Link to post
Share on other sites

As many have already said, i recommend the Samsung 840 as well. Direct replacement. It has been running great too.

Share this post


Link to post
Share on other sites

Hi guys I've decided that it's time to upgrade my R1 after owning it for a couple of years. Based on your replies Ill probably get a Samsung. I was wondering if I could use my original HD (500gb 7200rpm) as an external drive since I have no working desktop at the moment. Thanks!

Share this post


Link to post
Share on other sites

Using a samsung 840 here as well and have encountered no problems. As for using your current HDD as an external you will need a sata to ide set. Multiple tutorials on this are available on the web.

Share this post


Link to post
Share on other sites

I just installed a Samsung 840 EVO 250gb. Runs great so far, no problems yet. Plus i think the 840 EVO is the best choice, if you want to use the A08 BIOS fix, didnt hear of any problems with it until now.

Share this post


Link to post
Share on other sites
Using a samsung 840 here as well and have encountered no problems. As for using your current HDD as an external you will need a sata to ide set. Multiple tutorials on this are available on the web.

Thanks man. Yeah i did some searching while my post wasn't approved yet. I found that HD to USB enclosures usually have that sata to ide thingy. I'll just get one along with the SSD.

Btw if you guys have step by step install instructions for SSD please do post them. ( can't find one).

And please include the windows install part using a CD or USB. My laptop can't detect the optical drive at the moment.

Hope I can upgrade before Christmas. I'll keep you guys posted.

Share this post


Link to post
Share on other sites

I'm running Samsung EVO 840 500 Gb with no problems for 3 months whatsoever. Boots usually < 10 seconds and haven't had any stability issues, also very fast. Definitely recommend.

Share this post


Link to post
Share on other sites
I'm running Samsung EVO 840 500 Gb with no problems for 3 months whatsoever. Boots usually < 10 seconds and haven't had any stability issues, also very fast. Definitely recommend.

Which BIOS are you using? and can you please give benchmarks on random read and write speeds.

Share this post


Link to post
Share on other sites

Anyone using 850 series from Samsung evo or pro for M14xr1? Since now 840 is hard to find and replacing by 850

Share this post


Link to post
Share on other sites
I've just installed a 840 Pro in my m14x R1 works great and has no issue's so far, Runs at sata 2 speeds but i'm yet to try the bios fix, hoping i can get it up to full speed with that. I've got my ssd in the primary bay and a hdd in place of the dvd drive was a simple process. alienware laptops are great to work with in my opinion.

i used Samsung 840 Pro too and runs at sata 2 speeds, do you know how to make it run on sata 3? there are BIOS FIX in the forum, but i can't download it. :(

Share this post


Link to post
Share on other sites
i used Samsung 840 Pro too and runs at sata 2 speeds, do you know how to make it run on sata 3? there are BIOS FIX in the forum, but i can't download it. :(

I used the Bios Fix in the forum, you will need to meet the requirements to download its a bit of a pain

Share this post


Link to post
Share on other sites

Bought the 850 Pro 256GB for my M14x R1 and it works like a charm. But haven't bench-marked it to verify the speeds but I have flashed the SATA fix A08 bios and boot up takes less than 20 seconds. Pretty happy with it.

post-5959-14495000630377_thumb.jpg

Share this post


Link to post
Share on other sites
Bought the 850 Pro 256GB for my M14x R1 and it works like a charm. But haven't bench-marked it to verify the speeds but I have flashed the SATA fix A08 bios and boot up takes less than 20 seconds. Pretty happy with it.

Hey llcooljerry! Since the ssd upgrade, are you experiencing any issues? I'd like to get the same ssd for my m14. Thanks!

Share this post


Link to post
Share on other sites

I just installed the SanDisk Ultra II SSD 960GB in my m14x R1 and wow is it flying.  I did a fresh install of Windows 10 to get the most out of the performance.  Very happy with the drive and can boot up in 20 seconds.  Haven't yet installed the AO8 fix yet to get the SATA III speeds.

Share this post


Link to post
Share on other sites

the R1 chips is to old,so,buy a cheap and big ssd is the best choice,like some ssd base on  TLC flash .

enough is good.

Share this post


Link to post
Share on other sites

Curious as to whether you guys used the AO8 SATA III fix or not after installing the SSDs or would it just be fine using the stock AO8 from Dell.

Share this post


Link to post
Share on other sites

I'm currently using Crucial MX300 525GB on my Alienware M14X R1. Supposed to get a Samsung 850 Evo but it was too expensive in my country. Took less than 20 secs to boot up to Windows and definitely worth upgrading. The only downside is that it is running SATA2 only as BIOS is capping the speed.

Share this post


Link to post
Share on other sites

not sure on the 850 pro but the 860 evo works fine just need to get the sata bios upgrade for A08

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.