Jump to content
EwinRacing Flash Series Gaming Chairs
Tomá

Lenovo Y500 unlocked bios?

Recommended Posts

Can anyone unlock bios for this briliant model?And i have question about mod GT650M with DRR5 memory, is that same chip like in GTX660, so can we load GTX660 vbios do this GT650m?Thx for answers.

Share this post


Link to post
Share on other sites

First of all Hi @all

i just wanted to push this thred because I think this Y500 is a pretty nice Powerhouse an needs to get unchained :-)

I own this Laptop now for about 6 hours and I'm quite upset about the built in Centrino 2230 WiFi Card.

Unfortunately Lenovo keeps on locking their Bios and treating us with a Hardware Whitelist.

So as you can See, I'm absolutely new in here and I really hope that a couple of you guys know how to deal with it.

MY System is a y500 with following specs:

Win 8

Intel Core i7-3630QM

16GB RAM 2x8GB

16GB mSATA SSD Cache

1TB HDD

2x GT650m 2048MB GDDR5

I have dumped the Bios via Universal Bios Backup Tool 2.0

Edit: Almost forgotten :-) It is an InsydeH20 Bios

So Is it possible to delete the Whitelist and Unlock the Bios?

Is there an Entry wich has disabled the CPU Integrated Intel HD4000 GPU?

So, that's it at the moment and I hope It will be as easy as it actually is for the Y580.

Thank you all in advanced.

Frost-dc

Share this post


Link to post
Share on other sites

2x 650m?

Anyway, this should do the trick, provided we can flash it. Use this tool and flash with this command:

fptw64 -f LENOVO-6BCN34WW(V1.05).rom -bios

Share this post


Link to post
Share on other sites
2x 650m?

Latest and greatest in Lenovo's full size laptop toys. You can SLI an additional 650m in the ultrabay. I'm not sure what all you can get in the ultrabay besides the Blu-ray drive or the 650m. Laptop has few issues though including trouble with Widi as I think the laptops integrated intel hd 4000 mistakenly is disabled. No hd 4000 no widi apparently. Also god have mercy on the elan touchpads that curser jumps all over the screen.

Share this post


Link to post
Share on other sites

I actually ran into the same error as EN-TACT did (Post #174 http://forum.techinferno.com/lenovo-ibm/2260-lenovo-y580-y480-unlocked-bios-versions-18.html)

Error 28: Protected Range Registers are currently set by BIOS, preventing flash access.

Please contact the target system BIOS vendor for an option to disable Protected Range Registers.

So, any chance to deal with it?

Frost-dc

Share this post


Link to post
Share on other sites
Latest and greatest in Lenovo's full size laptop toys. You can SLI an additional 650m in the ultrabay. I'm not sure what all you can get in the ultrabay besides the Blu-ray drive or the 650m.

Oh, sounds pretty cool.

I actually ran into the same error as EN-TACT did (Post #174 http://forum.techinferno.com/lenovo-ibm/2260-lenovo-y580-y480-unlocked-bios-versions-18.html)

Error 28: Protected Range Registers are currently set by BIOS, preventing flash access.

Please contact the target system BIOS vendor for an option to disable Protected Range Registers.

So, any chance to deal with it?

Frost-dc

Yes, totally. If you let me temper with your system per team viewer that is. PM me if interested.

Share this post


Link to post
Share on other sites

Oh my goodness!

SVL7 really is the Man!!!

Now my Bios is unlocked.

Can't check the status of the whitelist, but my ne WiFi Card is already ordered.

Thank you very much!

I'll let you Guys know if my new Card is inside, and if it works / how it works.

Thx alot.

Frost-dc

Share this post


Link to post
Share on other sites

Cool. Just don't change any setting you're not familiar with, some might not work on your system.

Share this post


Link to post
Share on other sites

Do you know if you enable the Intel HD4000 through the unlocked BIOS? Ive heard the Y500 only runs on the GT650M that's why your battery life is less than the Y580 with the similar specs.

- - - Updated - - -

Do you know if you can enable the Intel HD4000 through the unlocked BIOS?

Share this post


Link to post
Share on other sites

I don't think it's that simple.

But to answer your question: By default it's set to "Auto-Selected".

But there are severeal entries in that specific sub-menu.

I took some Photos, so you can take a look by yourself. (bad quality, but should work)

post-9063-14494994171468_thumb.jpg

If you have any questions, feel free to ask.

(Take a look in the upper right corner :-) )

Frost-dc

post-9063-14494994165398_thumb.jpg

post-9063-14494994166564_thumb.jpg

post-9063-14494994167591_thumb.jpg

post-9063-14494994168828_thumb.jpg

post-9063-14494994169806_thumb.jpg

post-9063-14494994170369_thumb.jpg

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

am so glad I found a thread that kinda gives hope in enabling HD4000 issue, frost-dc were you able to enable HD4000 since I am a very new user and apparently I cannot see the pics nor download the modded bios version. is it safe to flash to this bios?, my bios version is 1.03 and I couldn`t find a link where I can update bios from lenovo website. I havn`t upgraded to sli yet so it would be a real treat if I could get the power efficiency of HD4000

Share this post


Link to post
Share on other sites

the unlocking of the HD 4000 and getting WiDi to work on the y500 is a hot topic over in the Lenovo forum. Lenovo has formally admitted that all y500 units with a manuf date prior to 11/28/12 have a touchpad issue "

After careful investigation, Lenovo has determined that a portion of Y500 systems with Elantech touchpads manufactured in November prior to 11/28/2012 could exhibit abnormal touchpad response characteristics. This is isolated to the Elantech touchpad assembly on these systems. Y500 systems manufactured after this date should not be affected.

Customers who experience these symptoms should contact Lenovo technical support for service to replace the touchpad assembly. This should be done after ruling out other potential causes such as incorrect drivers or conflicts with other attached pointing devices. We are in process of checking / updating service part stock to ensure that repairs would be completed with the latest level parts."

I have an Elan touchpad and was thinking of jumping ship with this puppy and going with the y580 instead, but then i ran into a whole thread on the problems with the graphics card while gaming in the current shipments. The y500 has so much potential. WiDi would be great. I don't plan on putting another graphics card in it and was wondering if that would make it possible for me to enable the HD 4000, add WiDi. I just need them to fix the touchpad issue first, but can't do it til after i use it for work purposes after surgery thru mid Feb. i guess by then the touchpad replacement issues will be better and maybe WiDi will be possible.

Share this post


Link to post
Share on other sites

thanks to these thread, now we have a chance to enable HD4000 and getting WiDi to work

my bios version is 1.03 same as eaglespeed.

luckily, my y500 touchpad work perfectly

Share this post


Link to post
Share on other sites
am so glad I found a thread that kinda gives hope in enabling HD4000 issue, frost-dc were you able to enable HD4000 since I am a very new user and apparently I cannot see the pics nor download the modded bios version. is it safe to flash to this bios?, my bios version is 1.03 and I couldn`t find a link where I can update bios from lenovo website. I havn`t upgraded to sli yet so it would be a real treat if I could get the power efficiency of HD4000

Well, in case that I don't know nothing about the consequences/errors that my occur, I would prefer not to play around with enabling the HD4000 explicit.

I should discuss that with svl7 for example, maybe he knows if it is safe to do so or eventually how to roll back if something goes wrong.

@svl7: Just give me a hook if you have any idea or a solution in mind.

But I tried something else.

It is absolutely no Problem to place a DVD/BD Drive into the Ultrabay Slot.

I've tested it with, an of course 9,5 mm, slim DVD Drive from my Company Laptop Dell Latitude E6520. - worked as expected.

So what I need actually, is a replacement Bezel for a Y500 DVD/BD Drive, but it seems that there is nothing available yet.

Frost-dc

Share this post


Link to post
Share on other sites

I'm pretty sure that setting the primary display to "PCI" will result in a non-booting system. 'PEG' should refer to PCI express graphics if I remember correctly, so this should set your system to use the 650m only. However... I can't tell whether this will cause problems as well. "SG" is switchable graphics if I'm not mistaken. Maybe an Alienware user with a more or less current system can give some more insights here (@Brian, @Michael,@whoever with a similar bios, lol)

Share this post


Link to post
Share on other sites

We're looking for an explanation regarding the graphics settings in the bios, to be precise the differences between SG, PEG and Auto. Thought there was something similar in the M18x.

Share this post


Link to post
Share on other sites

Wow, great thread. I am running 1.03, any chance 1.05 will work on my system? Also, what do I use to flash the bios? I'm not up to 5 posts yet so I can't see the pictures and download the bios.

Share this post


Link to post
Share on other sites
We're looking for an explanation regarding the graphics settings in the bios, to be precise the differences between SG, PEG and Auto. Thought there was something similar in the M18x.

All i know is that SG means Switchable Graphics, while PEG goes for dedicated Graphics. I guess each manufacturer implements the logic behind those choices differently though.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi folks, first timer. Definitely looking forward to some progress on this. Picked up a Y500 recently and popped in a Samsung 840 250GB SSD and switched back to Windows 7. Really hoping to get the HD4000 going to save on battery life - especially since I've got the 1080p screen. Then the last thing would be some news on the Ultrabay so I can get the original 1TB HDD in there for storage, but that's a different matter. Subscribed!

Share this post


Link to post
Share on other sites
thanks to these thread, now we have a chance to enable HD4000 and getting WiDi to work

my bios version is 1.03 same as eaglespeed.

luckily, my y500 touchpad work perfectly

me to I have no touchpad issue what so ever, except the the two finger tap right menu doesn`t work, but its no big deal, besides its much easier to navigate with a mouse attached. so you guys are saying that HD4000 can be enabled visa this bios version? I will try to download it again now.

Share this post


Link to post
Share on other sites
me to I have no touchpad issue what so ever, except the the two finger tap right menu doesn`t work, but its no big deal, besides its much easier to navigate with a mouse attached. so you guys are saying that HD4000 can be enabled visa this bios version? I will try to download it again now.

Did your Y500 come with the Elan touchpad or the Synaptics?

Share this post


Link to post
Share on other sites

Please discuss the touchpad issue on a separate thread.

Share this post


Link to post
Share on other sites

Glad to see that this has been made! What did you do to get past that flashing error?

Share this post


Link to post
Share on other sites

So I am currently on the original bios that came with the laptop 6BCN31WW(V1.03) and I'm working up the courage to flash it to Frost-dc's V1.05. Most likely I won't brick my machine doing this right? I mean the only thing different between the machines is that I have the Elan touchpad and he has the Synaptics. Just wanted to raise this question before I proceed.

Frost-dc, have you played around with the graphic settings yet? One of the Lenovo guys (Mark) is saying in the support forum that the Y500 is discrete video only so WiDi and Optimus is unsupported. It might be more complicated than just a couple of bios settings. My wish was to be able to run Optimus while traveling and when I get home, I can slap in the other 650m and run sLI. This doesn't seem like it will become a reality. Good part is, the battery life is still pretty good. I got The Campaign and most of the Bourne Legacy out of it on the plane. Literally died at the very end of Bourne Legacy which kind of sucked because it was a long flight and the suspense was killing me. I figure I'll buy an extra battery so that doesn't happen again, just need to find a cheap one on eBay because this thing is so new, all my searches are coming up for the 3000 Y500 and not the Ideapad Y500.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.