Jump to content

Recommended Posts

Also, I'm a little stumped at the moment. I bought an esata power to sata connector for the purpose of booting off from my 3.5 sata hdd. However, interrupted boot, BIOS cannot find the HDD, nor does Windows 10 or Mac OS Sierra (I'm on dual boot win10 and macOS). 

 

Is our elitebook providing power on its esata? There is a guide here about booting off of esata and he seemed to be able to boot (or at least made the bios detect his hdd) just by using that special cable. Mine just doesn't work. Any ideas why?

Share this post


Link to post
Share on other sites
6 hours ago, Onoakino said:

Also, I'm a little stumped at the moment. I bought an esata power to sata connector for the purpose of booting off from my 3.5 sata hdd. However, interrupted boot, BIOS cannot find the HDD, nor does Windows 10 or Mac OS Sierra (I'm on dual boot win10 and macOS). 

 

Is our elitebook providing power on its esata? There is a guide here about booting off of esata and he seemed to be able to boot (or at least made the bios detect his hdd) just by using that special cable. Mine just doesn't work. Any ideas why?

Not enough power. 3.5 HDD need 12v. esata generate 5v for 2.5 HDD

Share this post


Link to post
Share on other sites

Just googled the pictures of your thing, I would not  be at all surprise that there exist the same adapter with an external power source, do your homework

Share this post


Link to post
Share on other sites

@Onoakino Sorry, I wasn't here long time. I just want notice that the stock bluetooth socket isn't in white list in bios.                                     
                                       

Share this post


Link to post
Share on other sites

Hi, I recently updated my hp-2570p hackintosh to MacOSX High Sierra (legally in my country, as I own an older macMINI that I took the original system from).

 

In the last 2 years it ran beautifully with an i7-3740qm cpu, but with the new OS (10.13.6 instead of 10.11.6) the "context menu key" on its windows keyboard is no longer recognised.

I used to put a lot of useful shortcuts on this key, but now there is NO reaction to its pressing – or rather: ONLY when the left fn-key is pressed PREVIOUSLY is it recognised as right_alt / 0xe6  (by Karabiner's event viewer).

 

Anybody had a similar experience or KNOWS how this can be "turned back" ? Maybe some kext-issue (still the old one) ?

 

Thanks … hopefully

Edited by DANTech
typo.

Share this post


Link to post
Share on other sites
21 hours ago, DANTech said:

Anybody had a similar experience or KNOWS how this can be "turned back" ? Maybe some kext-issue (still the old one) ?

I had the same problem. But I do not remember the solution. Most likely - remove some kexts. And of course all kexts must be the latest version.

 

It's my kexts list:

 

ACPIBatteryManager.kext

AppleALC.kext

BrcmFirmwareData.kext

BrcmPatchRAM2.kext

FakePCIID.kext

FakeSMC.kext

HSSDBlockStorage.kext

IntelGraphicsFixup.kext

IntelMausiEthernet.kext

JMB38X.kext

Lilu.kext

VoodooPS2Controller.kext

Share this post


Link to post
Share on other sites
On 9/24/2018 at 6:55 PM, DANTech said:

Hi, I recently updated my hp-2570p hackintosh to MacOSX High Sierra (legally in my country, as I own an older macMINI that I took the original system from).

 

Anybody had a similar experience or KNOWS how this can be "turned back" ? Maybe some kext-issue (still the old one) ?

 

Thanks … hopefully

 

LOL! No such thing as hackintosh being legal (not in any country). And if I'm not mistaken it's 1 OSX 'license' per machine. To make it more legal? You can purchase another  https://www.apple.com/shop/product/MC573Z/A/mac-os-x-106-snow-leopard ... still makes its greyzone. But at least we would be supporting Apple just a little bit more. ;-)

 

Pertaining your Hackintosh problems. For support on separate kexts -- if you build it from scratch yourself -- I've had the best support at https://osxlatitude.com/forums/ or just use the kexts of Rehabman's repo's. You can find all the links or entire bootback script at https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.232948/ which works for 10.14 Mojave too btw without using the beta repo; although that could be an avenue you like to explore.

 

Note: and while on the matter of kexts. For a fully working SD(HC) card slot in 10.13.x ? Checkout this kext: https://www.insanelymac.com/forum/topic/321080-sineteks-driver-for-realtek-rtsx-sdhc-card-readers/ 

Edited by Rhyker2U
typo's and other useful aditions

Share this post


Link to post
Share on other sites

I'm still on Sierra 10.12.6. I want Mojave but I have to read more and hear more people who have 2570p reporting they have working Mojave on their machines.

 

I'm trying to solve the reboot issue (laptop would restars instead of shutdown) on Sierra after bridged the wlan usb to usb dock. 

 

Good to know hackintoshers are alive in this thread. :)

Share this post


Link to post
Share on other sites
On 27.9.2018 at 10:45 AM, Rhyker2U said:

Pertaining your Hackintosh problems. For support on separate kexts -- if you build it from scratch yourself -- I've had the best support at https://osxlatitude.com/forums/ or just use the kexts of Rehabman's repo's. You can find all the links or entire bootback script at https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.232948/ which works for 10.14 Mojave too btw without using the beta repo; although that could be an avenue you like to explore.

 

Note: and while on the matter of kexts. For a fully working SD(HC) card slot in 10.13.x ? Checkout this kext: https://www.insanelymac.com/forum/topic/321080-sineteks-driver-for-realtek-rtsx-sdhc-card-readers/ 

Hi Rhyker, nice to hear of such high (above others') ethical and moral standards ;-)

Congratulations.

 

"Pertaining" your (OWN - ?!? … => double morale?) Hackintosh problems:

I've had the best support results from googling, thinking and DIY/M (myself).

 

So, my problem was solved by reverting to Voodoo's predecessor ApplePS2SmartTouchPad.kext.

It seems that Voodoo's info.plist contains an item "HPQOEM" with some hp-probook-specific values that simply don't match and won't work with my EliteBook-2570p – but, I suspect, keep it from using "Default" settings... bad luck.

 

Re-installing ApplePS2SmartTouchPad made my keyboard accessible by Karabiner Elements again, with these settings:

ApplePS2SmartTouchPad.kext > PlugIns > ApplePS2SKeyboard.kext > info.plist
  :
CFBundleVersion		<string>	4.6.5
  :
v IOKitPersonalities
	v ApplePS2Keyboard
		:
		v Preferences
			:
		  Make context menu key into key   <integer>	16
			:
		ProductID		<integer>		65535
		Use ISO Layout		<boolean>		false	[for European keyboards: use "true"!]
		VendorID		<integer>		1452
  	:

Now the MENU key is recognised as "scan_previous_track", quite nonsensically, but thus can be twitched to some more meaningful task.

 

[ P.s.: I got it running with VoodooPS2Controller, too, but then the MENU key was chained to being a "context menu" or right mouse button. Arghhhhh !!! ]

Edited by DANTech

Share this post


Link to post
Share on other sites

hi, is there any way I can allocate less memory to hd 4000 video card? It get's like 2 Gb but uses only about 400 max. Didn't find such an option in bios.

Share this post


Link to post
Share on other sites

hi,

 

very nice and interesting forum with a lot of good information. I am interested in using my 2570p with an external graphic accelerator, instead I was looking at this 

https://***********/forums/thunderbolt-enclosures/aorus-gaming-box-what-gpus-do-work-and-which-ones-do-not/

Will this run on mine hp?? :frantics:

Share this post


Link to post
Share on other sites
1 hour ago, stoyancho said:

hi,

 

very nice and interesting forum with a lot of good information. I am interested in using my 2570p with an external graphic accelerator, instead I was looking at this 


https://***********/forums/thunderbolt-enclosures/aorus-gaming-box-what-gpus-do-work-and-which-ones-do-not/

Will this run on mine hp?? :frantics:

Of course not. Old laptop doesn't have thunderbolt. But you can use EXP GDC BEAST

DSC_0007.JPG

Share this post


Link to post
Share on other sites
13 hours ago, Phobosse said:

Of course not. Old laptop doesn't have thunderbolt. But you can use EXP GDC BEAST

DSC_0007.JPG

 

Share this post


Link to post
Share on other sites

Please explain.

 

With EXP GDC BEAST i will add external videocard. Will i see everything on my 2570 display or i will have to add external monitor for this?

 

On which chipsets in general it works?

 

Thanks.

Share this post


Link to post
Share on other sites

Does this laptop supports DDR3 1.5V with default bios? I want to order 2x8gb DDR3 1.5V from Elpida (ebj81ug8bbu0-gn-f)

Share this post


Link to post
Share on other sites

supports. myine was with 1,5 and later i bought low v sodimms. they worked together norm.

Share this post


Link to post
Share on other sites
On 10/14/2018 at 1:50 PM, Classique said:

Please explain.

 

With EXP GDC BEAST i will add external videocard. Will i see everything on my 2570 display or i will have to add external monitor for this?

 

On which chipsets in general it works?

 

Thanks.

I tried three video cards: rx580, gtx 760 and gtx 1060. gtx 1060 only can work with internal display, but on internal display performance ruduced by ~25-30

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By Iwillsolo
      Hello guys ...

      i wanna make sure that everything is going to work fine with my laptop so i got some questions

      First of all my laptop is Lenovo Z51-70
      CPU: I5-5200U 2.2ghz
      iGPU Intel HD 5500
      dGPU:AMD R9 M375
      Ram: 8GB (will raise it to 16GB)
      HDD: 1TB stock one
      SSD: 120GB (for my games and windows only)

      now i investigated  a little about eGPUs and found that i need a M.2 or thunderbolt, i've found that my wifi card use a M.2 a/e key aka ngff, so i will be using the GDC Beast NGFF version

      to the bad part / question part

      What do i need to know other than the stuff above?
      what is the white-listing thing? i found on support forums that my laptop support some wifi cards only and it's bios cann't be modified according to bios modifying forums (not here)
      in same time saw some posts on reddit that says if ur bios have UMA graphic option then you will need to disable PAX / WIRELESS and enable UMA and it will work fine, the question is that true?

      i wasn't able to find anyone who did it on Z51-70 i found only 1 post on reddit for Z41-70 (which after research found that both are using same M.2 a/e key slot and also same bios... but the one who posted only replied that it's recognized with some errors and never replied back with any updates so still not sure about it.....

       
    • By Bullfrog098
      Hi, just a quick question what would be the best EGPU adapter, because i see the really expensive ones but then you have the 400$ dollar one that Lowspecgamer used. Which do you guys recommend ?
    • By zepvalue
      Hello guys,
      Thanks for this incredible forum, I hope I will learn a lot from the gurus ! 

      I am trying to make my eGpu MSI GT X970 work on my laptop   with K1100M integrated GPU. 
       
      This are my specs:
      CPU: 2.7GHz Intel Core i7-4800MQ (quad-core, 6MB cache, up to 3.7GHz with Turbo Boost) PSU : ??? Graphics: NVIDIA Quadro K1100M / Intel HD Graphics 4600 RAM: 32 GB Storage: 1TB

      I got a V8.0 EXP GDC Laptop External Independent Video Card Dock  with the express card version ( I am not really hw savy) and I am looking for a good psu to power my MSI GTX 970 4G  
      Could you kindly suggest a good PSU that i could use to power this GPU ? I am also willing to do as many experiments needed
       
      Thanks for reading my post
      -zepvalue
       
       
       
    • By egovanno
      Hello everyone.
       
      I put on a eGpu setup after quite a bit struggle 2 years ago and I used play games just fine. After a while I sold my graphics card gtx 970.
      Now since 2 days I am trying to put the eGpu setup back again this time with a Gtx 770.
      I couldn't understand the problem. I can shut my dGpu off with diy 1.30 setup. ( usb booted)
      And my laptop sees  gtx 770 along with my igpu Intel HD graphics 4000.
      After driver installation when I try to play a game laptop is tring to use iGpu instead of Egpu. (tried to delete and install driver few times)
      With MSI afterburner I can see  eGpu is  %0 all the time.
      Can it be power problem cause graphic cards fans ( Msi gtx 770 twinfrost ) are working all the time they dont stop.
      Or what else can it be. 
      Thx.
       
       

    • By High_Voltage
      In case you own a Lenovo Y410p or Y510p laptop, you might be interested in upgrading its performance by installing an external graphics card. Ultrabay eGPU adapter designed by @gerald was proven to be a convenient plug-and-play option to do exactly that. However, for a long time only an AMD-branded GPUs could be used due to limitations in the Lenovo's stock BIOS. The purpose of the modified firmware presented here is to expand the range of available GPUs by enabling Nvidia support on Gerald's Ultrabay eGPU adapter.
       
      Huge thanks to:
      @MWichni - For efficiently assisting me during the development of this mod. By flashing dozens of BIOS builds over the course of several weeks and thoroughly describing the effects observed (or the lack thereof), he enabled me to fully understand necessary parts in BIOS structure and come up with a final solution. @svl7 - Whose unlocked BIOS / Whitelist mod has served as a basis for this modification. His discovery of a security hole in V2.07 BIOS has provided us with a convenient BIOS flashing method that does not require a physical programmer. The Unlocked BIOS and WLAN whitelist mods originally designed by him are also implemented in this BIOS mod. @gerald - For designing the aforementioned adapter. Without it, all this work would make very little sense.  
      Key features:
      Resolves the "40-second reboot" issue normally encountered while using Nvidia graphics cards with Ultrabay eGPU adapter, thus allowing all Nvidia cards to be used. Based on the latest V3.08 BIOS. Includes Svl7's WLAN whitelist removal mod - for the convenience of aftermarket WLAN card users. Includes Svl7's BIOS debug menu mod - for the ease of experimentation with newly available features, e.g. attempting to use Nvidia Optimus to pass eGPU video back to laptop's display.  
      NB! Svl7's Debug Menu is not a toy! It contains a lot of options that are either not supported or partially supported by the hardware platform and/or can disturb its normal operation or prevent the PC from booting up at all. Any of the entries not originally present in the stock BIOS should be modified at your own risk!
       
      DISCLAIMER:
      ANY MODIFICATIONS YOU ARE APPLYING TO YOUR HARDWARE ARE PERFORMED AT YOUR OWN RISK! AUTHOR OF THIS MOD DOES NOT HOLD ANY LIABILITY FOR LOSS OR DAMAGE RELATED TO USING THIS SOFTWARE.
       
      Screenshots:
       
      Installation instructions:
       
      If things don't go right:
       
      Error 43:
      If you intend using the GTX10XX-series Nvidia card as the eGPU (which you probably do), you are very likely to encounter the infamous Error 43 in Windows Device Manager. This is a widely known issue in the eGPU community and is not related to this particular mod in any way. Following this guide thoroughly will in most cases resolve the Error 43 issue.
       
      Download:
      Get your copy here!
       
      P.S.:
      Version of this mod for Lenovo Y400/Y500 models is coming soon!
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.