Jump to content

Recommended Posts

INFO: 2570P WWAN/WIFI/Bluetooth whitelist

I dug out my ES 6235 and did some tests. The laptop booted into Windows without issue, it just had to install the 6235 specific drivers. The BIOS doesn't give any hassle or show any nag screens like if you had a non-whitelisted device. Here's some screenshots:

post-8761-14494996210905_thumb.png

I'm not sure why this one works vs a regular 6235, as the vendor and HW IDs are the same as a regular 6235 (at least what I could find on the internet) and are not on the whitelist. Maybe an upgrade path for people who want new wifi cards. There's Intel 7260 cards on ebay for 17.80 US, maybe worth a gamble for someone. Worst case, throw it in your desktop with an adapter.

Intel 7260 HMWBNWB 802 11n PCI Express Bluetooth 4 0 Wi Fi Bluetooth Combo | eBay

- - - Updated - - -

Strong speculation: the WWAN slot can be WWAN+mPCIe with soldered resistors

This whitelisted device is a combo IEEE 802.16e WiMAX and 802.11 b/g/n WiFi wireless adapter which the 6150 product brief tells us uses Connector interface: PCIe electrical interface for WiFi, USB 2.0 for WiMAX.

The 2570P wifi slot is PCIe only with no USB lines connected. The WWAN slot is only USB 2.0 from the factory. Though the 2560P schematic shows port1 pci-e line to the WWAN slot which never made it to production.

So then this is a strong indicator that wiring up those extra 4 disconnected lines in the WWAN slot (23,25,31,33) using 0ohm SMT resistors could extend that slot from USB to USB+PCIe. If so it means too then it wouldn't be USB+mSATA as mSATA and mPCIe uses those same same transmission tracks.

Any thoughts as to whether conductive pen or using a pencil would work for this? I've done some SMT soldering before, but I'd rather try that before soldering on my primary pc. I've found that bridging those types of connections with some 30 awg wrapping wire works well.

post-8761-14494996210418_thumb.jpg

Share this post


Link to post
Share on other sites
I dug out my ES 6235 and did some tests. The laptop booted into Windows without issue, it just had to install the 6235 specific drivers. The BIOS doesn't give any hassle or show any nag screens like if you had a non-whitelisted device. Here's some screenshots:

[ATTACH=CONFIG]9170[/ATTACH][ATTACH=CONFIG]9171[/ATTACH]

I'm not sure why this one works vs a regular 6235, as the vendor and HW IDs are the same as a regular 6235 (at least what I could find on the internet) and are not on the whitelist. Maybe an upgrade path for people who want new wifi cards. There's Intel 7260 cards on ebay for 17.80 US, maybe worth a gamble for someone. Worst case, throw it in your desktop with an adapter.

Intel 7260 HMWBNWB 802 11n PCI Express Bluetooth 4 0 Wi Fi Bluetooth Combo | eBay

- - - Updated - - -

Any thoughts as to whether conductive pen or using a pencil would work for this? I've done some SMT soldering before, but I'd rather try that before soldering on my primary pc. I've found that bridging those types of connections with some 30 awg wrapping wire works well.

and from http://forum.techinferno.com/hp-business-class-notebooks/2537-12-5-hp-elitebook-2570p-owners-lounge-29.html#post69802 :

Worst case, please keep the WLAN disabled whitelist in future BIOS updates. I just tried an Intel 1000 and Atheros AR5B91 I had laying around. Both showed in the BIOS as TEST WLAN and showed in Windows. Safe to say that the whitelisting is broken or disabled.

wifi whitelist bug: BIOS programmer error or generous easter egg?

Thanks for posting this which inspired me to test a Intel 5100AGN I had laying around from a 2530P. Managed to trial install the full-sized card into the half-sized 2570P wifi slot by having it lean on an angle. I too got it detected and working without any bios nags. I too see a Test WLAN bios info item instead of a FCC ID as shown in the spoiler:

B4ezHTi.jpg[

kXhyhRf.png

The whitelist code that appears to be allowing this to pass through is below as found in 5EE86B35-0839-4A21-8845-F1ACB0F688AB_3_205.ROM module decompressed by PhoenixTool. You'll notice there is a 8086 Intel vendor ID entry, 5678:1234 and 0000:0000 (NULL?). Whitelist entries prior to this follow the pattern [PCI ID][alternate PCI ID][FCC ID][0xFFFF end-of-entry string]. This one bucks the trend. Is this a BIOS programmer oversight or a generous easter egg?

Anybody want to try a Intel 802.11ac (7260.HMWW) that's not in the whitelist and report what happens? 802.11ac would be a nice upgrade for us.

qzkc.png

Share this post


Link to post
Share on other sites
...Anybody wanna try a Ralink or a Intel 802.1ac (7260.HMWW) that's not in the whitelist and report what happens? 802.1ac would be a nice upgrade for us.

Share this post


Link to post
Share on other sites
I have this to test, Im pretty sure it's a RALINK. I have test it after the weekend though!

That's a USB card so can't be used in the pci-e only wifi slot unfortunately. You can try it in the WWAN slot (USB) but I'm pretty sure there is no such coding bug allowing non-whitelist USB WWAN/wifi cards to be used in the WWAN slot.

Anybody else can test non-Intel wifi (eg: Bigfoot Killer-N) as well as newer Intel 802.1ac?

Share this post


Link to post
Share on other sites
The first benchmark is utilizing your 560TI and the other HD4000. I would do two equal benchmarks if I were you.

Share this post


Link to post
Share on other sites
The first benchmark is utilizing your 560TI and the other HD4000. I would do two equal benchmarks if I were you.

Share this post


Link to post
Share on other sites

If you are using an Nvidia card your physics score would be higher if the setting is enabled in 3Dmark. You have to uncheck it to force CPU only physics.

Share this post


Link to post
Share on other sites
If you are using an Nvidia card your physics score would be higher if the setting is enabled in 3Dmark. You have to uncheck it to force CPU only physics.

Share this post


Link to post
Share on other sites
I've tried that too, it differs less than 100 points for me, at least when I made the test for my E530 + GX670. I'll make a test with my 2570p without the eGPU attached right now and come back to you =)

EDIT: The test shows a difference of ~600 points in score, so I agree with you.

EDIT2: This means that the higher physics score is correlated to the eGPU and not solely depending on CPU.

Share this post


Link to post
Share on other sites
Hmm I'm not so sure about that, If the Physics score purely depends on the CPU then @Aikimox should have similar or better Physics score than me:

My score(3820QM) vs Aikimox score(3840QM)

I score 1300 points more (~ +18%) so it must be some additional variables in this equation.

Likely because the iGPU isn't being used so the 35W can be dedicated for the CPU + higher turbo boost instead of being divided between iGPU+CPU. Can you monitor the CPU with Throttlestop or hwinfo64 to see what turbo multipliers you're hitting with and without the eGPU attached during the test?

Share this post


Link to post
Share on other sites
Still a very good score, did you run it stock of overclocked? I'd like to know if your CPU is able to hold 3.5ghz on all cores during 3Dmark11. Can you confirm this by running HWinfo64 while benching? I'm seeing a rather random effect.

Share this post


Link to post
Share on other sites

It shows unlocked here too. To check the cpu clocks click sensors and look in the maximum column.

Share this post


Link to post
Share on other sites
It shows unlocked here too. To check the cpu clocks click sensors and look in the maximum column.

Share this post


Link to post
Share on other sites
Since I can't monitor the frequencies when running the test I can't for sure tell if they are active simultaneously?

Anyway, I reset the sensor status just before running the benchmark and got this:

[ATTACH=CONFIG]9175[/ATTACH]

I seems like they are running @3,7GHz, except core#2 that seems to prefer 3,6GHz? Weird...

EDIT: Did a test in prime95 blend and actually reached 104c @core#2 which made the CPU to throttle.

i7-3820QM will run x37 (1 core), x36 (2 cores) or x35 (4 cores) at it's default 45W power limits as explained at Intel Core i7 3820QM Notebook Processor - NotebookCheck.net Tech .. You can easily view what it's doing by installing Throttlestop (download from

ThrottleStop - Downloads - Tech|Inferno Forums ) and then doing a 'TS bench' as shown below.

eg: I'm running x33 (2 cores / 4 threads) as I'd expect per Intel Core i5 3360M Notebook Processor - NotebookCheck.net Tech . TS is showing 2 threads per core as I have HyperThreading enabled.

Yours will show 8 threads. Incidentally Throttlestop would be the software you'd be using to set higher multipliers and/or power limits if your CPU was unlocked.

5vhh.png

Share this post


Link to post
Share on other sites

Not sure if anyone else is having this issue, but for the longest time I couldn't change the brightness of my display sometimes after going into suspend. This MS hotfix corrected the issue, but is designed for the following specific scenario:

  • You have a laptop that is running Windows 7 or Windows Server 2008 R2.
  • You set the When I close the lid setting to Do nothing on the laptop.
  • When the laptop starts to enter sleep mode (system power state S3), you close the lid before the laptop enters to the sleep mode.
  • You open the lid and resume the laptop from the sleep mode.

I'd wake the laptop from sleep and be unable to change the brightness from where I left it. The hotkey overlay would show empty/full dim and I couldn't change the brightness using the brightness slider in W7 properties.

Screen brightness changes and you cannot adjust the screen brightness after you resume a laptop from sleep mode in Windows 7 or Windows Server 2008 R2

Hopefully it helps someone!

Share this post


Link to post
Share on other sites
I don't know if somebody noticed it but there is a visible defference in PhysicsScore ind 3dm11 when used 90W and 65W adpater. Im curious whther there will be another boost when use 120W.

i7-3632QM with 90W

i7-3632QM with 65W

I need to correct myself. There is no PhysicsScore boost on 90W in comparison to 65W. The source of boost is ... eGPU. I don't know why. I thought Physics tests are independant to overal CPU+GPU performance but they're not.

i7+iGPU on 65W vs i7+iGPU on 90W vs i7+eGPU on 90W

Share this post


Link to post
Share on other sites
I need to correct myself. There is no PhysicsScore boost on 90W in comparison to 65W. The source of boost is ... eGPU. I don't know why. I thought Physics tests are independant to overal CPU+GPU performance but they're not.

i7+iGPU on 65W vs i7+iGPU on 90W vs i7+eGPU on 90W

Is the Physics test being done on the eGPU with an external LCD attached? If it is, disconnected it so Optimus renders using the iGPU instead. That engages the iGPU in the same way as the iGPU-only test. As mentioned earlier, with the iGPU active and functioning, turbo boost for the CPU has to be limited for the package (CPU+iGPU) to remain within TDP. So an additional benefit of the eGPU (with external LCD attached) is higher CPU performance when iGPU is disconnected or not being used for graphics acceleration.

i7-3820QM will run x37 (1 core), x36 (2 cores) or x35 (4 cores) at it's default 45W power limits as explained at Intel Core i7 3820QM Notebook Processor - NotebookCheck.net Tech .. You can easily view what it's doing by installing Throttlestop (download from

ThrottleStop - Downloads - Tech|Inferno Forums ) and then doing a 'TS bench' as shown below.

eg: I'm running x33 (2 cores / 4 threads) as I'd expect per Intel Core i5 3360M Notebook Processor - NotebookCheck.net Tech . TS is showing 2 threads per core as I have HyperThreading enabled.

Yours will show 8 threads. Incidentally Throttlestop would be the software you'd be using to set higher multipliers and/or power limits if your CPU was unlocked.

5vhh.png

@jacobsson , were you able to do some poking around in Throttlestop to see what your turbo and power limits are and whether they can be altered when click TRL and TPL buttons? You have a ES i7-3820QM which may have some unlocked features.

Share this post


Link to post
Share on other sites
Is the Physics test being done on the eGPU with an external LCD attached? If it is, disconnected it so Optimus renders using the iGPU instead. That engages the iGPU in the same way as the iGPU-only test. As mentioned earlier, with the iGPU active and functioning, turbo boost for the CPU has to be limited for the package (CPU+iGPU) to remain within TDP. So an additional benefit of the eGPU (with external LCD attached) is higher CPU performance when iGPU is disconnected or not being used for graphics acceleration.

Yes, You were right but here NVIDIA GeForce GTX 560 Ti video card benchmark result - Intel Core i7-3632QM,Hewlett-Packard 17DF you have i7+eGPU+90W on internal. 200pkt less than on external but still 300pkt more than on internal iGPU :)

Share this post


Link to post
Share on other sites
Yes, You were right but here NVIDIA GeForce GTX 560 Ti video card benchmark result - Intel Core i7-3632QM,Hewlett-Packard 17DF you have i7+eGPU+90W on internal. 200pkt less than on external but still 300pkt more than on internal iGPU :)

So loading the iGPU with what is buffer copies (eGPU->iGPU) does lower the 3dm11 physics. Unfortunately you cannot put a heavier load on the iGPU in the background. If you could it would likely eliminate that 300pt difference since the iGPU acceleration would be used to render the image, increasing package TDP and lowering TDP available for the CPU along with it.

Share this post


Link to post
Share on other sites

Greetings everyone...

My trusty 2530p has finally become too old & unreliable after years of service... so I just purchased a used 2570p i7-3520M on eBay. I should have it by the weekend, and I can't wait! I'm a recording engineer, so I'm looking forward to finally having a portable computer that can run the more processor intensive apps I use regularly (on my desktop PC). I also like to tinker/solder, so I'm happy to have a device I can actually service myself.

I'm sure I'll have questions at some point, but I just wanted to say hi and thank everyone here for a great, informative forum. I almost bought the new 820, but realized I could save a $1000 after reading this thread (and get something more appropriate for my purposes too). Oh, and I did read the whole thread! Interesting stuff.

Best,

Aj

Share this post


Link to post
Share on other sites

Added more conversation quotes here. After a string of emails which suggested that a ZBook 12 was to be considered I hit a brick wall.

Looks like in 12.5" it will be a ULV "820 G1". The recommendation is to look at a 14" Probook 600 as being the smallest genuine 2570P replacement. It has a socketted CPU, dual-drives, better HD/FHD panels and even a dGPU option. No expresscard slot though. The 12.5" 2570P small-and-mighty form factor being discontinued.

INFO: Request for "ZBOOK 12" emailed to HP PSG head executive and reply received
From: Lores, Enrique <enrique.lores@hp.com>

Date: Thu, Oct 10, 2013 at 1:47 AM

Subject: RE: Pls make a "ZBOOK 12" replacement for the Elitebook 2570P. "820 G1" = disappointing

To: Nando

Nando

Thanks for reaching out and expressing your views on the 2570P. This product is being discontinued as we transition our EliteBook platforms using newer Intel Haswell ULT chipset which require bonding to the board to achieve the thin and light design goals of our Elite Series notebooks. The EliteBook 800 series represent a new class of thin and light yet with enterprise class quality and durability but is not a replacement to the 2570P. We recently introduced the HP ProBook 600 series available in a 14” which supports socketed CPUs and dual high performance hard drives. This product was announced October 1 so you can expect to see it online shortly. This is the model I’d recommend you take a look at as a replacement to the 2570P. The ProBook 600 is about 20% thinner than previous generation and includes a rich feature set including all day battery life, discrete graphics, optional 4G LTE WWAN, USB 3.0, Display Port 1.2 paired up with new Full HD and HD+ screen options, all in one very sleek industrial design.

Thank you for providing your feedback. And thank you for your support of the HP brand and the products we build.

Enrique

From: Nando

Date: Tue, Oct 8, 2013 at 11:48 AM

Subject: Re: Pls make a "ZBOOK 12" replacement for the Elitebook 2570P. "820 G1" = disappointing

To: "Weisler, Dion" <dion.weisler@hp.com>, "Lores, Enrique" <enrique.lores@hp.com>

Hi Dion,

This is great news! I'm glad to know you are giving a 'ZBook 12' serious consideration. I've been a big fan of the 12" Elitebooks having owned 2570P, 2560P, 2530P and 2510P units and maintained owner's threads for each:

http://forum.techinferno.com/hp-business-class-notebooks/2537-12-5-hp-elitebook-2570p-owners-lounge.html

* *HP EliteBook 2560p Owners Lounge*

* *HP EliteBook 2530p Owners Lounge*

* *HP 2510p Owners Lounge*

* 'master blaster' is my work that's being hosted illegally by NBR. NBR ignore copyright-based DMCA takedowns of that material after them banning me for suggesting a 2570P over Lenovo notebooks. Legal enforcement of the takedown is tricky as I'm in Australia.

These threads gave these units global exposure. I'd like to continue my ownership streak.

Thank you also for taking the time to respond to my emails.

Nando

From: Weisler, Dion <dion.weisler@hp.com>

Date: Tue, Oct 8, 2013 at 11:21 AM

Subject: RE: Pls make a "ZBOOK 12" replacement for the Elitebook 2570P. "820 G1" = disappointing

To: Nando "Lores, Enrique" <enrique.lores@hp.com>

Hi Nando

I have discussed the matter with Enrique Lores who is the SVP for our Commercial Business. He will study this with his team. Unfortunately, because we do not talk about unannounced products, we will not be able to give you direct feedback on our decision. We take all our customer feedback very seriously and thank you for taking the time to write to us. Rest assured that your suggestion is being studied and we will make an appropriate decision.

Many thanks

Dion

From: Nando

Date: Tue, Oct 8, 2013 at 9:52 AM

Subject: Re: Pls make a "ZBOOK 12" replacement for the Elitebook 2570P. "820 G1" = disappointing

To: "Weisler, Dion" <dion.weisler@hp.com>

Hi Dion,

Am curious if you have anything to report about the request to create a Zbook 12?

The other reason I'm sending this email is I've updated the 12.5" HP Elitebook 2570P Owner's Lounge @ TechInferno. Done because the lack of a true HP 2570P (or other vendor) successor means I'm looking at a long 2570P ownership stint.

That updated thread making it easy to understand why a Zbook 12 is desirable system. A system that would fit nicely into the ZBook 14/15/17 range. The thread identifies missing 2570P performance features in the '820 G1' that your 2570P marketting team or even tech reviewers have completely missed. Namely, the upgradable CPU, ODD for second HDD/SSD, RAID-0/1 support, expresscard slot for eGPU use and upgradable wifi.

Not surprised then that the Lenovo's X230 was the dominant ultraportable in the last sales cycle.

Thanks,

Nando

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By zepvalue
      Hello guys,
      Thanks for this incredible forum, I hope I will learn a lot from the gurus ! 

      I am trying to make my eGpu MSI GT X970 work on my laptop   with K1100M integrated GPU. 
       
      This are my specs:
      CPU: 2.7GHz Intel Core i7-4800MQ (quad-core, 6MB cache, up to 3.7GHz with Turbo Boost) PSU : ??? Graphics: NVIDIA Quadro K1100M / Intel HD Graphics 4600 RAM: 32 GB Storage: 1TB

      I got a V8.0 EXP GDC Laptop External Independent Video Card Dock  with the express card version ( I am not really hw savy) and I am looking for a good psu to power my MSI GTX 970 4G  
      Could you kindly suggest a good PSU that i could use to power this GPU ? I am also willing to do as many experiments needed
       
      Thanks for reading my post
      -zepvalue
       
       
       
    • By egovanno
      Hello everyone.
       
      I put on a eGpu setup after quite a bit struggle 2 years ago and I used play games just fine. After a while I sold my graphics card gtx 970.
      Now since 2 days I am trying to put the eGpu setup back again this time with a Gtx 770.
      I couldn't understand the problem. I can shut my dGpu off with diy 1.30 setup. ( usb booted)
      And my laptop sees  gtx 770 along with my igpu Intel HD graphics 4000.
      After driver installation when I try to play a game laptop is tring to use iGpu instead of Egpu. (tried to delete and install driver few times)
      With MSI afterburner I can see  eGpu is  %0 all the time.
      Can it be power problem cause graphic cards fans ( Msi gtx 770 twinfrost ) are working all the time they dont stop.
      Or what else can it be. 
      Thx.
       
       

    • By High_Voltage
      In case you own a Lenovo Y410p or Y510p laptop, you might be interested in upgrading its performance by installing an external graphics card. Ultrabay eGPU adapter designed by @gerald was proven to be a convenient plug-and-play option to do exactly that. However, for a long time only an AMD-branded GPUs could be used due to limitations in the Lenovo's stock BIOS. The purpose of the modified firmware presented here is to expand the range of available GPUs by enabling Nvidia support on Gerald's Ultrabay eGPU adapter.
       
      Huge thanks to:
      @MWichni - For efficiently assisting me during the development of this mod. By flashing dozens of BIOS builds over the course of several weeks and thoroughly describing the effects observed (or the lack thereof), he enabled me to fully understand necessary parts in BIOS structure and come up with a final solution. @svl7 - Whose unlocked BIOS / Whitelist mod has served as a basis for this modification. His discovery of a security hole in V2.07 BIOS has provided us with a convenient BIOS flashing method that does not require a physical programmer. The Unlocked BIOS and WLAN whitelist mods originally designed by him are also implemented in this BIOS mod. @gerald - For designing the aforementioned adapter. Without it, all this work would make very little sense.  
      Key features:
      Resolves the "40-second reboot" issue normally encountered while using Nvidia graphics cards with Ultrabay eGPU adapter, thus allowing all Nvidia cards to be used. Based on the latest V3.08 BIOS. Includes Svl7's WLAN whitelist removal mod - for the convenience of aftermarket WLAN card users. Includes Svl7's BIOS debug menu mod - for the ease of experimentation with newly available features, e.g. attempting to use Nvidia Optimus to pass eGPU video back to laptop's display.  
      NB! Svl7's Debug Menu is not a toy! It contains a lot of options that are either not supported or partially supported by the hardware platform and/or can disturb its normal operation or prevent the PC from booting up at all. Any of the entries not originally present in the stock BIOS should be modified at your own risk!
       
      DISCLAIMER:
      ANY MODIFICATIONS YOU ARE APPLYING TO YOUR HARDWARE ARE PERFORMED AT YOUR OWN RISK! AUTHOR OF THIS MOD DOES NOT HOLD ANY LIABILITY FOR LOSS OR DAMAGE RELATED TO USING THIS SOFTWARE.
       
      Screenshots:
       
      Installation instructions:
       
      If things don't go right:
       
      Error 43:
      If you intend using the GTX10XX-series Nvidia card as the eGPU (which you probably do), you are very likely to encounter the infamous Error 43 in Windows Device Manager. This is a widely known issue in the eGPU community and is not related to this particular mod in any way. Following this guide thoroughly will in most cases resolve the Error 43 issue.
       
      Download:
      Get your copy here!
       
      P.S.:
      Version of this mod for Lenovo Y400/Y500 models is coming soon!
       
    • By anonbsnake
      Hi to everyone , I have troubles to eliminate the error 43.
      I have beast 8.0
      EXpress card cable
      cx650M Source power
       
      I have tried  to install different versions of driver nvidia but the error persists.
      When I start the laptop and the power supply at the same time I have a black screen. but if I wait about 10 minutes  and then I turn OFF the laptop the restore computer appears , seems like  the laptop worked normally (but I have no video signal).
      Sorry for my poor english.
       
    • By Bananenbrot hellcase.com
      Hallo Leute,
      Ich habe mir zu Weinachten eine Akitio Thunder 2 mit einer EVGA GTX 1060 6gb für meinen late 2013 IMac mit einem 120W AC Adapter von Leicke geholt.
      Zu meinem Problem, Ich habe alle mögliche Treiber probiert ich habe mein Windows zweimal neu aufgesetzt und
      habe verschiedene Sachen im Geräte Manager deaktiviert. Was kann ich da jetzt noch machen das die evt. doch geht?
      Danke schon mal im voraus
      Harry 

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.