Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

Does anyone know if modded A12 has an issue with display brightness (3d screen) changing on a 680m M17x r3? I have the modded A08 and everything is perfect, except the brightness doesn't change with fn4/fn5. I've tried the latest modded drivers (335.23) plus a few variants a couple of months old and none of them work. There are a bunch of display settings in the Bios, but I'm reticent to change them in case I end up with a blank screen!

Share this post


Link to post
Share on other sites

hi all m17x r3 users.

I am trying firmware mods for other fell laptops with similar hardware, but since the m17 r3 seems to have more overclocking options, I am checking the firmware.

however I would like to get the ME firmware of the alienware with the firmware options to compare them with my machine.

and I would need a firmware dump from you

that can be made with fptw software

fptw64.exe -D total_backup.rom

would backup the whole chip to a 4 mb file

and

fptw64.exe -D -ME me_region.rom

would backup only the ME region

to run those commands you need ftpw64

wich can be DL here:

fptw64

if anyone can provide one of those dumps, I would be very happy :)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
sorry for the late reply, been rather busy these last few days. :(

3. Well the 680m would more than double your GPU speed, but like you said the card is very expensive. This 6990m I got rather cheep has been running great other than the usual crappy AMD drivers. More than double the FPS of my old 460m. :D Hope some of this helps.

Hi,

It has been a while since I last follow the topic on M17xR3 with 680m. The last time I checked, if 680m is installed, the 3D display will stop functioning. Is this still true?

Thanks.

Share this post


Link to post
Share on other sites

Can someone post an unlocked x17R3 A12 unlocked bios but without the SATA fix?

If I need to make a donation for it, please tell me where to send and how much.

Thanks!

Share this post


Link to post
Share on other sites

yep is it possible to update the link to download the custom bios?

thanks

Share this post


Link to post
Share on other sites

Link has been updated but if your account is still Pre-Promotion @crash you will have to wait about a week and participate in the forums before you can access attachments here. 

Share this post


Link to post
Share on other sites

Hi folks, new to this forum. I'm running an M17x R3. Since i've bought it, i've upgrade to 20g of ram and also replaced drive with a 1tb ssd.  Machine has been running extremely well. Love my Alien. But i've just received an upgraded rendering software that is based on gpu rendering. Previous version worked fine on my 460m, new version of software, not so much.

 

So after lots of reading on video card upgrades, I bought a 580m on ebay (not the eurocom,  saw that one to late). Based on passmark benchmark, it should be close to double the original 460m speed. Should be good enough for me for now - or until the next rendering software upgrade.

 

However, I seem to be having an issue.....I did the swap of the 460m to the 580m and for most part, things went well. I upgraded the bios to A12 (not unlock). Upgraded the 460m drivers to the latest version, shares drivers with the 580m. Then swapped the cards (without removing the drivers). Powered back up and it found and recognizedo the 580m with now issues. Very easy upgrade.

 

The problem i'm having is performance. When I run the pass mark benchmark on the system, the performance of the 580m is like 500% less of the original 460m! Passmark numbers for 460m was around 1300, passmark numbers for 580m is currently around 300 and should be around 2600.

 

I did go into the A12 bios and changed the video to peg. No difference....

 

Elsewhere in this post and other forums, users are saying that they used an unlocked A12 bios. Could that be my issue?

 

Any help you can provide would greatly be appreciated. Thanks.

 

M

 

 

Share this post


Link to post
Share on other sites

Update: I got a copy of the A12 unlock bios. Did the upgrade. No change on the performance.  Also, I used guru3d ddu to Uninstall/remove all of the nvidia drivers.

 

To do so, I went into the bios an enabled the sg video and then booted into safe mode,. Ran ddu to remove all nvidia files. Rebooted, into setup, enabled peg, booted into windows.  Device manager said Microsoft vga driver. Installed latest nvidia drivers for gtx 580m and then rebooted.

 

Ran performance test, same issue.

 

Anyone know what'S going on?

Share this post


Link to post
Share on other sites

Update #2: I've now updated the video Bios of my GTX 580m. Things got a bit better, but still not performing as it should be. I checked a couple of Videos online about upgrading a 460m to 580m and on fellow said you should/have to remove the black trim around the copper heatsink, that sits on top of the GPU - in order to get a bigger cooling footprint. So I did. I cleaned the glue that was there as well. I also reseated the Thermo pads on the memory chips as well. However, had to use the older ones as I could not find pads in this part of the world....I'll have to order some new ones online.....Things are starting to work better. The 580m can actually run the Direct X9 Simple test from Passmark/Benchmark at full speed now. However, if I try to run the full suite of benchmarks, the Video Card crashes (overheats). So it looks like it's a heating/cooling issue. I'm also gonna order some new/better thermo past and see if that helps. I'll keep you posted.

Share this post


Link to post
Share on other sites

Update #3: I got some Artic Silver Céramique 2 and new thermal pads. Cleaned all the fans. Everything worked really well for a couple of days. The 580m was getting a passmark of more than 2600 (performance test). However, now I have a new problem and need some help. The Card started heating up again after a few days.....:dread:  As I'm typing this post, with nothing else running in the background, the temp of the GPU is at 58/59 deg. Doesn't make any sense. Why would it work fine for a few days and then start to heat up???  One person (from a different forum) responded that it might be the X Bracket on the back of the 580m card. When I bought the 580m, it did not have the X Bracket, so I used the one from my 460m card. The user on the other forum said the X bracket from my 460m card is most likely a rev A00 and that for the 580m I need a rev A01 or higher!! It's a stupid metal bracket, does that make any sense?? Help, info, anything? Anyone?

Edited by Michel Beaulieu

Share this post


Link to post
Share on other sites

Update #4: No Luck. Got a new x Bracket from Eurocom. New Pads, New Artci Silver Céramique 2, re-flashed the A12 bios - no luck....Seems like I have 2 issues and I'm thinking both are related to a defective Video Card now.....What I find is that even if it's in the 57 to 60deg range (hot for me not doing anything), the Video Card might still crash...Here's what I mean....I'm working away, everything works fine. I power off for the day, go home. then in the evening, have to do a little bit of work, so I turn on the laptop and it won't boot, just click, click, click sound when I try to turn it on....The only way for me to get the laptop working is to take everything apart, remove the video card and the bios battery and reset the bios. Then I can boot (without the gtx580m) as the laptop is running with just the built-in Video. Once in Windows, shut everything down. Put the GTX 580m back in, boot up, change bios to PEG and disable the SG and usually I'm back up and running..But it has happened a few times that it still won't boot. Now my old GTX 460m runs a bit hot also, between 57 to 60deg and if I do a 3d benchmark to push the card, the temp goes up as high as 64deg, but it's never crashed on my. The new gtx 580m would never make it to 64deg, it crashes around 62deg??

 

Anyone have a clue as to the possible issues here?? I would appreciated any feedback!! Thanks.

Share this post


Link to post
Share on other sites

@Michel Beaulieu do you have the 120 hz model or 60 hz? Also, try:

 

1. Disconnect power cable and remove battery. Hold down power button for 30 seconds. 

2. Plug the AC adapter in, hold the FN key (keep it pressed) and then press the power button, it will go through a restart and after 5 secs or so you can release the FN key.

3. If  the above doesn't work then remove cmos battery, disconnect power cable, remove battery, hold down power button for 30 secs. Let the system sit for a little bit, then replace the cmos battery and AC adapter and start the system. 

 

It's been awhile since I messed with an Alienware but the above should be accurate based on what I remember.  Additionally, install GPU-Z and turn on logging and see if the GPU is throttling during loads. Also when using that card, disable IGD (integrated graphics) as well. Short of that I'm not really sure, it's been years since I messed with an M17x-R3. 

Share this post


Link to post
Share on other sites

@Brian Thanks for the info/input. from what I can tell, my panel is the 60hz and not 3d. The original card was a 460m, trying to upgrade to 580m. I had bought 2 gtx 580m as I have a couple of M17xR3 that I'd like to update/upgrade, in order to extend their life....So I've put one of the other GTX 580m in. Windows/Pc boots with no issues. Windows see the video card as MS generic vga. I then go to install the NVidia drivers and it fails to find a NVidia card and therefore won't install the drivers....??

Share this post


Link to post
Share on other sites

I just upgraded my Alienware M17x R3 and I need to download this bios to get it to work.  I'm hoping this does it!!

Share this post


Link to post
Share on other sites

It wont let me download this file, I need it!!  I can't find it anywhere else.  How can I download it?  I guess my rank here isn't high enough??

Share this post


Link to post
Share on other sites

Update #5: We have a winner!! Ok, I got things figured out and working - supper fast......

First, the 580m was the issue. replaced it with a GTX-780m. Problem is fixed.

I also fixed the sound for my card. Had to reboot without the GTX-780m, used the internal card.

Removed the audio drivers that Windows had installed and installed the original IDT (dell) drivers.

tested the sound, and it worked.

Put the NVidia GTX-780m back in and rebooted, turned the sound card back on (in the bios) and booted into Windows.

Sound Card works with no issues. Video Card works with no issues.

I also update/swapped out the my i7-2720qm for a i7-2960xm!!

Wow, it's like having a new PC!! Here's the 3dMark11 numbers!!

 

3d Mark11 Score
P7664  with  NVIDIA GeForce GTX 780M(1x) and Intel Core i7-2960XM Processor

Graphics Score7922 

Physics Score7306 

Combined Score6551

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 2/14/2016 at 1:17 PM, Michel Beaulieu said:

Update #5: We have a winner!! Ok, I got things figured out and working - supper fast......

First, the 580m was the issue. replaced it with a GTX-780m. Problem is fixed.

I also fixed the sound for my card. Had to reboot without the GTX-780m, used the internal card.

Removed the audio drivers that Windows had installed and installed the original IDT (dell) drivers.

tested the sound, and it worked.

Put the NVidia GTX-780m back in and rebooted, turned the sound card back on (in the bios) and booted into Windows.

Sound Card works with no issues. Video Card works with no issues.

I also update/swapped out the my i7-2720qm for a i7-2960xm!!

Wow, it's like having a new PC!! Here's the 3dMark11 numbers!!

was thinking of putting an 880m in my old m17x r3. might try for the 780m instead. guess i'll keep reading up 

Thx for the info

Share this post


Link to post
Share on other sites

Is it safe to downgrade from this Unlocked A12 to the regular factory A12? I have the Unlocked installed and turned on the internal grafics, not knowing that it will lead into troubble. (I have a 120Hz 3D screen.) Reset doesnt work since the internal grafics are activated by default in this one.

Share this post


Link to post
Share on other sites

Thanks alot!!!  Just upgraded my membership on the site to download this file and it works beautifully. Good work, will keep you posted if it gives me any trouble recognizing my ssd (kingston savage 500gb)

Seems like a good, helpful, knowledgeable member base here. Will be making a post, looking for good or experienced advice on upgrading my rig from a 6970m to the gtx 780m. Will be prepping and ordering parts this week!

Thanks again for the good work!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad L440.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2322090.m570.l1313&_nkw=USB+Programmer+Ch341&_sacat=0
       
      https://www.amazon.com/s?k=ch341a&ref=nb_sb_noss_2
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/programming-EEPROM-Programmer-EZP2010-RT809H/dp/B075CGH1X1/ref=sr_1_18?dchild=1&keywords=SOIC8+clip&qid=1631766855&s=electronics&sr=1-18
       
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
       
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad X250, X260.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating your personal bios dump and to flash your bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2322090.m570.l1313&_nkw=USB+Programmer+Ch341&_sacat=0
       
      https://www.amazon.com/s?k=ch341a&ref=nb_sb_noss_2
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/programming-EEPROM-Programmer-EZP2010-RT809H/dp/B075CGH1X1/ref=sr_1_18?dchild=1&keywords=SOIC8+clip&qid=1631766855&s=electronics&sr=1-18
       
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
       
      Note: 
      Each bios mod prepare personally and based on your personal bios dump which contain your personal data like Serial numbers, UUID, Service TAG, MAC addresses, Windows keys, NVRAM settings, etc.
      For creating your personal bios dump and to flash bios mod, you need use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
      Just dump your Bios (from your laptop) using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T450s.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or already upgraded Display and after that can't adjust screen brightness, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2322090.m570.l1313&_nkw=USB+Programmer+Ch341&_sacat=0
       
      https://www.amazon.com/s?k=ch341a&ref=nb_sb_noss_2
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/programming-EEPROM-Programmer-EZP2010-RT809H/dp/B075CGH1X1/ref=sr_1_18?dchild=1&keywords=SOIC8+clip&qid=1631766855&s=electronics&sr=1-18
       
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
       
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad X240.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden advanced menus and settings in bios setup menu, or upgrade to new display (and don't lost a brightness control), then you can post your request in this thread.
      Important!
      For creating your personal bios dump and to flash your bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2322090.m570.l1313&_nkw=USB+Programmer+Ch341&_sacat=0
       
      https://www.amazon.com/s?k=ch341a&ref=nb_sb_noss_2
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/programming-EEPROM-Programmer-EZP2010-RT809H/dp/B075CGH1X1/ref=sr_1_18?dchild=1&keywords=SOIC8+clip&qid=1631766855&s=electronics&sr=1-18
       
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p / E440 / E540.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, and sign unlocked bios with digital RSA signature (to avoid 5 beeps problem), then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.