Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

I uninstalled mcafee which was default included software. no spyware/virus protection active for sure. I unblocked each file individually in properties. I set fptw64.exe to run as administrator. I unlocked my windows hidden administrator account and switched to it. I rechecked that all files were still unblocked. I opened command prompt with run as administrator while logged into administrator. I navigated to the folder that contains the unarchieved fptw64.exe. The 2 batch files and the modded bios are in this same directory. No matter what I use... batch file or the command svl gave me in the earlier post, I get "Error 284: Fail to load driver (PCI access for Windows). Tool needs to run with an administrator priviledge account." I'm scratching my head. I'm sorry guys, anything I missed? I read back a few pages but it seemed there was no more relevant info for the windows 8 bios revision.

Share this post


Link to post
Share on other sites
I uninstalled mcafee which was default included software. no spyware/virus protection active for sure. I unblocked each file individually in properties. I set fptw64.exe to run as administrator. I unlocked my windows hidden administrator account and switched to it. I rechecked that all files were still unblocked. I opened command prompt with run as administrator while logged into administrator. I navigated to the folder that contains the unarchieved fptw64.exe. The 2 batch files and the modded bios are in this same directory. No matter what I use... batch file or the command svl gave me in the earlier post, I get "Error 284: Fail to load driver (PCI access for Windows). Tool needs to run with an administrator priviledge account." I'm scratching my head. I'm sorry guys, anything I missed? I read back a few pages but it seemed there was no more relevant info for the windows 8 bios revision.

For Error 284 set the exe to compatibility mode Windows 7

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Alright, I now duplicate the exact error in post 163. Error 104. Flash Devices found are identical as post 163, so I'll skip the screenshot. Let me know how I can help.

Share this post


Link to post
Share on other sites
Can you unlock the 5DCN40WW?

I have the Y580 that came with oem Win 7. I want to use the bios in post #155, but I dont want to risk it if it's for Windows 8 machines.

Drivers and software - IdeaPad Y580 Notebook

Yeah, can do when I find time, but you can also use the one in the first post, that should work fine for your system. Same for the win8 version actually.

Alright, I now duplicate the exact error in post 163. Error 104. Flash Devices found are identical as post 163, so I'll skip the screenshot. Let me know how I can help.

It's weird... I'd expect all boards to have the same chips. Also both of the listed parts should actually be supported by the tool, maybe the command sets are a bit off... might be fixable by going through some datasheets.

Share this post


Link to post
Share on other sites

Still having the same issue with this tool. Keeps throwing the "Error 104: The two SPI flash devices do not have compatible command sets"

As for what else it prints, this is before it.

--- Flash Devices Found ---

EN25Q32B ID:0x1C3016 Size: 4096KB (32768Kb)

W25Q16BV ID:0xEF4015 Size: 2048KB (16384Kb)

Also, as an added note, I had to edit the batch files to point to the folder where I've put them, and the program for some reason. Even though it was working perfectly fine earlier (Aside from the error given). I'm stuck now, and I'm not sure what else to do.

Share this post


Link to post
Share on other sites
Post #155. That should do the trick, if it allows to flash it.

I ran into this situation...does it need to run at full command prompt or go outside windows?

"http://forum.techinferno.com

To flash the BIOS press y, to abort press n or any other key.

Confirm with enter.

Flash? y

'fptw64.exe' is not recognized as an internal or external command,

operable program or batch file.

Reboot if the flash was successful.

Press any key to continue . . ."

Share this post


Link to post
Share on other sites
I ran into this situation...does it need to run at full command prompt or go outside windows?

"http://forum.techinferno.com

To flash the BIOS press y, to abort press n or any other key.

Confirm with enter.

Flash? y

'fptw64.exe' is not recognized as an internal or external command,

operable program or batch file.

Reboot if the flash was successful.

Press any key to continue . . ."

I solved that issue by editing the .bat, and inserting my working directory before it executes fptw64.exe

Share this post


Link to post
Share on other sites

No need to modify the bat, just put it in the same folder as the tool, along with the bios. But of course the other way works as well.

@wnhughes2001: You flashed the bios from post #155, right? Mind posting some pictures of the menus?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi,

I'm trying to install the bios from thread #155. I have a Y580 that came with windows 7, and now is running windows 8. I have the original modded bios from thread #1 installed currently.

I unblocked all files and ran as administrator and get this error:

------------------------------------------------------

C:\BIOS>FLASH.bat

*************************

http://forum.techinferno.com

To flash the BIOS press y, to abort press n or any other key.

Confirm with enter.

Flash? y

Intel ® Flash Programming Tool. Version: 8.0.10.1464

Copyright © 2007 - 2012, Intel Corporation. All rights reserved.

Platform: Intel® HM76 Express Chipset

Reading HSFSTS register... Flash Descriptor: Valid

--- Flash Devices Found ---

EN25Q32B ID:0x1C3016 Size: 4096KB (32768Kb)

W25Q16BV ID:0xEF4015 Size: 2048KB (16384Kb)

Error 104: The 2 SPI flash devices do not have compatible command sets.

Reboot if the flash was successful.

Press any key to continue . . .

------------------------------------------------------

It might be that the windows 8 y580 bios is not compatible wit the windows 7 y580. There is an updated bios for which is version 5dcn40ww.exe. Would be great to get that un-whitelisted. The reason to get 5dcn40ww is that playing some 3D games I get crashes and this bios is supposed to fix some of the crashes in games.

P.S. The BACKUP.bat gets the same error, Error 104.

Any help would be appreciated.

Share this post


Link to post
Share on other sites

As you've read through the forum, there are issues for those who have the Y580, WIN8-64b and cannot flash the modified BIOS, resulting in various errors... svl7 attempted to resolve this on my machine, to which I provided the BIOS dump (5DCN90WW). Still awaiting to hear from him.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
As you've read through the forum, there are issues for those who have the Y580, WIN8-64b and cannot flash the modified BIOS, resulting in various errors... svl7 attempted to resolve this on my machine, to which I provided the BIOS dump (5DCN90WW). Still awaiting to hear from him.

Thanks, and thanks svl7

Share this post


Link to post
Share on other sites

Y580 owners that originally came with Windows 8.

Are you able to enable secure boot in the bios?

I am unable to find this feature on my laptop that came with Windows 7, but I upgraded to 8.

Share this post


Link to post
Share on other sites

Hey,

I've been looking for a way around the restrictions on the vbios settings (i.e. can't modify core voltage etc) for sometime so that I can take more advantage of the 640m LE in my y480 for gaming purposes. I am using msi afterburner to overclock and although I am not the most savvy person with this type of thing I do understand the risks with increasing the clocks/voltage and I do know how to overclock safely. In short I was wondering if either the bios you have posted will solve my problem in a way I haven't discovered yet or if there is another way to work around the issue I'm facing.

Thanks for the assistance.

Share this post


Link to post
Share on other sites

It's under the SECURITY header > Secure Boot. I was able to enable it. If your Y580 came with WIN7, your BIOS is different from Y580, WIN8.

Share this post


Link to post
Share on other sites

Hi everyone!

I have a Y580 that came with Windows 8 and the BIOS 5DCN90WW.

I tried flashing the unlocked BIOS from the post #155. Thank you for your work svl7 :-)

I tried with several configurations, but always got the same error when running the bat file to do a backup: Error 104: The two SPI flash devices do not have compatible command sets.

The flash devices found are exactly the same as the one indicated on the screenshot from the post #163.

I tried to execute the backup bat on several configurations:

1. The stock Windows 8

2. The stock Windows 8 after uninstall the antivirus

3. When starting Windows 8 in "Safe mode" (even though it is not called like this anymore) with a command prompt only

4. With Windows 7 x64 SP1

@En-TACT, did you already get this error on your system? If yes, how were you able to avoid it?

Share this post


Link to post
Share on other sites
Hi everyone!

I have a Y580 that came with Windows 8 and the BIOS 5DCN90WW.

I tried flashing the unlocked BIOS from the post #155. Thank you for your work svl7 :-)

I tried with several configurations, but always got the same error when running the bat file to do a backup: Error 104: The two SPI flash devices do not have compatible command sets.

The flash devices found are exactly the same as the one indicated on the screenshot from the post #163.

I tried to execute the backup bat on several configurations:

1. The stock Windows 8

2. The stock Windows 8 after uninstall the antivirus

3. When starting Windows 8 in "Safe mode" (even though it is not called like this anymore) with a command prompt only

4. With Windows 7 x64 SP1

@En-TACT, did you already get this error on your system? If yes, how were you able to avoid it?

We're waiting to hear from svl7

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Hi everyone!

I have a Y580 that came with Windows 8 and the BIOS 5DCN90WW.

I tried flashing the unlocked BIOS from the post #155. Thank you for your work svl7 :-)

I tried with several configurations, but always got the same error when running the bat file to do a backup: Error 104: The two SPI flash devices do not have compatible command sets.

The flash devices found are exactly the same as the one indicated on the screenshot from the post #163.

I tried to execute the backup bat on several configurations:

1. The stock Windows 8

2. The stock Windows 8 after uninstall the antivirus

3. When starting Windows 8 in "Safe mode" (even though it is not called like this anymore) with a command prompt only

4. With Windows 7 x64 SP1

@En-TACT, did you already get this error on your system? If yes, how were you able to avoid it?

I did not receive this error.. I got error:

Error 28: Protected Range Registers are currently set by BIOS, preventing flash access.

Please contact the target system BIOS vendor for an option to disable Protected Range Registers.

Share this post


Link to post
Share on other sites

Thanks, I was wondering if you got the error we get before getting the one you have. So strange that we get different errors with apparently the same system.

- - - Updated - - -

@En-TACT, in one of your posts you said that it was necessary to unblock all the files. When I extracted the archives, all the files seemed unblocked.

On your machine, how did you do to unblock them? Maybe I missed something.

Share this post


Link to post
Share on other sites

All bios will work with Win8 and Win7, but only the more recent ones (not yet available at Lenovo's site) have the secure boot / fast boot features. It probably also introduced the Win8 activation stuff.

I'm not sure what I can do about error 104. Error 28 can be solved, but for some reasons it didn't work properly on the system of EN-TACT, so I have find a workaround for my method.

Share this post


Link to post
Share on other sites
Thanks, I was wondering if you got the error we get before getting the one you have. So strange that we get different errors with apparently the same system.

- - - Updated - - -

@En-TACT, in one of your posts you said that it was necessary to unblock all the files. When I extracted the archives, all the files seemed unblocked.

On your machine, how did you do to unblock them? Maybe I missed something.

Right click each file and go to > General tab > click on Unblock (if available). Then for file fptw64, right click > Compatibility tab > check mark Run as Administrator. Finally, for FLASH right click > select Run as administrator to execute process.

Share this post


Link to post
Share on other sites
Right click each file and go to > General tab > click on Unblock (if available). Then for file fptw64, right click > Compatibility tab > check mark Run as Administrator. Finally, for FLASH right click > select Run as administrator to execute process.

Thank you for your response =) I am still sticking with the Error 104 though. I guess we cannot do anything about it for now.

All bios will work with Win8 and Win7, but only the more recent ones (not yet available at Lenovo's site) have the secure boot / fast boot features. It probably also introduced the Win8 activation stuff.

I'm not sure what I can do about error 104. Error 28 can be solved, but for some reasons it didn't work properly on the system of EN-TACT, so I have find a workaround for my method.

Thank you for your work svl7. Let's hope that Lenovo will release a BIOS update for the latest versions and hopefully it will be possible to reuse the flashing utility they will provide.

About the "no whitelist" BIOS of the first post, did anybody already downgrade (or upgrade I should say) from a BIOS 5DCN90WW (v8.01) to the BIOS of the first post (v2.06)?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Andrew2009
      Please could you check if it is possible to unlock my A17 BIOS? I have Alienware 17 R5(2013). 120 Ghz 3D. gtx 980 m. I want upgrade to 1070 but I have dark picture. Turns on but does not start with 1070. 980m-All good. What could it be?
    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Klem
      In this thread you can post your requests for Lenovo G500 and G400 bios unlock.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
       
      For prepare unlocked bios you should post your request here and then send me your file backup of bios via PM or upload it into any fileserver and send me the link.  For creating backup of bios use attached utility. Extract attached archive directly on the Desktop and run utility as Administrator (right click mouse, choice "Run as Administrator). Utility will create archive "results" directly on the Desktop. Send me this archive "results" via PM or upload it into any fileserver and send me the link.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Klem
      In this thread you can post your requests for Lenovo G780.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, in this case you can post your request in this thread.
       
      For prepare unlocked bios you can post your request in this thread, upload your file bios backup into any fileserver and post the download link. Or you can send me your file backup of bios via PM.  For creating backup of bios use attached utility. Extract attached archive directly on the Desktop and run Backup Utility as Administrator (right click mouse, choice "Run as Administrator"). Utility will create archive "results" directly on the Desktop. Send me this archive "results" via PM.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.