Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

Hey, I switched a video setting on my y580 and it doesn't show anything on the screen now. I switched the graphics device setting from "SG" to "auto-correct" and now when I turn on my laptop I can hear the fans spinning and the keyboard light up but the screen doesn't turn on at all... Anybody got a clue how I can fix this?

 

Edit: nvm, found this: 

 

Edited by Ilman

Share this post


Link to post
Share on other sites

Is there any risk of loosing windows 10 licence by flashing this unlocked bios ?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hey guys,

so I have a question about the downloading files. I flashed my Y580 like 4 years ago with the V2.06 bios that runs the geforce on 1ghz. Now I am intereseted in upgrading to V8.01 since on Win10 the usb 3.0 ports do not work properly (usb 2.0 speed). Is there a version that provides the whitelist for the wifi card but does not overclock the gpu?

Share this post


Link to post
Share on other sites

looking for the modded bios with fixed gpu throttling I currently have the v2.07 1ghz bios is  that the same or is there a better version?

Share this post


Link to post
Share on other sites

Sadly i can't download it :( ." If you are unable to download this file, it may be due to one or a combination of the following reasons:" Please help. 
Thank you.

Edited by Getrox

Share this post


Link to post
Share on other sites

so i've installed the 2.7 custom bios. the whitelist part worked perfectly and I now have an ac wifi card. However, it doesn't seem like the gpu unlocked. I'm in linux so things are a bit different for gpu overclocking. in the nvidia-settings app config files you can enable coolbits to do overclocking in the nvidia app. from there before the unlock my stock speed was 950 and I could boost it by 135 to 1085. this did not change after I unlocked the bios. does anyone have any tips for me?

Share this post


Link to post
Share on other sites

Hello. This is my very first post, so if i'm doing something wrong, please inform me to do it correctly.

My question is: Does anyone know how to, and where to download moded BIOS with advanced options for my Lenovo G580 (20150)? My current bios version is 5ECN96WW.

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello guys. Does anybody knows if the moded BIOS of lenovo y580 is applicable to Lenovo g580 (20150)?

Share this post


Link to post
Share on other sites
10 hours ago, Bill.gr said:

Hello guys. Does anybody knows if the moded BIOS of lenovo y580 is applicable to Lenovo g580 (20150)?

Hi!

No it's a different bios. If you want to unlock your bios, then you can send me your file backup of bios via PM. For creating backup of bios you can use attached program. Unzip attached archive directly on the Desktop and run the program as Administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.

https://www.sendspace.com/file/mxoavw

Share this post


Link to post
Share on other sites

hi!
i wanted to change my wifi card in my y580 which one you recommend to me? one of my freind told me the intel centrino 6200, is this ok?

 

Share this post


Link to post
Share on other sites
6 hours ago, Klem said:

Hi!

No it's a different bios. If you want to unlock your bios, then you can send me your file backup of bios via PM. For creating backup of bios you can use attached program. Unzip attached archive directly on the Desktop and run the program as Administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.

https://www.sendspace.com/file/mxoavw

Hi. i've send you a PM with my results file. Thanks for fast reply...!!! :)

Share this post


Link to post
Share on other sites
18 minutes ago, Bill.gr said:

Hi. i've send you a PM with my results file. Thanks for fast reply...!!! :)

Ok. Your mod bios done. I sent it to you via PM.

Share this post


Link to post
Share on other sites

O.K i received you PM. Thanks. I will try it later this night and reply here to let you know.

Share this post


Link to post
Share on other sites

Hey everyone,

 

I found the original full v8.01 Bios. I used the "DOS" folder inside to upgrade from 2.07 to 8.01 and then used the tutorial on page 1.

 

Use the button above to download the file (Arrow to the bottom)

http://pan.baidu.com/s/1z7Fki

 

Cheers

Share this post


Link to post
Share on other sites

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

Edited by Kurupt31509
Adding info

Share this post


Link to post
Share on other sites
2 hours ago, Kurupt31509 said:

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

 

Please see my link above your post. There you can download not only a nomal bios but a zip which has everything in it that could be interesting.

For example a crisis recovery image with a tutorial inside. Not tested but looks promising.

 

And again: The zip contains a bios with original 8.01 ecc data which should be interesting for everyone who wants to upgrade from 2.07 to 8.01. After flashing I had an original 8.01 and then followed the tutorial on page 1... works like a charm!

Share this post


Link to post
Share on other sites
2 hours ago, Kurupt31509 said:

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

 

In the zip file from the link that Makinachan just posted, there is a folder called "Crisis," and inside of that folder is a readme and a bin file called "QIWY3.bin". Here is what the readme says:

 

Quote

*******************************************************************************************************************
QIWY3/QIWY4 System BIOS Crisis Release Notification           10/11/2012

[Checksum]:
QIWY3.bin    Checksum: B745 h

[Procedure]:
1. Save QIWY3.bin to device root directory
2. Shutdown the system and plug out AC.
3. Insert the device.
4. Press Fn + R.
5. Plug in AC.
6. Release Fn + R.
7. Power on the unit.
8. The process of Crisis runs automatically and will listen to warning beep sound.
9. The system will auto restarts and boot normally.

 

I don't see any recovery names appearing for a stock Y580 version 8.01 bios when I use the Phoenix tool to try and find one, but according to this information the recovery name to recover a Y580 version 8.01 bios should be "QIW3.bin."

 

I made this thread a while back which you might help:

The recovery process for recovering a Y580 bios should be the same as the one for the Y500, but I'm unsure as to whether or not it would work with a Y580 version 8.01 bios.

Share this post


Link to post
Share on other sites

does it matter what usb slot i use and does the size of usb matter 

should i keep the same bios file name or use QIW3.BIN

 

MY ORIGINAL BIOS WAS .ROM DOES THAT MATTER

Share this post


Link to post
Share on other sites

Should it be fn+r or fn+b either way im not having any luck im using an 8gb usb my 4gb doesnt have activity light

Share this post


Link to post
Share on other sites
On 18/10/2012 at 8:21 AM, svl7 said:

Lenovo Y500 - 'unlocked' BIOS / wwan-wlan whitelist removal

 

The Lenovo Y580 / Y480 comes with a pretty locked down BIOS, and in addition to this with a whitelist which prevents the user from getting 3rd-party wwan/wlan cards to work properly. The modified BIOS versions here will take care of this.

 

Keep in mind that not necessarily all options available in the modified bios will work. Some might not do anything at all, others could possibly leave your system in a state which will prevent it from booting. Use care when changing stuff in the modified bios, don't touch things you're not familiar with. Use all the mods and software posted here on your own risk.

NOTE: This will only flash the bios region. It won't reset the nvars set in the bios. While it is technically possible to update from v2.0x to v8.01 by using the method described below, I can't really recommend it since the EC of your system won't get updated. While it might work (possibly even without any issues) I can't recommend it.

Therefore if you're on v2.0x and want to update, the better option is to wait until Lenovo provides an official 8.xx firmware update with EC and BIOS. You can then still flash the modified version as described below, once you're on a proper v8.xx firmware.

 

Attached you'll find a modified version of the Y580 / Y480 BIOS v8.01 (5DCN90WW).

-----------------------------------------

>> For users with a v2.0x BIOS: <<

Download links

Old version:

Hidden Content

 

Current 2.0x version:

Lenovo Y580 / Y480 BIOS v2.07 (5DCN40WW) -> unlocked, whitelist removed, Nvidia 660m @ 1GHz default 3d clocks

Flash with the included InsydeFlash utility.

-----------------------------------------

 

>> Instructions for v8.0x BIOS users: <<

The attached BIOS ("Lenovo Y580 - Y480 BIOS v8.01 (5DCN90WW) - Mod") is unlocked, whitelist stuff removed and the 660m is tweaked to 1GHz default 3d core clock. 

The only way I know of which allows you to flash the modified BIOS for v8.01 users does unfortunately also describe certain information which you don't want to loose (serials, Windows licencse etc.). Don't worry, I got it all sorted out, but due to this the flashing procedure is a bit more complicated than usual. Make sure you follow the instructions carefully.

 

 

Hidden Content

 

It might look a bit complicated at first, but that's the easiest way I could think of. Let me know if anything is unclear.

 

 

The attached v8.0x modified versions include:

- unlocked menus

- whitelist removed (wwan / wlan)

- Nvidia 660m 'GHz edition' - 1000MHz default 3d clocks

 

>> Here's the 'buy me a beer' link in case you like this. Modding makes me thirsty :) <<

 

Use at your own risk, you are responsible for your system and the changes you make on it. My programs come with absolutely no warranty to the extend permitted by applicable law.

 

Thanks @X0pas1 for testing, and for some pics - see below:

 

  Reveal hidden contents

1qTSe.thumb.jpg.32a8331351d50af0e73fbb212N6Ed.thumb.jpg.a463a818f83ecbce034c98a5d8fPM.thumb.jpg.0d26d05e171c6f32e2440d92iCvPi.thumb.jpg.6f1a12ad602ff469b079e208K4JmK.thumb.jpg.e9d1075fa4e8b2ee89ceb823lScBM.thumb.jpg.0b262df1d08f0dab889cda0cpEZQJ.thumb.jpg.5180fdab03e0d8aad063296bWIupC.thumb.jpg.effb199e004e16ee1be08879

 

 

I'd appreciate it if someone could also post some pictures of the more interesting sub-menus, e.g. advanced CPU control, video settings and similar.

 

UPDATE 1/17/16

DOWNLOAD LINK FOR FILES REFERENCED IN THIS POST:

 

 

Hi. Can you do the exact same thing for my Lenovo G580 (20150) BIOS? In fact i have major problem with my bios. Won't boot, no logo, one short beep and black screen...tried almost everything without any luck. Thanks in advance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.