Jump to content
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

Hey, I switched a video setting on my y580 and it doesn't show anything on the screen now. I switched the graphics device setting from "SG" to "auto-correct" and now when I turn on my laptop I can hear the fans spinning and the keyboard light up but the screen doesn't turn on at all... Anybody got a clue how I can fix this?

 

Edit: nvm, found this: 

 

Edited by Ilman

Share this post


Link to post
Share on other sites

Is there any risk of loosing windows 10 licence by flashing this unlocked bios ?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hey guys,

so I have a question about the downloading files. I flashed my Y580 like 4 years ago with the V2.06 bios that runs the geforce on 1ghz. Now I am intereseted in upgrading to V8.01 since on Win10 the usb 3.0 ports do not work properly (usb 2.0 speed). Is there a version that provides the whitelist for the wifi card but does not overclock the gpu?

Share this post


Link to post
Share on other sites

looking for the modded bios with fixed gpu throttling I currently have the v2.07 1ghz bios is  that the same or is there a better version?

Share this post


Link to post
Share on other sites

Sadly i can't download it :( ." If you are unable to download this file, it may be due to one or a combination of the following reasons:" Please help. 
Thank you.

Edited by Getrox

Share this post


Link to post
Share on other sites

so i've installed the 2.7 custom bios. the whitelist part worked perfectly and I now have an ac wifi card. However, it doesn't seem like the gpu unlocked. I'm in linux so things are a bit different for gpu overclocking. in the nvidia-settings app config files you can enable coolbits to do overclocking in the nvidia app. from there before the unlock my stock speed was 950 and I could boost it by 135 to 1085. this did not change after I unlocked the bios. does anyone have any tips for me?

Share this post


Link to post
Share on other sites

Hello. This is my very first post, so if i'm doing something wrong, please inform me to do it correctly.

My question is: Does anyone know how to, and where to download moded BIOS with advanced options for my Lenovo G580 (20150)? My current bios version is 5ECN96WW.

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello guys. Does anybody knows if the moded BIOS of lenovo y580 is applicable to Lenovo g580 (20150)?

Share this post


Link to post
Share on other sites
10 hours ago, Bill.gr said:

Hello guys. Does anybody knows if the moded BIOS of lenovo y580 is applicable to Lenovo g580 (20150)?

Hi!

No it's a different bios. If you want to unlock your bios, then you can send me your file backup of bios via PM. For creating backup of bios you can use attached program. Unzip attached archive directly on the Desktop and run the program as Administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.

https://www.sendspace.com/file/mxoavw

Share this post


Link to post
Share on other sites

hi!
i wanted to change my wifi card in my y580 which one you recommend to me? one of my freind told me the intel centrino 6200, is this ok?

 

Share this post


Link to post
Share on other sites
6 hours ago, Klem said:

Hi!

No it's a different bios. If you want to unlock your bios, then you can send me your file backup of bios via PM. For creating backup of bios you can use attached program. Unzip attached archive directly on the Desktop and run the program as Administrator (right click mouse). Program will create archive "results" directly on the Desktop. Send me this archive "results" via PM.

https://www.sendspace.com/file/mxoavw

Hi. i've send you a PM with my results file. Thanks for fast reply...!!! :)

Share this post


Link to post
Share on other sites
18 minutes ago, Bill.gr said:

Hi. i've send you a PM with my results file. Thanks for fast reply...!!! :)

Ok. Your mod bios done. I sent it to you via PM.

Share this post


Link to post
Share on other sites

O.K i received you PM. Thanks. I will try it later this night and reply here to let you know.

Share this post


Link to post
Share on other sites

Hey everyone,

 

I found the original full v8.01 Bios. I used the "DOS" folder inside to upgrade from 2.07 to 8.01 and then used the tutorial on page 1.

 

Use the button above to download the file (Arrow to the bottom)

http://pan.baidu.com/s/1z7Fki

 

Cheers

Share this post


Link to post
Share on other sites

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

Edited by Kurupt31509
Adding info

Share this post


Link to post
Share on other sites
2 hours ago, Kurupt31509 said:

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

 

Please see my link above your post. There you can download not only a nomal bios but a zip which has everything in it that could be interesting.

For example a crisis recovery image with a tutorial inside. Not tested but looks promising.

 

And again: The zip contains a bios with original 8.01 ecc data which should be interesting for everyone who wants to upgrade from 2.07 to 8.01. After flashing I had an original 8.01 and then followed the tutorial on page 1... works like a charm!

Share this post


Link to post
Share on other sites
2 hours ago, Kurupt31509 said:

I flashed modded v8.01 bios worked great i must have changed a wrong setting now pc wont boot stuck in on off loop im trying to blind flash original bios via fn+b then power on fan spins up but wont flash because i dont have the correct bios recovery file name i have tried phoenix tool to get correct file name but can not find it does anyone know the correct bios recovery file name please help!!!!! Thanks ahead of time it is bios 5dcn90ww.rom v.8.01

 

In the zip file from the link that Makinachan just posted, there is a folder called "Crisis," and inside of that folder is a readme and a bin file called "QIWY3.bin". Here is what the readme says:

 

Quote

*******************************************************************************************************************
QIWY3/QIWY4 System BIOS Crisis Release Notification           10/11/2012

[Checksum]:
QIWY3.bin    Checksum: B745 h

[Procedure]:
1. Save QIWY3.bin to device root directory
2. Shutdown the system and plug out AC.
3. Insert the device.
4. Press Fn + R.
5. Plug in AC.
6. Release Fn + R.
7. Power on the unit.
8. The process of Crisis runs automatically and will listen to warning beep sound.
9. The system will auto restarts and boot normally.

 

I don't see any recovery names appearing for a stock Y580 version 8.01 bios when I use the Phoenix tool to try and find one, but according to this information the recovery name to recover a Y580 version 8.01 bios should be "QIW3.bin."

 

I made this thread a while back which you might help:

The recovery process for recovering a Y580 bios should be the same as the one for the Y500, but I'm unsure as to whether or not it would work with a Y580 version 8.01 bios.

Share this post


Link to post
Share on other sites

does it matter what usb slot i use and does the size of usb matter 

should i keep the same bios file name or use QIW3.BIN

 

MY ORIGINAL BIOS WAS .ROM DOES THAT MATTER

Share this post


Link to post
Share on other sites

Should it be fn+r or fn+b either way im not having any luck im using an 8gb usb my 4gb doesnt have activity light

Share this post


Link to post
Share on other sites
On 18/10/2012 at 8:21 AM, svl7 said:

Lenovo Y500 - 'unlocked' BIOS / wwan-wlan whitelist removal

 

The Lenovo Y580 / Y480 comes with a pretty locked down BIOS, and in addition to this with a whitelist which prevents the user from getting 3rd-party wwan/wlan cards to work properly. The modified BIOS versions here will take care of this.

 

Keep in mind that not necessarily all options available in the modified bios will work. Some might not do anything at all, others could possibly leave your system in a state which will prevent it from booting. Use care when changing stuff in the modified bios, don't touch things you're not familiar with. Use all the mods and software posted here on your own risk.

NOTE: This will only flash the bios region. It won't reset the nvars set in the bios. While it is technically possible to update from v2.0x to v8.01 by using the method described below, I can't really recommend it since the EC of your system won't get updated. While it might work (possibly even without any issues) I can't recommend it.

Therefore if you're on v2.0x and want to update, the better option is to wait until Lenovo provides an official 8.xx firmware update with EC and BIOS. You can then still flash the modified version as described below, once you're on a proper v8.xx firmware.

 

Attached you'll find a modified version of the Y580 / Y480 BIOS v8.01 (5DCN90WW).

-----------------------------------------

>> For users with a v2.0x BIOS: <<

Download links

Old version:

Hidden Content

 

Current 2.0x version:

Lenovo Y580 / Y480 BIOS v2.07 (5DCN40WW) -> unlocked, whitelist removed, Nvidia 660m @ 1GHz default 3d clocks

Flash with the included InsydeFlash utility.

-----------------------------------------

 

>> Instructions for v8.0x BIOS users: <<

The attached BIOS ("Lenovo Y580 - Y480 BIOS v8.01 (5DCN90WW) - Mod") is unlocked, whitelist stuff removed and the 660m is tweaked to 1GHz default 3d core clock. 

The only way I know of which allows you to flash the modified BIOS for v8.01 users does unfortunately also describe certain information which you don't want to loose (serials, Windows licencse etc.). Don't worry, I got it all sorted out, but due to this the flashing procedure is a bit more complicated than usual. Make sure you follow the instructions carefully.

 

 

Hidden Content

 

It might look a bit complicated at first, but that's the easiest way I could think of. Let me know if anything is unclear.

 

 

The attached v8.0x modified versions include:

- unlocked menus

- whitelist removed (wwan / wlan)

- Nvidia 660m 'GHz edition' - 1000MHz default 3d clocks

 

>> Here's the 'buy me a beer' link in case you like this. Modding makes me thirsty :) <<

 

Use at your own risk, you are responsible for your system and the changes you make on it. My programs come with absolutely no warranty to the extend permitted by applicable law.

 

Thanks @X0pas1 for testing, and for some pics - see below:

 

  Reveal hidden contents

1qTSe.thumb.jpg.32a8331351d50af0e73fbb212N6Ed.thumb.jpg.a463a818f83ecbce034c98a5d8fPM.thumb.jpg.0d26d05e171c6f32e2440d92iCvPi.thumb.jpg.6f1a12ad602ff469b079e208K4JmK.thumb.jpg.e9d1075fa4e8b2ee89ceb823lScBM.thumb.jpg.0b262df1d08f0dab889cda0cpEZQJ.thumb.jpg.5180fdab03e0d8aad063296bWIupC.thumb.jpg.effb199e004e16ee1be08879

 

 

I'd appreciate it if someone could also post some pictures of the more interesting sub-menus, e.g. advanced CPU control, video settings and similar.

 

UPDATE 1/17/16

DOWNLOAD LINK FOR FILES REFERENCED IN THIS POST:

 

 

Hi. Can you do the exact same thing for my Lenovo G580 (20150) BIOS? In fact i have major problem with my bios. Won't boot, no logo, one short beep and black screen...tried almost everything without any luck. Thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By GrayCryptoSpordium
      Well everyone...I have a confession to make-I flashed svl7 modified 970m vbios before I wiped my drivers! Everything seemed to run fine, I could game but noticed my clocks fluctuating a bit crazy. Figured I'd try a OC profile in afterburner while running a 27 27 26 26 clock in TS a bit stupid I know. Well 3d mark froze so I did a reboot...Black Screen on startup I heard windows boot so I feared I bricked my card. Tried external monitor..works fine. This is where my stupidity really hit the cosmos. I had another m15x 900p LCD laying around plugged that in. Worked fine back too overclocking bro! Well same thing happened. My profile was not overly crazy as I can remember. But I bricked another screen. Plugged in external monitor everything fine. I was using latest nvidia drivers 436.48 I believe. So I wiped drivers using DDU. Reflashed to stock clevo bios. Tried both LCD again still nothing. Installed old 7970m still nothing. Cleared CMos again nope. Reinstalled 970m with svl7 vbios with newest driver and been gaming on my external monitor. Have done some OC with inspector. Everything seems to work as it should. Temps and performance are great. Did I brick my monitors??? Never heard of this problem. 
    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
    • By 9vul14
      Hey allI, I need help  with modding my BIOS. I was wondering if anyone could help me mod my BIOS to unlock the 'Advanced' tab which I don't have on my InsydeH20 F.52 Rev 5.0 Bios? Thanks so much and I look forward to your response! Laptop: HP Pavilion x360  ba109tx
       
      Specs: 
      i7-8550U
      Nvidia Geforce 940MX
      Intel(R) UHD Graphics 620
      12GB DDR4-2400 SODIMM RAM
      128GB SSD, 1TB HDD
       
      Laptop Product Page: https://support.hp.com/gb-en/document/c05650773
      Vanilla BIOS: https://support.hp.com/sg-en/drivers/selfservice/hp-pavilion-14-ba100-x360-convertible-pc/16851098/model/18161600
    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.