Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

I need to know exactly what you did. If the bios fix tool is used without following the instructions then it can cause issues, I guess I should fix that.

Was your original bios v8.01 or v8.00?

Share this post


Link to post
Share on other sites

Great, thanks for your support @svl7, first of all.

My original BIOS was 8.0, but by now I have to admit that I am only 80% sure of that (I read so much stuff within the last 6-7 hours to fix this problem)

I followed your page 1 tutorial for 8.x BIOSes. Still have my backup made within the tutorial. I had to use the Error 104 fix while dumping the backup, and also while flashing in DOS mode.

Dump and flash went flawlessly with the fix. I then rebooted and got stuck with the black screen. I tried several approaches from this thread, but with no luck at all (blindly resetting BIOS, 30sec Power button for the CMOS reset etc.)

Hm, that's all I can think of, if you need any more information, let me know.

Share this post


Link to post
Share on other sites

The problem is that flashing from v8.00 to v8.01 doesn't necessarily need to work, because v8.01 might need a different EC version, I can't tell for sure as I don't have such a system for testing.

The method in the first post only flashes the bios.

Can you send me the backup of your original bios per PM?

Share this post


Link to post
Share on other sites

@svl7, As you see a lot of members are very lazy to look& read all messages on this thread, so may be it will be usefull to publish FAQ in first post?

Share this post


Link to post
Share on other sites

Thanks for topic and good tutorial. I will make this BIOS "unlock" on my Y580 only when I will get acsess to files :)

Share this post


Link to post
Share on other sites

Hi there! I got an error 103 while trying to make a backup.

With original fpart:

Intel ® Flash Programming Tool. Version: 8.0.10.1464 Copyright © 2007 - 2012, Intel Corporation. All rights reserved.

Platform: Intel® HM76 Express Chipset

Reading HSFSTS register... Flash Descriptor: Valid

--- Flash Devices Found ---

W25Q32BV ID:0xEF4016 Size: 4096KB (32768Kb)

EN25QH16 ID:0x1C7015 Size: 2048KB (16384Kb)

Error 104: The 2 SPI flash devices do not have compatible command sets.

Share this post


Link to post
Share on other sites

I feel like a real fool. Can someone post screenshots of their step by step process for creating their BIOS backup? I have a Y580 8.01 WIN8 and whenever I trying to run fptw64.exe from my desktop, a command line window will open up and close in a blink of an eye. What the hell am I doing wrong????

Share this post


Link to post
Share on other sites

You need to use command line as admin. So start -> cmd -> run as admin -> cd to wherever fptw64 is -> run with parameters.

Share this post


Link to post
Share on other sites

After having the graphics card @ 1ghz for a few months, the fan grill became so brittle it fell off from the heat. The chassis started falling apart, and eventually I was plagued with heavy artifacting even after a stock bios flash.

Not sure if I had a faulty board, or if the heat will do this to every 580. I never used the computer on cloth or any materials that would cause improper ventilation.

Share this post


Link to post
Share on other sites

Hello svl7,

As promised, I have just sent you some drink money :)

I finally received my Intel AC 2760 chip the other day, which I installed and loaded Intel's drivers.

I've gone from dropping my wifi connection every couple of minutes to having a stable connection!

I think I still need to work on the Bluetooth setup, but at least the wifi seems to be solid now!

I couldn't have done that without your (Lenovo Y580 / Y480 BIOS v2.07 (5DCN40WW) -> unlocked, whitelist removed, Nvidia 660m @ 1GHz default 3d clocks) modified BIOS!

A huge "Thank You!" to you and everyone else that has assisted you in the work you've done on these mods!

Fitz

Share this post


Link to post
Share on other sites

Thx, Dude!

Allmost i have a other Question, iam still on Y580 with BIOS V2.07

If i want to patch the unlocked one, i got the message that the BIOS isnt newer than the one is installed .. any idea?

Thx!

Share this post


Link to post
Share on other sites

For those who have upgraded their wireless to ac7260. just a reminder regarding the bluetooth.. If your bluetooth disconnects randomly, remember to disable power manangement.

Power Management: Device Manager -> Bluetooth -> Intel ...Bluetooth ...-> (right click -> properties) -> "Power Management" tab -> Uncheck "Allow this computer ...to save power"

Share this post


Link to post
Share on other sites

Whats the diffrent between BIOS 2.07 and 8.00? I have 2.07 and Win8 64bit. It make PC slower or somethink bad like this?

Now I am confused. When I tried to use 2.07 version I can see Error:

"The version of rom file isnt newer than version of bios."

I checked, I have got 2.07 BIOS version. But I tried aslo do a copy of bios, from 8.0x tutorial I got Error:

"Error 200: Invalid parameter value specified by user. Use -? option to see help."

So, what I should do?

Share this post


Link to post
Share on other sites

in the file "platform" in the first line set RESSDIS and flashing 2.07 to 2.07(unlocked) will be available

Share this post


Link to post
Share on other sites

I wish I can.

No, I didnt backup original BIOS. The tool didnt work on my laptop. I have Win8 64bit and 2,07 BIOS.

Share this post


Link to post
Share on other sites

Hey! What disadvantages may I have by having the v2.07 BIOS?

I want to upgrade to a Centrino N6205.

I am running Windows 8.1 64 bit (config below)

MaximX

Share this post


Link to post
Share on other sites

I bricked my notebook whith flash modded bios 8.1. I follow instruction but when I start notebook it's blackscreen and nothing more. Need help.

Share this post


Link to post
Share on other sites

Then you most likely did not follow the instructions properly. What exactly did you do? Step by step. What was your original bios?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.