Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

would be great to see an unlocked no whitelist bios along with a GHz edition vbios just like the dell, and a little bit overvolt~

keep up the good work svl7!

Share this post


Link to post
Share on other sites

hey svl7 i dont have any permissions on this forum. i cant pm and posts are delayed.. also i cant download at all.. any other method to test out this bios of yours?

Share this post


Link to post
Share on other sites
svl7-I tried to download the mod bios without the WLAN whitelist to try and was not allowed too. I'm wondering if you are still testing it and will you make it available to the rest of us? By the way great work in unlocking the bios!

Nope, it's working fine, and it's attached to the first post, you should be able to download it. Public link coming soon.

would be great to see an unlocked no whitelist bios along with a GHz edition vbios just like the dell, and a little bit overvolt~

keep up the good work svl7!

Yeah it would :P Hahaha, I'll see what I can do.

hey svl7 i dont have any permissions on this forum. i cant pm and posts are delayed.. also i cant download at all.. any other method to test out this bios of yours?

Read the forum rules, you need 5 quality posts in order to download attachments. The unlocked bios is already available to everyone, public link in the first post. Whitelist bios will follow.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

is there any kind of special flashers that we need to use this, or is the flasher bundled in the zip file? (sorry, haven't downloaded nor tried yet due to the fact that i'm waiting for further updates)

and also another question, would you be able to disable the intel hd 4000 and just use the nvidia graphics after this custom bios? i'm having issues with windows 8 where i can't control the brightness since intel hd 4000 is the main controller, nvidia has working drivers so i think that'll fix my problem if it is possible.

Share this post


Link to post
Share on other sites

Just download it and read the file in there... it's all described.

And yes, you should be able to use the Nvidia card as primary device, but I'm not sure whether this will solve your brightness isssue, due to Optimus your system will always use parts of the HD4000 cause it's needed to bring the picture to the screen.

Share this post


Link to post
Share on other sites
Just download it and read the file in there... it's all described.

And yes, you should be able to use the Nvidia card as primary device, but I'm not sure whether this will solve your brightness isssue, due to Optimus your system will always use parts of the HD4000 cause it's needed to bring the picture to the screen.

ah rats, guess i'll have to wait until Intel fixes it for Windows 8

I'll update my bios once a GHz edition for the video card pops up. I'm greatly looking forward to that =D

Share this post


Link to post
Share on other sites

I get the following error "The version of rom file isn't newer than version of bios."

I have already installed your unlocked version, now I am trying to install the unlocked/no whitelist version.

Please advise.

Share this post


Link to post
Share on other sites

Damn, forgot to change this... you'll need to modifiy the platform file, first line in the 'common flash' section -> change RESSEN to RESSDIS and try again.

Share this post


Link to post
Share on other sites

@svl7: your unlocked bios works awesome! i'm hoping to change the wlan card since there's no whitelist now anyways. btw, any news/eta on the vbios OV/OC?

Share this post


Link to post
Share on other sites

Bought a 6205 card off of Amazon, do a search for product code B004NNZB4A, and swapped it in my Y580 with the unlocked/no-whitelist BIOS. Connected to the 5ghz on my WNDR3700. Works great and much better than the stock 2200N that was in here. Thanks again for your work svl7 on the BIOS and empirehell on your wifi card recommendation!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I installed the Lenovo Y480 / Y580 BIOS version 5DCN39WW (V2.06) [unlocked]. excellent! But there is a problem. I can not change the fan speed depending on the temperature. In the BIOS change but really do not.

Share this post


Link to post
Share on other sites

There's a whole section for temperature and fan control on the new bios. Try peeking around more.

Share this post


Link to post
Share on other sites
I installed the Lenovo Y480 / Y580 BIOS version 5DCN39WW (V2.06) [unlocked]. excellent! But there is a problem. I can not change the fan speed depending on the temperature. In the BIOS change but really do not.

I agree. I have tried:

Low Speed/Temp 60%/70%/80% fan @ 40 C / 40 C / 45 C / 50 C

+

High Speed/Temp 100% fan @ 50 C / 55 C / 60 C / 60 C

There's a whole section for temperature and fan control on the new bios. Try peeking around more.

Do you say this because you found how to correctly control fan speeds and are being cryptic or have you not tried o.O

Share this post


Link to post
Share on other sites
Damn, forgot to change this... you'll need to modifiy the platform file, first line in the 'common flash' section -> change RESSEN to RESSDIS and try again.

can u tell us where we can find the platform file?

Share this post


Link to post
Share on other sites
Do you say this because you found how to correctly control fan speeds and are being cryptic or have you not tried o.O

i just saw the menus, but left it on default. does it not work? =O

Share this post


Link to post
Share on other sites

Not necessarily all available options will work, there's a reason why some of them are hidden. The bios vendor always uses the same framework, so there might be hidden settings available which don't work with your system.

can u tell us where we can find the platform file?

Extract the downloaded file, it's packed in there.

Share this post


Link to post
Share on other sites
Not necessarily all available options will work, there's a reason why some of them are hidden.

Yeah .. like WOL wil never work..

the reason for that is that the motherboard in a shutdown state is not supplying power (even with AC on) to the network adapter so it can't be waken.

but options are in the bios.

I'm looking forward for a vbios.. thanks. svl7

Share this post


Link to post
Share on other sites

Hi! I'm trying to install a 6205 and I want to install the no-whitelist bios

However, after unzipping and executing the file, i get a DC Detect error!

What am I doing wrong? :o

Share this post


Link to post
Share on other sites
Do you have your AC adapter plugged in?

Yup! I haven't plugged in my battery yet, It's running on power.

Is it my power settings or something?

Share this post


Link to post
Share on other sites

Ok, then plug in your battery as well, then it should work.

For security reasons you need both, battery and AC in order to flash, or you need to modify the flash settings in order to circumvent these security measures.

Share this post


Link to post
Share on other sites

Be advised !

If you try to completely disable your INTEL video card using the new settings/options made available in the new unlocked y580 bios you will disable as well :

the laptop LCD screen and the HDMI port

since the lcd screen inverter and the HDMI output are directly connected/tied thru the motherboard to the INTEL GPU on the processor ... no bios option will be able to disable it properly because its not designed for that at the circuitry level

On this machine design you can disable the NVIDIA GPU completely but not the other one (the Intel graphics or IGFX) ... when all enabled the intel one manages the Nvidia and the switching goes on thru the optimus scheme implemented at hardware/driver level between the intel GPU inside the CPU and the Nvidia GPU

http://www.nvidia.com/object/LO_optimus_whitepapers.html

Share this post


Link to post
Share on other sites

That's correct, that's also why I advise all users not to change anything they're not familiar with (first post). There are more options which can cause the system to not boot after changing them.

Share this post


Link to post
Share on other sites

Intell Centrino-N 6300 wont work with this modded bios, it's install, looks like everithing well, but can't connect to any wireless AP.

I modified bios by replace some not used DEVID with 6300 DEVID and card run in proper.

Here is zip with ROM and InsydeFlash Y580_n6300wifi_whitelisted.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Klem
      In this thread you can post your requests for Lenovo G780.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, in this case you can post your request in this thread.
       
      For prepare unlocked bios you can post your request in this thread, upload your file bios backup into any fileserver and post the download link. Or you can send me your file backup of bios via PM.  For creating backup of bios use attached utility. Extract attached archive directly on the Desktop and run Backup Utility as Administrator (right click mouse, choice "Run as Administrator"). Utility will create archive "results" directly on the Desktop. Send me this archive "results" via PM.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By Krak
      Hi everyone, I have a problem. I need to unlock the bios settings because I only have basic functions and I need to increase the memory of VRam. Sorry if I posted a post not in this topic.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad X240.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden advanced menus and settings in bios setup menu, or upgrade to new display (with brightness control), then you can post your request in this thread.
      Important!
      For creating your personal bios dump and to flash your bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/itm/USB-Programmer-CH341A-Series-Burner-Chip-24-EEPROM-BIOS-Writer-25-SPI-Flash-AU/153117073868?epid=577511738&hash=item23a67d21cc:g:XKEAAOSw5UdbW-iL
       
      https://www.amazon.com/Parts-tower-CH341A-Programmer-Software/dp/B01FVVHCVC/ref=sr_1_4?ie=UTF8&qid=1522179315&sr=8-4&keywords=ch341a&dpID=51BO7eGgO5L&preST=_SY300_QL70_&dpSrc=srch
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/MAUSAN-Socket-Adapter-150MIL-205MIL/dp/B06ZYSNJF3/ref=pd_sbs_21_3?_encoding=UTF8&psc=1&refRID=XM79QJWGED6B4K2VEZDJ
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.