Jump to content
terzer

Dell Inspiron 7720 650m GDDR5 modded vBIOS

Recommended Posts

at least it would be great if the overclock limit would be remove...

but since we have an unclear probleme with bricked inspiron i think we first should check up this before we rebuild this modded vbios into the bios.

i can put it back into a bios, but i don´t think it helps when the newer models still brick.

and its far above my skills to figure out whats the problem. so we have to wait until the russians or svl7 figure it out.

slv7 is realy busy at the moment. so please all be kindly and wait until he found some free space. i´m sure he will help us :)

Share this post


Link to post
Share on other sites

I will get a new Mainboard from Dell. The bios mod is dead for me.

Since nobody has an explanation for the brick problem, i wouldn´t recommend flashing it to newer models.

The fact is, the notebooks get bricked after complete power loss. If you don´t remove battery it will run without problems. But this is no solution...

I think if you remove the power supply and battery, something gets erased from the memory, maybe the UEFI Bios is alsways loaded into RAM for fast boot or something like that (i´m no expert, i just try to explain this behaviour). And after power loss it has to be loaded again into memory, thats where the brick occures?? Is the checksum from Mod bios and OEM the same? Maybe its different and gets checked when its loaded to memory after power loss? And this leads to brick?

Although its strange that the bios recovery doesn´t work... maybe its different on our inspiron than on other dell notebooks. I saw my usb stick only light up one time, then nothing happens. It seems that the notebook is checking for files on the usb stick, but can´t/don´t want to read it because something is wrong. Maybe the BIOS.CAP has to be named different? I really don´t know whats wrong here.

Share this post


Link to post
Share on other sites

I have not used videobios from svl7 .... yes, I analyzed it videobios to understand what has been done ... it was not hard ...

Share this post


Link to post
Share on other sites
I have not used videobios from svl7 .... yes, I analyzed it videobios to understand what has been done ... it was not hard ...

oh hello russian friend,you´re the guy with the bios mod from the russian board we talking here,right? :)

your mod runs pretty fine for the 3610QM model.

maybe when you remove the gpu overclock limit,it would great :P

anyway, cool thing you are here with us :)

EDIT: in your russian forum you talk alot about a 230W PSU. does anyone have it already?

Share this post


Link to post
Share on other sites
Nah, I modified A11. Vbios is at 970MHz? So they used my vbios...?

Nope, Olehkh didn't.

- - - Updated - - -

oh hello russian friend,you´re the guy with the bios mod from the russian board we talking here,right? :)

your mod runs pretty fine for the 3610QM model.

maybe when you remove the gpu overclock limit,it would great :P

anyway, cool thing you are here with us :)

EDIT: in your russian forum you talk alot about a 230W PSU. does anyone have it already?

Dear friend, Olehkh didn't do any limit or whatever else into the opened BIOS. it's the totally opened mod.

Share this post


Link to post
Share on other sites

I want to make a small clarification, I'm not from Russia, I'm from Ukraine :) but it's not important ... more important for me to find out why it was felt that my BIOS version ONLY works with processors 3610M ....

Share this post


Link to post
Share on other sites

Dear friend, Olehkh didn't do any limit or whatever else into the opened BIOS. it's the totally opened mod.

hmm that is strange... because i tried so manny things and alway get stuck on 1020 mhz gpu coreclock speed. maybe it was a little bit to late yester day. (around 4 AM :D) and an i failed :P

i try it again :)

I want to make a small clarification, I'm not from Russia, I'm from Ukraine :) but it's not important ... more important for me to find out why it was felt that my BIOS version ONLY works with processors 3610M ....

oh i´m sorry, im no expert on this. :(

some of us think there is another mainboard layout,but i can´t check because all of my friends have the same model like me.

EDIT: okay now i tried a lot of things to overclock. cant find any option for that in the open bios. so i tried software overclocking and nvidia inspector doesnt work for me. i tried serveral power states but none work. only Pstate 0 work. and even if i use a batch file(1100mhz set there), it only increses the clock speed about +135 mhz.

batchfiles are fine ;)

msi afterburner also has its limit at +135mhz.

may i have missed the wrigh option o unlock this in the bios settings??

Share this post


Link to post
Share on other sites

Let's wait until smb. make mod based on the Lenovo 16th vbios. the aim is 1200 MHz but we'll see how it goes...

Share this post


Link to post
Share on other sites
Can somebody with newer 17re SE and i7 3630qm dump his bios with this toolkit:

Universal BIOS Backup Toolkit

Please upload the cap file, this would maybe help recover my bios!!! I have an idea...

Dump the BIOS to do their own utility dosflash ... option-bak filename

Share this post


Link to post
Share on other sites
Can somebody with newer 17re SE and i7 3630qm dump his bios with this toolkit:

Universal BIOS Backup Toolkit

Please upload the cap file, this would maybe help recover my bios!!! I have an idea...

plase note, the best way to make BIOS dump is to use the standard Dell's utility like that:

dosflash -file BIOS.cap -bak a12, where "a12" is the dump's filename you choose

Share this post


Link to post
Share on other sites
Can somebody with newer 17re SE and i7 3630qm dump his bios with this toolkit:

Universal BIOS Backup Toolkit

Please upload the cap file, this would maybe help recover my bios!!! I have an idea...

by the way, that idea? I described how to restore bios to 7720 .... you tried to restore the BIOS according to my instructions?

Share this post


Link to post
Share on other sites

@Olehkh

What do you mean with "vidnvyty" ?

I tried the bios directly from Dell (extracted A12 Bios.cap) like you described in your instruction. Didn´t work...

I also tried a bios wich an another user uploaded long time ago on bios-mods.com. Same issue... still bricked.

Whats the trick with this Notebook to get it recovered??!?! I can´t believe that its fully bricked, because bios was working till power loss.

And it seems that the Notebook tries to read from USB, because the LED on the USB Stick flickers one time if i power on through plug and "end" button trick.

Share this post


Link to post
Share on other sites
@Olehkh

What do you mean with "vidnvyty" ?

I tried the bios directly from Dell (extracted A12 Bios.cap) like you described in your instruction. Didn´t work...

I also tried a bios wich an another user uploaded long time ago on bios-mods.com. Same issue... still bricked.

Whats the trick with this Notebook to get it recovered??!?! I can´t believe that its fully bricked, because bios was working till power loss.

And it seems that the Notebook tries to read from USB, because the LED on the USB Stick flickers one time if i power on through plug and "end" button trick.

i tried now the recovery method that plehkh has written at my own and it works pretty fine ;)

i write you a message in german,maybe that helps

now im out of options trying to getting higher then 1020 mhz gpu core speed.

i also tried a lot of options in the bios,but none seems to work.

Share this post


Link to post
Share on other sites

@gebiter

i tried the method from your message many times. It doesn´t work.

My 7720 came with A11 bios and the Windows 8 key is integrated into the bios.

I updated on the first day to A12. It worked flawless.

The older versions of 7720 didn´t have the key integrated into the bios, so here´s maybe the issue...

When somebody gets a new mainboard on this notebook, he also gets now a Windows 8 DVD with a key (i have read this somewhere...).

On the replacement mainboard the key isn´t stored anymore on the Mainboard, thats the reason why you get a DVD + Key.

The russians are thinking that here´s maybe the problem for bricks on the new models...

Share this post


Link to post
Share on other sites
@gebiter

The russians are thinking that here´s maybe the problem for bricks on the new models...

this is a false statement

P.S. detailed description of how you tried to restore the bios .... maybe you made ​​a mistake

Share this post


Link to post
Share on other sites

i heard about the key in the bios as well,my old dell has that to. so when i get the inspiron last summer i think they maybe have changed it.

good to know ;)

Share this post


Link to post
Share on other sites
this is a false statement

P.S. detailed description of how you tried to restore the bios .... maybe you made ​​a mistake

1. Formated a 1GB USB Stick as FAT

2. Extracted BIOS.CAP and DOSFLASH.exe from 7720A12.EXE

3. copied BIOS.CAP + DOSFLASH.exe to USB Stick

4. Put USB stick into first USB PORT (directly beside the audio out)

5. Press and hold END Button then plug in power suppy plug into Notebook and release END Button

6. Notebook turns on, Fan is running at full speed and USB stick lights only 1 time up

7. Nothing more happens, screen stays black and fan spinning at 100%

Share this post


Link to post
Share on other sites

I found that to recovery flash the bios I had to put the USB drive into the port closest to the HDMI port, not closest to the user. I have a 3610QM version of the PC

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

My mainboard got fixed today. The new one has no W8 Key on it !

Its a refurbished board... also the new PSU came. voltage still drops to 1012mv and oc over 950mhz is not possible.

If i could raise the voltage, it could maybe help. But i don´t want to flash bios mod again and brick my notebook!

@Olehkh

do you need a dump from my bios? The new mainboard was A10, i flashed today A12 without problem

Share this post


Link to post
Share on other sites

maybe the voltage from the GPU drop but i think thats the fault of the original bios.

hmm,when you get a refurbished board you may can recover your bios. just try the mothod that olehkh has posted before with original bios ;)

when it works and you can "recover" ,i think you may can use a bios mod.

but thats just an idea ;) don´t try it when you not want

Share this post


Link to post
Share on other sites

@gebiter

recovery works, i just tried it with oem A12 bios.

Can i load the Mod Bios from USB just for testing?

I don´t want to flash it yet, because I´m not shure what will happen...

Maybe recovery just works, because my mainboard is now ok. And it also could have been working on my old Mainboard, but i never testet it before brick. So its hard to say...

Share this post


Link to post
Share on other sites
My mainboard got fixed today. The new one has no W8 Key on it !

Its a refurbished board... also the new PSU came. voltage still drops to 1012mv and oc over 950mhz is not possible.

If i could raise the voltage, it could maybe help. But i don´t want to flash bios mod again and brick my notebook!

@Olehkh

do you need a dump from my bios? The new mainboard was A10, i flashed today A12 without problem

Frankly, I do not see any problems in the firmware mod models 7720, which completed win8 ... additionally can advise sew fashion dos mode only, after installing Boot List Option - Legacy ... so let your dump ... I personally for you can make your fashion dump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.