Jump to content
EwinRacing Flash Series Gaming Chairs
Brian

OFFICIAL: Alienware M18x Owners Lounge

Recommended Posts

I Have an aw18 with similar screen bleed, but mine is also bleeding from the middle just above the Alienware logo on the screen... its doing my head in...

i cant live with it either, im going to call AW and ask for a replacement... only just had my sound problem repaired, complete motherboard change. i hate it when you buy a new machine that is so expensive and someone comes around and tears it apart....

fingers crossed the screen i get is dead pixel free and no light bleed.... i have a feeling this is going to get painful...

i will post a picture later...

thanks

Ian

Share this post


Link to post
Share on other sites

i know what you mean, i hate it as well, you spend lots of money and get only a long line of waiting an repairs in the worst case..

technician chenged the panel, now its horrible! he was like 'maybe it's built to be this way'. i wanted to slap the stupid s%*#. write away contacted dell againnow i have to wait for an answer till monday. this is so damn annoying.

here is a pic of how great it looks, just so everyone has to suffer with me 😉

uzuvebu8.jpg

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hehe that's why I voted leaving the original alone. IPS is infamous for bleeding and glowing corners.

Sent from my GT-N7000

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

i knew ^^ but that voice in my head made me believe there is a small chance it might turn out ok😉 well, i'll wait for the answer of dell tomorrow -.-

Share this post


Link to post
Share on other sites

so tonight i got fed up, took this thing apart and fixed this sh*% myself, so now i have pretty much no bleeding anymore, just a liiiittle bit which i'm only able to see in total darkness with a complete black image on the screen :D now i'm actually enjoying the machine! :D

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

first i took away the front bezel with the alienware letters on it. then i unscrewed the display pannel. then i noticed, that unscrewed, the bleeding was just maybe a third as bad (since bending the screen makes it worse). still had one bad corner though. so i checked in which direction the pannel needs to move in order to get rid of the bad bleeding part. then i unscrewed the metal frame on that side of the pannel and bent it just a little tiny bit in this direction, rescrewed it into the frame and checked again. when i was satisfied, i put the screws back in. there is one screw in the lower right of the metal frame which i didn't tighten all the way, as it would keep producing a glowing corner (and i was just too tired to unscrew everything and bend it some more). then i put the bezel back on. now almost all of the bleedkng is gone, i only got maybe a fourth of what i had in the beginning with the original pannel =)

Share this post


Link to post
Share on other sites

hi all

i have two question to aw18 with 780m sli owners:

1. yesterday i've been playing farcry 3 with stock clocks etc. no oc on the gpus. i was playing for maybe 10 - 15 minutes and the gpus maxed out at around 85 degrees c. what are your temps on these cards?

2. i ran some 3d mark vantage and got something over 34k, while i hit 38k with my m18-r2 (oc on the gpus though). is this 'low' score normal or is it supposed to be much higher?

and the fan tables are so bad, i read about it but couldn't believe they are this bad -.- i'm used to use hwinfo and have the fans spin some more than with the regular ec, but the systems stays cool (i never hit over 72 degrees on the gpus, not even 3 hours of crysis). but with this system, fan control is not usable so we have to rely on the dell fantables, which make the fans spin way not enough..

Share this post


Link to post
Share on other sites

Hello all, I have got a Alienware m18x r3 but what i need to know is their a unlocked bios mode for this laptop and if yes which one is the best one for using thanks to anyone that can advise me ......

Share this post


Link to post
Share on other sites

Flashing unsigned firmware per software is locked down. If you want to use an unlocked bios you can buy a bios chip with an unlocked bios from me and do some soldering on your board. that's currently the only way to get all options in the bios.

Share this post


Link to post
Share on other sites

@sv17 ​thanx but no thanx dont fancy damaging my new lappy.....thanx anyway

- - - Updated - - -

@sv17 i have flashed my 780m sli thanx to you but could you give me a stable setting for the overclocking as at the moment i have the core clock set to 950mhz but i have not touched the memory speed yet ....

Share this post


Link to post
Share on other sites

Although I'm new here. I've had an Alienware m17xR3 for almost 3 years now. I've now purchased an m18x with the following specs:

Intel i7-4930MX

32GB 12800MHz

Dual GTX 780M

triple play SSD where I pulled out the 3 SSD's

Replaced them with an Intel 480GB 530 series, a 1TB storage HD, and added a slot-load optical drive. The 256GB mSata drive is solely for games (Steam)

I'm having power up issues. After turning off the laptop, it sometimes refuses to turn on, even though it is cool as a cucumber.

I notice that this happens when I power down while still in SLI and I don't have power connected on first power-up attempt. I can plug the power in and it still won't power up. But if I power up after shutdown with power plugged in, it seems to be ok.

If I reboot after turning off SLI, I haven't experienced this problem (yet), as I don't do it often enough.

Has anyone experienced a similar issue? I'm thinking that it's a BIOS issue, due to the load of the cards on the battery. But why doesn't it turn on if I plug power back in? Could it be in an indeterminate state?

Share this post


Link to post
Share on other sites

i had this issue on my m17x-r2 with an amd 6990. but there, the laptop just wouldn't power on on battery if i oc'd the card. without oc, no probs, bit as soon as it used more juice on startup, no luck.

btw i had probs with the background bleeding again. now i just took the two support rods off the pannel, now all my backlight bleed issues are completely gone 👍 =D

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Failure to power up after OCing is understandable. My work colleague has a m17x R1 that has SLI graphics. If he powers up on battery, the BIOS settings automatically disable SLI. I'm surprised that Dell hasn't done that across the board.

I have a warranty on the laptop, but I'm afraid that if I call in, they'll simply recommend swapping hardware to see if anything changes.

Share this post


Link to post
Share on other sites

so i finally got the liquid ultra and did a repaste job on my 4930mx, as well as i repasted both 780m's with ICD24.

here is a 3DMark11 run with the same settings (cpu @4.0GHz - GPUs +80 / +100 since this is my 24/7 setting).

check the temps ^^

post-1903-14494996896077_thumb.jpg

  • Thumbs Up 3

Share this post


Link to post
Share on other sites
so i finally got the liquid ultra and did a repaste job on my 4930mx, as well as i repasted both 780m's with ICD24.

here is a 3DMark11 run with the same settings (cpu @4.0GHz - GPUs +80 / +100 since this is my 24/7 setting).

check the temps ^^

[ATTACH]10231[/ATTACH]

Head over to the Notebook review. There is a thread dealing with the Coollaboratory Paste.

Repasting M18xR2 with CooLaboratory Liquid Ultra, any tips before I start?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Flashing unsigned firmware per software is locked down. If you want to use an unlocked bios you can buy a bios chip with an unlocked bios from me and do some soldering on your board. that's currently the only way to get all options in the bios.

I have a m18xr2 with bios a12 . can I flash a flash with nodded bios or not .

Also it has GTX 675m n Sli . performance is OK but can I manage to get some more from them without. Destroying them .

Xheers

Sent from my V5 using Tapatalk

Share this post


Link to post
Share on other sites

Whats up GUys.

I am new to this forum but i am considering purchasing an Alienware 18.

here are the main specs

Intel Core i7-4910MQ Quad Core processor

Dual NVIDIA GeForce GTX 880M graphics with 16GB total (2x 8GB) GDDR5 - NVIDIA SLI Enabled

1 TB RAID (7200RPM) + 80GB mSATA SSD Caching

32GB Dual Channel DDR3: at 1600MHz

Dual layer Blu-Ray Writer/Reader (BDRE, DVDRW, CDRW).

I have a Sager NP9380-S but it has been discontinued and its not really a looker so i wanted to get an Alienware 18 for the screen size and the fact that Alienware is also a BEAST of a laptop. I was considering getting an upgrade to the 880m for my 9380-s but i saw when the cards came out from JohnKiss's review that they throttle at real bad. Looking and researching the forums i guess the issue of the cards throttling has NOT been addressed. I am still thinking of getting the ALIENWARE and just use 780m drivers until the issue of throttling is addressed. How are the framerates for games with theses cards? How bad is it throttling now with new 880m drivers? I wanted 2 play watchdogs and hopefully GTA V when it comes out and hopefully i can get 60fps+ with these cards and a good vbios or driver. Any thoughts or incites? Thanks

Share this post


Link to post
Share on other sites

HI all.

Im new on forum and i need help. It is time that i refresh my R1 and what i want is to get new termal pads for gpu heatsinks but i was woderint are they actualy needed?

I have 2x HD6990m wht 100W 3x chopper AMD heatsinks. On one of them all pads fell off.

Share this post


Link to post
Share on other sites

Hi can someone please help me. My gpu clock started stucking on max 715/900 on my HD6990m in idle :(. Can anyone help me fix this? Nothing is running in back. i have no idea what happend.

Share this post


Link to post
Share on other sites

I'm entertaining the thougt of upgrading my M18x r1 with a newer/stronger CPU and GPUs.

my specs at the moment are:

i7 2670QM

2x HD6990m

16Gb RAM (Original)

512Gb Samsung 850PRO SSD

1000Gb Hitatchi Travelstar

I think a new CPU with the 3pipe Heatsink would be the best choice but i dont know wich CPU fits and is supported.

I would like to keep the GPUs for now because i think they are still pretty fast, if they can work toghether properly (some games dont realy like Xfire)

Any Suggestions?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Henrik9979
      First I want to thank the community, who have inspired me to do this project.
      I will give you guys the chance to follow me on this journey.
       
      I hope you will all help me come up with ideas, techniques and parts that could become handy.
       
      This modding may be possible to convert to allot of laptops.
       
      Let's begin!
      Here is the measurement of the went hole.
      77mm X 16mm

       
      I have 2 ideas for what can be done.
       
    • By svl7
      Patched this together on request, M18x R1 BIOS A05 (unlocked) with the RST 11.5 OROM.
      The orom comes from the station-drivers site, not sure whether it will work fine with the M18x, though I don't really see why it shouldn't.
      Btw, something's weird with the original orom in the R1 BIOS, the checksum is wrong... confusing.
      Anyway, here's the BIOS, let me know how it performs. Also remember to use the latest RST driver for this ROM.
      Flash with your favorite BIOS utility or the tools provided by Dell.
      As always, use at your own risk.
       
      Download link:
       
    • By gaffycool
      Hi everyone,
      I am having issues with my gtx 880m. I currently have a m18x r1 unlocked a05 bios and modded drivers (368.69 also tired 372.90)
       
      basically when im playing battlefront the game plays for about 1 min, and then crashes and I got this direct x error message on screen (shown in pic below)
      I managed to fix this error by turning on vertical sync in settings in the game and also in the nvidia control panel (it was set to auto, or adaptive and I changed this to on), and this fixed this create texture error.
       
      Now I am getting a completely new error and I was able to play the game for now more than 1 min, usually around 10-12 mins before crashing, i am now seeing a new error,
       
      directx function "DX11 Renderer::tryMap" failed with DXGI_ERROR_DEVICE_REMOVED ("The video card has been physically reomved from the system, or a driver upgrade for the video card has occurred. ").
       
      I have tried to change drivers, change clock speeds, turn off overclocking and running everything on low, I have also tried to delete the ndvi64.api file from system32 as suggested in an ea forum, and still no luck.
       
      Anyone else had this error? took me 3 days to finally get the gtx 880m to work in the mx18 r1 and now the only game that plays is battlefield, which works floorlessly on ultra for 4+ hours game play constantly with no issues. but its just when I play battlefront it crashes
       
      ive tried to even do the directx web installer to install latest files and still didnt work..
       
      any help would be appreciated and im sure would help out alot of mx18r1 users or gtx 880m users out there.
       
      thanks
       

       
      then I managed to fix this error
    • By Brian
      Since we didn't have one yet, this is it. I'll update this post with the newest driver releases,and news for the R3. Please keep all M17x-R3 posts confined to this thread if possible.


      System Files Download Links System Bios Bios A03 Chipset Intel HM67 Cougar Point chipset, Intel Management Engine Interface Audio IDT 92HD73,A00. If the Dell IDT driver gives you problems, try this one. Card Reader Realtek RTS5209 Card Reader USB 3.0 NEC USB 3.0 Touchpad Synaptics TouchPad - 15.1.19, A00 Bluetooth Dell Wireless 375 Bluetooth Module - 6.3.0.6300, A00 Dell Wireless 1501 Half Mini-Card Dell Wireless WLAN 1501 Half MiniCard - 5.60.48.35, A00 Intel Wireless 6300 Intel WiFi Link 6300 - 13.3, A00 Intel WiMAX Link 6250 Intel WiMAX Link 6250 - tic TRFXW0115MUP, A06-1 Intel Wifi Link 6250 Intel Wifi Link 6250 - TRWFW1318D,A04 Atheros AR8151 Atheros AR8151 - 1.0.0.36,A00 Intel Rapid Storage (HDD) Intel Rapid Storage Technology - 10.0.0.1046,A00 Free Fall Sensor ST Microelectronics DE351DL Free Fall Sensor - 2.00.11.14, A00 AMD 6870M Display AMD Mobility Radeon HD6870 - 8.80.6-101202a-109902C-Dell.4, A00 Intel HD Graphics 3000 Intel HD Graphics 3000 - 2246, A00 nVidia Internal 3D Stereo Controller nVidia Internal 3D Stereo Controller - 266.08, A00 nVidia GeForce GTX 460M nVidia GeForce GTX 460M -266.08, A00 Alienware OSD Alienware OSD Application - 0.31.0.8C, A00 Alienware Command Center Alienware Command Center - 2.6.2.0, A00 Alienware Wallpapers Alienware Wallpapers - A01 Alienware GUISE custom theme Custom Desktop Themes - A-02 Alienguise Theme Combo-Win7   Intel Management Engine Interface
    • By CoolSheep
      Hi
      My m18x has dual 580m and I can't switch to them, fn-f7 just boots the Intel graphics. I might also get "Error : MXM Structure not found or invalid"Anyone know what the problem is?
      Thanks
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.