Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
svl7

Sony Vaio SVS13 / SVS15 series - 'unlocked' BIOS - tester(s) wanted

Recommended Posts

Hey guys, I've seen that the Sony Vaio SVS13 / SVS15 series vbios mod is relatively popular, so you might as well be interested in a bios with the hidden menus available.

If someone wants to test it, let me know. Also if someone could post screenshots of the current bios menus, that would be nice, thanks. :)

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

An unlocked BIOS would be pretty cool, especially one that unlocked SATA-3 speeds for the drive (though that may be very difficult to achieve).

Here are pics of the BIOS options: SVS15 BIOS options - Imgur

Didn't take a pic of the main tab, but you can only set the date and time there and it shows the serial numbers, UUID, etc.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Alright, if you (or anyone else) wants to test it, let me know, then I'll send it to you.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Alright, if you (or anyone else) wants to test it, let me know, then I'll send it to you.

If's there's a way to force a flash back in case something goes wrong, I can test it.

Right now I've got your BIOD with 950 \ 1000 clocks and it's working like a charm.

What did you unlock, some hidden menu?

Thanks for working on it wayway

Share this post


Link to post
Share on other sites

There's the Insyde USB recovery method, though there shouldn't be any issues. The mod should make all hidden menus and options available. If it works I can combine it with the vbios mod.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Doesn't that method vary depending on the laptop? I don't know what the method is for this specific machine :X

Anyway, I'm willing to test it, hoping it doesn't brick anything because I can't really afford a bricked laptop now.

Maybe I'll try to flash it using the USB recovery method to ensure there's a working recovery method.

Share this post


Link to post
Share on other sites

No, the key combo may vary, but the concept generally stays the same for all modern Insyde uefis.

I recommend flashing the mod with the InsydeFlash utility provided by Sony.

Share this post


Link to post
Share on other sites

I used the InsydeFlash for the 3 vBIOS mods I tried, the ones that came with the BIOD mod itself (like the ones you made).

Worked without problems in Windows 7 64bits and Windows 8 64bits as well.

When you have the mod ready you can give it to me so I can test it.

Anyway, thanks for the work done, I wish I knew the tools to make that possible ;)

Share this post


Link to post
Share on other sites

Oh right, hahahaha, I still haven't uploaded it. Will do so after dinner, check back in an hour or two. Sorry :D

Share this post


Link to post
Share on other sites

So, here you go. Flash with the InsydeFlash utility which is included in the official Sony updates.

Share this post


Link to post
Share on other sites

I've downloaded it, downloaded the latest BIOS from Sony, extracted the exe, replaced the ROM inside with yours and executed the InsydeFlash.exe

It got stuck in "Initialization" for quite a while and I sort of feared for the worst, but then it did its thing. I rebooted, got into the BIOS menu and it's the same old, just reset to the default values due to the flash.

I guess it didn't work for some reason, but at least it didn't brick my laptop. I know it's your BIOS because the GPU clocks went down to 500 \ 900 instead of 950 \ 1000.

Edit: I tried again with the newer InsydeFlash (5.16 instead of 5.07) that comes with your clock mod BIOS and, while it does flash the ROM right away the results are the same, no extra options in the BIOS.

I double-checked the file and it's definitely the one you uploaded.

Share this post


Link to post
Share on other sites

Right, kinda thought so... guess the same mod as for the AW series doesn't seem to work in this case. I need to see whether there's another possiblility.

Share this post


Link to post
Share on other sites

I'd hope so, it's always nice to have more options to play with, and maybe even have that SATA2 "bug" fixed.

I'll keep watch for any progress here in this thread should you want to try something else.

Thanks for the effort nonetheless ;)

Share this post


Link to post
Share on other sites

I am definitely willing to test this mod. I installed a mSATA SSD in my SVS15 hoping it would be recognized as the 2nd SATA Drive but no such luck. I'm hoping that there will be an unlockable option in the BIOS which will allow this. Let me know if you need a tester.

Share this post


Link to post
Share on other sites

If you have two Sata ports and one doesn't work then you should definitely contact Sony... Anyway, you might need to allocate a drive letter for the mSATA device.

Regarding the bios... I'll post here when I have some news about this, need to find some time.

Share this post


Link to post
Share on other sites

The BIOS shows,

SATA Disk Drive 1: 120GB (this is my ssd)

SATA Disk Drive 2: None (I thought this would be the mSata)

I installed the mSata ssd but the BIOS still says "None." Since the BIOS doesn't recognize it I can't assign a letter. I'm wondering if there's some sort of switch or jumper on the motherboard which would enable power to the mSata port. I've been trying to find a schematic for the board but have been unsuccessful.

Share this post


Link to post
Share on other sites

I think the mSATA port is just used for WWAN purposes, the 2nd SATA drive is probably the ODD. You can install a HDD in there.

Share this post


Link to post
Share on other sites

The ODD is recognized and listed seperately. I feel like there is huge potential here but I just can't figure it out. The second SATA drive has to either be mSATA or a port multiplier built into SATA 1. Sony has so many computers running on RAID 0 I'm sure the option is there but has to be unlocked.

Share this post


Link to post
Share on other sites
The ODD is recognized and listed seperately. I feel like there is huge potential here but I just can't figure it out. The second SATA drive has to either be mSATA or a port multiplier built into SATA 1. Sony has so many computers running on RAID 0 I'm sure the option is there but has to be unlocked.

Yes it is. I have the model with the 512gb ssd and it was in raid0 direct from sony. in bios it is recognized as 2x256gb harddrives

Share this post


Link to post
Share on other sites

guyz plz help me out

i just bought a Sony vaio svs15125 with Win 8

i just wanna get rid of Win 8 & install Win 7

but the problem is i can't access the bios

i can't even see press **** to enter bios thing :o

wat I should do :(

Share this post


Link to post
Share on other sites
guyz plz help me out

i just bought a Sony vaio svs15125 with Win 8

i just wanna get rid of Win 8 & install Win 7

but the problem is i can't access the bios

i can't even see press **** to enter bios thing :o

wat I should do :(

Keep F2 pressed as you turn the laptop on. I think it's the F2 key on that laptop, if it doesn't work try with the Esc, F10, F1 and Del keys, it's definitely one of those.

Share this post


Link to post
Share on other sites

Here's new test version which hopefully finally brings access to some more bios menus. If you want to try it let me know so I can give you the password.

The reason for this is that I need to get feedback on the mod since I don't have a system to test it myself. If you ask for the password I'll expect you to test the bios and let me know how it works.

SVS13-15_series_-_BIOS_R0142C5_[unlocked][TEST].zip

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

What options have you unlocked. Also I'm assuming that this probably resets my graphics card clocks correct?

Sent from my Nexus 4 using Tapatalk 2

Share this post


Link to post
Share on other sites

Well... since I can't test it I don't know whether I unlocked even one option :) As I only want to test the unlocked menus with this mod I didn't include a modified vbios, so the GPU will be at default clocks after flashing. I can still add the modified vbios in case everything else is fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.