Jump to content
EwinRacing Flash Series Gaming Chairs
StamatisX

[M17x R2] with AMD 7970M CrossfireX

Recommended Posts

I received early in the morning a couple of 7970Ms and a cfx cable from MXM Upgrade Home Page

3DMark11

post-3-14494993316907_thumb.jpg

Unigine

post-3-14494993317732_thumb.jpg

If you are upgrading from the 5870Ms, the screws are a bit bigger in diameter and they won't fit the backplate of the 7970M (probably a clevo card? I will find out soon). Other issues I encounter is that both display and HDMI port don't work so I attach my Dell 2410 with a VGA cable... Temps are fine and I am idling at 56-58 C with the external monitor attached (which brings the clocks up to 300/1200 @0,825V) so not that bad.

7970M.zip

  • Thumbs Up 8

Share this post


Link to post
Share on other sites

You can't play any game.. you have 0 MB Memory PWHAHAHAHA :D

Do you have any power issues (like svl7 at M15x) when benchmarking?

Share this post


Link to post
Share on other sites

I'll test them for you! Just send the pair to me and I'll keep them for a reasonable period of time (18-24 months or until something better comes out). Then, as a bonus to you, I'll pay return shipping. :D :D :D

  • Thumbs Up 4

Share this post


Link to post
Share on other sites

Hahahahaha :D Great deal, go for it! LMAO

Share this post


Link to post
Share on other sites

btw I need to buy a second PSU asap... tried to play Metro 2033 and crashed the PSU 3 times in a row (no CPU overclock)

I wonder where I can get one...

Share this post


Link to post
Share on other sites

Will an M18X PSU work for you? I happen to have a spare one. :D

Share this post


Link to post
Share on other sites

Definitely interested, I told my father to send me a diode bridge that can handle at least 20A so I can connect the 2 PSUs in parallel.

I will probably need an something like this

post-3-14494993318564_thumb.jpg

Share this post


Link to post
Share on other sites

Better use solder, it's neater and makes better contact.

Share this post


Link to post
Share on other sites

@svl7:

we all know you are obsessed with soldering.

Btw my free60 doesn't glitch anymore. I suspect cold solder joints, damn lead free solder! - Can you fix it ? ;)

@all:

I'd prefer the screw terminal, as it is mechanically stable. Just don't forget to use cable-end sleeves.

Share this post


Link to post
Share on other sites

Just ordered the second PSU from Dell. It will be here on Tuesday. Now I will have to wait for my father to send me the diode bridge.

Also an update concerning temperatures

Metro 2033, everything maxed out, primary GPU was hitting 96C and the secondary 86C. Really hot...

post-3-144949933191_thumb.png

Share this post


Link to post
Share on other sites

Undervolting to 0.975V help the temperatures a lot, 9C difference... but I experience throttling during gameplay, the FPS drop and the load on both GPUs drops to 64%. (It's not due to temperatures since the secondary GPU is 5C lower)

Anyways... I run a Metro 2033 benchmark real quick

post-3-14494993319412_thumb.jpg

Share this post


Link to post
Share on other sites

The problem right now is the PSU... 240W are simply not enough when playing games like Metro 2033 maxed out in CFX... especially when you have a XM CPU OCed... You can always undervolt @0.975V but then you will experience throttling.. I will be able to answer your question in a couple of days, when I will have an extra PSU to run in parallel, to keep my CPU overclocked and run the GPUs at stock clocks. Then I will tell you what the system can do.

Another issue that should be taken into consideration is the display and HDMI ports not working... CrossfireX or not...

Share this post


Link to post
Share on other sites

M17x R2 with 7970m is awesome i reallly hope the parallell psu unlocks those beasts. Stamatis seems the lowest i got true stability on was 1.025v stock clocks. I could flash lower but i too got clock drops at lower volts. But under good temps and not an extreme load the low volt SVL7 uses would be fine

Share this post


Link to post
Share on other sites

Howdy fellas,

Long time lurker, but here's my first post on your forums:

I too have an m17x-R2 that I bought with the ATI 4870s in CrossFire, got hooked on the NBR forums about the possibilities of the upgrades for this thing and successfully installed the 6990Ms in CrossFire. Then I got word of the 7970Ms available and bought myself a pair here. I specified the P170EM version of the cards and had them in my hands within a week. I already saw the success that others had with installing these cards from Eurocom, I was thinking that the ones I bought were just a vBIOS flash away from getting up and running if I ran into any problems.

Well, I got them installed and got a blank screen. So then I backed out the card in the secondary slot and tried to boot just off of just 1 7970M - still no luck. I switched cards and again, no luck. Attempting to boot off the secondary slot was a dead end as well. The machine would post as I was able to hear Windows start up - just no display on the screen. So my next thought: make a bootable USB drive and blind flash it to ichime's vBIOS from his successful Eurocom cards. I did a few test runs with my 6990s installed and got the keystrokes & timing down to blind flash and made a batch file with all the appropriate commands and assumed that I had successfully flashed it - but still no display on my R2 from these things.

Making sure that I had operational cards, I installed one in my wife's m17x-R3 and was able to flash it to the Dell OEM vBIOS through DOS and it fired right up without any problems. So now I could confirm that I was able to flash the vBIOS in DOS under ATIFlash and move the cards from the R3 into the R2 after a successful flash, yet not yielding any successful results.

So my question is: Do you guys have any insight as to why these Clevo-based cards would *NOT* work in my R2? I'm at a loss of ideas to try and any help would be appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Nospheratu
      Dolby Home Theater v4 - M17x R2 and IDT High Definition Audio   So I decided I needed a headset with a mic and I'm a sucker for matching peripherals so I set my sights on the TactX headset (Rebranded SteelSeries 5HV2). There's some pretty appalling reviews of it online but I have to try them out for myself. One of the "problem" areas is an apparent lack of bass since its tuned for FPS gaming. In preparation I figured I should get some sound enhancement software. I've been using the Dolby Home Theater v4 application on my HTPC with a Xonar DX soundcard and its very effective particularly with movies and it's volume leveler feature. All processing effects can be switched off for music by just switching profiles using a handy system tray utility so its very convenient to use. You can read more about it on Dolby's official page.
       
      System Tray Utility

      I'm not sure if many users are still soldiering on with the M17x R2 but heres a fix if you wanted the use the Dolby Home Theater v4 application. Support for the IDT High Definition controller used in this machine is non-existant. The only driver I could use was the one's directly from Dell (apart from this Dolby Driver) so I hope this is of some help to fellow M17x R2 users who are looking for more customisable sound.

      I've replicated my steps a few times and I'm fairly certain should work without isue on an Alienware M17x R2 with Windows 8.1 as that's what I'm using. You could give it a try if you have an onboard IDT HD Audio card as well.

      Fixing the INF for use with an IDT High Definition Audio sound card 1. Uninstall all audio applications/drivers and reboot. Windows should install the default "High Definition Audio" driver. 2. Download the installation files from here. Extract the rar. 3. Extract the "Dolby PCEE Drivers.msi" installation file using msiexec and the command line. eg...
        msiexec /a "C:\Dolby PCEE Drivers.msi" /qb TARGETDIR="C:\Extracted Dolby PCEE Drivers"  

      4. Using the above extraction path as reference, go to C:\Extracted Dolby PCEE Drivers\Dolby PCEE Drivers\Drivers64\Release. You should see a file called PCEE4-DHT.INF 5. Open the file and find and replace all occurances of HDAUDIOFUNC_01&VEN_11D1 with HDAUDIOFUNC_01&VEN_111D. Save and close. 5.1 Optional depending on whether you're running Windows 8.1. Reboot with Driver signing off. ie. Hold down Shift when clicking Restart. Select Troubleshoot->Advanced Options->Startup Settings. Click Restart. Once the machine reboots press F7 at the Startup Settings screen to Disable driver signature enforcement. 6. Go back to the extracted Dolby PCEE Drivers folder and run "Dolby PCEE Drivers.msi". Select the "DHT(release)" driver. You should be prompted on whether to install the driver or not, select Install.

      Your drivers should now be installed. If you're using another machine (not an M17xR2) with IDT HD Audio and can hear a marked difference in sound when you go to your Playback Device's properties and switch between the Dolby profiles on the Dolby tab you can go ahead and install the "Dolby Home Theater v4.msi" application.

      If you do not have the Dolby Tab under your speaker playback device and have the Enhancements Tab instead read on. At this point if I plugged in a pair of Headphones into the 2nd or 3rd audio jacks, the Headphones properties under Playback Devices contained the Dolby Tab and the Dolby effects were working with the headphone playback devices.

      Enabling the Dolby Tab and effects on the Speaker Playback Device 1. Open regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render. There should be multiple entries here. Expand the entries and look for the ones with both "FxProperties" and "Properties" keys. To identify the Speakers playback device one of the "Properties" key values will have a string value called "{a45c254e-df1c-4efd-8020-67d146a850e0},2" with a data value of "Speakers". We're interested in the "FxProperties" key above this "Properties" key. 2. Under this "FxProperties" key, delete all values apart from (Default). 3. Copy and paste the below to Notepad making sure to change ****** to the name of the parent key of that particular "FxProperties" key. eg. Mines was called {36018a56-954a-437d-8bdb-0b6bbf830dbc}. The name will vary as it changes with every driver install.
       
      Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\*********************\FxProperties] "{b725f130-47ef-101a-a5f1-02608c9eebac},10"="Dolby PCEE4" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},3"="{C53E5AAF-5F6F-41c2-9F63-ADEBBC9B6B64}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},0"="{00000000-0000-0000-0000-000000000000}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},1"="{BC8E3B67-3306-4eef-B230-6798E9A67F0B}" "{1da5d803-d492-4edd-8c23-e0c0ffee7f0e},5"=dword:00000000
      3. Run this reg file and select yes when prompted on whether you want to add this information to the registry. If you have a look at the same "FxProperties" key again you will notice the above values have been added. 4. Reboot the machine. 5. You should now have Dolby effects working on your speaker device. Install the "Dolby Home Theater v4.msi" and you're done!

      Notes: The effects are only really worth while if you're using headphones, the M17x R2's speakers aren't that good. So this exercise is a bit pointless really. I'm not a fan of processed sound but what really annoyed me was that the effects only worked when the Headphones were plugged in. Hopefully some of you guys enjoy it.

      Credits: I'd like to thank @fr33jack from guru3d forums for providing the install files on his post here and @epguy19 also from guru3D for pointing out the flaw in the drivers INF for the IDT device ID on his post here. I'd also like to thank @erp-ster7n from the laptopvideo2go forums for the insight into the enhancement tab mods with his post here.

      DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.
       
    • By Crustieraxe
      Hello Guys this is my first post here!
       
      So my original post was this:
       
      "I don't even know if any active forum is out there on this laptop and on this issue, but after installing my new DHCG2 LTN173HT02 120hz display, I am unable to boot up on it. I do have a modded bios which the video setting is set to PEG, and just about read every forum about this but have not found a solution. I have tried resetting the bios, made sure the cable is plugged into the Edp port, and have made sure I have an UFEI Windows installation and legacy mode is turned off. I don't know what else to do and if anyone could help it would mean alot to me! "
       
      The reason it was not booting up on a pure UEFI environment is because my 660m did not have the GOP compliant driver vbios. You would need this in order to boot up in a pure UEFI environment which at the time I didn't know, and my fix was to stick to legacy. Any card before the 660m will most likely require this if you need to boot up in a pure UEFI environment. If you do not have this vbios driver while it is set to UEFI and plug in the 120hz lcd, it will beep 8 times and you will be forced to plug back in the 60hz display to change it back to legacy.
       
      This was the vbios that I can say worked for me and had the GOP compliant driver for the 660m
       
      https://www.techpowerup.com/vgabios/144032/144032
       
      ------------------------------------------------------------------
       
      These are the steps to upgrade from a normal 1600x900 60hz display to a 1920x1080 3D 120hz Display which is needed if you want to update your graphics card to a more modern one.
       
      I am making this guide because I felt frustrated that for this awesome computer, there aren't really any post in 2020 to upgrade the LCD panel to the 3D 120hz one. And The older posts I scavaged through really helped me little in doing this upgrade.
       
      Anyways lets begin
       
       
      1) If you have a stock AMD graphics card, and are wanting to install the 120hz display, then your journey ends here and you will have to upgrade to an NVIDIA graphics card to do so. If you have an NVIDIA, you may continue
       
      1a) ( Only if upgrading to pascal graphics card )Your NVIDIA card Needs to have a GOP compliant vbios  or else it will not let you select the UEFI option on the bios. This is needed because you need to set a UEFI environment before upgrading to a 1060/1070 Since these cards don't support legacy mode. This means you will need to flash a vbios onto your card that will allow you to boot on a UEFI Environment. You will need to verify first wether your card has a GOP compliant vbios by searching up your vbios version in GPU-Z. If you have a 660m that doesn't have this, then here is the link to that vbios that does. https://www.techpowerup.com/vgabios/144032/144032 I think that all of the Nvida 6XXm are not GOP driver compliant and need this but do not quote me.
       
      2) On the 60hz display, I would start by making sure that you have windows 10 installed or reinstall with UEFI support as it is needed if you are installing a pascal graphics card. If you have legacy mode enabled, and are not planning to upgrade to a pascal graphics card and keeping your old Nvidia 6XXM, then disregard this and head on to step 5 (although I would recommend to read everything)
       
      3) turn the laptop off and boot into the bios. In order to boot into the bios, spam the F2 key while it is turning on.
       
      4) Once in the bios, go to the Boot menu, and make sure to Disable "Secure Boot", Make sure that importantly if you converted over to a UEFI installation of windows, UEFI mode is chosen (UEFI  Environment will be needed for a pascal graphic card and legacy will not be compatible) then again, if you are on a legacy installation of windows 10, disregard this if you don't want to upgrade to a pascal graphics card.
       
      5) we can now start looking at the 120hz display. I bought mine on ebay with this seller https://www.ebay.com/itm/New-Dell-Alienware-M17X-R4-17-3-FHD-WLED-3D-V-M-LCD-Screen-DP-N-DHCG2-GN36T/273644412867?hash=item3fb67a5fc3:g:9A0AAOSw5AhcP1pw:sc:USPSPriority!32720!US!-1 (Just in case the link goes bad, this was the listing name"Alienware M17X R4 17.3" FHD WLED 3D V M LCD Screen DP/N DHCG2 GN36T"  with the screen model being  LTN173HT02 and Dell part number GN36T )
       
      6) Since my listing came with the video cables, I did not have to go out and look for the video cable. If yours did not come with the cables, You will also NEED to get the video cable it is required. the Dell Part number is N392W. I cannot stress enough This video cable is required and the 60hz's video cable CANNOT be used with the 120hz one or else you will brick your computer from what I read.
       
      7) Once it comes In, we can start to take apart the computer to Install our new display. I watched this video to remove the old 60hz and install the 120hz panel 
       
       
       
      8) Before I would remove the whole 60hz lcd panel, I would first make sure that you can boot on the 120hz panel. Notice that there is one connecter with screws on both sides right next to where the 60hz screen connecter is. Make sure that you put the 120hz one with the connector where screws are. This is known as the Edp port and cannot be confused with the LVDS port. Again, you want to plug the new 120hz display into the EDP port and unplug the 60hz one.
       
      9) If the installation was done correctly, then you should have no problem booting with the screen. if it is giving you 8 beeps, then just plug in the 60hz display, and navigate back to the bios to make sure everything is in order and refer back to steps 2-3. If you happen to be an advanced user like me and went ahead and installed a modded bios, then on the 60hz display make sure that the video setting is set to PEG. I dont think this is necessary to have a modded bios since the bios automatically changes the video setting when the 120hz display is detected and should be a last resort option to install a modded bios. I got my modded A12 bios from a guy in this forum named klem for 10 US dollars thorough paypal. Shoot him a message in the forum below.
       
       
      10) Once the new LCD is tested and you know you can boot up with no problems, go ahead and finish removing the old 60hz LCD and proceed to finish installing the 120hz LCD. And you are done. 
       
      A couple of words from my personal experience: When I installed the 120hz display, and booted up windows on it, and turned the computer off, it refused to turn on for some weird reason. I don't know why it would turn on when the AC and battery where on. regardless of what this was, I fixed it by Reseting the CMOS. If you don't know how to do this, do a quick google search and after turning it on i got 5 beeps which i then turned the computer off, and then turned it back on which the computer just reset itself and when it turned back on I was able to boot up into windows.
       
      This is the forum that I was able to find about upgrading the graphics card to the 1060.
       
      Anyways I hope I at least helped someone transform their computer! In 2020!
       
       
    • By lilkuz2005
      hello all, i just got a gtx 980m from a seller on amazon. i have the card installed in my alienware m17x r4, i have updated the bios to A15 stock, in the bios its showing the card is there, in windows 10 the card is also shown in device manager, but it has the code 43 error, i have disabled driver signing and installed a modded driver but its not working, i have uefi legacy mode enabled, i need help getting this working, do i need a modded bios to get the card working? is my card a g-sync version ? any help with this would be great, also if it is a g-sync card, can i vbios flash it with a non g-sync vbios? how can i tell if this card is a clevo or msi ? thanks in advance
    • By depmixels
      hello everyone, I have a MSI GT683R with a dying (pretty much dead actually) GTX560M in it.
       
      I am looking to upgrade it to a new GPU, I have found a AMD Firepro M6100. (I first wanted to upgrade to a GTX970M, but that's too expensive for now... and corona is also making things difficult) I have already ordered a second heatsink to modify because I didn't want to modify the original heatsink it came with.
       
      But, my question is. Does it even work in this system? I have heard of people getting it to work in the barebone variant of this system. But I am not sure if it would work in the 'fully loaded' variant.
       
      Also, my games are mostly RAM/CPU dependent and I am looking for a little extra power in this system. I have found a I7-2860qm and I want to upgrade to 32GB of RAM, is it possible on this system? the sticker says 'max. 16GB of RAM' But I have feeling it says that due to the limitation of the cpu that's already on this system (I7-2630QM, 16GB RAM max.)
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       

      View full article
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.