Jump to content
EwinRacing Flash Series Gaming Chairs
Qvixot

AMD 7970m Driver Problem (P150EM) PLEASE HELP!!!

Recommended Posts

Hello everyone! First of all sorry if this isn't the correct forum to post this.

I bought a laptop few days ago. The laptop is Sager P150EM.

Cpu:i7 3610qm 

Gpu: amd hd 7970m

Ram: 8gb

Os: windows 8.1 pro

So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?

Share this post


Link to post
Share on other sites

If laptop have recovery partition try to reinstall windows from it. If this is fresh install then it seems there is problems with outdated or incompatible drivers. 

Share this post


Link to post
Share on other sites

translated by google.

1) ULPS - disabling

2) AMD's rejection of the technology to switch between integrated and discrete Enduro graphics. For those who want to continue to benefit from the Mantle and Enduro. Max - Radeon 19.4.3

2.1)Catalyst Control Center instal for CD,

2.2)driver for - Pci Bus (ACPI\PNP0A08\0) - 6 pst.

2.3)and update Radeon 19.4.3 not Catalyst Control Center

 

when the "Pci Bus" does not have time to deliver, you get bsod.
you need to start without a video card, and then with a video, it should help. Yes, you need one more card for this) you can not work.

 

Edited by kolbak

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Radstark
      Title sums it up.
       
      TL;DR: we have a Clevo that runs a desktop CPU, one with those huge 82 Wh batteries. We remove the GPU and let it use the CPU's integrated graphics. How much time for the battery to go from 100 to 0? Is it comparable to an ultrabook's?
       
      I'm theorizing a mobile set with a static eGPU and an upgradable CPU. Given a hypothetical user that needs fast processing on the go and long battery life while retaining very high degrees of mobility, but at home wants a powerful machine to run most games, I guess that would be their best bet. It would surely be more convenient to keep everything in the same disk. And even though the thing would be quite heavy to carry around, changing CPU would be more cost-efficient than changing an entire laptop. (Not sure if I'm right here, and also I'm not sure whether the motherboard in a Clevo would be replaceable when the new CPU needs a different socket, which is another reason why I'm asking here.)
       
      If my above guesses aren't correct, then an ultrabook with Thunderbolt and without a dedicated GPU would be a better choice. If they are, then we would be carrying more weight in exchange of a more cost-efficient setup, which I think would be a fair tradeoff.
       
      Also I am aware of the heating problems that these laptops suffer from, at least compared to a desktop setup. Would they be solved by moving the GPU out of the chassis, and instead plugging it with an eGPU dock via Thunderbolt port?
       
      What do you think? Is it doable? If not, why?
    • By Binarious
      I installed an NVIDIA Quadro P4000 Max-Q in a Clevo P750DM-G.
       
      Device manager hardware ID shows:
      PCI\VEN_10DE&DEV_1BB7&SUBSYS_75021558&REV_A1
       
      I have done the standard inf file mod, then disabled driver enforcement as I have done successfully in the past, but it's not working this time. The install starts, then fails less than half way through. I have tried the DCH version, standard version, and studio versions and none of them will work. I am probably missing something. Could it be the result of the vBIOS?
       
      Below are screenshots starting with GPUz
       

       
       
       

       
       

       
       
       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.