Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

AMD 7970m - modified VBIOS

Recommended Posts

Hi guys

I have a very strange problem. I first had a Dell vbios which worked fine but the HDMI port didn't work. I then received a new vbios which by the seller which should fix the hdmi problem. Its a Clevo vbios with SSID 0270 for Clevo P278WM (see picture in the attachment). The problem I have is that there is no way to change the vbios anymore. It is like this vbios is locked in a special way (never had something like that). I always receive a 0FL01 error. I tried to force it. I also tried it with about 10 different vbios and with winflash. I was so desperate I event tried it with all different versions of Atiflash. No I just get: Adapter not found. But the card works great. Is overclocked and I get 7000 3dmark11 gpu score.

Has anyone an idea how to unlock this bios and change it to a different one? Or any way to get a working hdmi?

Greetings from Switzerland[ATTACH=CONFIG]7846[/ATTACH]

Weird, never had this. Try the same command you used but with the -st flag added to it.

I hope, svl7 finds the time to help us with Clevo PxxEM 7970 vbios :)

I'm sorry, I forgot to attach the vbios P150EM https://mega.co.nz/#!rUdiUQ7I!CUjASEpFTMCHnynzWUHnF1SABnl0uuD42yuavTJhAUw

Right... .modified them a while ago, never uploaded them. I'll see that I put it up.

Share this post


Link to post
Share on other sites

I tried it with the -st flag added but still no success (see picture). It is able to see my adapter no at 0 after I used the newest Atiflash version again.

Do you have some other ideas? How is it possible that a bios version locks itself from other vbios? I was able to flash it once to this version but now its game over. The cards works perfect (its just the hdmi out missing).

Is there an other tool or way to really force the system to flash with an other bios version?

post-9345-14494995534974_thumb.jpg

Share this post


Link to post
Share on other sites

Not sure what's wrong, especially since you were able to flash it to this version... The only systems I know of that have issues with flashing a 7970m are certain Clevo notebooks with crappy bios implementation.

In case something else crosses my mind I'll let you know, at the moment all I can think of is to either try it in another system or replace the vbios chip.

Share this post


Link to post
Share on other sites

Maybe I now have one of these crappy clevo notebooks vbios :-)... Its a Clevo P270WM vbios. But anyway its not too bad. At least the system runs on the internal screen and the good old vga. But maybe you will have an other idea.

Thank you very much for your great work. You help a lot of people! Makes me proud that you are from the same country. It seems some swiss people are very important for the overclocking community.

PS: You had a great 3dmark11 score with the 7970m (7944 gpu points)... crazy stuff.

Share this post


Link to post
Share on other sites

Hehe, thanks!

The flashing isn't related to the vbios, I was talking about the notebooks themselves, but since you have an MSI system I doubt the problem is your bios, especially since it worked when you first flashed it.

Share this post


Link to post
Share on other sites

Hey svl7 I'm coming back to you as I'd like to know how I could enable that performance option to change my voltage in CCC, do you have any idea ? (don't know if you remember, I flashed the modified bios, but nothing changed)

Share this post


Link to post
Share on other sites

hello, I have an alienware m18x r2 with dual 7970. I tried overclocking by flashing 1.075 vbios, and then raised the clocks at 940/1480. With one GPU I get about 6900 on 3dmark11. With 2x GPUs I get 9970 points. I think the score for both gpus is too low. I have seen people to get about 10.000 points on stock clocks. I have tried the latest 13.4 amd driver. Anyone know what is holding me back?? :)

Share this post


Link to post
Share on other sites
hello, I have an alienware m18x r2 with dual 7970. I tried overclocking by flashing 1.075 vbios, and then raised the clocks at 940/1480. With one GPU I get about 6900 on 3dmark11. With 2x GPUs I get 9970 points. I think the score for both gpus is too low. I have seen people to get about 10.000 points on stock clocks. I have tried the latest 13.4 amd driver. Anyone know what is holding me back?? :)

Share this post


Link to post
Share on other sites
Hey svl7 I'm coming back to you as I'd like to know how I could enable that performance option to change my voltage in CCC, do you have any idea ? (don't know if you remember, I flashed the modified bios, but nothing changed)

If all you want to do is adjust 3D voltage on your card through software you can run MSI Afterburner with the -xcl parameter, reboot and then open up Sapphire TRIXX. You will be able to adjust clocks and 3D voltage through TRIXX.

As a bonus CCC will also have OverDrive enabled to adjust 3D clocks. In order to adjust voltage with CCC you would have to create an oc profile and then edit the profiles xml file. The TRIXX method is much simpler.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
I tried it with the -st flag added but still no success (see picture). It is able to see my adapter no at 0 after I used the newest Atiflash version again.

Do you have some other ideas? How is it possible that a bios version locks itself from other vbios? I was able to flash it once to this version but now its game over. The cards works perfect (its just the hdmi out missing).

Is there an other tool or way to really force the system to flash with an other bios version?

[ATTACH=CONFIG]7848[/ATTACH]

@Darksnow47 Can you try "atiflash -unlock 0"

I can't remember what I was searching for but came across that for users who wanted to flash their desktop 6950's to 6970's and that was the first step. Its worth a shot.

Share this post


Link to post
Share on other sites
If all you want to do is adjust 3D voltage on your card through software you can run MSI Afterburner with the -xcl parameter, reboot and then open up Sapphire TRIXX. You will be able to adjust clocks and 3D voltage through TRIXX.

As a bonus CCC will also have OverDrive enabled to adjust 3D clocks. In order to adjust voltage with CCC you would have to create an oc profile and then edit the profiles xml file. The TRIXX method is much simpler.

Hallo again nospheratu... :Banane48:

As you know about my problem with my 2x 7970m and their voltage problem, do you know an other way to enable overdrive in ccc? Because the -xcl command in afterburner doesn't energise the overdrive in ccc.

I was thinking that if I can enable overdrive in ccc and then edit the profile in XML I could try to lower vddc from there

Share this post


Link to post
Share on other sites
Hallo again nospheratu... :Banane48:

As you know about my problem with my 2x 7970m and their voltage problem, do you know an other way to enable overdrive in ccc? Because the -xcl command in afterburner doesn't energise the overdrive in ccc.

I was thinking that if I can enable overdrive in ccc and then edit the profile in XML I could try to lower vddc from there

Hey AlienHack :D

sangemaru tested it and he said he was only able to increase voltage through the CCC profile method and lowering voltage had no effect. You can always give it a try though. Maybe try the 13.4 cats to see if afterburner and the -xcl parameter works. If I remember correctly you're running 13.6 beta2's atm?

Share this post


Link to post
Share on other sites

Hi there. I have an Alienware M15X and I just installed a i7-940xm and an HD 7970 (DELL) and I am having incredibly bad throttle issues. I purchased the 240watt M17X power supply so I think I am getting enough steady power, and temps are really good, but it hovers around 450Mhz during benchmarks..... so bad...... I read this thread quite a bit and it is still a little over my head. This is a really spendy brand new card and I don't want to trash it because I'm a noob but I really need to get to that unlocked voltage control. Any advice?

Share this post


Link to post
Share on other sites

Welcome UniverseUV777 :)

Are you running stock settings on both the CPU and GPU? I don't think stealth mode affects these cards but make sure it is off anyway. Also are you getting any sort of warning that the PSU is unsupported or is it working fine and charging your battery?

If you look at the detailed view in GPUshark what is the 3D voltage set to?

Share this post


Link to post
Share on other sites

Hey - it is possible the under- and overvoltage a 7970m on thep170em?

thx

Share this post


Link to post
Share on other sites

Hello, svl7

You can make for me mod bios dell 022 1.075?

Like this Dell 7970m - 015.022.000.001.000000.C42904A1.119 - Overdrive Mod_1050v, just 1.075.

Thanks

Share this post


Link to post
Share on other sites

Has anybody resolved the "card stuck at 0.975v" issue? My primary card works at 0.975v and won't reflect any changes on 3D voltage when I flashed the modded Dell vBIOS from svl7's mod pack but my secondary card does.

I've reverted to stock vBIOS as I experienced some screen issues after a few boots on the modded Dell rom. Both my cards are Clevo's.

I've swapped the cards around and the issue follows the card so I'm thinking it has something to do with the card and not my machine/OS. Currently my primary card is running at 0.975v and my secondary card is at 1.00v in 3D mode.

What makes this even stranger is the vBIOS I'm running is the exact same stock P270WM 7970M vBIOS on both cards which is supposed to be running default 3D voltage of 1.025v... I think.

Another issue it that randomly either card will get stuck at 0.900v on idle 2D mode when the default is supposed to be 0.825v.

I am able to adjust the voltage for the primary card using using TRIXX after using the Afterburner -xcl parameter but this only works for the primary card.

Share this post


Link to post
Share on other sites

Hi folks,just tried to gain more fps in game with overcloking my 7970M CrossfireX setup(M18X-R2), but I havent`good resuts: First flashed with 900-1300-ov1075v ROM and play Tomb Raider with it, tested with the internal game benchmarking that shows a increase in 10-15 in the FPS levels, but just passed 15 minutes of play and the machine crashed with a horrible sound. Thereafter I turn off the laptop and flashed back to the original bios to try the same level of overcloking, but this time configuring the AMD overdrive with 900 GPU 1300 MEM to test it again in the same game and monitoring the temps played Tomb Raider again and about the same time the game soft crashed turning back to desktop screen...

My ASICS scores as follows are 76.6% to GPU 1 and 81.6% to GPU 2. Are these ASIC qualit scores too low for a good overclock? Any ideas about what could I do to safely find the sweet point of these GPUs? Can I overclock if the GPU is downclocked to 1.000V?

Thanks for the help in advance =)

Share this post


Link to post
Share on other sites

I purchased a clevo 7970m card for 300 on ebay. I'ii be upgrading the gpu in my G73jh laptop. The vBIOS is BR43595.003 . Can you please point me in the right direction. I am not afraid to mod and flash. Just not sure how to start. I have some questions.

Is there a guide somewhere that explains exactly how to do this for my particular card?

Which vBois flash with enduro off should I use?

Any other info and steps would be helpful.

Thanks

Share this post


Link to post
Share on other sites
I purchased a clevo 7970m card for 300 on ebay. I'ii be upgrading the gpu in my G73jh laptop. The vBIOS is BR43595.003 . Can you please point me in the right direction. I am not afraid to mod and flash. Just not sure how to start. I have some questions.

Is there a guide somewhere that explains exactly how to do this for my particular card?

Which vBois flash with enduro off should I use?

Any other info and steps would be helpful.

Thanks

Anybody here can help???

Hi slv7, Can you please let me know which vbios I need to turn Enduro off on a clevo with vBIOS BR43595.003? I don't know where to look. THis is to go an asus G73jh laptop. Thanks

Share this post


Link to post
Share on other sites

Hi, fellas) Could anybody help me out with this one plz? Is it possible to flash the Clevo 7970M form P150EM with vbios version 015.018.000.000 to the Dell vbios provided in the 1st post? The reason why i want to do this is that the Clevo card don't have auto fan control and i have to set it up using HWInfo. Tnx a lot)

Share this post


Link to post
Share on other sites
chmod1337, geischtli and svl7 - thank you for the vBIOS patcher. I tried it and it works awesomely. A donation has been sent for your work. I hope others follow suit in rewarding your generosity and labor.

I still have not dialed in the 7970M CF yet. It seems each benchmark can handle a different overclock. Vantage will handle a higher (1GHz) GPU overclock on my system than 3DMark11 does (about 950Mhz on core). For several days it seemed 950/1400 at 1.1v was perfect for everything, but now 3DMark11 decided it does not like that any more. Not sure what changed.

Question: do you know what causes the black screen with overclocking on AMD cards? It is too high core, memory or voltage? Or any one of the above?

Oddly, I can run Furmark at just about any overclock without issue. I just ran it with 1000/1300 with no artifacts, black screen... smooth as silk. Temps are cool, but don't know what I should back down on to avoid the black screen with other benchmarks and games?

MrFox did you ever figure out what causes the black screen? I get the same thing overvolted or not, at the hiegher clocks such as 950-1400 or 940-1350. It runs so smoothly but i cant keep it because of blackscreens. Any advice

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mx90
      Hello, I've got a Dell Precision M4700 with a 3940xm. I've read that in this particular CPU and laptop model, the bios is locked because the stock settings are considered an overclock. As-is, the core temps on the CPU do reach up to 90-100. They seem to spike up and down a bit when benchmarked with Intel's Extreme Tuning Utility, but they certainly do reach over 90C. Is there no way to unlock this bios (version a18, though a19 is released - I haven't updated yet, should I?) and even if there were, would my only option be a heatsink mod on top of that?
       
       
      edit: I've mistakenly posted this under Desktop & General Hardware, perhaps a mod could move or delete the thread? Apologies!
    • By mx90
      Hello, I've got a Quadro M2200 (GPU: GM206GL-A Revision A1, and MxM 3.0a Maxwell card) with the following bios: 84.06.76.00.1C
       
      I've read that this card is very similar to the GTX 965m, but that it has been underclocked considerably. It seems to be a good candidate for unlocking since I hardly see the temperature exceed 70C as-is. I'm requesting help with this - I'm not sure if it's possible to simply flash the vbios from a Dell GTX 965m (MxM 3.0a) or if some type of edit of the card's current vbios would do the trick. I'm hoping someone could help me out with the specifics of doing such an edit if that's the case. 
       
      Thanks!
    • By fibul
      Hello Everyone,
      I am an owner of MSI GT70-20C and my GTX770m gpu i now dead.
      I have a question and i hope someone will help.
       
      I have ordered GTX 970m 6GB DDR5 and i cannot find the exact vBios for that graphic card.
      My current bios version is: E1763IMS.51B
       
      Thanks in advance,
    • By victordenis99
      I own an Asus Fx504-gm laptop with an 8th gen i7 and nvidia gtx 1060. I ve been having issues with random hard freezes and I later found out that absolutely anyone with this exact model has the same issue and not even Asus service can fix it as they just replace every component and the problem persists so my guess is that this is software related.
      I ve been noticing that I Always hit power limit(I monitorised it with afterburner) and so I have power limit throttling. The thing is, for this laptop the power limit is locked and I cannot modify it.
      My last resort is to try a modified bios that can unlock the power limit slider. My question is: Is this possible? Are there any modified bioses that can unlock the power limit or the only way is to unlock it via the motherboard? If so, where can I get a reliable modified bios for my laptop and how can I check compatibility? Thx.
    • By ajdrenter
      Hello all! I have been researching upgrade paths for my M17x R4 and I have decided on the GTX 1060. Now, I was given this laptop with a dead GPU, and I had an M17x R3 already. So I moved the GTX 560m into the R4 which has worked fine. Now as I understand it a few things are needed for this upgrade including the 120hz panel and the ability to disable the legacy ROM for a pure UEFI boot. I have the 120hz screen, but the 560m uses the GF116 architecture which does not have a vBIOS which supports GOP. So I am thinking the only solution is to buy a cheaper "in-between" card which supports both boot modes, which will allow me to disable the legacy option in setup. Does anyone have any suggestions as to what cheap card to buy as a transitional part? I have been considering a 765m but I am also wondering if there are any other good choices.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.