Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
CerberusVI

M17 R4 GTX 980M upgrade

Recommended Posts

Hi all! So im trying to upgrade an R4 with the 120HZ 3d display and Nvidia gtx 675M. I reformatted the SSD to GPT and installed fresh windows 10 with UEFI, after installing the 980M i get 8 beeps.

 

I have tried disabling legacy mode in the bios but i cannot, i hooked up an external monitor to it and got it to load up fine once and then it crashed while i was trying to modify the .inf for the latest 980m drivers. But after that i cannot get it to boot properly with the 980m.  Do i absolutely need a unlocked bios for this to work?  If i have no integrated graphics card how do i disable legacy mode?

Share this post


Link to post
Share on other sites

Yes you'll need a pure UEFI environment which means disabling the Legacy ROM option. You'll have to put the 675M back in to get back into the BIOS. 

 

I have never done the upgrade on an R4 so I'm not sure if you need the unlocked BIOS or not. Since you have the 120Hz display it should already be set to PEG as default so there should be no need to change the video mode, which is one of the big reasons to flash the unlocked BIOS. 

Share this post


Link to post
Share on other sites

well i put the 675 back in and now i cannot get back into the bios, i just get 8 beeps. I've disconnected the power supply, removed battery, removed cmos battery, let it sit over night, cycled the power button and i still cannot get the bios to reset so i can get into the bios. 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, CerberusVI said:

well i put the 675 back in and now i cannot get back into the bios, i just get 8 beeps. I've disconnected the power supply, removed battery, removed cmos battery, let it sit over night, cycled the power button and i still cannot get the bios to reset so i can get into the bios. 

Hi!

It has related with the BIOS settings. It needs to be set in bios to PEG mode to work correctly.

 

I recommend you to read this topic:

and this:

http://forum.notebookreview.com/threads/msi-gtx-1070-mxm-successfully-working-on-alienware-m17x-r4-another-socket-victory-against-bga-crap.803637/

Edited by Klem

Share this post


Link to post
Share on other sites
5 hours ago, CerberusVI said:

well i put the 675 back in and now i cannot get back into the bios, i just get 8 beeps. I've disconnected the power supply, removed battery, removed cmos battery, let it sit over night, cycled the power button and i still cannot get the bios to reset so i can get into the bios. 

 

That's a tough one. A CMOS reset should usually do the trick. The laptop doesn't seem to be recognizing the Nvidia card. You mentioned above that you could sometimes get the 980M to work before it crashed. Does this still work sometimes or is it 8 beeps every time?

There is a chance that you've damaged the 675M but it's probably the BIOS settings.

Just as a 'Hail Mary', you could try downloading Windows 10 onto a USB using the Microsoft Media Creation Tool and start up the laptop with the USB plugged in. If it's not posting due to a driver issue then doing this should force the PC to go into recovery mode. I used this trick over the weekend while testing a faulty 880M in a 17. It wouldn't post after installing the driver but I got it to boot after putting the USB in. 

Share this post


Link to post
Share on other sites

So with the suggestion of a friend i got the 675M to work again. All i did was the built in display test  (power button and D on start) and everything started working. I was able to flash my bios with an unlocked version from Klem. After that i was still getting the MXM GOP error trying to disable legacy boot,  So i used NVflash and flashed a different Vbios for the 675M from the forum and was able to disable fastboot and legacy mode for UEFI after  that. 

 

So i have 980M working in windows 10, It shows up in device manager with Nvidia Driver version 399.24. But now my issue is the GPU fan is not coming on at all, Even at idle it eventually thermal throttled and turned off until i put a laptop cooler on it. I ran Counterstrike source video test just because it was small and i was getting 299FPS but was getting dangerously hot.

 

Do i need to flash the Vbios on this 980M for the laptop to control the fan? if so where would i get a vbios that will work?

Share this post


Link to post
Share on other sites

vBIOS' are available from TechPowerUp. When you search for one, click on the Unverified Uploads in the GPU Brand dropdown as it will give you more options. There is also the Prema mod vBIOS for the 980M which a lot of people seem to use. I'm not sure where you can download that from though. Maybe try NotebookReview

 

The other option is to use HWiNFO to manually control your fans. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.