Jump to content
EwinRacing Flash Series Gaming Chairs
depmixels

AMD Firepro M6100 in GT683R? (MS-16F2) (and other upgrades)

Recommended Posts

hello everyone, I have a MSI GT683R with a dying (pretty much dead actually) GTX560M in it.

 

I am looking to upgrade it to a new GPU, I have found a AMD Firepro M6100. (I first wanted to upgrade to a GTX970M, but that's too expensive for now... and corona is also making things difficult) I have already ordered a second heatsink to modify because I didn't want to modify the original heatsink it came with.

 

But, my question is. Does it even work in this system? I have heard of people getting it to work in the barebone variant of this system. But I am not sure if it would work in the 'fully loaded' variant.

 

Also, my games are mostly RAM/CPU dependent and I am looking for a little extra power in this system. I have found a I7-2860qm and I want to upgrade to 32GB of RAM, is it possible on this system? the sticker says 'max. 16GB of RAM' But I have feeling it says that due to the limitation of the cpu that's already on this system (I7-2630QM, 16GB RAM max.)

Share this post


Link to post
Share on other sites

I've tried it in Gt780 - it does not boot, think the result will be the same for MSI GT683R

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 3/16/2020 at 8:13 PM, Lama876 said:

I've tried it in Gt780 - it does not boot, think the result will be the same for MSI GT683R

well, it does work... although you have to do it via VGA screen and use a unlocked BIOS to chan PCI ROM PRIORITY is set from EFI to Legacy.

 

Even though I managed to break this graphics card... it still sometimes show image, I am trying to get it to work on the internal screen

Share this post


Link to post
Share on other sites

Have you tried switching to PCI Legacy on unlocked BIOS from this topic?

 

Does it help getting image on internal screen?

 

If you have these unlocked BIOSes - please send GT780 and GT683 my way :)

 

 

 

 

Share this post


Link to post
Share on other sites
9 hours ago, Lama876 said:

Have you tried switching to PCI Legacy on unlocked BIOS from this topic?

 

Does it help getting image on internal screen?

 

If you have these unlocked BIOSes - please send GT780 and GT683 my way :)

 

 

 

 

well, that is exactly what I did and it didn't work, and no. i used a different unlocked bios. I am sorry :(

9 hours ago, Lama876 said:

 

If you have these unlocked BIOSes - please send GT780 and GT683 my way :)

 

 

btw, you are a promoted user. You can download these too right? if you can't... well i'll see what I can do for you

Share this post


Link to post
Share on other sites

I didn't know there is a different unlocked BIOS, can you send it to me to try? Maybe it will help with other cards, do you have it for for only for GT683 or for GT780 as well?

 

Maybe changing Vendor ID to MSI ( 1462 ) in vBIOS would help? Do you know vBIOS editor that can change Vendor ID on GCN 2.0 (8000 series and up) AMD cards?

 

As for these BIOSes - yeah I just got promoted, downloaded a couple of BIOSes and now forum do not allow download more for some reason lol,


Funny enough I didn't got those that I was really after :)  GT683 and GT780

 

 

Share this post


Link to post
Share on other sites
On 3/23/2020 at 12:00 AM, Lama876 said:

I didn't know there is a different unlocked BIOS, can you send it to me to try? Maybe it will help with other cards, do you have it for for only for GT683 or for GT780 as well?

 

Maybe changing Vendor ID to MSI ( 1462 ) in vBIOS would help? Do you know vBIOS editor that can change Vendor ID on GCN 2.0 (8000 series and up) AMD cards?

 

As for these BIOSes - yeah I just got promoted, downloaded a couple of BIOSes and now forum do not allow download more for some reason lol,


Funny enough I didn't got those that I was really after :)  GT683 and GT780

 

 

Sorry for the late comment, i'll see if I could get them for you

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/23/2020 at 12:00 AM, Lama876 said:

I didn't know there is a different unlocked BIOS, can you send it to me to try? Maybe it will help with other cards, do you have it for for only for GT683 or for GT780 as well?

 

Maybe changing Vendor ID to MSI ( 1462 ) in vBIOS would help? Do you know vBIOS editor that can change Vendor ID on GCN 2.0 (8000 series and up) AMD cards?

 

As for these BIOSes - yeah I just got promoted, downloaded a couple of BIOSes and now forum do not allow download more for some reason lol,


Funny enough I didn't got those that I was really after :)  GT683 and GT780

 

 

I think i got them, I now hope I won't get banned.

I actually founded it a bit unfair that only subscribed/promoted people could download this.
I could understand why they did it, but there are so little amount of downloads compared to the amount of views the post has gotten. so many people.. that couldn't get their hands on them

 

Here's the link, i put them in a zip. uuhhh i cannot use external links so I guess.. i have to comment multiple times?

 

I wasn't sure exactly which bios you wanted, soooo i downloaded multiple...

Edited by depmixels
removal of external link

Share this post


Link to post
Share on other sites
1 hour ago, depmixels said:

I think i got them, I now hope I won't get banned.

I actually founded it a bit unfair that only subscribed/promoted people could download this.
I could understand why they did it, but there are so little amount of downloads compared to the amount of views the post has gotten. so many people.. that couldn't get their hands on them

 

Here's the link, i put them in a zip.  https://drive.google.com/file/d/1udbT4ElOP_s3CGAdstsvCC2dztekRT16/view?usp=sharing

 

I wasn't sure exactly which bios you wanted, soooo i downloaded multiple...

Hi!

You should delete your external link, it's against from the forum rules!

You can read "User Account Promotion Rules" in this place:  https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By TheLoser1124
      Hello, A couple of days ago I got a new GPU but when I installed it into my computer I was unable to use it but now I know why. When checking the device manger I went into the events tab of my GPU when I went to view all events, I noticed an error it said " event 411 kernel PnP " and It also said Problem Status: 0xC01E0438. I believe this is why my GPU hasn't been working on my PC. If you know how to fix this problem or have info on how to fix this problem that would be greatly appreciated. I'm also using a EVGA NVIDIA GeForce GTX 1660.
    • By ajdrenter
      Hello all! I have been researching upgrade paths for my M17x R4 and I have decided on the GTX 1060. Now, I was given this laptop with a dead GPU, and I had an M17x R3 already. So I moved the GTX 560m into the R4 which has worked fine. Now as I understand it a few things are needed for this upgrade including the 120hz panel and the ability to disable the legacy ROM for a pure UEFI boot. I have the 120hz screen, but the 560m uses the GF116 architecture which does not have a vBIOS which supports GOP. So I am thinking the only solution is to buy a cheaper "in-between" card which supports both boot modes, which will allow me to disable the legacy option in setup. Does anyone have any suggestions as to what cheap card to buy as a transitional part? I have been considering a 765m but I am also wondering if there are any other good choices.
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       

      View full article
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.