Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
BasedKnight

P770DM-G 980M Won't Boot

Recommended Posts

I recently purchased a replacement 980M (Clevo model) for my P770DM-G after the original died, however, after installing the card the laptop doesn't boot. I only get a black screen, and after a couple minutes the fans spin to max before shutting down, which is the same thing that happens when I try to boot it without any gpu at all. I've tried the reset procedure, unplugging, removing battery, and removing CMOS, to no avail. It does beep before shutting down (I counted 22 times exactly). Anyone have any insight as to what the problem is?

Share this post


Link to post
Share on other sites
9 hours ago, BasedKnight said:

I recently purchased a replacement 980M (Clevo model) for my P770DM-G after the original died, however, after installing the card the laptop doesn't boot. I only get a black screen, and after a couple minutes the fans spin to max before shutting down, which is the same thing that happens when I try to boot it without any gpu at all. I've tried the reset procedure, unplugging, removing battery, and removing CMOS, to no avail. It does beep before shutting down (I counted 22 times exactly). Anyone have any insight as to what the problem is?

Hi!

I think in your case it's a hardware problem. I think when your previous graphic card was died, then at the same time some element on the motherboard died at the same time, maybe some kind of power element to the graphic card.

Share this post


Link to post
Share on other sites

The motherboard should be ok. I since managed to get the laptop to boot to Windows but there is no video. I've been attempting to blind flash a stock 980M vBIOS using these instructions, 

, but with no luck. It fails everytime. Since I have no video, I enabled logging through nvflash and the error I get everytime in the log file is 'no nvidia display adapter detected'. I also get 2 beeps after Step 9, but according to the instructions it should only beep once when the flash is successful. It seems that the card and the laptop itself are both working there is just some incompatibility some where.

Share this post


Link to post
Share on other sites
10 minutes ago, BasedKnight said:

The motherboard should be ok. I since managed to get the laptop to boot to Windows but there is no video. I've been attempting to blind flash a stock 980M vBIOS using these instructions, 

, but with no luck. It fails everytime. Since I have no video, I enabled logging through nvflash and the error I get everytime in the log file is 'no nvidia display adapter detected'. I also get 2 beeps after Step 9, but according to the instructions it should only beep once when the flash is successful. It seems that the card and the laptop itself are both working there is just some incompatibility some where.

 

The motherboard itself is working, yes, but I mean that maybe some element on the motherboard is faulty, which giving the supply voltage only to the graphics card. Perhaps that’s why the new video card is not detected by the system, because it does not receive the necessary supply voltage.

Edited by Klem

Share this post


Link to post
Share on other sites

I suppose that is possible. The original card died due to MOSFET failure. One failed, so I removed it and the card ran on the remaining 2 for awhile (just had to reduce the clocks to avoid black screens when running demanding games), then the remaining ones eventually burned out. I was sure it was something up with the vBIOS since I purchased the replacement from China, but I guess there is no way to know for sure if it's board related until I'm able to test another 980M.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By mtvgt
      Hi guys,
      i have m18x R1 model with A05 unlocked bios and i try to connect ati mobility 4870 card/s.
      I read ton of posts but people that seem to have similar problem with different card didn't post any solution. Case is when i connect 4870 i get black screen and 8 beeps.
      When i use only integrated graphics (no cards installed) laptop is starting normally.
      When i use integrated graphics (nvidia card installed as master) laptop is starting normally.
      When i use nvidia card installed as master laptop is starting normally.
      When i use nvidia card installed as master and ati 4870 installed as slave laptop is starting normally but in devices manager i see there is error 10 with ati card.
      When i use ati 4870 card installed as master i get 8 beeps and black screen.
      I tried to google for answers but unfortunatelly didn't find any. Do you know if that old card can work in m18x ? Maybe it's not supported at all? Do you have any ideas what else can i try?
    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES with most menus and options unlocked.
       
      THESE BIOS MODS ARE ONLY FOR PEOPLE WHO KNOW WHAT THEY ARE DOING!
       
       
       
      NEW:
      I'VE BEEN BUSY WITH SOME STUFF PLUS MY SYSTEM HASN'T BEEN WORKING FOR SOME TIME BUT I SHOULD BE ABLE TO CONTINUE MY WORK SOON 
       
      I'M CURRENTLY WORKING ON V3.0 WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      I'M ALSO WORKING ON MODS FOR OTHER MODELS TOO.
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
       
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
       
      TM, KM AND DM SERIES
       
      P6 AND P4 SERIES
       
      INSTRUCTIONS
        IF YOU LIKE MY WORK FEEL FRE TO BUY ME A COFFEE   ENJOY!
    • By racerxdl
      Hi all,
       
      It has been a while since I did anything to my laptop (Clevo P670RG-G) and since I recently got a VR Headset I wish I could overclock my GPU a little. So far the NVidia software (on windows) doesn't allow me to overclock it (the linux sort of allows, which some custom Xorg options) so I decided to give a try modding the vbios.
       
      I read all sorts of issues / guides about it, and it seens that the hardware topology (where the vbios is stored and how things are connected) changes from machine to machine.
       
      What I know about my laptop is that it has two VBios, one for Hybrid Mode and one for Discrete Mode. I'm currently running the discrete mode.
       
      I dumped my VBios using GPU-z and opened up in Maxwell II Bios Tweaker. Everything seens fine so far.
       
      So I have few questions about it:
       
      - There is a way to just unlock the VBios to show the overclocking options in NVidia software? (That way I dont need to reflash to change clocks)
      - I can just flash this GPU-z dump to my VBios?
      - If I brick my GPU, that GPU-z dumped image is the raw SPI image, so if I managed to physically access the VBios, I can just reflash over it?
      - I saw some people saying that I might need as well to flash the main laptop bios as well, is that really needed?
       
      Thanks!
       
      Lucas

    • By BAKED
      There are several threads on requesting BIOS modifications here on T | I but I thought another one wouldn't hurt.
       
            Your request should look like:
      Brand Model Type of modification(For example: Unlocked, added support, Logo, microcode, ME firmware etc  
      I'll respond as soon as I have time as I'm also currently working on other projects(Requests by PM is also ok)
      If anyone else have the knowledge and time feel free to respond to requests 
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.